15:30:51 <msimonin> #startmeeting Performance Team
15:30:52 <openstack> Meeting started Tue Dec 12 15:30:51 2017 UTC and is due to finish in 60 minutes.  The chair is msimonin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:56 <openstack> The meeting name has been set to 'performance_team'
15:31:11 <msimonin> Hi, is anyone here ? :)
15:31:34 <tovin07> hi
15:31:39 <tovin07> I;m here
15:31:45 <msimonin> hi tovin07
15:31:50 <tovin07> hi msimonin
15:31:53 <msimonin> let's wait a bit
15:31:57 <tovin07> yup
15:33:19 <msimonin> So if we are only two of us this will be super fast meeting :)
15:33:49 <ilyashakhat> hi!
15:33:52 <msimonin> Btw DinaBelova asked me to chair today as she can join
15:33:57 <msimonin> hi ilyashakhat :)
15:34:12 <msimonin> nice to see you here guys, I was afraid to be alone here
15:34:55 <msimonin> shall we start / do you know if other people come ?
15:35:12 <ilyashakhat> let's start
15:35:21 <msimonin> #topic Action Items
15:35:49 <msimonin> So I don't recall if wa had some
15:36:09 <ilyashakhat> me too
15:36:18 <tovin07> I'm testing some case to check if __call__ can help for this bug
15:36:20 <tovin07> tovin07 fix https://bugs.launchpad.net/osprofiler/+bug/1731864
15:36:21 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
15:36:32 <msimonin> oh yes I remember
15:36:39 <tovin07> I will publish a patch for this one later this week
15:36:45 <msimonin> tovin07: any progress ?
15:36:51 <tovin07> hope it can fix :D
15:37:08 <msimonin> oh cool I'm looking forward to seeing this
15:37:16 <tovin07> that what I've worked last week
15:37:22 <tovin07> the next one is msimonin contact oslo.messaging team and propose them direct osprofiler integration to the library
15:37:36 <msimonin> This one was on me
15:37:37 <msimonin> :)
15:37:45 <msimonin> I didn't make any progress here
15:37:58 <msimonin> Last time I mentionned that I told kgiusti about that
15:38:14 <msimonin> We agreed to talk at the PTG
15:38:39 <tovin07> yep
15:38:47 <tovin07> that's all from me and what I can remember :D
15:38:55 <msimonin> thanks tovin07 :)
15:39:17 <tovin07> I think that we can move to the next section
15:39:37 <msimonin> should I put on action on you tovin07 ?
15:39:42 <msimonin> to release the patch ?
15:40:10 <tovin07> yees
15:40:43 <msimonin> #action tovin07 to propose a patch for https://bugs.launchpad.net/osprofiler/+bug/1731864 within the week
15:40:44 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
15:40:50 <msimonin> done :)
15:41:19 <msimonin> So I propose to move to the next part of the meeting
15:41:21 <msimonin> #topic Current status
15:41:40 <msimonin> ilyashakhat: anything to share ?
15:41:44 <ilyashakhat> yep
15:42:03 <ilyashakhat> I'm posting patches with more tests on osprofiler
15:42:26 <ilyashakhat> the first is approved by tovin07 (thanks!) but not accepted by zuul yet
15:42:35 <msimonin> Could you link it ?
15:42:44 <tovin07> ohh
15:42:54 <ilyashakhat> https://review.openstack.org/#/c/515108/
15:42:57 <tovin07> I saw that your patch pass all Zuul gate
15:43:10 <tovin07> ahha
15:43:17 <tovin07> that's another story :D
15:43:24 <tovin07> lemme check
15:43:50 <msimonin> oh yes zuul is given a -1
15:43:50 <tovin07> It said
15:43:52 <tovin07> ssh: connect to host 15.184.68.203 port 22: Connection timed out
15:43:53 <ilyashakhat> it's again "SSH Error: data could not be sent to remote host"
15:44:17 <ilyashakhat> hopefully it's infra glitch
15:44:29 <ilyashakhat> I also have https://review.openstack.org/#/c/523935/
15:44:52 <ilyashakhat> which is adding profiling into tempest which will allow us to run all tests with profiling
15:45:36 <msimonin> It seems to require more reviews than the previous
15:45:40 <msimonin> Anything we can do ?
15:45:41 <ilyashakhat> yes
15:46:17 <ilyashakhat> please review it :)
15:46:37 <tovin07> yep
15:46:40 <ilyashakhat> I hope tempest team will pay attention to it once see reviews from osprofiler team
15:46:53 <tovin07> I agree with that :D
15:46:54 <msimonin> #action tovin07, msimonin review https://review.openstack.org/#/c/523935/ (tempest/osprofiler integration)
15:47:04 <msimonin> One question what setup is required to test it ?
15:47:38 <ilyashakhat> it can be run with defaults (messaging + ceilometer)
15:48:04 <msimonin> in a devstack environment ?
15:48:08 <ilyashakhat> yes
15:48:35 <ilyashakhat> or you can run it on any other env, but configure profiling manually
15:48:45 <msimonin> I'm not familiar with tempest, how can
15:48:50 <ilyashakhat> ahh
15:48:54 <msimonin> devstack is perfect from my side
15:49:05 <ilyashakhat> I think I need to make a job to show how it works
15:49:23 <ilyashakhat> (ideally)
15:49:53 <msimonin> My only point is to know how to enable profiling in tempest when I get my devstack up and running (including your patchset) ?
15:50:10 <msimonin> ok tempest.conf
15:50:10 <msimonin> :)
15:50:12 <msimonin> sorry
15:50:38 <ilyashakhat> set variable "key" in [profiler] section equal to SECRET_KEY
15:50:50 <msimonin> ilyashakhat: ack, thanks
15:51:04 <ilyashakhat> (I realize that I need to add more info on this)
15:51:23 <ilyashakhat> please ping me if you have any issues with the patch
15:51:32 <msimonin> sure
15:51:37 <msimonin> thank you
15:52:04 <ilyashakhat> and I have one more patch :)
15:52:06 <ilyashakhat> https://review.openstack.org/#/c/527406/
15:52:07 <msimonin> Anything else to share ilyashakhat  ?
15:52:26 <msimonin> one more patch :)
15:52:31 <ilyashakhat> this will make it easy to enable profiling with Redis driver
15:52:56 <ilyashakhat> (since we agreed that Redis driver is the easiest replacement for Ceilometer)
15:53:01 <msimonin> oh yes we needed to install it manually :)
15:53:07 <tovin07> #link https://review.openstack.org/#/c/527406/
15:53:20 <msimonin> +1 for redis :)
15:53:22 <tovin07> I will review this :D
15:53:35 <msimonin> With this patch this will be very convenient
15:54:08 <msimonin> #action tovin07, msimonin to review https://review.openstack.org/#/c/527406/ (automatic installation of collectors in devstack)
15:54:31 <msimonin> Anything else to share ilyashakhat  ?
15:55:21 <ilyashakhat> nop :)
15:55:42 <msimonin> thanks
15:55:55 <msimonin> tovin07: do you want to share something ?
15:56:09 <tovin07> nop
15:56:46 <msimonin> thank you :)
15:57:40 <msimonin> From my side, we have some activities concerning the communication bus evaluation
15:57:53 <msimonin> For now we run some baseline experiments
15:58:03 <msimonin> using RabbitMQ and qpid-dispatch-router
15:59:07 <msimonin> I'll share with you the outcomes when the time will come
15:59:09 <msimonin> :)
15:59:18 <tovin07> oh, thanks :D
15:59:48 <msimonin> For what it worth you can check https://github.com/msimonin/qpid-dispatch-xp/tree/master/synthetic
16:00:14 <ilyashakhat> ok, cool :)
16:00:38 <msimonin> any feedback welcome :)
16:00:48 <msimonin> let's move to the next topic
16:00:59 <msimonin> #topic Open Discussion
16:01:36 <msimonin> We can start with tovin07
16:01:40 <tovin07> this time, I do not have anything to share :D
16:01:42 <msimonin> anything to discuss ?
16:01:45 <msimonin> ok
16:01:53 <msimonin> ilyashakhat ?
16:04:43 <msimonin> I guess this will be time for the conclusion :)
16:05:03 <msimonin> Thanks for participating, hope DinaBelova will be here next time
16:05:11 <ilyashakhat> thank you!
16:05:23 <msimonin> Bye
16:05:24 <msimonin> #endmeeting