16:00:55 <lbragstad> #startmeeting policy
16:00:55 <openstack> Meeting started Wed Mar 15 16:00:55 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:00 <openstack> The meeting name has been set to 'policy'
16:01:12 <lbragstad> agenda #link https://etherpad.openstack.org/p/keystone-policy-meeting
16:01:21 <lbragstad> ping antwash, raildo, ktychkova, dolphm, dstanek, rderose, htruta, atrmr, gagehugo, lamt, thinrichs, edmondsw, ruan, ayoung, ravelar, morgan, raj_singh, johnthetubaguy, knikolla
16:01:27 <gagehugo> o/
16:02:21 <lamt> o/
16:02:41 <lamt> still getting used to DST.
16:02:58 <knikolla> o/
16:03:08 <lbragstad> same here - it threw me for a loop earlier
16:03:47 * johnthetubaguy hides at the back of the room
16:04:25 <lbragstad> here is the agenda #link https://etherpad.openstack.org/p/keystone-policy-meeting
16:04:26 <lbragstad> #topic reviews
16:04:32 <lbragstad> we have several things that have been in the pipe for a while
16:05:06 <lbragstad> since we have a light agenda today - as well as a low attendance (i know a bunch of people are out due to spring break)
16:05:20 <lbragstad> i figured we could use today for reviews, unless people have specific things they want to discuss
16:05:39 <johnthetubaguy> I am pushing on the nova specs side of things
16:05:43 <johnthetubaguy> but no news as such
16:05:55 <lbragstad> johnthetubaguy still pushing the specs through?
16:06:10 <johnthetubaguy> sneti and aunnam are get lots of the polcy docs patches up for review already
16:06:15 <johnthetubaguy> yeah, still pushing them
16:06:23 <lbragstad> nice
16:06:28 <johnthetubaguy> we have *a lot* of specs up for review
16:06:32 <johnthetubaguy> its a bit scary
16:06:49 <lbragstad> that brings us to our first review actually - #link https://review.openstack.org/#/c/439070/
16:07:11 <lbragstad> ^ antwash has been spinning that over the past week and I think it's starting to look pretty good
16:07:29 <lbragstad> I'd like to see some documentation on the usage of it - but once that merges i'd like to propose a new release of oslo.policy
16:07:44 <lbragstad> that way keystone and nova can start using the same interface for the policy-docs specs
16:08:22 <johnthetubaguy> yeah, need to bump global requirements to start using that too I think
16:08:42 <lbragstad> johnthetubaguy ah - good point
16:08:50 <lbragstad> johnthetubaguy i can look into that once it merges
16:08:53 <johnthetubaguy> the other bit is in the sample generator I think aunnam was going to look at making sure the rules are commented out by default
16:08:59 <johnthetubaguy> lbragstad: cool, that be great
16:09:13 <lbragstad> johnthetubaguy i want to say antwash was looking into that, too
16:09:23 <johnthetubaguy> ah, thats cool if thats already happening
16:09:38 <lbragstad> #link https://review.openstack.org/#/c/443330/2
16:09:43 <lbragstad> i think that's it ^
16:09:50 <aunnam> then we both must talk to each other
16:10:02 <lbragstad> aunnam ++
16:10:08 <lbragstad> aunnam meet antwash
16:10:16 <antwash> yeah I -1 it myself until the other patch gets merged
16:10:22 <johnthetubaguy> ah, there is a bit more we need there
16:10:24 <aunnam> https://review.openstack.org/#/c/443330/2 but this is for description support right?
16:10:25 <lbragstad> antwash meet aunnam
16:10:26 <lbragstad> :)
16:10:34 <aunnam> not commenting the rule
16:10:41 <lbragstad> aunnam yeah - support for rendering the description i believe
16:10:46 <johnthetubaguy> aunnam +1
16:10:54 <johnthetubaguy> lbragstad: I think thats an extra thing
16:11:01 <lbragstad> johnthetubaguy which part?
16:11:02 <johnthetubaguy> we have the operations in the same with that patch
16:11:07 <johnthetubaguy> in the sample
16:11:12 <johnthetubaguy> but currently it look like this:
16:11:29 <johnthetubaguy> https://docs.openstack.org/developer/nova/sample_policy.html
16:11:40 <johnthetubaguy> we need the rule line to start with a comment as well
16:11:55 <lbragstad> ah
16:11:57 <lbragstad> ok
16:11:59 <johnthetubaguy> I think aunnam was looking at how to re-write the tests to support that
16:12:07 <johnthetubaguy> if I remember that correctly
16:12:10 <aunnam> johnthetubaguy, yes
16:12:20 <johnthetubaguy> aunnam: did that work out ok?
16:12:26 <lbragstad> aunnam johnthetubaguy this is all stuff that needs to go into oslo.policy though, right?
16:12:27 <johnthetubaguy> want to share your plan there?
16:12:35 <johnthetubaguy> lbragstad: yes
16:12:50 <aunnam> johnthetubaguy, not yet, i started looking into code today
16:13:02 <johnthetubaguy> cool, sounds like that doesn't overlap
16:13:11 <johnthetubaguy> I am sure lbragstad would love to review that when it goes up
16:13:16 <lbragstad> ++
16:13:35 <lbragstad> so - it sounds like i'm hearing that three different things need to happen
16:13:50 <johnthetubaguy> cool, that sounds like all the bits we need now, yeah, lets summarise
16:14:06 <antwash> We're going to have to write a set of new test to support the new policy? and leave the test to that support the old policy alone?
16:14:13 <lbragstad> 1.) we need to merge support for adding descriptions to oslo.policy objects at registration time ( #link https://review.openstack.org/#/c/439070/ )
16:14:35 <lbragstad> 2.) add support to render descriptions in sample policy files ( #link https://review.openstack.org/#/c/443330/2 )
16:15:00 <lbragstad> 3.) add support to comment out rule lines in sample policy files
16:15:17 <lbragstad> all three of which need to be done in oslo.policy
16:15:36 <lbragstad> and not necessarily in that order
16:15:41 <lbragstad> does that sound accurate?
16:15:49 <johnthetubaguy> lbragstad: yes, we have already merged the things that supports multi-line description I think
16:16:07 <lbragstad> johnthetubaguy in oslo.policy or nova?
16:16:13 <johnthetubaguy> antwash: I think I found a way for aunnam to fix the existing tests so the tweak is really small
16:16:25 <johnthetubaguy> aunnam: I think that multi line fix was in 1.20 right?
16:16:33 <aunnam> lbragstad, yes as these two patches has been merged already https://review.openstack.org/#/c/441342/ https://review.openstack.org/#/c/443332/
16:16:38 <lbragstad> ah - #link https://review.openstack.org/#/c/441342/
16:16:59 <aunnam> johnthetubaguy, yes
16:17:15 <johnthetubaguy> so step 0 is done, just need those three
16:17:34 <lbragstad> ok - so steps 1 - 3 in my list above still need to happen
16:18:13 <lbragstad> s/happen/happen?
16:18:58 <johnthetubaguy> yep
16:19:07 <lbragstad> awesome - i'm going to make some action items
16:19:36 <lbragstad> #action get approval on #link https://review.openstack.org/#/c/439070/
16:20:03 <lbragstad> #action review and approve support for rendering descriptions in sample policy files - #link https://review.openstack.org/#/c/443330/2
16:20:15 <lbragstad> is anyone willing to pick up #3?
16:20:25 <lbragstad> aunnam you were already working on that?
16:20:41 <aunnam> johnthetubaguy, https://github.com/openstack/oslo.policy/blob/master/oslo_policy/tests/test_generator.py#L278 as it is getting rules from sample policy file
16:21:04 <johnthetubaguy> yeah, I think aunnam and sneti were going to sort out #3
16:21:16 <aunnam> lbragstad, yes i started looking into the failing tests if I comment out the rule
16:22:09 <lbragstad> aunnam ah - so that's test refactoring specific to nova, but we still need support for commenting out the default rule in oslo.policy?
16:22:30 <antwash> for #2, we're referring to adding the mulitiline description support..right?
16:23:07 <lbragstad> antwash yeah - #2 is an action item to make sure oslo.policy renders descriptions in sample policy files
16:23:09 <johnthetubaguy> #2 is about getting the URLs and actions into the sample file I think
16:23:27 <johnthetubaguy> the descriptions are already in the sample files
16:23:40 <lbragstad> aha
16:23:41 <johnthetubaguy> it already supports multi-line descriptions too
16:23:42 <lbragstad> #undo
16:23:43 <openstack> Removing item from minutes: #action review and approve support for rendering descriptions in sample policy files - #link https://review.openstack.org/#/c/443330/2
16:24:14 <johnthetubaguy> yeah, my brain read what I expected, not what you wrote, I hate it when that happens
16:24:27 <antwash> this patch adds the urls and actions to the file though https://review.openstack.org/#/c/443330/
16:24:41 <johnthetubaguy> yeah, thats (2) in my head
16:24:48 <johnthetubaguy> its doing the correct thing
16:24:50 <johnthetubaguy> roughly
16:24:59 <lbragstad> #action add support so oslo.policy to include URLs and actions in the rendered sample policy descriptions #link https://review.openstack.org/#/c/443330
16:25:08 <lbragstad> ^ moar better?
16:25:18 <johnthetubaguy> yeah, that looks cool
16:25:27 <aunnam> lbragstad, ya i think that test is specific to nova, so without that test my change is working fine
16:25:29 <lbragstad> antwash makes sense?
16:25:42 <aunnam> lbragstad, will look into it again
16:25:46 <lbragstad> ok
16:26:21 <antwash> lbragstad: yeah I think so now, the idea is to add the URL/ACTION apart of the description when rendering the file
16:26:33 <lbragstad> antwash yep - exactly
16:26:45 <antwash> That's why the multiline support was added here https://review.openstack.org/#/c/441342/
16:27:40 <lbragstad> #action add support to oslo.policy to comment out the default rule when rendering sample policy files
16:27:45 <lbragstad> ^ that should be #3
16:27:58 <aunnam> lbragstad, yes
16:28:27 <lbragstad> so after those three action items are addressed, the sample policy files should just be one big commented out file (much like a generated config file)
16:28:37 <lbragstad> that has better descriptions
16:30:19 <lbragstad> and once all three are done - i'll propose a new version of oslo.policy and look at bumping requirements so that we can consume it
16:30:54 <lbragstad> #action lbragstad to roll a new version of oslo.policy and bump global requirements once the above actions are complete
16:31:13 <johnthetubaguy> yeah, that sounds good
16:31:17 <lbragstad> awesome
16:31:53 <lbragstad> I'll be available to do oslo.policy reviews all week - so if anyone has things that need to be reviewed, let me know
16:32:29 <aunnam> lbragstad, sure, thanks
16:32:52 <lbragstad> and with all ^ that work being done to move us closer to policy docs - i'd like to see if we can get #link https://review.openstack.org/#/c/435078/ merged soon
16:33:40 <antwash> ++
16:33:56 <lbragstad> so if anyone wants to give that a once over - I'd appreciate any feedback on it
16:34:32 <lbragstad> and we can also focus on landing #link https://review.openstack.org/#/q/status:open+project:openstack/keystone+branch:master+topic:bp/policy-in-code
16:35:10 <lbragstad> ideally, once all that is done keystone should be up-to-par with nova as far as policy is concerned (i believe)
16:36:27 <lbragstad> i think that's all i had for review
16:36:29 <lbragstad> reviews*
16:36:34 <lbragstad> #topic open discussion
16:37:12 <lbragstad> we have a bunch of time left to discuss things if folks want
16:37:44 <lbragstad> otherwise we can end early and go do oslo.policy reviews ;)
16:37:49 <antwash> I don't have nothing on my end
16:39:47 <lbragstad> alrighty - well thanks for coming and ping me if you need anything oslo.policy-wise
16:39:50 <lbragstad> #endmeeting