16:00:04 <lbragstad> #startmeeting policy
16:00:08 <lbragstad> ping  raildo, ktychkova, rderose, htruta, hrybacki, atrmr, gagehugo, lamt, thinrichs, edmondsw, ruan, ayoung, morgan, raj_singh, johnthetubaguy, knikolla, nhelgeson
16:00:09 <openstack> Meeting started Wed Jun  7 16:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'policy'
16:00:16 <knikolla> o/
16:00:18 <lbragstad> #link https://etherpad.openstack.org/p/keystone-policy-meeting
16:00:19 <cmurphy> o/
16:00:21 <lbragstad> o/
16:00:24 <blancos> o/
16:00:59 * johnthetubaguy lurks
16:01:10 <gagehugo> o/
16:02:23 <lbragstad> #topic policy docs in keystone
16:02:44 <edmondsw> o/ (sort of)
16:02:51 <lbragstad> as mentioned in the keystone meeting yesterday - there is an effort to pick up the policy docs works
16:03:02 <lbragstad> there isn't much left to document
16:03:04 <lbragstad> #link https://review.openstack.org/#/q/status:open+project:openstack/keystone+branch:master+topic:bp/policy-docs
16:03:22 <lbragstad> it's really just addressing the remaining comments and getting those patches across the finish line
16:03:31 <lbragstad> then the policy-docs spec will be implemented
16:04:06 <lbragstad> samueldmq: hrybacki and myself are working on addressing the comments, any reviews would be greatly appreciated
16:04:54 <lbragstad> #topic policy specs and goals
16:04:58 <samueldmq> hi all
16:05:08 <lbragstad> we have a bunch of policy goals and specs in flight
16:05:50 <lbragstad> it would be nice to merge the ones we agree with or provide feedback on them
16:06:00 <lbragstad> #link https://review.openstack.org/#/c/460344/
16:06:08 <lbragstad> ^ general policy goals document
16:06:16 <lbragstad> #link https://review.openstack.org/#/c/462733/
16:06:37 <lbragstad> ^ roadmap for providing security via policy improvements (which I could probably update)
16:06:45 <lbragstad> #link https://review.openstack.org/#/c/460344/
16:06:50 <lbragstad> ^ global role assignments in keystone
16:07:33 <samueldmq> those are all pretty neat imo, it would be great to get feedback from other projects too
16:07:43 <lbragstad> we've been getting feedback, slow but sure
16:07:47 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/117949.html
16:08:07 <lbragstad> yeah - project feedback on those would be good
16:08:30 <lbragstad> maybe we can make a point to get on the meeting agenda for other projects to raise awareness?
16:08:53 <samueldmq> lbragstad: that'd be great
16:09:16 <lbragstad> i think the cinder meeting is taking place rightn ow
16:09:26 <smcginnis> yep
16:09:46 <lbragstad> ok - if we end this one early - i'll swing by and ask
16:09:58 <lbragstad> otherwise i'll propose it for the agenda next week
16:10:55 <lbragstad> I've also proposed a queens goal for moving policy into code and documenting it
16:10:56 <lbragstad> #link https://review.openstack.org/#/c/469954/
16:11:20 <lbragstad> since several folks here are familiar with that concept, any reviews there (keeping me honest) would be great
16:12:40 <lbragstad> #action lbragstad to swing to get cross-project involvement on https://review.openstack.org/#/c/462733/ and https://review.openstack.org/#/c/468436/
16:12:46 <lbragstad> #undo
16:12:47 <openstack> Removing item from minutes: #action lbragstad to swing to get cross-project involvement on https://review.openstack.org/#/c/462733/ and https://review.openstack.org/#/c/468436/
16:12:50 <samueldmq> lbragstad: that is for Queens correct?
16:12:58 <lbragstad> #action lbragstad to get cross-project involvement on https://review.openstack.org/#/c/462733/ and https://review.openstack.org/#/c/468436/
16:13:01 <lbragstad> samueldmq: yes
16:13:26 <samueldmq> nice, seems a good target, would be really hard if we were targeting Pike
16:13:41 <lbragstad> samueldmq: which would impact keystone, but it would hopefully set us up for other policy improvements if we decide to start introducing better roles by default
16:13:53 <lbragstad> which johnthetubaguy had some specs proposed to do
16:14:11 <lbragstad> #undo
16:14:11 <openstack> Removing item from minutes: #action lbragstad to get cross-project involvement on https://review.openstack.org/#/c/462733/ and https://review.openstack.org/#/c/468436/
16:14:11 <samueldmq> lbragstad: would be great to have a wiki page
16:14:25 <samueldmq> stating where each spec sits in the roadmap
16:14:34 <lbragstad> #action lbragstad to get cross-project involvement on https://review.openstack.org/#/c/460344/ and https://review.openstack.org/#/c/462733/
16:14:45 * lbragstad has too many tabs open
16:15:20 <lbragstad> samueldmq: yeah
16:15:39 <lbragstad> have people been keeping up with the admin-ness (global roles) discussion?
16:16:53 <samueldmq> lbragstad: what discussion? in the ML? or just considering the options (global roles vs admin project) and reviewing
16:17:05 <lbragstad> samueldmq: yeah - the ML thread specifically
16:17:29 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/117419.html
16:17:54 <lbragstad> how do people feel about the options and feedback we've gotten from operators?
16:19:50 <samueldmq> lbragstad: I prefer #2, the new global role concept
16:20:04 <samueldmq> looks like people are inclined to that one too
16:20:13 <gagehugo> I think #2 seemed to be more accepted of the choices from what the response emails sounded like
16:20:21 <gagehugo> samueldmq yeah
16:20:26 <lbragstad> that seems to be the consensus on the thread
16:21:26 <lbragstad> ok - so i'll propose that spec backlog instead of ongoing, since the work hasn't started yet
16:21:44 <lbragstad> i'll carve out some time to start working on the implementation
16:21:52 <lbragstad> and propose it early
16:22:16 <lbragstad> my goal would be to try and have it in a place where we can merge the work as soon as queens opens for development
16:23:12 <lbragstad> if anyone is interested in helping with that effort, let me know or leave a comment on the contributors section of the review
16:23:31 <lbragstad> #action lbragstad to propose global roles to backlog in preparation for queens
16:24:45 <lbragstad> i think that's about all i had for specs and goals
16:24:49 <lbragstad> #topic open discussion
16:25:53 <lbragstad> floor is open in case anyone has anything they'd like to discuss
16:27:23 <lbragstad> alrighty - well looks like we can get some time back
16:27:29 <lbragstad> thanks for coming!
16:27:31 <lbragstad> #endmeeting