18:00:34 <gmann> #startmeeting policy-popup
18:00:35 <openstack> Meeting started Thu Jun 25 18:00:34 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:39 <openstack> The meeting name has been set to 'policy_popup'
18:00:45 <raildo> o/
18:00:46 <gmann> this is right time.
18:00:50 <gmann> raildo: hi
18:01:01 <raildo> gmann, yo, how you doing?
18:01:20 <redrobot> \o
18:01:22 <raildo> #link Agenda: https://etherpad.opendev.org/p/default-policy-meeting-agenda
18:01:29 <gmann> 3 meeting today :) and gate stuff you know
18:01:34 <gmann> redrobot: hi
18:01:50 <gmann> let's wait for couple of min if more people shows up
18:01:57 <raildo> gmann, yeah, things are getting crazy this last days...
18:02:02 <raildo> yep
18:04:18 <gmann> let's start
18:04:24 <raildo> let's do it!
18:04:30 <gmann> #topic PTG feedback
18:04:47 <gmann> this is our first meeting after PTG
18:05:04 <gmann> we had great amount of discussion over new policy things and feedback too
18:05:41 <gmann> from oslo-nova cross projects sessions we captured the json->yaml migration plan which we will discuss in next topic
18:05:47 <raildo> indeed, the idea of making a virtual PTG it was pretty good, imho
18:06:02 <gmann> and keystone sessions on more investigation we should do to find out the missing things
18:06:12 <gmann> raildo: true,
18:06:43 <raildo> also some projects like manila, barbican, cyborg have some plans to start supporting default policies during victoria cycle
18:06:45 <gmann> discussions were productive
18:06:55 <gmann> yeah and neutron also
18:06:57 * gouthamr sneaks in
18:07:20 <raildo> yep, pretty cool result for the PTG :)
18:07:23 <gmann> we need to get some pre-work done before more projects start shipping that
18:07:29 <raildo> gouthamr, hey o/
18:07:35 <gouthamr> o/ raildo
18:07:42 <gmann> discussions are n etherpad if anyone missed the sessions
18:08:35 <gmann> raildo: gouthamr redrobot  please link the spec or code links on wiki if you have started or know about any other project has started
18:09:42 <gmann> anything else on PTG side?
18:09:52 <raildo> gouthamr, redrobot also, we added a fixed topic for "review requests" on the agenda, you can link any patch that needs our attention over it
18:10:02 <raildo> gmann, nope
18:10:13 <gmann> #topic Pre-work before adopting new policy on more projects
18:10:19 <redrobot> raildo, nice
18:10:32 <gmann> #link https://specs.openstack.org/openstack/oslo-specs/specs/victoria/policy-json-to-yaml.html
18:10:49 <gmann> ^^ this oslo spec captured the json->yaml transition plan
18:11:08 <gmann> this is very much needed things to finish before you ship the new policy to avoid the operators
18:11:28 <gmann> I will be working on this on priority and try to finish early in this cycle
18:12:03 <gmann> and one things we need on project side is to add the upgrade-checks for json format and switch the config option default value.
18:12:10 <bnemec> Even though that has merged, please take a look and let us know if there are any issues.
18:12:19 <gmann> I have plan to do in nova first as example
18:12:26 <bnemec> It's a security sensitive change so the more eyes we get on it the better.
18:12:28 <gmann> bnemec: +1
18:12:30 <raildo> bnemec, ack
18:13:16 <gmann> feedback from other projects will be valuable here if anything we are still missing or can do in better way from operators persepctive
18:14:13 <gmann> I will say we should add these pre-work things on projects review also to ack them and get more feedback if any
18:14:33 <gmann> let me record the action also
18:14:52 <gmann> #action to start the upgrade-check on nova as ref
18:15:30 <gmann> raildo: you want to take action to update wiki for pre-work section and there we will start listing down the things we need to burn down before projects start the implementation
18:15:58 <gmann> so that everyone can easily check the status and also can help
18:16:16 <gmann> #action gmann to start the upgrade-check on nova as ref
18:16:21 <raildo> #actoin to update wiki page with the pre-work for victoria cycle regarding the up-grade-check and json-to-yaml migration
18:16:27 <gmann> thanks
18:16:31 <raildo> oh lord...
18:16:36 <raildo> #action to update wiki page with the pre-work for victoria cycle regarding the up-grade-check and json-to-yaml migration
18:16:56 <raildo> gmann, awesome :) anything else?
18:17:11 <gmann> nothing else, let's move
18:17:22 <gmann> #topic Review Requests
18:17:31 <gmann> any review request?
18:17:53 <gmann> i know cyborg started the code last cycle but did not check if that is rebased and ready now
18:18:30 <gmann> no updates seems #link https://review.opendev.org/#/c/699102/
18:19:10 <raildo> gmann, ack, let's keep our eyes on it
18:19:14 <gmann> anyways do ping us review here in meeting or add in wiki.
18:19:16 <gmann> yeah
18:19:37 <gmann> #topic Open Floor
18:20:00 <gmann> any other topic to discuss
18:20:25 <raildo> nothing from my side
18:20:42 <gmann> neutron team is starting the discussion, i talked to amotoki and due to TZ he could not not join meting.
18:21:21 <gmann> I will send the updated over ML and if we get more people from Asia TZ then we can adjust the meeting time also
18:22:15 <raildo> I'm ok with moving meeting time if needed, but let's see how it goes
18:22:57 <gmann> yeah, once we get more movementum and more things to discuss then we can re-iterate the timing.
18:23:11 <raildo> ack
18:24:02 <gmann> ok, let's close for today if nothing else to discuss and we will meet on 9th July(hope i am counted date correctly :))
18:24:39 <raildo> that's right
18:24:44 <raildo> thanks everyone!
18:24:48 <gmann> ok
18:24:56 <gmann> thanks all for joining
18:25:01 <gmann> #endmeeting