18:01:15 <gmann> #startmeeting policy_popup
18:01:16 <openstack> Meeting started Thu Aug 20 18:01:15 2020 UTC and is due to finish in 60 minutes. The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:19 <openstack> The meeting name has been set to 'policy_popup'
18:01:28 <gmann> raildo: you there?
18:01:42 <raildo> gmann, yeah, how you doing?
18:01:51 <gmann> i am good how r u
18:02:05 <raildo> not to bad :)
18:02:24 <gmann> i think we missed to have meeting on 6th
18:02:34 <gmann> anyways let's start
18:03:04 <raildo> sure
18:03:37 <gmann> just added the agenda in etherpad #link https://etherpad.opendev.org/p/default-policy-meeting-agenda
18:03:45 <gmann> same as previous meeting
18:04:00 <gmann> #topic General doubts about Default policy
18:04:22 <gmann> #link https://review.opendev.org/#/c/743318/
18:04:33 <gmann> i did not get chance to review this
18:04:59 <gmann> i will check today or tomorrow
18:05:03 <raildo> gmann, yeah, I need to address Ben's comment, but would be nice for you to take a look as well :)
18:05:10 <gmann> sure
18:05:47 <gmann> #action gmann to review https://review.opendev.org/#/c/743318/
18:05:58 <gmann> #action raildo need to address the feedback on https://review.opendev.org/#/c/743318/
18:06:26 <raildo> as general news, I'm looking to be a mentor in a open source initiative in the collage that I graduated, the idea is to get someone to work on the default policy for Barbican
18:06:26 <gmann> #topic Review Requests
18:06:46 <gmann> raildo: that will be nice.
18:07:18 <gmann> we can engage the contributors in this pop up team and start targeting few projects, like baribican you mentioned
18:07:21 <raildo> and also, I'm raising awareness for this topic inside Red Hat, so I hope to have more folks working on this at least for the next cycle
18:07:29 <gmann> cool
18:07:56 <gmann> cyborg can be one to finish it as they are close
18:08:00 <gmann> #link https://review.opendev.org/#/c/740542/
18:08:22 <raildo> gmann, yeah, I was taking a look on this patch, things are getting there :)
18:08:51 <gmann> i reviewed their policy patch, mainly i would like to see test coverage first and then set of changes to see the impact
18:08:56 <gmann> basically how I did in nova
18:09:04 <raildo> ++
18:09:19 <gmann> they do not have much policy so it will be easy
18:09:36 <gmann> not like nova which has around 100s of policy :)
18:09:55 <gmann> any other project you seen started the work?
18:10:12 <raildo> gmann, I'm expecting barbican to be a mid term between both
18:10:22 <gmann> ok
18:10:44 <raildo> gmann, I do not, would be nice to join the team's meetings at least for neutron and manila
18:11:03 <raildo> gmann, since they we're planning to work on this topic during victoria cycle
18:11:32 <gmann> yeah, let me check with amotoki for neutron.
18:11:43 <gmann> and gouthamr if he has any plan for manila
18:11:59 <raildo> cool
18:12:20 <gmann> #action gmann to check neutron and manila plan for policy work.
18:12:28 <gmann> #topic Open Floor
18:13:01 <gmann> one update on this is- i started working on tooling for json->yaml conversion.
18:13:27 <raildo> gmann, cool, do you have some patches that want me to take a look?
18:13:34 <gmann> and upgrade checks on nova side to declare the json format as deprecated
18:13:53 <gmann> raildo: not yet, most probably next week early I should be able to push those
18:14:04 <raildo> sounds good to me
18:14:47 <gmann> there are some challenges i am seeing on how policy json file can be generated and how to decide whether it is default rule or not.
18:15:06 <gmann> but it will be more clear when it is up for review and unit tests
18:15:22 <raildo> agreed
18:15:25 <gmann> that is it from my side.
18:15:34 <gmann> raildo you have something ?
18:15:39 <raildo> nothing else from my side
18:15:48 <raildo> gmann, glad to see you around :)
18:16:04 <gmann> raildo: :)
18:16:14 <raildo> gmann, have a good one!
18:16:15 <gmann> let's close today
18:16:24 <gmann> raildo: thanks, you too.
18:16:30 <gmann> #endmeeting