18:01:31 <gmann> #startmeeting policy_popup
18:01:32 <openstack> Meeting started Thu Sep 17 18:01:31 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:35 <openstack> The meeting name has been set to 'policy_popup'
18:02:32 <gmann> ricolin: ping
18:02:37 <gmann> raildo: ping
18:02:42 <gmann> ricolin: please ignore
18:02:44 <raildo> o/
18:03:19 <gmann> let's start
18:03:26 <raildo> let's do it
18:04:14 <gmann> today agenda #link https://etherpad.opendev.org/p/default-policy-meeting-agenda
18:05:16 <gmann> #topic General doubts about Default policy
18:05:27 <gmann> #link https://bugs.launchpad.net/oslo.policy/+bug/1886857
18:05:28 <openstack> Launchpad bug 1886857 in oslo.policy "Improve documentation of what data is used in checks" [High,In progress] - Assigned to Raildo Mascena de Sousa Filho (raildo)
18:05:41 <gmann> A.I.:(raildo): need to adreess the feedback on https://review.opendev.org/#/c/743318/
18:05:51 <gmann> raildo ^^
18:06:03 <raildo> gmann, ops.. I forgot about this patch.. I'll send a new patch set until EOD
18:06:15 <raildo> gmann, do you have any suggestions for the docs side as well?
18:07:11 <gmann> raildo: i think i missed to review it, I will do it tomorrow and then you can update it together
18:07:21 <gmann> #action gmann to review https://review.opendev.org/#/c/743318/
18:07:42 <raildo> gmann, sounds good to me
18:07:59 <gmann> next is 'Migrate Default Policy Format from JSON to YAML'
18:08:11 <gmann> Oslo tool and other updates are now released
18:08:26 <gmann> I have finished the nova side work also
18:08:48 <gmann> I have added these two items here too - https://wiki.openstack.org/wiki/Consistent_and_Secure_Default_Policies_Popup_Team#Pre-work_to_provide_a_smooth_migration_path_to_the_new_policy
18:09:09 <raildo> gmann, awesome
18:09:19 <gmann> changing the policy_file default value from policy.json to policy.yaml is needed in all project side
18:09:31 <gmann> which we will cover and encourage projects to do in Wallaby cycle
18:09:43 <gmann> or at least before they switch to new policies
18:10:16 <raildo> gmann, do we have some docs on how to do it already?
18:10:52 <gmann> raildo: ve nova example but not doc. i think that is good idea
18:11:01 <gmann> i can work on that sometime
18:11:41 <raildo> gmann, yeah, I mean at least some tips on how to perform this change, or test if it worked after change to yaml...
18:11:41 <gmann> #action gmann to prepare the doc/steps to change the default value of policy_file to policy.yaml
18:11:59 <gmann> raildo:  yeah, key thing is to add the upgrade checks
18:12:15 <raildo> sure
18:12:16 <gmann> and yes test the things
18:12:36 <gmann> also i modified the wiki page to show the current progress in clear way - #link https://wiki.openstack.org/wiki/Consistent_and_Secure_Default_Policies_Popup_Team#Team_Progress
18:13:22 <gmann> #topic Review Requests
18:13:23 <gmann> Cyborg patches:
18:13:36 <raildo> cool, we should start the barbican work next week or so
18:13:46 <gmann> #link https://review.opendev.org/#/q/topic:policy-popup+(status:open+OR+status:merged)
18:13:56 <gmann> most of the patches are merged, it is great progress
18:14:03 <gmann> raildo: great
18:14:27 <raildo> gmann, I saw some nits on the release note patch but things looks great on the cyborg side
18:14:34 <gmann> raildo: what is process for barbican? spec first or direct policy changes
18:14:56 <gmann> raildo: nice, thanks for review i will also check the reno things it is imprtant
18:15:17 <raildo> gmann, we're defining the policy work on https://wiki.openstack.org/wiki/Barbican/Policy
18:15:27 <raildo> gmann, so I don't think we're going to need a spec for it
18:15:39 <gmann> ko, that work fine.
18:15:41 <gmann> ok
18:15:52 <raildo> gmann, and I already spoke with the PTL about it, so he'll be reviewing those patches as well
18:16:16 <gmann> nice,
18:16:55 <gmann> anything else on review request ?
18:17:15 <raildo> nothing that I'm aware of
18:17:20 <gmann> #Topic Open Floor
18:17:26 <gmann> PTG planning
18:17:40 <gmann> as you know, i have booked 2 slot for PTG
18:18:10 <gmann> its Monday 23.00-00 UTC and Tuesday 00--1.00 UTC in Havana room
18:18:33 <gmann> also added a proposal for Forum discussion
18:18:39 <gmann> this is Forum etherpad #link https://etherpad.opendev.org/p/consistent-and-secure-default-policies-wallaby
18:18:43 <raildo> awesome
18:19:00 <gmann> so we will collect the feedback from Forum and then discuss further in PTG slots
18:19:41 <gmann> also how we can adopt the new policy in horizon, amotoki has few ideas of that which will discuss in PTG also
18:20:31 <gmann> I will prepare etherpad for PTG too
18:20:55 <raildo> gmann, we should send an email to mailing list as a remind for the other services that will be planning to implement it on the next cycle
18:21:12 <gmann> raildo: +1, i will do today with etherpad up
18:21:35 <raildo> gmann, thanks sir
18:21:52 <gmann> anything on PTG side or any other topic to discuss ?
18:22:04 <raildo> nothing from my side
18:22:57 <gmann> let's close the meeting then
18:23:19 <gmann> thanks raildo for joining
18:23:20 <gmann> #endmeeting