17:08:03 <gmann> #startmeeting policy_popup
17:08:03 <opendevmeet> Meeting started Tue May  7 17:08:03 2024 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:08:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:08:03 <opendevmeet> The meeting name has been set to 'policy_popup'
17:08:13 <gmann> sorry for late, who all here today
17:08:27 <gmann> this is agenda for today #link https://etherpad.opendev.org/p/rbac-goal-tracking#L172
17:08:51 <gmann> gouthamr: I started here
17:09:39 <gouthamr> o/
17:09:49 * gouthamr ETOOMANYCHANNELS :D
17:10:05 <gmann> let's go through the agenda and then I will open it for any topic not misted in agenda
17:10:12 <gouthamr> ++
17:10:21 <gmann> #topic Previous meeting action item:
17:10:37 <gmann> we had vPTG and some action items from there
17:11:41 <gmann> I am going to list those action item and also in meeting agenda so that it will be easy to read/track them
17:11:44 <gmann> 1. Enable 'enforce_scope' by default:
17:12:02 <gmann> #link https://review.opendev.org/c/openstack/governance/+/915179
17:12:13 <gmann> ^^ the proposal and seeing no negative feedback on this
17:12:36 <gouthamr> yeah; i'm hoping a few more TC members take notice
17:12:49 <gmann> sure
17:12:52 <gmann> #link https://bugs.launchpad.net/keystone/+bug/2059780
17:13:30 <gmann> in parallel, takashi also testing the heat case and opened the keysotne bug ^^
17:13:56 <gmann> there were a few fix already merged in keystone side so I will check with him about status
17:14:13 <gmann> #action gmann to check with heat for enforce_scope removal testing
17:15:14 <gmann> 2. Domain Manager Persona: Luzi
17:15:29 <gmann> #link https://review.opendev.org/c/openstack/keystone-specs/+/903172
17:15:46 <gmann> spec is up and under review, seems positive response on this
17:15:52 <gmann> I have reviewed and lgtm
17:16:14 <gmann> 3. Global reader: johnthetubaguy
17:16:35 <gmann> john will propose the spec on this and we can wait until that is up
17:17:11 <gmann> those are all things we discussed in PTG
17:17:31 * gouthamr will review https://review.opendev.org/c/openstack/keystone-specs/+/903172
17:17:31 <gmann> #topic Reviews:
17:17:35 <gmann> thanks
17:17:51 <gmann> we have domain manager spec review in the list, which we already discussed
17:18:08 <gmann> #topic Open Discussion:
17:18:23 <gmann> gouthamr: we can discuss anything else you would like to bring today?
17:19:30 <gouthamr> nothing specific gmann; probably we can bounce your email on enabling the oslo.policy defaults per-project in their CI again to the ML
17:20:06 <gouthamr> its one of two things you were hoping to get done in https://review.opendev.org/c/openstack/governance/+/915179 ; and since we're at M-1, now's a better time to deal with breakages than later
17:20:49 <gouthamr> the manila change seemed relatively harmless
17:20:59 <gouthamr> #link https://review.opendev.org/c/openstack/manila/+/916025 ([manila] RBAC: Enable "new" defaults and scope checks)
17:21:01 <gmann> yes, as i checked most of them project who has implemented the phase-1 has enabled the new default by default or planning to do in this cyle
17:21:05 <gmann> thanks
17:21:30 <gmann> I implemented the phase-1 in tacker in previous release so I will check if we can enable them in this release or not
17:21:49 <gmann> I am keeping track of who all implemented phase 1 is enabling the new default or so
17:22:00 <gmann> Magnum also on candidate but need to check if they have done
17:22:35 <gmann> yes, they did #link https://github.com/openstack/magnum/blob/0737a157ddb4f0f0fd47320d809e5361a9c877e6/magnum/common/policy.py#L39
17:23:21 <gouthamr> nice
17:24:04 <gmann> I should target a few more projects to complete the phase-1 this cycle but have not planned yet
17:24:27 <gmann> +1 on manila change. thanks gouthamr for taking care of it
17:24:38 <gouthamr> ty for the review
17:24:46 <gouthamr> does this list need to change now?
17:24:59 <gouthamr> #link https://etherpad.opendev.org/p/rbac-goal-tracking#L143 (Project wise tracking of the goal status)
17:25:50 <gmann> gouthamr: those are release wise tracking. but overall status you can see here #LINK https://etherpad.opendev.org/p/rbac-goal-tracking#L26
17:25:53 <gmann> #link https://etherpad.opendev.org/p/rbac-goal-tracking#L26
17:25:57 <gouthamr> ah
17:26:18 <gmann> I think I should move release wise tracking data at the end
17:26:36 <gouthamr> np; i should start reading from the top instead :D
17:27:44 <gmann> gouthamr: done, check if that is clear
17:28:29 <gouthamr> gmann: looks good now
17:28:39 <gmann> cool
17:28:48 <gmann> anything else for today?
17:31:15 <gmann> ok if nothing else let's close the meeting. our next meeting will be on 21st May but I will be around to answer any query related to RBAC
17:31:20 <gmann> thanks gouthamr for joining
17:31:22 <gouthamr> ++ thanks gmann
17:31:25 <gmann> #endmeeting