19:00:51 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:51 <openstack> Meeting started Thu Aug 14 19:00:51 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:54 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:01:06 <amitgandhinz> #topic roll call
19:01:20 <amitgandhinz> hi, who is here for the Poppy meeting?
19:01:25 <malini> o/
19:01:28 <ametts> o/
19:01:29 <guimarin> hi from Fastly
19:01:49 <amitgandhinz> hi guimarin!
19:02:10 <guimarin> hi amitgandhinz!
19:03:32 <amitgandhinz> anyone else here for Poppy?
19:03:57 <megan_w_> o/
19:04:07 <catherine_r> ja!
19:05:01 <obulpathi> o/ obulpathi
19:05:04 <oz_akan> hi
19:05:28 <amitgandhinz> the agenda for today's meeting is here: #link: https://wiki.openstack.org/wiki/Meetings/Poppy#Agenda
19:05:39 <amitgandhinz> lets get started
19:05:44 <amitgandhinz> #topic introductions
19:06:04 <amitgandhinz> lets do a quick round of introductions....
19:06:12 <megan_w_> I'll go
19:06:23 <amitgandhinz> ok
19:06:23 <megan_w_> this is megan wohlford, i am a product manager at rackspace
19:06:41 <amitgandhinz> My name is Amit Gandhi.  I am the PTL for Poppy and also work at Rackspace
19:06:59 <malini> I am Malini Kamalambal - SDT @ Rackspace
19:07:12 <ametts> Allan Metts, Director of Engineering for Rackspace's Atlanta site
19:07:19 <megan_w_> maybe explain the acronyms :)
19:07:24 <catherine_r> Hi, I'm an information developer/technical writer at Rackspace.
19:07:25 <obulpathi> My name is Obul. I am a software engineer at Rackspace
19:07:44 * amitgandhinz PTL = Project Technical Lead
19:07:50 <malini> SDT is a Software Developer in Test ;)
19:08:42 <oz_akan> I am Oz
19:08:47 <guimarin> my name is michael guimarin Senior Sales Engineer/BD integrations Fastly CDN
19:09:48 <tonytan4ever> Hi I am Tony Tan, I am an SD with Rackspace.
19:10:22 <amitgandhinz> ok cool, i think thats everyone.  A lot of rackers =) and welcome guimarin from Fastly =)
19:10:44 <amitgandhinz> #topic Discuss how to get started with Poppy (wiki, gerrit, stack forge)
19:10:49 <obulpathi> welcome michael
19:10:55 <guimarin> thanks!
19:11:22 <amitgandhinz> so ive spent the last few days updating the wiki etc with getting started guides for stackforge/openstack, gerrit, and poppy
19:11:34 <amitgandhinz> has everyone had a chance to read the material put up so far?
19:11:53 <malini> yeap
19:11:59 <guimarin> yes
19:12:05 <obulpathi> most of it
19:12:06 <amitgandhinz> basically the idea is to have enough material for new contributors interested in poppy to get up and running as soon as possible
19:12:45 <amitgandhinz> does any one have any questions on how to get started with gerrit and stackforge?
19:13:19 <obulpathi> none from my side
19:13:21 <amitgandhinz> has everyone been able to sign up for a launchpad id etc
19:13:40 <obulpathi> yes from me
19:13:51 <malini> same here
19:13:58 <guimarin> i haven't done that yet, my directive was to figure out scope and what was required. your api's seem easy enough so i'm probably just going to see how far down the integration i can go before anyone notices. :)
19:14:56 <tonytan4ever> I am still learning and adapting to this gerrit workflow.
19:15:02 <amitgandhinz> haha ok.  let us know if you have any issues getting started with gerrit.  The system can be different to straight up github if you're not used to it
19:15:40 <amitgandhinz> ok lets move on to the next topic
19:15:41 <obulpathi> tonytan4ever: it took me some time to get used to gerrit too
19:15:47 <amitgandhinz> #topic Getting Started doc improvements
19:16:41 <amitgandhinz> What area's do you think we need to add to improve the getting started guides
19:16:59 <amitgandhinz> guimarin: since you have been reading up this material and are new to the project, any suggestions?
19:17:02 <catherine_r> I will edit what is there for RS and OS style guides.
19:17:21 <amitgandhinz> catherine_r: thanks!
19:17:46 <amitgandhinz> #action: catherine will edit existing Getting Started guides on wiki for RS and OS style guides
19:17:49 <catherine_r> via gerrit review
19:18:02 <megan_w_> amitgandhinz: are you referencing the wiki page?
19:18:16 <megan_w_> or a specific sub page?
19:18:26 <amitgandhinz> #link: https://wiki.openstack.org/wiki/Poppy
19:18:48 <catherine_r> Actually, I will start with this: https://review.openstack.org/#/c/113944/
19:18:56 <catherine_r> Then move to wiki.
19:19:20 <catherine_r> If that is OK.
19:19:36 <amitgandhinz> I am also currently working on getting those docs (referenced by catherine_r) so that they are served via readthedocs
19:19:37 <megan_w_> amitgandhinz: moving "meetings" to a link at the top might help.  i had a bit of trouble finding it
19:20:01 <amitgandhinz> #action move poppy/meetings higher up the page on the wiki
19:20:18 <obulpathi> +1 to moving meeting to higher
19:20:25 <obulpathi> Poppy User Guide link is broken on wiki
19:20:48 <amitgandhinz> obulpathi: that link needs to point to readthedocs once its available
19:21:00 <obulpathi> ok
19:22:21 <amitgandhinz> guimarin: any suggestions? or did you find you had enough useful info so far?
19:23:16 <megan_w_> we should put a graphic that illustrates the generic api and the plugins
19:23:21 <guimarin> amitgandhinz my experience so far is that things seem to be how they are in these types of projects
19:23:35 <guimarin> the metal meets the road so to speak when i try to connect our api with yours
19:23:37 <amitgandhinz> megan_w_: like this? #link: https://wiki.openstack.org/wiki/Poppy/Server_Architecture
19:23:51 <megan_w_> yep
19:24:09 <guimarin> but it looks simple enough that i don't think we should have a problem, that said, i'll jump into the poppy channel when we do
19:24:51 <amitgandhinz> guimarin: ok sounds good.  I plan to add some more docs explaining how the api's meet.  The code already has a prototyped fastly driver and we are about to start making it read
19:24:55 <amitgandhinz> s/read/real
19:25:35 <amitgandhinz> ok anything else on this topic before we move on?
19:26:10 <amitgandhinz> ok moving on...
19:26:13 <guimarin> oh that's great, if you even got one Fastly API call working, say view service
19:26:19 <guimarin> then we can replicate that pretty easily
19:26:35 <guimarin> i noticed the overlap in API calls you have listed is almost 100%
19:27:22 <amitgandhinz> yeh there are a lot of similarities - makes the integration easier =)
19:27:42 <amitgandhinz> ok moving on....
19:27:47 <amitgandhinz> #topic: General Guidelines for contributing to OpenStack
19:28:15 <amitgandhinz> is everyone familiar with contributing code the openstack way?
19:28:29 <amitgandhinz> #link: https://wiki.openstack.org/wiki/Poppy/Contributing
19:28:45 <guimarin> yes
19:28:54 <amitgandhinz> #link: https://wiki.openstack.org/wiki/How_To_Contribute
19:28:58 <malini> yes..it'll get easy over time
19:29:12 <obulpathi> yes
19:29:13 <megan_w_> amitgandhinz: any rules on +1s?
19:29:28 <megan_w_> meaning, any limits to getting things reviewed before they are incorportated?
19:29:35 <megan_w_> incorporated *
19:29:41 <amitgandhinz> we need at least two +1's from anyone, and at least one +2 from a core reviewer
19:29:48 <amitgandhinz> currently i am the only core reviewer ;-)
19:30:02 <guimarin> haha
19:30:04 <megan_w_> nice
19:30:19 <malini> bribing amitgandhinz is the way to go ;-)
19:30:27 <obulpathi> hahaha
19:30:31 <amitgandhinz> does the team feel we need another core reviewer at this stage?
19:30:37 <tonytan4ever> so one core view will give +2 instead of +1 ?
19:30:39 <amitgandhinz> i have the power muwahahaha
19:31:00 <amitgandhinz> core reviewers can choose to give a +1 or +2
19:31:01 <obulpathi> I think once core reviewer is enough for now
19:31:14 <malini> one is bad enough!
19:31:45 <amitgandhinz> ok, i think as our contributors grow, or i get too slow at reviewing, we can revisit adding another core
19:31:45 <tonytan4ever> I have no problem with the number of core viewers.
19:32:04 <obulpathi> if people participate actively and contribute, then probably we can propose their name as a core reviewer
19:32:22 <obulpathi> s/if/when
19:32:26 <amitgandhinz> obulpathi: agreed
19:32:39 <amitgandhinz> ok moving on to the juicy topic =)
19:32:43 <amitgandhinz> #topic: Reseller Model (how do providers recommend setting up a Reseller Model for thousands of customers)
19:32:58 <amitgandhinz> so this question came up in day to day Poppy discussions....
19:33:17 <amitgandhinz> Since poppy basically works as a reseller model (where the deployer of poppy is the reseller)
19:33:35 <amitgandhinz> how do customer services get provisioned
19:33:45 <amitgandhinz> ie do we lump all customers into a master account
19:34:01 <amitgandhinz> or do we provision multiple customer accounts somehow that is still manageable by the master account
19:34:14 <amitgandhinz> guimarin: do you have insight into this from Fastly's point of view?
19:34:25 <guimarin> yes
19:34:27 <guimarin> haha
19:34:41 <guimarin> so we have a contract in place right now that should cover the business metrics of this
19:34:47 <obulpathi> we would like some insight especially from the point of view of authentication, logging, billing, limits
19:34:47 <guimarin> but how the actual technical integration works
19:35:19 <guimarin> It's easiest to do these things with seperate services per customer
19:35:46 <oz_akan> lets make all core contributors core reviewers? there aren't many at the moment, people can vote +1 as long as Amit is arond
19:35:49 <amitgandhinz> so one service per customer?
19:36:07 <guimarin> hmm
19:36:12 <guimarin> well let's do a thought experiment
19:36:15 <guimarin> if we do one service
19:36:19 <guimarin> and lump all the customers into it
19:36:29 <guimarin> seperating out logs, and billilng by customer is going to be tricky
19:36:42 <amitgandhinz> you mean one customer and all services in that customer?
19:36:58 <obulpathi> also .. some cdn providers have manual steps to activate and enable some features
19:37:10 <obulpathi> this will be little tricky to do programatically
19:37:25 <guimarin> i can only speak for fastly, and everything we have is API accessible, so for us at least, that isn't a blocker
19:37:32 <chrisueland> hi.  Chris from MaxCDN here
19:37:46 <obulpathi> hi Chris, welcome to poppy :)
19:37:49 <chrisueland> hi hi
19:37:52 <malini> hello chrisueland
19:37:57 <amitgandhinz> hi chrisueland!
19:37:58 <tonytan4ever> Hi Chris, I was looking for the MaxCDN guy.
19:38:09 <chrisueland> hey guys! sorry I'm late.  how's it going so far?
19:38:42 <megan_w_> so far so good.  we're on the topic creating lots of customers, in the 15k-20k range
19:38:52 <amitgandhinz> its good.  we are currently discussing the reseller model and how to provision thousands of customer services (one account with many services, or one service per account)
19:38:56 <megan_w_> should they all have seperate zones/services/etc
19:38:58 <amitgandhinz> in maxcdn service = pullzone
19:39:05 <tonytan4ever> A MaxCDN's normal user account only supports 2 Pull zones, and each pull zone only support 1 origin.
19:39:21 <tonytan4ever> Correct me if I'm wrong chris.
19:39:24 <chrisueland> right on - (hey megan)
19:39:31 <chrisueland> It's unlimited, just depends on the pkg
19:39:36 <amitgandhinz> tonytan4ever: lets hold off on your question for now
19:40:34 <megan_w_> so if an operator like rackspace wants to launch poppy.  how they they provision each of their cusotmres?  a new account for each one?
19:40:46 <megan_w_> or a single account with tons of services/pullzones
19:41:25 <megan_w_> my hunch is that a service/pullzone for each customer is the right call
19:41:34 <megan_w_> all under a single "reseller" account
19:41:40 <megan_w_> does that align?
19:42:43 <guimarin> 1 service
19:42:45 <guimarin> per customer
19:42:49 <guimarin> rackspace single account
19:42:51 <guimarin> for Fastly
19:43:23 <guimarin> let's go with that for now
19:44:06 <amitgandhinz> guimarin: with fastly, is there an api to create a customer within a master account?
19:44:09 <chrisueland> we have a couple of ways to do it: 1) have a CDN Manager account for Rackspace, and then sub users
19:44:27 <guimarin> amitgandhinz not at this time
19:44:38 <chrisueland> or have a CDN account for Rackspace w/ zone(s) per customer
19:44:42 <obulpathi> +1 for master account
19:44:54 <guimarin> ^^ +1
19:44:57 <obulpathi> it makes handling credentials easy
19:45:15 <guimarin> yes i agree, i'd like to see it
19:45:36 <obulpathi> also it provides the separation of concerns like logging, billing and other
19:45:39 <guimarin> if that's where we want to move, then we should have customer accounts with their service, so 1:1, denote they are rackspace, and then move them over
19:45:56 <guimarin> so in this case 20k customers each with 1 service, or really N services
19:46:03 <amitgandhinz> yeh that would be nice.  feels safer from a security standpoint too
19:46:37 <megan_w_> so we're leaving towards the master account/sub account model
19:46:48 <chrisueland> our "hosting platform" or reseller system is called CDN Manager
19:47:05 <amitgandhinz> #action: amitgandhinz to look into CDN Manager
19:47:10 <chrisueland> and it supports full sub accounts/branding/aggregate stats/admin functions
19:47:43 <chrisueland> kind of like WHM if you're familiar w/ Cpanel
19:47:50 <amitgandhinz> guimarin: im guessing you will need to go back to your team to see when/how fastly could support this?
19:48:05 <obulpathi> chrisueland: is everything an API for subaccounts? or are there any manual steps needed?
19:48:07 <amitgandhinz> chrisueland: does CDN Manager have an API?
19:48:16 <amitgandhinz> obulpathi: nice
19:49:03 <oz_akan> amitgandhinz: now, are we going to expect every provider to support master account model in order poppy to support that provider?
19:49:18 <amitgandhinz> ok sounds like we are all leaning towards master account/sub accounts model
19:49:20 <guimarin> amitgandhinz, that's the direction we were going with these partnerships
19:49:32 <chrisueland> it is, but I don't see it on the main docs.  I'll take an action item to get the url for the docs.
19:49:37 <amitgandhinz> oz_akan: maybe we can make the provider implementation smart enough to toggle with or without it?
19:49:43 <guimarin> we have everything in place but the ability for the master account to have credentials on all the sub accounts
19:49:55 <amitgandhinz> guimarin: cool
19:50:08 <guimarin> which granted is the important part, but it's not primetime yet, let me circle back with the team and check our priorities
19:50:12 <obulpathi> guimarin: sweet
19:50:16 <megan_w_> taking this one step further...
19:50:23 <megan_w_> should Poppy assume the master account already exists?
19:50:28 <megan_w_> and just ask for credentials
19:50:30 <oz_akan> amitgandhinz: I think that should be the default to start with
19:50:36 <megan_w_> then create sub accounts programatically?
19:50:41 <oz_akan> should / might
19:50:53 <amitgandhinz> Poppy would need to own those subaccounts also
19:51:08 <guimarin> megan_w_ with fastly right now we'll probably give an API endpoint on creation to designate a rackspace account, so that when we get the master account working properly we can pull them all in at once
19:51:22 <guimarin> s/poppy/rackspace
19:51:31 <megan_w_> ok
19:51:45 <oz_akan> can't pappy hold master / sub account logic?
19:51:46 <amitgandhinz> ok cool
19:51:50 <megan_w_> i would think if we got this route, we'll also needs calls like "list all subaccounts"
19:52:01 <megan_w_> go*
19:52:10 <megan_w_> sorry, my typing gets worse every day
19:52:18 <amitgandhinz> we have 9 minutes left, which i want to use for open questions - i think tonytan4ever had one for chrisueland
19:52:29 <amitgandhinz> we can carry this conversation over to the #poppy channel
19:52:35 <amitgandhinz> #topic open discussion
19:52:42 <amitgandhinz> tonytan4ever: you are up
19:53:17 <tonytan4ever> How does CDN manager's API differ from a normal account's API ?
19:53:35 <obulpathi> to add to the subaccounts topic: CloudFront (or AWS) supports AMI ... which *I think* works in a similar way .. need to investigate more on thsi
19:53:44 <amitgandhinz> #info leaning towards master account/sub account model but will need to support providers without master account concept
19:53:46 <chrisueland> tonytan4ever:  CDN Manager can be what we call a Master Brand
19:54:20 <obulpathi> +1 for support with out master account concept
19:54:21 <chrisueland> tonytan4ever:  and the Master Brand can create Accounts, the Accounts have Zones
19:54:37 <tonytan4ever> Ok.
19:54:46 <chrisueland> tonytan4ever: So, for example: VPS.net is a Master Brand, and they have thousands of users (think MaxCDN accounts) inside their Master Brand
19:55:19 <tonytan4ever> and also Masters can access each subaccounts ?
19:55:25 <chrisueland> tonytan4ever: They can add users, change passwords, view aggregate stats, login as a client (if they have permission), pay their bill as a provider (and then bill their clients how ever they do it)
19:55:33 <megan_w_> nice
19:55:36 <chrisueland> tonytan4ever: yes, that is the default behavior that's been requested so far
19:55:47 <amitgandhinz> cool, we will need to dig into it later
19:55:49 <chrisueland> tonytan4ever: not sure if there's a toggle for it
19:56:08 <tonytan4ever> That's good for us. Also each MaxCDN pullzone only support 1 origin, correct ?
19:56:09 <amitgandhinz> #action: dig into MaxCDN CDN Manager API for Master/Sub Accounts
19:56:12 <chrisueland> tonytan4ever: we don't have the API docs public because it's traditionally been a more hands on configuration - but everything's available through the API
19:56:22 <tonytan4ever> cool
19:57:03 <chrisueland> tonytan4ever: the final note is we can brand a CP as a customer.  ie: VPS.net looks like their brand - has a vps.net URL for the CP, custom SSL cert, etc
19:57:54 <amitgandhinz> 3 minutes remaining
19:58:07 <chrisueland> tonytan4ever: ie: you can see the customized login page here http://cdn.vps.net
19:58:22 <tonytan4ever> The 1 origin for one pullzone scheme is a little bit different than other CDN provider
19:58:43 <chrisueland> tonytan4ever: what do you mean?
19:59:23 <tonytan4ever> I mean if I go to MaxCDN control panel, I create a pullzone there, and I can only specify one origin for that pull zone.
19:59:46 <chrisueland> tonytan4ever: are you talking about round robin? or sharding on path?
19:59:54 <amitgandhinz> we have noticed that fastly and cloudfront support multiple origins in the service/distribution
20:00:05 <amitgandhinz> then you can specify rules to those origins
20:00:11 <amitgandhinz> ok time is up
20:00:11 <megan_w_> sharding on path is the idea
20:00:13 <tonytan4ever> fastly can do round bin too.
20:00:14 <megan_w_> ah
20:00:17 <amitgandhinz> lets continue in the #poppy channel
20:00:18 <chrisueland> yeah, we have all that too
20:00:19 <megan_w_> ok
20:00:21 <chrisueland> it's called EdgeRules
20:00:26 <chrisueland> and needs to be enabled per account
20:00:35 <amitgandhinz> #endmeeting