19:00:09 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:11 <openstack> Meeting started Thu Aug 28 19:00:09 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:14 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:32 <amitgandhinz> #topic roll call
19:00:43 <amitgandhinz> welcome, who do we have today for the poppy meeting?
19:00:53 <obulpathi> 0/
19:00:58 <obulpathi> o/
19:01:00 <guimarin> guimarin from fastly
19:01:16 <Fred-MaxCDN> Fred from MaxCDN
19:01:36 <obulpathi> hi guimarin
19:01:41 <obulpathi> hi Fred
19:01:46 <amitgandhinz> hey guimarin and Fred-MaxCDN !
19:01:53 <malini1> o/
19:01:53 <guimarin> hi all!
19:02:12 <Fred-MaxCDN> Hey Guys
19:02:26 <tonytan4ever> me here...
19:02:32 <tonytan4ever> Hi Fred.
19:02:49 <tonytan4ever> Hi guimarin
19:02:53 <amitgandhinz> ok, most of us are here
19:03:06 <amitgandhinz> fyi megan_w is out the next couple of meetings
19:03:38 <amitgandhinz> #topic Review last weeks action items
19:03:51 <amitgandhinz> following the agenda here: #link: https://wiki.openstack.org/wiki/Meetings/Poppy#Next_meeting
19:04:08 <amitgandhinz> #link: http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-08-21-19.02.html
19:04:28 <amitgandhinz> so action items from last week, going down the list...
19:04:48 <amitgandhinz> 1.  amitgandhinz to investigate MaxCDN CDN Manager API for master/sub accounts
19:05:01 <amitgandhinz> i still havent had the chance to do that, sorry
19:05:27 <amitgandhinz> i'll add it on to my todo for the next week.
19:05:49 <amitgandhinz> #action: amitgandhinz to investigate MaxCDN CDN Manager API for master/sub accounts
19:06:13 <amitgandhinz> related to this, guimarin - do you have any updates on the fastly side around master/sub accounts
19:06:25 <amitgandhinz> iirc some work had been done, and you were working on exposing apis?
19:06:40 <guimarin> just a second, had to put sandwich down
19:06:56 <guimarin> so have you guys got into contact with the other divs in rackspace about Fastly
19:07:12 <guimarin> my understanding since going back to my team is that you're building out an account management system on your side
19:07:24 <guimarin> using our existing api's
19:07:38 <guimarin> i can have edwardb who just joined reach out to megan_w about this
19:07:46 <amitgandhinz> im not aware of those discussions.
19:07:54 <guimarin> edward-fastly can you comment on that
19:08:03 <amitgandhinz> ok please cc me on that email also - megan_w is out for then next 10 days
19:08:07 <catherine_r> Here - a little late - sorry.
19:08:18 <obulpathi> hi catherine_r
19:09:12 <amitgandhinz> #action guimarin, edward-fastly, and amitgandhinz to look into what "building out an account management system" is about.
19:09:31 <amitgandhinz> guimarin: ok we can take that offline
19:09:35 <guimarin> sounds good
19:09:36 <guimarin> thanks
19:09:55 <amitgandhinz> ok next action item: amitgandhinz to investigate bp permissions
19:10:18 <amitgandhinz> after working with obul we found that anyone can create a bp.  to be assigned a bp in launchpad, only the PTL can assign work
19:10:35 <amitgandhinz> are there any other questions around this item?
19:10:48 <obulpathi> FYI: we can edit the whiteboard, link bug reports etc to a bp
19:11:00 <obulpathi> I think this is mostly what we need
19:11:16 <tonytan4ever> Seems developer cannot change the state of a BP.
19:11:17 <amitgandhinz> basically assignment is done by the PTL as they are the one who sets the direction of the project
19:12:00 <amitgandhinz> tonytan4ever: agreed.  its a little annoying, but basically the PTL has to change the state also.  Through these meetings and other discussions in the #openstack-poppy channel
19:12:17 <amitgandhinz> ok item 3 is the same as 2
19:12:29 <amitgandhinz> 4) obulpathi to get on the atlanta openstack meetup schedule for poppy
19:12:35 <amitgandhinz> obulpathi: can you please comment on that
19:12:51 <obulpathi> So I had a discussion with the organizers of the local openstack meetup
19:13:07 <obulpathi> I proposed the poppy meeting for october 16
19:13:30 <obulpathi> to discuss about poppy architecture and what it means for openstack and to gather early feedback from openstack users
19:13:38 <obulpathi> its still going on
19:13:48 <obulpathi> only one organizer has responded so far
19:14:08 <edward-fastly> hey amitgandhinz are you saying megan is out today and for 10 more days?
19:14:13 <obulpathi> I will keep bugging them and schedule the talk
19:14:39 <amitgandhinz> edward-fastly: megan_w returns on Sep 9
19:14:53 <obulpathi> thats it for now on action item 4
19:15:02 <amitgandhinz> ok thanks obulpathi
19:15:22 <amitgandhinz> #action: obulpathi to keep bugging the atlanta openstack meetup organizers to get on the schedule
19:15:34 <obulpathi> got it
19:16:00 <amitgandhinz> #topic: Updates on Blueprints and Bugs
19:16:15 <amitgandhinz> #link: https://blueprints.launchpad.net/poppy
19:16:48 <amitgandhinz> how is the progress on bp/create-service, tonytan4ever
19:17:21 <tonytan4ever> I just finished design discussion and started coding since yesterday.
19:17:40 <amitgandhinz> ok, i'll leave the state as started
19:17:49 <tonytan4ever> Sounds good to me.
19:18:09 <amitgandhinz> #link: https://blueprints.launchpad.net/poppy/+spec/flavors
19:18:19 <amitgandhinz> this one is in review
19:18:38 <obulpathi> will review it
19:18:39 <amitgandhinz> could use some review love
19:18:42 <amitgandhinz> thanks obulpathi
19:18:50 <obulpathi> :)
19:19:09 <tonytan4ever> #link: https://blueprints.launchpad.net/poppy/+spec/poppy-models
19:19:18 <amitgandhinz> poppy-models: https://blueprints.launchpad.net/poppy/+spec/poppy-models
19:19:19 <tonytan4ever> this one is under review as well.
19:19:50 <tonytan4ever> I got a few review comments, and I will address them ASAP.
19:20:16 <amitgandhinz> ok thanks tonytan4ever.  i had posted a large comment there.  did those make sense?
19:20:24 <tonytan4ever> Yes.
19:20:48 <amitgandhinz> Ok cool.  let me know if you need more discussion on this.  we can talk about it in the normal channel
19:21:18 <amitgandhinz> #link: https://blueprints.launchpad.net/poppy/+spec/add-docstrings
19:21:19 <tonytan4ever> Sure.
19:21:29 <amitgandhinz> ametts doesnt appear to be in the room
19:21:40 <amitgandhinz> doesnt appear to be started yet
19:21:54 <amitgandhinz> #link: https://blueprints.launchpad.net/poppy/+spec/health
19:21:59 <amitgandhinz> obulpathi: any update on this
19:22:04 <obulpathi> health end point is almost done
19:22:24 <obulpathi> I got side tracked due to opencafe bug and cassandra testing
19:22:44 <amitgandhinz> ok, lets try to get this one done (avoid sidetracking if possible lol)
19:22:44 <obulpathi> so the status is still the same for that bp
19:22:47 <amitgandhinz> ok
19:22:55 <obulpathi> sure .. will get it done asap
19:23:01 <amitgandhinz> do you have what you need to check for the health of provider api's?
19:23:35 <obulpathi> right now I am just hitting cloudfront uri and checking if its alive
19:23:44 <obulpathi> I need to do the same thing to fastly and maxcdn
19:24:19 <obulpathi> I have not investigated that part yet
19:25:00 <amitgandhinz> guimarin: Fred-MaxCDN: do your api's have a health endpoint to check if your api's are up and behaving?  *i havent looks at the docs on that yet
19:25:13 <amitgandhinz> s/looks/looked
19:25:24 <guimarin> you can subscribe at status.fastly.com
19:25:28 <guimarin> for that information
19:25:54 <obulpathi> oh cool
19:25:59 <obulpathi> I will check that
19:26:02 <guimarin> we use a third party service, but they have a 'webhook'
19:26:03 <obulpathi> thanks guimarin
19:26:07 <guimarin> interface that you can have a deamon on
19:26:25 <amitgandhinz> obulpathi: the rss feed maybe the way to go #link: http://status.fastly.com/history.atom
19:26:37 <guimarin> right if you want to scrape it
19:26:42 <obulpathi> ok
19:26:44 <guimarin> but we have the ability to notify by email, sms
19:26:45 <guimarin> etc.
19:26:51 <guimarin> but if you go to the webhook notification
19:26:55 <Fred-MaxCDN> we have it on staus.maxcdn.com but we can add historical data if you wish
19:26:57 <guimarin> they will looks like send you a json call
19:27:38 <amitgandhinz> guimarin: cool.
19:27:48 <amitgandhinz> Fred-MaxCDN: is the a programmatic way to access the status?
19:27:50 <obulpathi> thanks Fred-MaxCDN. will look in to status.maxcdn.com
19:27:55 <guimarin> and it looks like maxcdn has the same service as fastly
19:28:04 <guimarin> looks like they just need to enable that same json webhook thingy
19:28:12 <amitgandhinz> fyi this is something that would be used by an operator to check all systems that poppy talk to are operating optimally
19:28:56 <amitgandhinz> ok cool, they both look similar
19:29:21 <obulpathi> great
19:29:23 <amitgandhinz> alright, lets move on to the next topic
19:29:31 <Fred-MaxCDN> yes we have it. I need to get the public page up for you guys
19:29:51 <amitgandhinz> #topic Load Testing tools and Best Practices
19:30:34 <amitgandhinz> ok, what we are looking to do is deploy a bunch of different websites for testing (static sites, word press sites, file download sites, etc)
19:30:58 <amitgandhinz> then enable CDN on them using Poppy with the various providers
19:31:24 <amitgandhinz> then load test those sites to ensure that the cdn configurations are set up correctly and the cdn providers are handling the traffic at the edge
19:31:38 <amitgandhinz> there are a number of tools out there, which malini1 is starting to investigate
19:32:01 <malini1> when you say load test, do you mean accessing from servers around the world?
19:32:07 <amitgandhinz> i am interested to hear from guimarin and Fred-MaxCDN on their recommended approaches
19:32:11 <amitgandhinz> malini1:  yes
19:32:26 <guimarin> so do you mean for setting up services or for testing them?
19:32:45 <amitgandhinz> so accessing the sites from around the world, and also hitting the sites hard enough to ensure the edge is serving the traffic etc
19:33:08 <amitgandhinz> guimarin: testing that the service was configured correctly and that the provider is doing what its supposed to
19:33:15 <amitgandhinz> eg honoring restrictions/conditions
19:33:17 <malini1> I am looking at http://www.webpagetest.org/, & seems like fastly/maxCDN already partner with them
19:33:21 <amitgandhinz> actually service content from the edge
19:33:26 <amitgandhinz> s/service/serving
19:33:37 <guimarin> right so those are two seperate things
19:33:41 <Fred-MaxCDN> we can use load impact , also catchpoint for global availability
19:34:24 <malini1> Fred-MaxCDN: are those opensource tools?
19:34:34 <Fred-MaxCDN> no
19:34:35 <guimarin> right so checking that the CDN is working is different from how well is the CDN working
19:34:38 <guimarin> what i typically do is this
19:35:03 <guimarin> https://gist.github.com/guimarin/9280636
19:35:09 <guimarin> and piont it at the CDN and the origin
19:35:30 <guimarin> now you can get fancier if you want to spend money, but i find running this on VPSs around the world give me a pretty good idea
19:35:46 <malini1> guimarin: what is a VPS?
19:35:54 <guimarin> virtual private server
19:36:03 <guimarin> linode/digital ocean/ec2
19:36:04 <guimarin> etc
19:36:18 <malini1> thanks!
19:37:05 <amitgandhinz> ok so that will help in testing the conditions from geo's etc
19:37:08 <amitgandhinz> very cool
19:37:10 <amitgandhinz> and simple!
19:37:20 <malini1> guimarin: do u have any recommendation on how the VPSs are geographically distributed etc.?
19:37:44 <guimarin> so the thing about this
19:37:50 <guimarin> is that testing is done by like 4 companies
19:37:58 <guimarin> and it's really easy to er, modify the tests
19:38:06 <guimarin> so that' swhy i have this oss script
19:38:06 <amitgandhinz> malini1: i think we would just spin up servers with a range of providers around the world depending on what we are testing
19:38:08 <guimarin> that people can use
19:38:29 <guimarin> what you really want is a huge Real user metrics RUM setup
19:38:54 <guimarin> i fyou want to do comparisons, etc.
19:39:13 <guimarin> bc then you see what actual users see, but the apachebenchmark test is free to set up and cheap to run on your own
19:39:21 <malini1> I will ping you with more questions in #openstack-poppy
19:39:23 <guimarin> if you guys want some more info on this we can take it offline
19:39:32 <amitgandhinz> im assuming if we didnt have RUM then we would have to have enough load generators and be careful of generating hotspots
19:39:38 <malini1> I am familiar with ab, but just need to figire out the geo part
19:40:11 <guimarin> so webpagetest is another really interesting tool, but it also needs to have some toggles toggled to get something that you want as opposed to the default
19:40:34 <malini1> webpagetest looked really interesting -mainly because of the geo footprint
19:40:49 <Fred-MaxCDN> I used to use multiple vps boxes but at most I could cover 10 or 20 location , it is good when you deal with large file delivery but for small file you need more locations.
19:41:15 <guimarin> yes it's open source and our cpo steve sauders says it's the best middle ground for people that want to run tests on verifiable systems
19:41:31 <guimarin> we also look at cedexis and catch point but you have topay for them
19:41:45 <guimarin> and their methodology needs to be understood so you undestand the limits of the test
19:41:55 <guimarin> eg. if the testing box is in teh same data center as the CDN pop it's kind of useless
19:42:32 <amitgandhinz> ok, malini1 do you have enough info on this topic, we can talk about it more in the normal channel
19:42:38 <malini1> thanks guimarin & Fred-MaxCDN!
19:42:45 <amitgandhinz> yup thanks, really useful info!
19:42:46 <malini1> yes amitgandhinz
19:42:59 <Fred-MaxCDN> sure thing
19:43:02 <amitgandhinz> #topic: Log Delivery
19:43:14 <amitgandhinz> ok, so this is a topic that i have started to investigate
19:43:49 <amitgandhinz> basically i am looking at how the various providers are distributing the logs (so that poppy can retrieve them), and later use for both analytics, and metering
19:44:29 <amitgandhinz> so far i have looked at fastly, maxcdn, and cloudfront api's
19:44:43 <amitgandhinz> cloudfront dumps their logs into S3 buckets
19:45:03 <amitgandhinz> fastly has a range of options (S3 included) - do you plan to support Swift/CloudFiles
19:45:07 <guimarin> Fastly: under the model we discussed, each customer with themselves seperate and their own service, each can stream real-time logs via syslog ( about 1s latency ) to a your endpoint, a bunch of third party endpoints, or over FTP ( minimum 1min latency ) to the same sinks.
19:45:21 <amitgandhinz> and maxcdn appears to have a realtime api to query and get back a json response
19:45:38 <Fred-MaxCDN> we also have the s3 option
19:45:54 <amitgandhinz> Fred-MaxCDN: ah, thanks i didnt see that option
19:45:55 <tonytan4ever> sweet, real time analytics.
19:46:11 <guimarin> supporting cloudfiles is the goal
19:46:44 <amitgandhinz> I think with poppy, it needs to be flexible on the sinks it provides, as each provider is bound to be different
19:47:00 <obulpathi> +1
19:47:06 <amitgandhinz> s3 is definitely a common one i am seeing
19:47:23 <guimarin> looking at the roadmap there is a DNS issue that needs to be resolved  before we add cloudflies
19:47:50 <amitgandhinz> my concern with providing an endpoint for syslog to stream to is the amount of info that will be streamed
19:48:10 <amitgandhinz> guimarin: do you have data on the size of each log that is streamed?
19:48:52 <guimarin> that depends on how much you get to add
19:48:58 <guimarin> the logs are just apache common format logs
19:49:02 <guimarin> just streamed using syslog
19:49:07 <amitgandhinz> true, i saw the format options
19:49:46 <guimarin> but back to the other point, i think defaulting to S3 FTP or similar is probably a good diea, but i would give people the option to do syslog streaming if they wanted
19:50:04 <amitgandhinz> hmm...i will have to talk to our ops folks on the streaming concept though
19:50:04 <guimarin> especially if s3 support is so widespread thorugh all the providers
19:50:13 <amitgandhinz> i like the concept, im just concerned about how fat the pipe will be
19:50:37 <guimarin> tha'ts reasonable, it will also be as fat as the # of qps
19:50:54 <guimarin> let me tell you the guys doing 10k qps are certainly getting a lot of logs
19:52:04 <amitgandhinz> ok, i will talk to our ops team, but we can experiment with this
19:52:15 <amitgandhinz> im only at the beginning of looking at the logging story
19:52:19 <Fred-MaxCDN> gzipping the logs before shoot could help
19:52:27 <amitgandhinz> but im getting a good idea about it
19:52:39 <amitgandhinz> Fred-MaxCDN: do you guys have plans to support CloudFiles/Swift also?
19:53:10 <obulpathi> +1 for zipping logs
19:53:11 <Fred-MaxCDN> I need to check the dev roadmap
19:54:34 <amitgandhinz> ok we have 5 minutes left...
19:54:34 <guimarin> just fyi fastly ftp log transfer which is one of the options we're discussing, currently supports gziping up to level 9
19:54:59 <guimarin> same with s3
19:55:19 <amitgandhinz> cool.
19:55:22 <amitgandhinz> that will def helpt
19:55:29 * amitgandhinz really cant type today
19:55:43 <amitgandhinz> ok lets move on to the last agenda item
19:55:53 <amitgandhinz> #topic: switching PUT to POST
19:56:08 <amitgandhinz> so i kind of thought about this yesterday and am interested in feedback
19:56:24 <amitgandhinz> currently when we PUT /service with pass the servicename in both the url and the body
19:56:27 <amitgandhinz> seems redundant
19:56:39 <amitgandhinz> its in the body to keep consistent with the GET which will return the servicename
19:56:50 <amitgandhinz> same applies to /flavors
19:57:05 <amitgandhinz> i propose we change it to POST /v1.0/services
19:57:13 <amitgandhinz> and pass the servicename in the body
19:57:26 <amitgandhinz> let the server decide the location (which will end up being v1.0/services/servicename
19:57:39 <amitgandhinz> and then we no longer have duplication
19:57:42 <amitgandhinz> thoughts?
19:57:52 <tonytan4ever> +1 for change to POST with a shortened url.
19:58:12 <obulpathi> looks like a good idea
19:58:35 <amitgandhinz> malini1: ??
19:58:58 <amitgandhinz> ok 1 minute remaining =P
19:58:58 <obulpathi> will get be GET /services/servicename?
19:59:03 <amitgandhinz> obulpathi: yes
19:59:09 <obulpathi> ok
19:59:35 <amitgandhinz> ok i will document the change then
19:59:45 <amitgandhinz> i will take malini1's silence as a vote for it =P
19:59:50 <obulpathi> hahaha
19:59:57 <amitgandhinz> ok time is up
20:00:04 <amitgandhinz> thanks everyone, that was a lot to cover today
20:00:09 <amitgandhinz> was very productive and helpful
20:00:15 <amitgandhinz> #endmeeting