19:00:16 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:16 <openstack> Meeting started Thu Sep  4 19:00:16 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:19 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:38 <amitgandhinz> #topic rollcall
19:00:42 <malini> o/
19:00:47 <amitgandhinz> hi Poppy folks!
19:00:53 <amitgandhinz> who do we have here for the poppy meeting today?
19:00:59 <mikehn> <-
19:01:11 <tonytan4ever> Yo.
19:01:19 <catherine_r> o/
19:01:20 <oz_akan> hello
19:01:53 <obulpathi> o/
19:02:09 <oz_akan> hi obulpathi
19:02:14 <oz_akan> long time no see
19:02:19 <obulpathi> you are so fast!
19:02:30 <obulpathi> oz_akan: ^
19:02:38 <ametts_> o/
19:03:32 <oz_akan> obulpathi: should I get the blue pill?
19:03:36 <amitgandhinz> anyone from fastly/maxcdn/akamai today?
19:04:42 <obulpathi> oz_akan: sorry, I already took the red pill.
19:04:54 <amitgandhinz> mikehn: since you are new here, could you give another quick intro like you did on the #openstack-poppy channel
19:05:17 <malini> oz_akan, obulpathi: I know this is the poppy meeting, but can you stop talking pills?
19:05:29 <malini> hello mikehn!
19:05:42 <oz_akan> )
19:05:44 <oz_akan> :)
19:06:32 <tonytan4ever> Hello mikehn, it's a pleasure to see you here.
19:06:55 <nitin__> Another new guy to #openstack-poppy channel.
19:07:02 <malini> hello nitin__!
19:07:06 <amitgandhinz> ah yes nitin__, welcome!
19:07:07 <nitin__> Hello,
19:07:14 <amitgandhinz> can we get a quick intro from you too
19:07:14 <nitin__> thanks !
19:07:20 <nitin__> Sure
19:07:26 <obulpathi> hello there nitin__
19:07:50 <nitin__> Nitin Agarwal ,  Software Developer and Programmer pursuing B.tech (Computer science)
19:08:13 <nitin__> I had spent my Summer 2014 at CERN, European Organisation for Nuclear Research.
19:08:48 <amitgandhinz> welcome =)
19:08:49 <obulpathi> nitin__, where do you study?
19:08:52 <malini> glad to have you here nitin__!
19:08:55 <nitin__> Evaluated Orchestrating Docker on OpenStack.
19:09:17 <nitin__> obulpathi: International Institute of Information Technology Hyderabad, INDIA.
19:09:52 <obulpathi> nitin__: cool, welcome to Poppy
19:09:56 <amitgandhinz> cool.  welcome to the team nitin__
19:09:56 <mikehn> amitgandhinz: sure
19:10:26 <nitin__> at cern, http://openlab.web.cern.ch/about/people/nitin-agarwal
19:10:38 <mpanetta> Would love to visit CERN one day.
19:10:49 <nitin__> thanks amitgandhinz obulpathi
19:11:13 <oz_akan> welcome nitin__
19:11:15 <mikehn> <- Michiel, product management at Hibernia Networks, responsible for ip,ethernet & cdn
19:11:21 <nitin__> oz_akan: thanks !
19:11:38 <amitgandhinz> thanks mikehn
19:11:54 <amitgandhinz> ok, lets move on, a few topics to get through today
19:12:10 <amitgandhinz> #topic: Review last weeks action items
19:12:19 <amitgandhinz> #link: http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-08-28-19.00.html
19:12:42 <amitgandhinz> ok, first one is me.  I still have not reviewed the MaxCDN CDN Manager API.
19:12:57 <amitgandhinz> I will roll it over to next time again.
19:13:14 <amitgandhinz> #action amitgandhinz to investigate MaxCDN CDN Manager API for master/sub accounts
19:13:47 <amitgandhinz> ok next item was to dig more into the account management system that was being discussed with fastly
19:14:06 <amitgandhinz> no progress has been made here either.  I will probably wait for megan_w to return to discuss that item
19:14:24 <amitgandhinz> #action megan_w, guimarin, edward-fastly, and amitgandhinz to look into what "building out an account management system" is about
19:14:49 <amitgandhinz> ok last item, obulpathi to keep bugging the atlanta openstack meetup organizers
19:14:55 <amitgandhinz> any update there?
19:15:01 <obulpathi> no one has got back to me so far
19:15:05 <obulpathi> I emailed them again
19:15:14 <amitgandhinz> ok
19:15:22 <amitgandhinz> #action  obulpathi to keep bugging the atlanta openstack meetup organizers to get on the schedule
19:15:22 <obulpathi> I will discuss about the poppy talk in this months meetup
19:15:33 <amitgandhinz> sounds good
19:15:35 <obulpathi> and get it scheduled
19:15:52 <amitgandhinz> #topic Updates on Blueprints and Bugs
19:16:05 <amitgandhinz> #link https://blueprints.launchpad.net/poppy
19:16:38 <amitgandhinz> #link: https://blueprints.launchpad.net/poppy/+spec/create-service
19:16:43 <amitgandhinz> tonytan4ever: any updates on this?
19:17:14 <tonytan4ever> Working on it, my evaluation is about 30% done/
19:17:43 <tonytan4ever> Should be able to get the PR out for review around next Monday.
19:17:49 <amitgandhinz> ok
19:18:05 <amitgandhinz> lets try to get it out incrementally - maybe the transport/manager/storage parts
19:18:12 <amitgandhinz> followed by each provider integration
19:18:27 <amitgandhinz> it might make the patchsets smaller that way and faster feedback and turnaround
19:18:41 <tonytan4ever> Sounds good.
19:18:46 <amitgandhinz> ok next one...
19:18:50 <amitgandhinz> #link https://blueprints.launchpad.net/poppy/+spec/flavors
19:18:54 <amitgandhinz> this one is mine
19:18:58 <amitgandhinz> desperately needs reviews
19:19:16 <obulpathi> I am reviewing this pr
19:19:24 <tonytan4ever> I am reviewing and feedbacking, no worries.
19:19:29 <obulpathi> its a little bit, so taking time
19:19:30 <malini> me too
19:19:33 <amitgandhinz> #link: https://review.openstack.org/#/c/115130/
19:19:44 <amitgandhinz> yeh sorry, its a biggie
19:19:48 <amitgandhinz> lots of layers
19:20:38 <tonytan4ever> And this one has some overlap with my next link poppy-models as well.
19:20:55 <amitgandhinz> nice segway
19:20:57 <amitgandhinz> #link https://blueprints.launchpad.net/poppy/+spec/poppy-models
19:21:12 <amitgandhinz> the status still shows started
19:21:19 <amitgandhinz> this is making good progress right?
19:21:25 <tonytan4ever> Yes
19:21:34 <tonytan4ever> Actual status is in-review.
19:22:08 <tonytan4ever> I should be able to roll out the latest PR with review comments addressed by today.
19:22:13 <amitgandhinz> ok cool
19:22:19 <amitgandhinz> lets try to make this one land
19:22:55 <amitgandhinz> ok i will discuss the next bp regarding the sqla driver later (have an agenda item for it)
19:23:12 <amitgandhinz> #link https://blueprints.launchpad.net/poppy/+spec/health
19:23:16 <amitgandhinz> obulpathi: updates?
19:23:41 <obulpathi> Its mostly done. I am stuck at routing urls dynamically in pecan
19:24:06 <obulpathi> ocne I fix it, will do a final pr
19:24:11 <amitgandhinz> ok cool
19:24:17 <amitgandhinz> i'll keep it at Good Progress then
19:24:23 <obulpathi> yes, thanks
19:24:44 <amitgandhinz> ok lets go to the next topic
19:24:52 <amitgandhinz> #topic Limit Counts
19:25:08 <amitgandhinz> What limit counts should exist on adding origins/backends for a service/zone/distribution.
19:25:36 <amitgandhinz> so i think we determined that fastly had no limits for backends that was apparent from their docs
19:25:50 <amitgandhinz> max cdn had just one origin per zone???
19:26:25 <amitgandhinz> aaron-Ma1CDN: ^^
19:26:27 <obulpathi> link# http://docs.aws.amazon.com/general/latest/gr/aws_service_limits.html#limits_cloudfront
19:26:42 <obulpathi> you can find the CloudFront limits in the above link
19:27:08 <amitgandhinz> cloudfront has a limit of 25 per distribution
19:27:28 <amitgandhinz> mikehn: im not familiar with hybernia cdn
19:27:40 <amitgandhinz> does it limit the number of origins in a service definition?
19:28:37 <mikehn> let me look how you define 'service'
19:28:50 <amitgandhinz> similar to cloudfronts distributions
19:28:55 <amitgandhinz> maxcdn;s pullzones
19:28:59 <amitgandhinz> fastly's service
19:29:41 <obulpathi> a service is what a customer creates when he wants to serve his site through a cdn provider
19:29:51 <mikehn> we have a staged structure which is account / username / site
19:30:07 <obulpathi> then its the site
19:30:18 <mikehn> and for 'site' (which is service?) there is no limit of # of site's configured under a tuple of {account, username}
19:30:46 <obulpathi> for a single site, do you allow multiple origins?
19:31:01 <mikehn> at this moment not
19:31:17 <obulpathi> ok. thanks
19:31:37 <malini> mikehn: do you have any API docs et. which we can look at?
19:31:39 <amitgandhinz> mikehn: do you have a link to the rest api docs for hyberniacdn?
19:31:41 <mikehn> yes
19:31:44 <amitgandhinz> malini: jinx haha
19:31:51 <mikehn> https://portal.hiberniacdn.com/api/
19:32:26 <mikehn> got a number of references back to our global order entry portal, so skip that :)
19:33:15 <amitgandhinz> ok so i think the conclusion is that the number of supported origins differ widely between providers
19:33:24 <mikehn> yep
19:33:32 <amitgandhinz> either we limit support to 1 origin per site/service/distribution/pullzone
19:33:39 <amitgandhinz> or we let the operator define the min/max
19:33:52 <mikehn> if you want to abstract it, i vote for the latter
19:33:52 <amitgandhinz> or we let the operator define it per flavor
19:33:58 <malini> it would be a shame for poppy to limit to 1
19:34:05 <mikehn> +1 to that
19:34:11 <oz_akan> +1
19:34:19 <amitgandhinz> i agree, and it depends on what providers an operator chooses to offer
19:34:39 <obulpathi> leaving it to the operator to define it sounds good
19:34:44 <amitgandhinz> if we define it per flavor, then the operator has to do homework on the mins supported
19:34:52 <mikehn> min = always 1?
19:35:00 <mikehn> without origin, it's kinda hard to serve content
19:35:12 <oz_akan> :)
19:35:14 <amitgandhinz> yes
19:35:18 <amitgandhinz> sorry i think i meant max lol
19:35:25 <amitgandhinz> =P
19:35:58 <tonytan4ever> I think we can define a min=1, and let operator define max
19:36:09 <amitgandhinz> ok, so we make it as part of the flavor definitions the operator creates
19:36:42 <amitgandhinz> #link: http://docs.cloudcdn.apiary.io/#flavors
19:37:13 <malini> amitgandhinz: you mean max value will be specified as part of create flavor API call?
19:37:13 <amitgandhinz> any more questions on this?
19:37:18 <amitgandhinz> yes
19:37:26 <amitgandhinz> and it would exist per flavor (not per provider)
19:37:39 <malini> But we dont have patch on flavors yet
19:37:49 <malini> So updating tht value will be a pain
19:38:02 <amitgandhinz> send the whole blob
19:38:03 <malini> why cant it be just a configurable value?
19:38:26 <amitgandhinz> because its flavor based, and operators (eg oz_akan) wants an api to manage it
19:38:31 <amitgandhinz> similar to nova flavor management
19:38:50 <amitgandhinz> conf values per flavor are stored in the datastore
19:38:57 <malini> ok
19:39:13 <amitgandhinz> we can discuss implementation more outside this meeting
19:39:19 <malini> sure
19:39:26 <amitgandhinz> but i think we agree on the approach
19:39:29 <obulpathi> +1
19:39:48 <amitgandhinz> #agreed max limits to be defined with the flavors by the operator
19:40:02 <amitgandhinz> ok moving on now...
19:40:15 <amitgandhinz> #topic Acceptable TTL values and Granularity
19:40:41 <amitgandhinz> the min ttl setting on assets vary greatly between providers
19:41:07 <amitgandhinz> i saw some starting at a min TTL of 5 minutes, others at 1 hour etc
19:41:22 <amitgandhinz> and then the increments also differ in what is supported
19:41:31 <amitgandhinz> how should we handle this variety?
19:42:26 <mikehn> again, let the operator define it
19:43:01 <tonytan4ever> Again, per flavor ?
19:43:01 <malini> +1
19:43:20 <mikehn> yeah
19:43:21 <amitgandhinz> so operator defines min and max ttl
19:43:26 <amitgandhinz> what about increments
19:43:56 <mikehn> let operator define it
19:44:00 <amitgandhinz> let the operator define the factor of again
19:44:12 <malini> hmmm…with increments it really sounds like we'll need to specify excatly what those values could be
19:44:31 <malini> since it can't be really a factor
19:44:37 <amitgandhinz> if we say the range is {1, 6000) and increment is 5 ....
19:44:38 <malini> 1 hr vs 1 month vs 6 months
19:44:40 <mikehn> malini: and there you have the first difficulty when you want to aggregate and abstract the 100's of cdn-api's out there
19:44:50 <malini> mikehn: :)
19:44:54 <amitgandhinz> then we could do 1, 5, 10 .... ?
19:45:10 <malini> amitgandhinz: tht still wont be good enough
19:45:19 <amitgandhinz> we always represent ttl and increments in minutes
19:45:27 <obulpathi> or should we just round the user supplied value to the nearest supported by the flavor?
19:45:31 <mikehn> so either define it fixed (1,5,10) and deal with the consequences, or make sure you have a variable input & output
19:45:33 <malini> since providers could allow 1 & 10, but not 5
19:45:33 <amitgandhinz> so if you want one month = 30 days = n minutes
19:45:59 <mikehn> amitgandhinz: or make it like 1d, 1w, 5h, 5s
19:46:02 <amitgandhinz> malini: if providers support 1 and 10, then increment would be 10
19:46:09 <mikehn> then you dont have that discussion
19:46:14 <amitgandhinz> mikehn: hmmm....
19:46:23 <mikehn> and we would convert the metric from a human readable format into a machine one
19:46:36 <malini> amitgandhinz: providers dont always need to allow increments.
19:47:01 <mikehn> malini: indeed, so keep the option open for "not defining it"
19:47:54 <amitgandhinz> ok i like that.  makes it really flexible
19:48:00 <mikehn> default null, otherwise <defined>
19:48:13 <amitgandhinz> or if we do want increments, then increment becomes the smallest unit possible, eg 1m
19:48:18 <amitgandhinz> s/do/dont
19:48:51 <mikehn> amitgandhinz: provider's api is definitely checking those values as well, so keep in mind where you want to do conformity checks
19:49:32 <amitgandhinz> yeh, when we send the configs on to the providers, its always possible for them to reject it for whatever reason.
19:49:42 <amitgandhinz> that comes back in the status response
19:49:55 <mikehn> amitgandhinz: good, so my suggestion is to not vote for your "or if we do want increments, then increment becomes the smallest unit possible, eg 1m"
19:50:23 <mikehn> and move that portion to the interaction with the provider
19:50:55 <malini> we should let the operators define allowed values for ttl, if none specified allow all
19:51:18 <amitgandhinz> ok, so i think we are all leaning towards operator defining the min/max ttl for a flavor, and the increments (null, 1m, 1h, 1d, 1w, etc)
19:51:37 <obulpathi> +1
19:51:38 <amitgandhinz> where 1 is really n
19:51:44 <mikehn> yes
19:51:53 <mikehn> good, next topic ;p
19:51:59 <amitgandhinz> #agreed operator defining the min/max ttl for a flavor, and the increments (null, 1m, 1h, 1d, 1w, etc)
19:52:16 <amitgandhinz> #topic deprecate mockdb driver in favor of sqla driver
19:52:23 <amitgandhinz> ok this one should be quick
19:52:37 <amitgandhinz> the mockdb driver feels pointless and a pain to maintain and serves no purpose
19:52:46 <amitgandhinz> mocking is done using unittest mock
19:52:46 <mikehn> </done>
19:53:02 <amitgandhinz> so lets to sqlalchemy which adds value to those not needing cassandra
19:53:11 <malini> amitgandhinz: +1
19:53:15 <obulpathi> +1
19:53:20 <tonytan4ever> Make sense for me.
19:53:27 <amitgandhinz> #agreed: eprecate mockdb driver in favor of sqla driver
19:53:32 <amitgandhinz> easy
19:53:40 <amitgandhinz> #topic Open Discussion
19:53:49 <amitgandhinz> ok we have 7 minutes in here
19:54:09 <amitgandhinz> any other topics ppl want to discuss before we move back to the #openstack-poppy channel?
19:54:18 <malini> do the new folks need any help getting started etc.?
19:54:27 <obulpathi> devkulkarni: are you here?
19:54:44 <mikehn> malini: let's do that in #poppy
19:54:55 <nitin__> malini: yes
19:55:22 <nitin__> are #openstack-poppy and #poppy different channels .
19:55:22 <malini> We are always on #openstack-poppy. Feel free to ping any of us there
19:55:30 <nitin__> Sure
19:55:32 <amitgandhinz> ok any other topics to discuss here?
19:55:32 <obulpathi> nitin__: welcome to poppy once again.
19:55:44 <nitin__> obulpathi: thanks again.
19:55:58 <mikehn> ok thx for the meeting
19:56:09 <amitgandhinz> thanks for attending mikehn
19:56:15 <amitgandhinz> and nitin__
19:56:18 <obulpathi> thanks for participating mikehn
19:56:33 <amitgandhinz> ok lets carry on chatting in the poppy channel
19:56:33 <mikehn> no biggie
19:56:39 <amitgandhinz> thanks everyone
19:56:46 <amitgandhinz> #endmeeting