19:00:11 <malini> #startmeeting Poppy Weekly Meeting
19:00:12 <openstack> Meeting started Thu Sep 25 19:00:11 2014 UTC and is due to finish in 60 minutes.  The chair is malini. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:17 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:30 <malini> can we get a rollcall plz?
19:00:36 <miqui> miqui is here
19:00:37 <obulpathi> o/
19:00:47 <guimarin> guimarin from fastly here
19:00:49 <obulpathi> hi miqui .. welcome to Poppy
19:00:53 <miqui> thanks
19:01:01 <ametts> o/
19:01:14 <obulpathi> hi guimarin
19:01:30 <guimarin> hi
19:01:30 <tonytan4ever> Howdy all
19:01:47 <malini> looks like we have a good crowd today :)
19:01:55 <malini> miqui: want to introduce yourself?
19:02:17 <miqui> hi folks, am located EST tz, work for HP
19:02:29 <miqui> for 15+ yrs... excited about opensource...
19:02:45 <malini> great to have you here miqui !
19:02:52 <miqui> thanks malini....
19:02:53 <obulpathi> oh cool.
19:03:04 <malini> starting with the agenda
19:03:14 <malini> #topic action items from last time
19:03:35 <malini> amitgandhinz to investigate MaxCDN CDN Manager API for master/sub accounts (
19:03:47 <malini> Since amit is out, lets carry it over to next week
19:03:54 <malini> #action amitgandhinz to investigate MaxCDN CDN Manager API for master/sub accounts
19:04:03 <obulpathi> malini: can you please post the link the previous action items?
19:04:04 <malini> obulpathi to keep bugging the atlanta openstack meetup organizers to get on the schedule
19:04:17 <malini> obulpathi:sure
19:04:19 <obulpathi> and yes, on that node .. I got it done this time :)
19:04:19 <malini> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-09-18-19.00.html
19:04:38 <malini> obulpathi: great! can you share the details?
19:04:55 <obulpathi> Poppy meetup is scheduled 16 th November
19:05:03 <malini> yayyy!!
19:05:12 <obulpathi> for more details: http://www.meetup.com/openstack-atlanta/events/207006052/
19:05:18 <malini> tht is right after the Paris summit
19:05:30 <obulpathi> yes, we will also be celebrating the Juno release
19:05:37 <miqui> obulpathi:  16th Oct or Nov?
19:05:56 <obulpathi> miqui: yes,
19:06:01 <obulpathi> this is a local meetup is Atlanta
19:06:11 <obulpathi> we meet every month and discuss about openstack
19:06:12 <miqui> yep. signed up...will be there...
19:06:12 <catherine> meetup says 10/16
19:06:15 <malini> ok..right before the summit then :-P
19:06:28 <obulpathi> next month we will be talking about Poppy there
19:06:34 <obulpathi> Cool. see you at the meetup
19:06:40 <malini> great job obulpathi! this will help bring some visibility for Poppy
19:06:48 <obulpathi> thanks malini :)
19:06:58 <malini> #link https://wiki.openstack.org/wiki/Meetings/Poppy#New_Items
19:07:03 <malini> next item in the agenda
19:07:26 <malini> #topic blueprints
19:07:39 <malini> #link https://blueprints.launchpad.net/poppy
19:07:53 <malini> first one is create-service
19:07:59 <malini> tonytan4ever: updates?
19:08:17 <tonytan4ever> This one is experiencing several rounds of review
19:08:31 <tonytan4ever> So it is currently under review
19:08:58 <malini> My API tests for that is also under review, which explains some of my review comments
19:09:29 <tonytan4ever> OK I will look into your test.
19:09:38 <malini> thanks! appreciate that
19:09:43 <malini> tonytan4ever: next one is https://blueprints.launchpad.net/poppy/+spec/get-service
19:09:56 <tonytan4ever> OK this one is currently under review as well.
19:10:26 <tonytan4ever> obulpathi has reviewed it, now someone else review would be appreciated.
19:10:34 <malini> I will review that after the meeting
19:10:55 <tonytan4ever> Then you are appreciated.
19:10:59 <malini> :)
19:11:37 <malini> miqui: these are our outstanding reviews https://review.openstack.org/#/q/status:open+project:stackforge/poppy,n,z if you would like to take a look
19:11:44 <malini> ok..moving along
19:11:47 <obulpathi> from my side
19:11:52 <miqui> great thanks malini
19:11:55 <miqui> will do..
19:12:00 <obulpathi> health is waiting to be merged
19:12:00 <malini> we have this one next https://blueprints.launchpad.net/poppy/+spec/list-services
19:12:07 <malini> miqui: yw
19:12:11 <obulpathi> list-services is in good-progress
19:12:23 <malini> it is currently unassigned
19:12:28 <obulpathi> it depends on tonys get services
19:12:38 <malini> Can you make sure to get tht assigned to yourself obulpathi?
19:12:55 <malini> we will need amit to do that
19:13:09 <obulpathi> only amit can assign it to me
19:13:20 <malini> yeap
19:13:36 <malini> next is sqla driver https://blueprints.launchpad.net/poppy/+spec/sqla-driver
19:13:42 <malini> nitin around?
19:14:01 <malini> guess not
19:14:14 <obulpathi> he said he will be off for couple of weeks
19:14:26 <malini> ok..thanks for the update obulpathi
19:14:33 <malini> next is also unassigned https://blueprints.launchpad.net/poppy/+spec/add-docstrings
19:14:57 <malini> nobody has started on this one yet & is up for grabs
19:15:02 <obulpathi> ok
19:15:07 <malini> (hint hint)
19:15:14 <miqui> i can grab that...
19:15:23 <obulpathi> cool ...
19:15:35 <miqui> seems like low hanging project intro fruit..
19:15:36 <malini> great..Thanks miqui!!
19:15:48 <malini> we will get that assigned to you when amit comes back
19:16:09 <malini> tht will be early next week, but should not stop you from starting
19:16:16 <miqui> k
19:16:30 <malini> And now the last in the list
19:16:34 <malini> obulpathi: https://blueprints.launchpad.net/poppy/+spec/health
19:16:47 <obulpathi> it is waiting to be merged
19:17:03 <obulpathi> addressed comments by malini, tony and amit
19:17:15 <obulpathi> and test coverage is also there
19:17:30 <malini> looks like we have a bunch of stuff ready to be merged
19:18:02 <malini> We will be in a better position by next week on tht
19:18:24 <malini> we don't have any bugs to discuss yet
19:18:43 <obulpathi> nop ...
19:18:47 <obulpathi> we don't have
19:18:47 <malini> next topic now
19:18:57 <malini> #topic Inquire/Discuss MaxCDN python API
19:19:07 <malini> tonytan4ever: want to lead this?
19:19:23 <tonytan4ever> First of all, is there any MaxCDN folks here ?
19:20:02 <tonytan4ever> 1..2..3 I guess not.
19:20:07 <malini> :(
19:20:17 <tonytan4ever> We can roll this over to next week.
19:20:22 <malini> megan_w_: can you help us get somebody from MaxCDN?
19:20:29 <megan_w_> sure
19:20:44 <malini> thanks!
19:20:52 <tonytan4ever> Thank you megan.
19:20:52 <megan_w_> we'll shoot to have them here next week, or we can meet during the week in the poppy channel
19:21:10 <malini> #action megan_w_ to get a MaxCDN point of contact
19:21:28 <malini> next topic
19:21:38 <malini> #topic Poppy standardization on provider specific restrictions
19:22:03 <malini> we discussed this briefly, but do not have a clear answer yet
19:22:14 <malini> Here is a brief synopsis of the problem:
19:22:42 <malini> Different providers have different rules on what service names could be, allowed ttl values etc.
19:22:51 <malini> How do we want poppy to handle this?
19:23:23 <tonytan4ever> You can look at http://docs.cloudcdn.apiary.io/,
19:23:28 <malini> If we choose the strictest rules to implement, it'll be greatly limiting
19:23:56 <tonytan4ever> there is a flavor details section that has the initial design of the implmenation.
19:24:10 <malini> I dont think I explained very well
19:24:32 <malini> for eg.
19:24:58 <malini> should Poppy limit  Max Length of domains list - because provider_a allows 2 & provider_b allows 10?
19:25:25 <malini> megan_w_, guimarin_: thoughts?
19:26:00 <megan_w_> can that be implemented in the plugins somehow instead of the base api?
19:26:22 <tonytan4ever> I think the idea on this one is, poppy will not limit it.
19:26:23 <megan_w_> just like we may adjust default settings per provider, should we set limits per provider?
19:26:45 <megan_w_> right, poppy itself shoud not limit
19:26:47 <tonytan4ever> Operator will set a standard per flavor
19:27:14 <malini> tonytan4ever: so accept whatever comes in & let it fail at the provider?
19:27:20 <obulpathi> so, one way I see is poppy can mediate the limits like name restrictions, number of origins / distribution /service ... but I am not sure how we cna take care of ttls
19:27:46 <malini> obulpathi: IMO we should not take care of this
19:28:09 <tonytan4ever> Not failed at the provider exactly, but to check against the flavor standard.
19:28:31 <obulpathi> for naming ... we can let user create a service / distribution with what ever name the user wants and we will create an intermediate name and store the map in cassandra
19:28:35 <tonytan4ever> Then take actions accordingly.
19:28:37 <obulpathi> malini: OK
19:29:00 <malini> My vote is to limit Poppy validations to rules defined in http://docs.cloudcdn.apiary.io/ (eg. make sure mandatory fields are present etc.), pass the request to the provider, let it fail & return the failure message when the user queries the service status
19:29:32 <malini> But tht sounds too simple, so obviously can't be right :D
19:29:39 <miqui> heheh
19:29:49 <obulpathi> hahahah
19:29:55 <obulpathi> simple is better
19:29:57 <megan_w_> let me ask a basic question then
19:30:17 <malini> megan_w_: shhot
19:30:19 <megan_w_> is there any real value to the end user if poppy sends them an error vs the provider sending an error?
19:30:36 <miqui> same difference..i think...
19:30:42 <megan_w_> if not (and i dont think there is), we should just let each provider return an error when their limit is hit
19:30:42 <malini> megan_w_: Poppy will return a faster response
19:30:55 <miqui> also depends on who smart the err msg from the provider is...
19:31:02 <megan_w_> very true
19:31:18 <malini> yes
19:31:44 <miqui> sanity errors from poppy, but operational errors from the provider.no?
19:31:46 <malini> If we end up validating provider specific validation, we might end up re-implementing all the provider logic for input validation
19:31:51 <obulpathi> miqui: +1
19:31:53 <miqui> after all the provider code will do the real work...
19:32:04 <obulpathi> we can check for basic errors .. sanity cehck
19:32:11 <malini> miqui: what is a sanity error?
19:32:13 <megan_w_> like what?
19:32:16 <obulpathi> and let the providers take care of operationsl errors
19:32:25 <megan_w_> missing feilds?
19:32:34 <miqui> like for example supplied params that do not make any sense at all
19:32:43 <megan_w_> right.  ok
19:33:06 <malini> so we'll validate for eg. the domain value is not 1234 etc.
19:33:08 <megan_w_> this seems like the right approach to me.  speed shouldn't be a major concern for a provisioning api, and the providers need to have smart errors for their own customers
19:33:09 <miqui> given xyz prvider poppy should handle the crazynes upfriont..
19:33:21 <malini> but not if the domain name is ascii  or not
19:34:06 <malini> tht sounds reasonable to me
19:34:17 <malini> & it will make our implementation a lot easier
19:34:28 <obulpathi> agreed: +1
19:34:31 <miqui> +1
19:34:37 <malini> We just need to make sure we capture & return the error messages from the provider
19:34:50 <miqui> yup
19:35:05 <megan_w_> malini: want to mark that as a decision using the meetingbot?
19:35:13 <megan_w_> or something so it doesn't get lost
19:35:16 <malini> megan_w_: yes.
19:35:27 <miqui> question: would a goal be for poppy simply the usage of a vendor api?
19:35:30 <malini> was looking for the right hash tag :)
19:35:49 <malini> megan_w_: want to answer that?
19:36:30 <megan_w_> miqui: yes, that's right
19:36:42 <miqui> k...
19:36:46 <miqui> thanks megan_w_
19:36:59 <ametts> malini: https://wiki.debian.org/MeetBot
19:37:18 <megan_w_> the idea is that operators can jump from provider to provider as needed without integrating with each api.
19:37:28 <megan_w_> rather, they just change flavors in poppy
19:37:36 <malini> #accepted Poppy will do basic sanity check on the inputs to make sure it is consistent with Poppy rules defined in http://docs.cloudcdn.apiary.io/ Provider specific validations is not within the scope of Poppy. Poppy will however capture the error message from providers & return it to the users.
19:37:42 <malini> thanks ametts!
19:38:06 <malini> #info Poppy will do basic sanity check on the inputs to make sure it is consistent with Poppy rules defined in http://docs.cloudcdn.apiary.io/ Provider specific validations is not within the scope of Poppy. Poppy will however capture the error message from providers & return it to the users.
19:38:24 <malini> tht's all we had in the agenda
19:38:32 <malini> #topic open discussion
19:38:40 <obulpathi> poppy also abstracts the differences between vendors and presents a uniform API ...
19:38:55 <obulpathi> just to add to what megan said
19:39:18 <malini> Anybody has stuff they would like to discuss?
19:39:20 <obulpathi> miqui: do you stay near Atlanta?
19:39:25 <miqui> yes
19:39:29 <obulpathi> awesome ..
19:39:53 <obulpathi> will look forward to meeting you at the meetup then
19:39:59 <miqui> yup...same here...
19:40:05 <obulpathi> :)
19:40:20 <malini> anything else?
19:40:23 <miqui> now just have to rfm all this poppy docs... hehehe
19:40:48 <malini> miqui: ping us in #openstack-poppy if something doesn't make sense
19:40:57 <miqui> awesome thanks....
19:41:03 <tonytan4ever> Wht is rfm ?
19:41:13 <miqui> Read The Fucking Manual...
19:41:19 <malini> :D
19:41:21 <tonytan4ever> Oh...
19:41:24 <miqui> sorry for the language...
19:41:33 <catherine> you left out the T! :)
19:41:43 <miqui> college prof told me that...learning progamming 101
19:42:00 <miqui> ooops   yu right catherine
19:42:02 <miqui> sorry
19:42:15 <tonytan4ever> Learned something.
19:42:17 <obulpathi> also called read the flaming manuals
19:42:20 <miqui> indeed
19:42:29 <malini> on the plus side, it is easier than reading somebody's comments in half awake state :)
19:42:31 <catherine> or Read the Fine Manuals.
19:42:31 <miqui> obulpathi:  ahahahahah yes...
19:43:14 <malini> looks like we are out of 'relevant' topics for the day
19:43:27 <malini> so unless anybody has anything
19:43:29 <malini> .
19:43:31 <malini> .....
19:43:34 <malini> …….....
19:43:42 <obulpathi> no nothing form me
19:43:52 <ametts> Thanks for running the meeting malini!
19:43:55 <tonytan4ever> I am good.
19:43:56 <catherine> Bye!
19:43:59 <miqui> thanks!
19:43:59 <tonytan4ever> Thanks everyone.
19:44:01 <tonytan4ever> Bye.
19:44:01 <miqui> bye
19:44:04 <obulpathi> thanks malini :)
19:44:05 <malini> my pleasure ametts :-P
19:44:05 <megan_w_> good meeting, see ya next week
19:44:09 <malini> thank you all
19:44:11 <obulpathi> see you all next week
19:44:22 <malini> see you next week & in #openstack-poppy
19:44:24 <malini> bye
19:44:28 <malini> #endmeeting