19:00:44 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:45 <openstack> Meeting started Thu Dec 11 19:00:44 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:49 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:01:02 <amitgandhinz> #topic RollCall
19:01:05 <malini> o/
19:01:07 <tonytan4ever> o/
19:01:10 <cpowell> o/
19:01:11 <miqui_> o/
19:01:35 <johnmdonahue> o/
19:02:06 <megan_w_> o/
19:02:53 <obulpathi> o/
19:02:54 <amitgandhinz> welcome johnmdonahue
19:03:23 <johnmdonahue> Thanks
19:03:31 <amitgandhinz> you are new to the meeting, do you mind giving us a quick intro?
19:04:27 <johnmdonahue> Sure. I'm an engineering manager at Edgecast
19:04:46 <malini> welcome johnmdonahue! Glad to have you here
19:04:49 <johnmdonahue> Will be heading up our efforts on poppy
19:04:50 <obulpathi> hi johnmdonahue, welcome to poppy!
19:04:56 <amitgandhinz> awesome, looking forward to working with you =)
19:05:00 <miqui_> welcome johnmdonahue....
19:05:16 <amitgandhinz> ok lets get this party started
19:05:25 <amitgandhinz> #topic Review Last Weeks Action Items
19:05:35 <amitgandhinz> #link Agenda: https://wiki.openstack.org/wiki/Meetings/Poppy
19:05:38 <johnmdonahue> thanks for having me everyone
19:05:48 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/weekly_poppy_meeting/2014/weekly_poppy_meeting.2014-12-04-19.00.html
19:06:10 <amitgandhinz> only one action item from last week
19:06:13 <amitgandhinz> that was mine
19:06:18 <amitgandhinz> amitgandhinz to set up a design discussion on the Message Queue Driver
19:06:22 <amitgandhinz> i havent done that
19:06:34 <cpowell> shame
19:06:35 <amitgandhinz> tbh that probably isnt going to happen until January
19:06:49 <malini> next year!!!
19:06:55 <amitgandhinz> too busy bug fixing lol
19:07:13 <amitgandhinz> #action amitgandhinz to set up a design discussion on the Message Queue Driver in early January
19:07:13 <amitgandhinz> =P
19:07:39 <amitgandhinz> #topic Update on Bugs and Blueprints
19:07:42 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-2
19:08:06 <amitgandhinz> so as mentioned last week, much of kilo-2 is going to be focused on stability and bug fixing
19:08:18 <amitgandhinz> we do have some blueprints too
19:08:43 <amitgandhinz> the bug list has really grown - already have 17 assigned to kilo
19:08:56 <amitgandhinz> lets go through the list of bugs and get them assigned to someone
19:09:26 <amitgandhinz> going through them in order of importance
19:09:34 <amitgandhinz> https://bugs.launchpad.net/bugs/1401306
19:09:35 <uvirtbot> Launchpad bug 1401306 in poppy "returned links don't show https when required" [Critical,New]
19:10:05 <tonytan4ever> I can have that one.
19:10:11 <amitgandhinz> basically when you do SSL termination at the LB (or anywhere before the poppy api), poppy ends up seeing requests as http and not https
19:10:21 <amitgandhinz> therefore links returned only show http and not https
19:10:28 <amitgandhinz> sold to tonytan4ever!
19:10:40 <cpowell> i wonder if this could be configured in Repose
19:11:06 <amitgandhinz> cpowell: its the request.host_uri that poppy see's
19:11:13 <cpowell> gotcha
19:11:22 <amitgandhinz> and it would affect lb termination also (so not isolated to repose)
19:11:45 <amitgandhinz> ok next one is https://bugs.launchpad.net/bugs/1401608
19:11:46 <uvirtbot> Launchpad bug 1401608 in poppy "Failed Provider Service causes DNS create failure" [Critical,New]
19:12:08 <amitgandhinz> obulpathi: already has this one
19:12:11 <obulpathi> I ahve a fix for this
19:12:15 <amitgandhinz> awesome!
19:12:17 <obulpathi> I am working on test cases for the bug
19:12:28 <amitgandhinz> ok, so still waiting on the patchset to be submitted?
19:12:29 <malini> good job obulpathi ;)
19:12:35 <obulpathi> :)
19:12:43 <obulpathi> I submitted the fix
19:12:49 <obulpathi> but I am adding the test cases
19:13:06 <amitgandhinz> ok.  be sure to update the commit messaeg with the bug so that things update automagically
19:13:14 <obulpathi> I will get the test cases ready by today evening and push out the final pr
19:13:19 <amitgandhinz> cool
19:13:21 <obulpathi> sure
19:13:33 <amitgandhinz> https://bugs.launchpad.net/bugs/1380679
19:13:35 <uvirtbot> Launchpad bug 1380679 in poppy "Remove project_id from the request url in tests" [High,Confirmed]
19:13:39 <amitgandhinz> obulpathi: this is assigned to you
19:13:44 <obulpathi> yep
19:14:04 <amitgandhinz> im inclined to lower this to medium
19:14:05 <obulpathi> tI started this, but got distracted by mimic and din't achive much progress after that
19:14:18 <malini> amitgandhinz: +1
19:14:31 <obulpathi> will submit the patch for this once I finish the dns bug
19:14:36 <obulpathi> ok
19:15:15 <amitgandhinz> https://bugs.launchpad.net/bugs/1401628
19:15:16 <uvirtbot> Launchpad bug 1401628 in poppy "href links returned from poppy are missing project_id" [High,Confirmed]
19:15:48 <amitgandhinz> basically here we run into the issue of when projectid is in the url, links returned should have it also
19:15:52 <amitgandhinz> when its not, it shouldnt
19:16:28 <obulpathi> we are stripping the tenant id in repose right?
19:16:33 <amitgandhinz> this will be similar to the http/https issue
19:16:38 <amitgandhinz> yeh, thats why poppy doesnt see it
19:16:48 <obulpathi> I think this is better handled by repose
19:16:55 <amitgandhinz> can i assign this to you tonytan4ever
19:16:58 <amitgandhinz> obulpathi: no
19:17:04 <tonytan4ever> Yeah
19:17:09 <tonytan4ever> sure.
19:17:13 <amitgandhinz> because repose strips it out before passing it to poppy
19:17:26 <amitgandhinz> if it doesnt, then poppy would need to change pecan routes to support projectid in the url
19:17:31 <amitgandhinz> we dont want that
19:17:32 <obulpathi> if poppy does not see it, how can it set it back in url?
19:17:41 <amitgandhinz> poppy has the projectid in the context
19:17:43 <amitgandhinz> in the header
19:17:50 <amitgandhinz> it can update the base_url  with it
19:17:55 <amitgandhinz> along side putting in the https
19:18:03 <amitgandhinz> hence tonytan4ever can do them both at once =P
19:18:18 <obulpathi> but say if a provider is is using openstack API V3
19:18:25 <obulpathi> and does not support tenat id in url
19:18:30 <obulpathi> how does it work then?
19:18:38 <amitgandhinz> it should be a conf parameter
19:18:41 <amitgandhinz> operator decides it
19:18:43 <obulpathi> oh ok
19:18:46 <obulpathi> got it
19:19:04 <amitgandhinz> its really a workaround for the rackspace keystone catalog =(
19:19:13 <obulpathi> understood
19:19:39 <amitgandhinz> https://bugs.launchpad.net/bugs/1392578
19:19:40 <obulpathi> I thought that if we can do it in repose, we don't need to worry about it in poppy at all
19:19:41 <uvirtbot> Launchpad bug 1392578 in poppy "Next link in GET /services is incorrect" [High,Triaged]
19:19:48 <morganfainberg> amitgandhinz, i hope you also communicate to RAX the need to "work around" this
19:20:32 <amitgandhinz> morganfainberg: i believe when they deploy keystone v3 they are planning to fix this (really really hopes)
19:20:36 <morganfainberg> amitgandhinz, i don't like hearing that people need to "work around" the keystone catalog for a big-provider
19:20:40 <morganfainberg> they are
19:20:43 <amitgandhinz> im pretty sure i heard a discussion around it
19:21:00 <morganfainberg> but it doesn't hurt for you to let them know you'll be m,uch happier when they do.
19:21:01 <morganfainberg> :)
19:21:07 <morganfainberg> another voice does help
19:21:18 <amitgandhinz> haha, i do (btw i also work for rackspace)
19:21:37 <morganfainberg> :)
19:21:49 * morganfainberg gets out of your meeting now.
19:21:50 <amitgandhinz> #link https://bugs.launchpad.net/poppy/+bug/1392578
19:21:51 <uvirtbot> Launchpad bug 1392578 in poppy "Next link in GET /services is incorrect" [High,Triaged]
19:22:11 <amitgandhinz> this one im changing to incomplete for now
19:22:21 <amitgandhinz> i dont think its an issue anymore, but needs to be retested
19:23:04 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1392578
19:23:04 <miqui_> amitgandhinz:  you can assing me 1401153
19:23:05 <uvirtbot> Launchpad bug 1392578 in poppy "Next link in GET /services is incorrect" [High,Triaged]
19:24:06 <amitgandhinz> https://bugs.launchpad.net/bugs/1400525
19:24:07 <uvirtbot> Launchpad bug 1400525 in poppy "Delete stuck in progress" [High,In progress]
19:24:12 <amitgandhinz> ok this one i am working on
19:24:29 <amitgandhinz> we also discussed doign archiving this morning in the normal channel
19:25:02 <amitgandhinz> those are all the high/critical items
19:25:21 <amitgandhinz> do we want to spend more time and go through all the mediums right now?
19:25:34 <amitgandhinz> or just pick them up as you have time?
19:25:38 <obulpathi> I have the cassandra one in progress now
19:25:47 <obulpathi> https://bugs.launchpad.net/poppy/+bug/1382155
19:25:49 <uvirtbot> Launchpad bug 1382155 in poppy "/health endpoint returns wrong status when cassandra is offline" [Medium,Confirmed]
19:25:58 <obulpathi> This one is in progress
19:26:12 <obulpathi> will submit pr after this dns bug fix
19:26:49 <obulpathi> amitgandhinz: I think we can pick them up as we time?
19:27:05 <amitgandhinz> ok, i think the status of the rest is correct
19:27:12 <amitgandhinz> miqui_:  i assigned you the logging bug
19:27:17 <miqui_> amitgandhinz: thanks..
19:27:23 <amitgandhinz> will you have time to work on that in the next few days
19:27:28 <amitgandhinz> i know cpowell is itching for it =P
19:27:39 <cpowell> its rather important for release
19:28:04 <miqui_> i have no problem...if cpowell wants to grab it.. thats ok...
19:28:35 <amitgandhinz> cpowell: just needs it, he's prob not going to work on it haha
19:28:55 <miqui_> ah...ok.
19:29:06 <amitgandhinz> for now i will leave it open
19:29:11 <miqui_> k
19:29:15 <amitgandhinz> if you can get to it before we do then great =)
19:29:23 <miqui_> k
19:29:42 <amitgandhinz> ok lets talk blueprints now
19:29:57 <amitgandhinz> miqui_: https://blueprints.launchpad.net/poppy/+spec/home-doc
19:30:00 <amitgandhinz> any update?
19:30:38 <miqui_> amitgandhinz:  been ramping on pecan primarily...but thats it so far..
19:30:46 <amitgandhinz> ok
19:30:49 <miqui_> i should be done with this one next couple of days...
19:30:55 <amitgandhinz> cool
19:30:55 <johnmdonahue> I have to jump into another meeting now but thanks for letting me listen in. we'll hopefully have more to contribute to the conversation in the coming weeks from the EC side. :)
19:31:09 <obulpathi> thanks for joining us johnmdonahue
19:31:20 <malini> it'll be cool to have an edgecast driver..yumm yumm
19:31:21 <amitgandhinz> thanks johnmdonahue
19:31:29 <amitgandhinz> im looking forward to it=D
19:31:35 <malini> thanks johnmdonahue
19:31:42 <johnmdonahue> Us too! Thanks everyone!
19:32:03 <amitgandhinz> malini: https://blueprints.launchpad.net/poppy/+spec/provider-url-in-conf
19:32:10 <amitgandhinz> i know you updated this for the fastly driver
19:32:17 <amitgandhinz> did you get this updated for the others?
19:32:26 <malini> yes..& tonytan4ever coneveniently has it for akamai
19:32:37 <malini> I am yet to update the rest
19:32:45 <amitgandhinz> i will keep it open then
19:33:08 <malini> I don't think I'll start on this till next year
19:33:18 <amitgandhinz> ok any other updates/questions on blueprints or bugs?
19:34:06 <malini> none from me
19:34:24 <amitgandhinz> #topic New Items
19:34:25 <tonytan4ever> I am good.
19:34:31 <amitgandhinz> nothing on the agenda
19:34:36 <amitgandhinz> #topic Open Discussion
19:34:44 <amitgandhinz> anyone have a topic to discuss?
19:35:28 <obulpathi> one small update
19:35:36 <amitgandhinz> go ahead
19:35:40 <obulpathi> I started working on mimic racksapce plugin: https://blueprints.launchpad.net/poppy/+spec/mimic-racksapce-dns
19:36:07 <obulpathi> can we mark it as started?
19:36:36 <amitgandhinz> updated
19:36:37 <ekarlso-> designate ? ;p
19:36:39 <amitgandhinz> and pulled into k2
19:36:44 <obulpathi> thanks :)
19:36:48 <amitgandhinz> ekarlso-: designate is next
19:37:11 <amitgandhinz> currently this works with the current rackspace cloud dns
19:37:33 <amitgandhinz> but its a driver model, so we have in our k3 roadmap to work on the designate driver
19:38:27 <amitgandhinz> obulpathi: also please watch the typo's on your bprints ;-)
19:38:50 <obulpathi> amitgandhi: this is something I have to improve on
19:39:04 <obulpathi> thanks for keeping an eye one me :D
19:39:05 <amitgandhinz> ekarlso-: fyi https://blueprints.launchpad.net/poppy/+spec/designate-dns-driver
19:39:21 <amitgandhinz> it may be in k3, else L-1
19:39:25 <malini> obulpathi: can u get ur name right? :D
19:39:29 <amitgandhinz> lol
19:39:34 <miqui_> lol
19:39:35 <obulpathi> lol
19:40:01 <obulpathi> this is my correct id, my official name is the wrong one :(
19:40:41 <malini> just kidding.. you are good with all the typos :D
19:40:43 <amitgandhinz> ok, any other work being done that we need to track?
19:40:59 <malini> I am working on endtoend tests
19:41:02 <obulpathi> none from me
19:41:25 <amitgandhinz> cool.  so lets try to squish as many bugs as possible
19:41:42 <malini> endtoend tests - deploy a test site to a cloud server with heat, create poppy service & validate CDN enabled content
19:41:50 <malini> does tht qualify for a bp?
19:41:58 <amitgandhinz> i think so
19:42:02 <amitgandhinz> please create it
19:42:06 <malini> ok..here I go
19:42:11 <amitgandhinz> make sure its nova (not cloud server)
19:42:42 <malini> sure..tht is just a yaml thing
19:42:47 <malini> 'JUST' yaml
19:42:52 <amitgandhinz> yeh, i think heat figures it out
19:42:59 <amitgandhinz> ok....
19:43:11 <amitgandhinz> fyi next week will be the last meeting for the year
19:43:23 <amitgandhinz> the week after is xmas day and the ny
19:43:37 <malini> this is the last meeting in 2 years!
19:44:12 <malini> well..next meeting
19:44:19 <malini> my turn to typo
19:44:26 <amitgandhinz> haha
19:44:27 <amitgandhinz> ok
19:44:50 <amitgandhinz> if nothing else to discuss, then you get 15 min back
19:45:34 <amitgandhinz> thanks everyone
19:45:44 <malini> thank you!
19:45:52 <amitgandhinz> #endmeeting