19:00:28 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:29 <openstack> Meeting started Thu Jan 15 19:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:32 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:39 <amitgandhinz> #topic RollCall
19:00:41 <mpanetta> o/
19:01:22 <catherineR> o/
19:02:01 <tonytan4ever> o/
19:02:16 <miqui_> hello
19:02:38 <amitgandhinz> #link https://wiki.openstack.org/wiki/Meetings/Poppy
19:02:54 <amitgandhinz> #topic Last Week Items
19:03:02 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-01-08-19.00.html
19:03:24 <obulpathi> o/
19:03:25 <amitgandhinz> ok first one was for malini - malini to add doc to cdn vendor wiki page on how to add a mimic plugin for their api
19:03:45 <amitgandhinz> she isnt here today, but i dont think she has done this yet
19:03:48 <amitgandhinz> so will roll it over
19:03:54 <amitgandhinz> #action: malini to add doc to cdn vendor wiki page on how to add a mimic plugin for their api
19:04:13 <amitgandhinz> next one was unassigned but - investigate how to do worker processes with non blocking io
19:04:27 <amitgandhinz> a few of us looked at taskflow
19:04:47 <amitgandhinz> the discussion (from the meeting just finished) was to compare taskflow with celery
19:05:07 <amitgandhinz> i will roll this task forward
19:05:14 <mpanetta> We need to make sure whatever we choose supports ssl, or some sort of encryption of the channel...
19:05:25 <amitgandhinz> #action ALL - investigate worker management
19:05:37 <amitgandhinz> the next one was to research oslo.messaging
19:05:58 <tonytan4ever> I did some research on this one using oslo.messaging with rabbit-mq
19:06:26 <tonytan4ever> Code looks pretty good.
19:06:32 <amitgandhinz> i did look into that.  we know we are going to use rabbitmq.  whether we choose to go with taskflow or celery, that may change the  need to explicitly use oslo.messaging directly
19:06:41 <wbrothers> I can take the action to add a cdn provider to the wiki
19:06:54 <amitgandhinz> thanks wbrothers
19:07:07 <amitgandhinz> #action: wbrothers to add doc to cdn vendor wiki page on how to add a mimic plugin for their api
19:07:49 <amitgandhinz> ok moving to the next topic...
19:07:58 <amitgandhinz> #topic Bugs and Blueprints
19:08:05 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-2
19:08:25 <amitgandhinz> ok bugs first....
19:08:32 <amitgandhinz> there are 3 PATCH bugs outstanding
19:08:42 <amitgandhinz> obulpathi: do you want to wrap these up?
19:08:58 <obulpathi> yes,
19:09:10 <obulpathi> 2 of them are we are not returning proper error messages
19:09:23 <obulpathi> one from provider and the other for JSON schema validation
19:09:36 <obulpathi> I will take them
19:09:43 <amitgandhinz> thansk
19:09:56 <amitgandhinz> tonytan4ever: https://bugs.launchpad.net/bugs/1409782
19:10:04 <tonytan4ever> In review for this one
19:10:17 <tonytan4ever> https://review.openstack.org/#/c/147326/
19:10:31 <amitgandhinz> hmm odd it didnt update the bug automatically
19:10:37 <amitgandhinz> ok lets get that reviewed
19:10:40 <tonytan4ever> Could use some reviews, cpowell, obulpathi, amitgandhinz
19:10:52 <tonytan4ever> since this one has something to do with OPs
19:10:55 <obulpathi> will review
19:11:38 <amitgandhinz> ok, on to the blueprints
19:11:43 <tonytan4ever> I just updated its status to In Progress.
19:11:51 <amitgandhinz> message queue driver
19:11:58 <amitgandhinz> so we just had a great discussion on this
19:12:19 <amitgandhinz> #agreed to use rabbitmq as the backend (although this is likely to be pluggable)
19:12:36 <amitgandhinz> #agreed to investigate taskflow vs celery differences
19:13:18 <amitgandhinz> so we will chat with the TF folks on their IRC channel to learn the diffs
19:13:37 <amitgandhinz> tonytan4ever: do you want to own that action?
19:13:48 <amitgandhinz> and then report back on the findings
19:13:49 <tonytan4ever> Sure
19:14:05 <tonytan4ever> But I am afraid I will be biased though...
19:14:11 <amitgandhinz> #action tonytan4ever to reach out to the TaskFlow IRC channel to learn the differences between celery and taskflow
19:14:22 <amitgandhinz> tonytan4ever: that will make for a lively converstaion haha
19:14:39 <miqui_> i can take a stab at it since i have not used either cele or tf
19:15:22 <tonytan4ever> What's the channel of for TF ? openstack-taskflow
19:15:24 <tonytan4ever> ?
19:15:37 <amitgandhinz> it will be on their wiki page
19:15:37 <miqui_> dont think so
19:16:03 <amitgandhinz> #openstack-state-management on freenode
19:16:12 <miqui_> ah bit to the punch..
19:16:12 <obulpathi> #openstack-state-management
19:16:21 <obulpathi> I am 10 secs late
19:16:21 <amitgandhinz> i get the prize =P
19:16:40 <amitgandhinz> ok next one....
19:16:41 <obulpathi> hahaa
19:16:44 <amitgandhinz> miqui_: Update home doc
19:16:48 <amitgandhinz> any update on this one?
19:17:13 <miqui_> a, comcerned about this one..that i keep put off to do reviews and stuff..
19:17:41 <amitgandhinz> did you want to take your name off it?
19:17:55 <miqui_> i spent more time looking at our message queque design topics...
19:18:00 <amitgandhinz> ya
19:18:19 <miqui_> if you are concerned this will miss the kilo-2 deadline then yes...
19:19:11 <amitgandhinz> k2 ends on thursday next week
19:19:15 <miqui_> i can try next couple of days to spend some time on it..
19:19:26 <amitgandhinz> ok give it a shot, else it may roll over to k3
19:19:27 <miqui_> hmmm...
19:19:33 <miqui_> k...
19:19:50 <amitgandhinz> obulpathi: DNS mimic plugin
19:20:02 <obulpathi> I started again on this one today
19:20:10 <obulpathi> its status remains the same
19:20:24 <amitgandhinz> how much more work is left on it?
19:20:31 <amitgandhinz> ie just started or nearly done?
19:20:32 <obulpathi> about 2 days work
19:20:36 <amitgandhinz> ok
19:20:50 <obulpathi> finished the dns tests
19:21:07 <obulpathi> so, back to this one
19:21:11 <amitgandhinz> ok
19:21:43 <amitgandhinz> alright, those are all the bp that are in flight
19:21:55 <amitgandhinz> i will do some grooming during the week to get the k3 cycle ready
19:22:38 <amitgandhinz> that will be hopefully getting us to a good point for a releasable version for operators (although it is technically releasable today)
19:23:01 <amitgandhinz> #topic New Items
19:23:13 <amitgandhinz> none
19:23:19 <amitgandhinz> #topic Open Discussion
19:23:27 <amitgandhinz> hmmm....what about to the irc bot?
19:23:39 <obulpathi> what about it?
19:23:55 <amitgandhinz> idk im not seeing the topic change messages
19:23:57 <mpanetta> It's missing :P
19:24:02 <obulpathi> oh ok
19:24:42 <amitgandhinz> ok....any topics anyone wants to discuss?
19:25:20 <miqui_> none from me...
19:25:49 <tonytan4ever> I have none, but I would like to see what would be the major tasks for us in K-3
19:25:50 <tonytan4ever> cyle
19:25:52 <mpanetta> Which means this meeting may not be recorded :(
19:26:14 <amitgandhinz> so far we have this: https://launchpad.net/poppy/+milestone/kilo-3
19:26:23 <amitgandhinz> and the stuff that will roll over from k2
19:26:45 <amitgandhinz> basically the queue driver, sqlalchemy support, and swift origin support
19:26:46 <tonytan4ever> OK
19:26:51 <amitgandhinz> speaking of which.....
19:27:09 <amitgandhinz> i spoke with some of the swift guys here regarding swift containers as origins
19:27:25 <tonytan4ever> I did not see message queue blueprint though.
19:27:32 <amitgandhinz> the approach we are going down is a piece of middleware that swift operators can deploy
19:27:42 <amitgandhinz> tonytan4ever: its still in k2 thats why
19:27:55 <tonytan4ever> Oh OKay.
19:28:09 <amitgandhinz> the middleware will allow poppy to set up containers to be cdn enabled
19:28:36 <amitgandhinz> and allow metadata to be set to allow edge servers to pull from origin with restricted access etc (ie provider verification)
19:29:06 <amitgandhinz> hopefully i should have a spec from one of the swift devs by next week which will determine what needs to happen in the poppy code to support it
19:30:11 <obulpathi> cool
19:30:35 <amitgandhinz> are there any important features we think we need to add
19:30:49 <amitgandhinz> i need to add bp for vanity ssl
19:31:28 <amitgandhinz> also i have bp for cookie forwards to origin, forward headers, CORS support etc
19:31:46 <amitgandhinz> those are small items that should be pretty easy to implement (famous last words haha)
19:32:06 <amitgandhinz> also we need to get devstack support
19:33:25 <obulpathi> is devstack a requirement?
19:33:42 <obulpathi> or it is just kind of like live-cd , using which people can play with poppy?
19:33:44 <amitgandhinz> it makes it easier for operators to install poppy on the env
19:33:51 <obulpathi> ok
19:35:23 <amitgandhinz> hopefully by the end of k3 we have a solid api with many of the loose ends handled, so that we can go into the next summit with a working product that operators can start deploying
19:36:41 <amitgandhinz> ok any other questions?
19:38:14 <obulpathi> no, nothing from me
19:38:18 <amitgandhinz> ok, thanks everyone
19:38:19 <miqui_> none from me..
19:38:24 <amitgandhinz> #endmeeting