18:59:20 <amitgandhinz> #startmeeting Poppy Weekly Meeting
18:59:20 <openstack> Meeting started Thu Jan 29 18:59:20 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:59:24 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
18:59:28 <amitgandhinz> #topic RollCall
18:59:39 <amitgandhinz> hi
18:59:44 <amitgandhinz> who do we have today?
19:00:04 <mpanetta> o/
19:00:10 <wbrothers> wbrother o/
19:00:17 <catherineR> o/
19:00:23 <tonytan4ever> o/
19:00:36 <obulpathi> o/
19:00:48 <mpanetta> The punman is here
19:00:48 <amitgandhinz> #link https://wiki.openstack.org/wiki/Meetings/Poppy
19:00:59 <amitgandhinz> mpanetta: dont encourage him
19:01:08 <amitgandhinz> he'll punish us
19:01:10 <amitgandhinz> =P
19:01:13 <mpanetta> I promise, I won't :P
19:01:23 <mpanetta> Oh god.. Not you too!
19:01:35 <mpanetta> pun-ish hah
19:01:42 <miqui> hello...
19:02:00 <wbrothers> BWAHAHAHAHAHAHA
19:02:05 <megan_w_> hi all
19:02:26 <amitgandhinz> ok lets get started
19:02:28 <amitgandhinz> #link https://wiki.openstack.org/wiki/Meetings/Poppy
19:02:38 <amitgandhinz> #topic Review Last Weeks Items
19:02:50 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-01-22-19.01.html
19:03:00 <amitgandhinz> only one action item here
19:03:08 <amitgandhinz> wbrothers to add doc to cdn vendor wiki page on how to add a mimic plugin for their api
19:03:18 * sriram is here
19:03:29 <obulpathi> hey sriram
19:03:32 <obulpathi> welcome to poppy :)
19:03:33 <mpanetta> Ooo!  You joining us now?
19:03:35 <wbrothers> The initial wiki content is out there
19:03:45 <amitgandhinz> #link https://wiki.openstack.org/wiki/Poppy/Provider_-_Getting_Started/Mimic_Driver
19:03:47 <amitgandhinz> very cool stuff
19:03:57 <sriram> mpanetta: yep
19:04:03 <amitgandhinz> this should really help the vendors (and anyone else) set up mimic drivers
19:04:22 <amitgandhinz> thanks wbrothers
19:04:33 <amitgandhinz> on a related note, i added a bunch of provider instructions also
19:04:36 <wbrothers> Feel free to email if you have questions
19:04:36 <amitgandhinz> #link https://wiki.openstack.org/wiki/Poppy/Provider_-_Getting_Started#Building_a_Provider_Driver
19:05:00 <amitgandhinz> covering Poppy Features and configuring your provider driver, and running api tests
19:05:19 <amitgandhinz> i still need to do the step by step instructions on building a provider (thats up next =) )
19:05:39 <amitgandhinz> but hopefully this will help edgecast and maxcdn get started with poppy
19:06:43 <amitgandhinz> i'd appreciate if others could start reviewing those provider instructions also
19:06:56 <amitgandhinz> lets make these the best getting started docs in openstack!
19:07:05 <miqui> +1
19:07:13 <tonytan4ever> +1
19:07:30 <sriram> +2(^10)
19:07:43 <amitgandhinz> #action everyone to review Getting Started guide for CDN providers
19:08:20 <amitgandhinz> #topic Kilo-3 Updates (Bugs and Blueprints)
19:08:26 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-3
19:09:04 <amitgandhinz> lets do bugs first
19:09:30 <amitgandhinz> miqui: https://bugs.launchpad.net/bugs/1381091
19:09:35 <amitgandhinz> any progress on that?
19:10:33 <miqui> no, i have been focusing how to run poppy locally so that i can map the actions to their outputs in the domhedoc
19:10:49 <amitgandhinz> ok.  do you need any help on that?
19:10:58 <miqui> am taking time off tomorrow so that i can figure all this out...
19:11:19 <miqui> yes, i will ping some of you tomorrow our channel
19:11:37 <amitgandhinz> ok, please ask us in the channel for help if you need it.  hopefully the docs are good, and if we need to add stuff this will be a good opportunity to discover missing instructions
19:11:50 <miqui> sure... thanks...
19:12:12 <amitgandhinz> obulpathi: https://bugs.launchpad.net/bugs/1380679
19:12:23 <obulpathi> In review
19:12:50 <amitgandhinz> ok cool.  lets get it reviewed =)
19:12:51 <obulpathi> I found only one place where the header was not used
19:12:58 <obulpathi> it was a negative test
19:12:58 <amitgandhinz> ok
19:13:06 <obulpathi> so it was failing for wrong reason
19:13:08 <obulpathi> fixed it
19:13:18 <amitgandhinz> obulpathi: https://bugs.launchpad.net/bugs/1412557
19:13:22 <obulpathi> In review
19:13:33 <obulpathi> Updated and added api tests
19:13:35 <amitgandhinz> sweet!  lets get that reviewed too =)
19:13:38 <obulpathi> both negative and positive
19:13:55 <amitgandhinz> and i completed this one: https://bugs.launchpad.net/bugs/1394720
19:14:23 <amitgandhinz> although i think something weird is happening as my master branch is now failing - im going to investigate why its no longer passing after the merge
19:14:40 <amitgandhinz> ok moving on to blueprints
19:15:00 <amitgandhinz> tonytan4ever: can you give us an update on the taskflow driver work (https://blueprints.launchpad.net/poppy/+spec/queue-driver)
19:15:48 <tonytan4ever> I'd say it's in good progress. A minimal example of poppy running job board worker/task_submitter is done now.
19:15:49 <miqui> on that one, what was finally decided?
19:15:57 <miqui> rabbitmq and tf ?
19:16:06 <amitgandhinz> miqui: taskflow was decided in last weeks meeting
19:16:14 <tonytan4ever> We use task flow job board paradigm
19:16:28 <tonytan4ever> which only utilizes a backend zookeeper.
19:16:33 <tonytan4ever> No rabbit-mq needed.
19:16:37 <sriram> tonytan4ever: cool is it using conductors now?
19:16:39 <miqui> k, i was not sure since we mentioned to investigate both celery and tf
19:16:43 <tonytan4ever> Yes.
19:16:49 <sriram> awesome.
19:17:21 <amitgandhinz> miqui: last week the majority had voted on TF
19:17:30 <miqui> k
19:17:31 <tonytan4ever> TaskFlow itself supports multiple backends, including rabbitmq, but the job-board/conductor mode only have support with zookeeper.
19:17:43 <sriram> yes, correct.
19:18:09 <tonytan4ever> And the normal worker/engine-run mode does not support asynchrounous task execution.
19:18:23 <tonytan4ever> So it is not applicable for poppy, we want the task to be async.
19:18:54 <tonytan4ever> And the normal worker/engine-run mode does have rabbitmq backend/
19:19:24 <mpanetta> So we are dropping the rabbitmq requirement?
19:19:28 <amitgandhinz> so we need the conductor to have async?
19:19:29 <tonytan4ever> So I have built a prototype of the taskflow "distributed_task" driver.
19:19:41 <tonytan4ever> amitgandhinz: That's right.
19:20:00 <amitgandhinz> do we need rabbit at all then?
19:20:08 <tonytan4ever> mpanetta: We gotta drop rabbitmq, but need zookeeper.
19:20:10 <mpanetta> I was wondering the same...
19:20:13 <mpanetta> Ok
19:20:16 <miqui> hmmm...
19:20:20 <tonytan4ever> We don't need rabbitmq at all.
19:20:31 <miqui> so its zookeeper and tf....
19:20:41 <tonytan4ever> Yep
19:20:50 <sriram> amitgandhinz: the conductor executes in the background, AFAIK. and we can have it post results somewhere that would be accessible by the location href provided on the first call.
19:21:20 <sriram> no rabbitmq at all.
19:21:38 <miqui> is this apache zookeeper right?
19:21:42 <sriram> yep
19:22:10 <tonytan4ever> sriram: All our background task just returns a 202, so no href link is not needed to return to the response.
19:22:20 <sriram> ah, I see.
19:22:21 <sriram> cool
19:22:27 <tonytan4ever> I mean background task http response.
19:22:58 <sriram> so there is no explicit check on when something is finished?
19:23:16 <sriram> pardon my ignorance, I havent looked into the code yet.
19:23:47 <tonytan4ever> We do want to utilize the retry/task dependency feature of taskflow to have finer control of the background task
19:24:12 <amitgandhinz> eventually we may return progress indicators, but that is out of scope (nie to have) at this point
19:24:15 <amitgandhinz> s/nie/nice
19:24:26 <sriram> amitgandhinz: cool
19:24:34 <tonytan4ever> Right now we don't check the "finished" state per se, but that's something we have in our eyes.
19:24:50 <sriram> understood, thanks for explaining.
19:24:52 <tonytan4ever> That's it for me.
19:25:04 <amitgandhinz> cool.  it sounds like good progress is being made on this
19:25:39 <amitgandhinz> ok next bp assigned is https://blueprints.launchpad.net/poppy/+spec/cookie-rules
19:25:46 <amitgandhinz> TBH i havent done anything on this yet
19:26:05 <amitgandhinz> ive thought about it a little though
19:26:12 <amitgandhinz> im going to have to add a new section into our service config to store "content rules"
19:26:49 <amitgandhinz> this is where the "cookie forwarding" rules would live, as well as header forwarding, and geo rules
19:27:08 <amitgandhinz> i'll spec it up over the next week in apiary and send it out for review before implementing
19:27:36 <amitgandhinz> unfortuantely it didnt fit into any of our existing sections as its not a restriction, and doesnt have a ttl associated with it
19:28:12 <amitgandhinz> also, with the new section, it also means a new column in our services columnfamily in casssandra
19:28:19 <amitgandhinz> which means a schema update
19:28:37 <amitgandhinz> which means we need to implement https://blueprints.launchpad.net/poppy/+spec/cassandra-schema-versioning before i can do this story
19:28:47 <amitgandhinz> (or do it as part of that story)
19:29:22 <amitgandhinz> ok....
19:29:28 <tonytan4ever> One question
19:29:30 <amitgandhinz> sure
19:30:09 <tonytan4ever> So we need one generic 'content rule' section for the cookie fowarding rule, or we need three sections for cookie fowarding, header fowarding, and geo rules, respectively ?
19:30:46 <amitgandhinz> im thinking at this point it would be one generic 'content_rules' section, and it would contain the ability to set each of those rules
19:31:05 <amitgandhinz> similar to how we have one restrictions section where we can set 'referrer', 'clientip', 'method', etc
19:31:41 <amitgandhinz> we would have one 'content rules' section where we set the rules with maybe a type, and values...
19:31:50 <amitgandhinz> im still designing how it should work
19:31:59 <tonytan4ever> K.
19:32:00 <amitgandhinz> but im trying to minimize sections
19:32:26 <amitgandhinz> try to design in a generic way that gives us future proof
19:32:39 <amitgandhinz> ok
19:32:45 <amitgandhinz> miqui: https://blueprints.launchpad.net/poppy/+spec/home-doc
19:33:00 <amitgandhinz> i guess this is dependant on getting your local env up and running
19:33:06 <miqui> correct...
19:33:13 <amitgandhinz> ok
19:33:14 <miqui> amd going to dedicate all day on that tomorrow...
19:33:21 <amitgandhinz> cool
19:33:25 <amitgandhinz> obulpathi: https://blueprints.launchpad.net/poppy/+spec/mimic-racksapce-dns
19:33:34 <obulpathi> I did not make any progress on this
19:33:41 <miqui> once i get past this then i can then at least see the output each route/service..
19:34:07 <amitgandhinz> ok
19:34:28 <amitgandhinz> any other blueprints in progress that we have not discussed>
19:35:13 <amitgandhinz> ok
19:35:29 <amitgandhinz> #topic New Items
19:35:33 <amitgandhinz> nothing to see here
19:35:35 <amitgandhinz> moving on =P
19:35:41 <amitgandhinz> #topic Open Discussion
19:35:54 <amitgandhinz> any one have a topic they want to discuss?
19:36:31 <sriram> is there anything I need to know, on getting started with poppy?
19:36:40 <amitgandhinz> sriram: yes!
19:36:40 <sriram> any gotchas etc.
19:36:45 <amitgandhinz> first you have to pass the drug test
19:36:48 <amitgandhinz> =P
19:36:50 <amitgandhinz> then....
19:36:51 <miqui> i did!
19:36:56 <sriram> haha :P
19:36:57 <mpanetta> Don't take a drug test immediately after coding
19:37:13 <amitgandhinz> https://wiki.openstack.org/wiki/Poppy
19:37:16 <sriram> what if I monkey-patch myself?
19:37:19 <sriram> ;)
19:37:22 <mpanetta> That sounds painful
19:37:36 <tonytan4ever> What happens with coding while in-poppy-cated ?
19:37:43 <sriram> ha.
19:38:01 <miqui> zuul gates get you!
19:38:19 <amitgandhinz> since you are already familiar with openstack projects, that part should be a breeze
19:38:34 <mpanetta> I wanna kill pip right about now :P
19:38:40 <mpanetta> Or maybe PBR, I can't tell which
19:38:48 <sriram> cool, I'll look up the wiki and learn what I can.
19:38:50 <miqui> what is PBR?
19:38:52 <amitgandhinz> we use docker a lot locally (for running cassandra)
19:39:01 <sriram> miqui: python build readiness.
19:39:03 <amitgandhinz> pbr is a beer
19:39:08 <miqui> ahahahaha
19:39:25 <sriram> miqui: helps to easily bootstrap python projects.
19:39:30 <mpanetta> That, and python build reasonableness
19:39:40 <mpanetta> Beer sounds better tho :P
19:39:54 <sriram> err, mpanetta is right.
19:40:02 <sriram> not readiness, lol.
19:40:12 <miqui> so, as far as zookeer....
19:40:15 <mpanetta> To be fair, I was just on the page yesterday :P
19:40:22 <miqui> i guess we have to ramp up on this...
19:40:43 <sriram> amitgandhinz: I see.
19:40:44 <amitgandhinz> yeh taskflow seems to be built to only support zookeeper as of now
19:41:02 <amitgandhinz> sriram: so docker will be your friend for running cassandra locally, and running api tests, mimic etc
19:41:03 <sriram> is that a development thing? I have cassandra running locally on my box.
19:41:16 <amitgandhinz> thats fine too if you like java on your box =P
19:41:29 <sriram> amitgandhinz: ah, I see. so provides a clean slate everytime. :)
19:41:35 <amitgandhinz> yup
19:41:39 <sriram> cool, I can do that as well.
19:41:50 <amitgandhinz> besides that, we use pecan
19:42:14 <sriram> yeah, have worked with pecan before.
19:42:15 <miqui> sriram: docker.io
19:42:22 <amitgandhinz> for the providers, you can sign up for a free account at fastly and set up the fastly provider
19:42:26 <miqui> it is awesome...
19:42:44 <sriram> miqui: I'll check it out, thanks.
19:42:46 <mpanetta> Fastly has free accounts?
19:42:57 <amitgandhinz> well its a limit of free for n requests
19:43:01 <amitgandhinz> and n is pretty high
19:43:12 <sriram> I have to rate-limit myself then, :P
19:43:33 <mpanetta> Neat-o
19:44:11 <sriram> amitgandhinz: will sign up for an account.
19:45:27 * amitgandhinz back.  my network died for some reason
19:45:59 <amitgandhinz> ok, any other topics to discuss?
19:46:34 <sriram> nope. I'll begin to get myself familiar with poppy.
19:46:37 <miqui> not from me..
19:47:06 <amitgandhinz> ok, thanks everyone
19:47:12 <amitgandhinz> you all get 13 min back =)
19:47:40 <amitgandhinz> #endmeeting