19:00:11 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:11 <openstack> Meeting started Thu Apr  9 19:00:11 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:15 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:18 <amitgandhinz> #topic Roll Call
19:00:27 <amitgandhinz> hullo hullo
19:00:33 <wbrothers> I'm here
19:00:43 <sriram> /o\
19:00:51 <sriram> \o/
19:01:01 <mpanetta> \o
19:01:15 <sriram> -o-
19:01:31 * sriram just stretching :P
19:01:35 <mpanetta> -o-
19:01:40 <mpanetta> \o/
19:01:55 <tonytan4ever> o/
19:02:07 <amitgandhinz> lol
19:02:14 <amitgandhinz> ok lets get this show on the road
19:02:35 <amitgandhinz> #topic Last Week (well 2 weeks ago) Today
19:02:47 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-03-26-19.00.html
19:02:55 <amitgandhinz> ok no action items
19:03:04 <amitgandhinz> we really need to start assigning ourselves action items =P
19:03:22 <amitgandhinz> #topic Kilo Review
19:03:25 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-3
19:03:49 <obulpathi> o/
19:04:08 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/gate-api-tests
19:04:12 <amitgandhinz> that one is me =/
19:04:30 <amitgandhinz> i still havent got around to doing this, im going to take my name off it until i can pick it up again
19:04:46 <sriram> cool
19:05:12 <amitgandhinz> tonytan4ever: Custom Certs
19:05:44 <tonytan4ever> We gonna go for manual provisioning for custom cert
19:06:16 <amitgandhinz> what is the latest status on the SPS provisioning for custom certs
19:06:24 <tonytan4ever> and I tested custom cert with the SPS branch it works.
19:06:31 <amitgandhinz> w00t!
19:06:45 <obulpathi> awesome!
19:06:51 <miqui> am here sorry am late
19:06:55 <amitgandhinz> so is this one ready for review now?
19:06:59 <amitgandhinz> hi miqui =)
19:07:13 <tonytan4ever> It is ready for review.
19:07:24 <amitgandhinz> cool
19:07:34 <tonytan4ever> But it is mixed with SAN cert  support, I don't expect it to be merged anytime soon though.
19:07:54 <sriram> cool
19:08:07 <amitgandhinz> The SAN one is blocked due to akamai rt?
19:08:15 <sriram> perhaps that can be action items, just reviewing everything.
19:08:30 <amitgandhinz> #action sriram to review everything
19:08:34 <tonytan4ever> Kind of.
19:08:40 <sriram> haha
19:08:43 <sriram> done
19:09:47 <amitgandhinz> hmm i wonder if we can get the custom one merged, and disable the san one from running its tasks in taskflow
19:09:55 <amitgandhinz> it would be nice to be able to feature flag that stuff
19:10:09 <sriram> should be possible, there is a feature called TargetFlow
19:10:13 <amitgandhinz> but lets first hold off until this manual stuff is good to go
19:10:30 <sriram> in taskflow, where you can specify till which flow needs to get executed.
19:10:31 <amitgandhinz> then we can get the custom automated one in (assuming it works end to end)
19:10:39 * sriram throws it out there :)
19:10:40 <amitgandhinz> and then let SAN follow after
19:10:50 <tonytan4ever> I wouldn't suggest, manual process and SPS process has different flow and code.
19:11:01 <amitgandhinz> ok
19:11:21 <malini1> manual is done manually *-)
19:11:27 <amitgandhinz> lol
19:11:37 <miqui> he
19:11:46 <tonytan4ever> Plus I need to hear from Akamai we have enough custom cert slots.
19:11:59 <amitgandhinz> ya
19:12:10 <amitgandhinz> ok, shared certs got merged yesterday - yay =D
19:12:18 <amitgandhinz> so that one is working
19:12:56 <tonytan4ever> That one currently has some problem in testing
19:13:12 <tonytan4ever> I have contacted Akamai to ask them to take a look.
19:13:53 <tonytan4ever> We created Cname, policy, and sharded certs succesfully, for some reason the content does not get pulled from origin.
19:14:44 <tonytan4ever> This is referring to preview environment.
19:15:25 <amitgandhinz> sorry, got booted off the web
19:15:27 <amitgandhinz> must have been something i said lol
19:15:41 <sriram> the web is sentient amitgandhinz
19:15:47 <amitgandhinz> ok moving on...
19:16:11 <amitgandhinz> miqui: how is the devstack integration going?
19:16:40 <miqui> making progress....installing devstack w/ few problems...
19:16:45 <miqui> but am close to get past that..
19:16:50 <sriram> woot!
19:17:05 <amitgandhinz> cool.  yeh i keep hearing install devstack is a beast
19:17:16 <amitgandhinz> malini has done it before so ask her questions if needed
19:17:17 <miqui> want to do it enough so that i can do it in my sleep
19:17:24 <amitgandhinz> haha
19:17:31 <malini> tht might turn into a nightmare
19:17:32 <miqui> yup thanks...
19:17:37 <miqui> hahahah
19:18:00 <miqui> i have have a 16gig laptop so it should be enough..
19:18:12 <sriram> there must be heat template to spin up devstack.
19:18:15 <amitgandhinz> make sure you do it in a clean environment each time
19:18:19 <sriram> if not, that could be a great idea :P
19:18:30 <miqui> amitgandhinz: yup i have a laptop for that..
19:19:06 <miqui> i re-image with every attempt...
19:19:15 <miqui> so its clean..
19:20:53 <mpanetta> amitgandhinz: The internets don't like you today...
19:21:05 <amitgandhinz> i think its the vpn
19:21:08 <amitgandhinz> im hardwired now
19:21:11 <mpanetta> Ah
19:21:28 <amitgandhinz> alright
19:21:36 <amitgandhinz> #topic Bugs
19:22:09 <amitgandhinz> ok obul reminds me about Log Delivery
19:22:16 * amitgandhinz looking for that bp
19:22:23 <malini> https://blueprints.launchpad.net/poppy/+spec/log-delivery
19:22:55 <amitgandhinz> ok got it thanks
19:22:59 <obulpathi> ok
19:23:02 <amitgandhinz> obulpathi:
19:23:07 <obulpathi> :)
19:23:32 <obulpathi> so, the log delivery bp adds log_delivery options to service endpoint
19:23:50 <obulpathi> right now the only option is: enabled, a boolean
19:24:27 <obulpathi> if enabled, poppy creates a swift container  named .CDNACCESSLOGS
19:24:51 <obulpathi> you can specify preferred datacenters for log delivery container
19:25:02 <obulpathi> so, this part is almost done
19:25:11 <obulpathi> make some final changes and polishing
19:25:31 <obulpathi> should have everything by tomorrow
19:25:33 <amitgandhinz> cool
19:25:35 <amitgandhinz> =D
19:26:17 <obulpathi> once this is done, will work on Pig Latin scripts to separate the logs per user and ship them to containers using taskflow
19:26:30 <obulpathi> thats pretty much it to the blueprint
19:26:41 <amitgandhinz> thanks
19:26:48 <obulpathi> :)
19:26:49 <amitgandhinz> ok is that it for bp's?
19:26:57 <obulpathi> yep
19:27:02 <amitgandhinz> ok bugs....
19:27:24 <amitgandhinz> there have been a few bugs fixed recently
19:27:40 <amitgandhinz> i added one that fixes teh referrer restrictioins behavior (in review)
19:27:59 <amitgandhinz> the problem here was that previously we were applying referer restrictions to the whole site
19:28:04 <miqui> i have to drop guys...ttyl...
19:28:20 <obulpathi> ttyl miqui
19:28:27 <amitgandhinz> which would then refuse anyone without a referer header, including new visitors coming in from a browser
19:28:47 <amitgandhinz> this patch fixes that by allowing customers to specify a path for the restriction
19:28:47 <amitgandhinz> this will also apply to geo restrictions later
19:29:17 <amitgandhinz> a bunch have been merged, which means ya'll reviewed them and i dont need to discuss them haha
19:29:37 <obulpathi> cool
19:29:41 <obulpathi> will review
19:30:56 <tonytan4ever> I reviewed it.
19:31:05 <amitgandhinz> #topic Open Discussion
19:31:10 <amitgandhinz> ok anything else to discuss?
19:31:30 <obulpathi> nop nothing from me
19:32:09 <sriram> nop
19:32:16 <tonytan4ever> I am good
19:32:31 <malini> me too
19:32:44 <amitgandhinz> ok thanks everyone
19:32:48 <amitgandhinz> #endmeeting