19:01:30 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:01:31 <openstack> Meeting started Thu Jun 11 19:01:30 2015 UTC and is due to finish in 60 minutes. The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:35 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:01:36 <amitgandhinz> #topic Roll Call
19:01:37 <tonytan4ever> o/
19:01:38 <Obulpath_> o/
19:01:40 <malini> o/
19:01:45 <sriram> o/
19:01:48 <sriram> Obulpath_: lol
19:01:50 <cathR> o/
19:02:00 <Obulpath_> hahha
19:02:02 <malini> Obulpath_: sounds very medical
19:02:07 <amitgandhinz> windows paths, linux paths, obul paths
19:02:11 <amitgandhinz> he's the new OS
19:02:11 <sriram> Obulpath_: path to salvation? :P
19:02:32 <Obulpath_> It should have been _Obulpathi
19:02:50 <sriram> ha
19:02:54 <Obulpath_> but the _ got attached after the name, instead of before the name
19:03:19 <amitgandhinz> #topic Last Week Recap
19:03:21 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-06-04-19.04.html
19:03:26 <amitgandhinz> yay action items !
19:03:38 <amitgandhinz> sriram to add pig files to repo for log delivery
19:03:43 <sriram> and I actually did mine this time lol
19:03:51 <amitgandhinz> w00t!
19:03:54 <malini> sriram: 10 min before the meeting ;)
19:03:56 <sriram> https://review.openstack.org/#/c/190755/
19:04:00 <amitgandhinz> it counts =)
19:04:10 <sriram> it hasnt even passed the jenkins gate yet ha. :P
19:04:13 <amitgandhinz> lol
19:04:18 <malini> I was kidding p - of course
19:04:24 <amitgandhinz> next - amitgandhinz to release K package
19:04:29 <amitgandhinz> this is done!
19:04:33 <sriram> woohoo
19:04:42 * sriram gets his party mode on
19:04:50 <Obulpath_> Awesome!
19:04:55 <amitgandhinz> https://launchpad.net/poppy/kilo/kilo-3 released!
19:05:07 <amitgandhinz> next - amitgandhinz to groom L1 series
19:05:08 <tonytan4ever> Yay
19:05:10 <amitgandhinz> this is done =)
19:05:24 <malini> yayy..we have a mission now
19:06:07 <amitgandhinz> https://launchpad.net/poppy/liberty
19:06:22 <amitgandhinz> this is liberty 1 https://launchpad.net/poppy/+milestone/liberty-1
19:06:27 <amitgandhinz> it is due on June 25
19:06:31 <amitgandhinz> now hurry up and code =P
19:07:03 <Obulpath_> hhaha ..
19:07:08 <Obulpath_> we are on it
19:07:08 <malini> I was abt to ask for the e2e test updates - but not after u mentioned the date
19:07:10 <sriram> ah, I need to reference this bp in my patch: https://blueprints.launchpad.net/poppy/+spec/log-delivery
19:07:20 <sriram> I'll do that shortly after the meeting
19:07:43 <sriram> but yeah, after that we should be good.
19:07:48 <amitgandhinz> #topic Discuss Liberty 1 Progress
19:07:54 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/liberty-1
19:08:14 <amitgandhinz> so this release i kept it small but still aggressive
19:08:26 <amitgandhinz> since we only have a couple of weeks left in it
19:08:53 <sriram> is this bug still valid? https://bugs.launchpad.net/poppy/+bug/1421183
19:08:55 <openstack> Launchpad bug 1421183 in Poppy "PATCH - Adding a second rule to an origin causes the service to go to failed state" [High,New]
19:08:57 <sriram> malini: ^
19:09:02 <amitgandhinz> idk the bugs just rolled over from kilo
19:09:16 <amitgandhinz> #action amitgandhinz and malini to groom the bugs
19:09:30 <sriram> yeah, we need 'em cleaned up
19:09:38 <malini> Imagine 'groom the bug'
19:09:46 <amitgandhinz> spiders are hairy
19:09:50 <sriram> heh
19:10:08 <amitgandhinz> did anantha make it into the channel?
19:10:10 <sriram> get your groom on LOL
19:10:11 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/host-header-forwarding
19:10:19 <anantha> Yeah, I'm here
19:10:42 <amitgandhinz> odd, your name was not tab completing
19:10:50 <amitgandhinz> cool, hows the progress on the host header forwarding
19:11:10 <amitgandhinz> this is in review right
19:11:18 <amitgandhinz> https://review.openstack.org/189854
19:12:09 <anantha> amitgandhinz: Yes it is in review. I have to modify some tests that assert the response body.
19:12:20 <sriram> anantha: awesome
19:12:22 <malini> woot..woot..it has api tests <:o)
19:12:24 <amitgandhinz> ok cool. great progress on this btw
19:12:34 <sriram> anantha: jsut keep pestering people to review it :P
19:12:42 <anantha> Lol, sure.
19:12:55 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/security-testing
19:13:04 <sriram> oooo, security
19:13:10 <amitgandhinz> malini: any idea on the state of this one
19:13:21 <malini> I dont think mike has started on it
19:13:25 <malini> I will follow up
19:13:30 <amitgandhinz> there are already two patches
19:13:32 <amitgandhinz> one was merged
19:13:37 <amitgandhinz> the other one is in conflict
19:14:00 <amitgandhinz> #action malini to sync up with michael xin regarding security tests
19:14:12 <sriram> jian5397: ping
19:14:13 <malini> jian5397: ^
19:14:33 * sriram sees you hiding lol
19:14:34 <amitgandhinz> oooh secret names
19:14:48 <amitgandhinz> lol
19:14:50 <michaelxin> sriram: malini I am here
19:14:53 <michaelxin> hi
19:15:00 <malini> hello michaelxin!
19:15:03 <amitgandhinz> hi =)
19:15:07 <sriram> hello! :D
19:15:08 <amitgandhinz> just looking to get an update on https://blueprints.launchpad.net/poppy/+spec/security-testing
19:15:10 <michaelxin> I talked with henry about this.
19:15:21 <michaelxin> He should be following up with you today.
19:15:43 <michaelxin> I might go ahead and schedule a meeting so that we can have a concrete dates and actions
19:15:49 <michaelxin> I will schedule a meeting.
19:16:00 <amitgandhinz> cool. i also want to get an idea of how much is left to submit etc
19:16:21 <amitgandhinz> ok moving on....
19:16:25 <amitgandhinz> miqui: https://blueprints.launchpad.net/poppy/+spec/devstack
19:16:31 <amitgandhinz> any update on this?
19:16:55 <miqui> hi guys...
19:17:18 <miqui> sorry, no updates....am stuck on that one on and off...
19:17:40 <amitgandhinz> ok
19:17:49 <amitgandhinz> sriram: https://blueprints.launchpad.net/poppy/+spec/log-delivery
19:17:54 <amitgandhinz> you said this was in review right?
19:18:01 <sriram> yeh
19:18:08 <sriram> just need to update the commit message
19:18:12 <amitgandhinz> cool
19:18:13 <sriram> with implements bp
19:18:24 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/geo-restrictions
19:18:39 <amitgandhinz> this one will soon need to be rebased to work since it was submitted a while back
19:18:51 <tonytan4ever> Yeah。
19:18:59 <tonytan4ever> I will rebase it.
19:19:13 <amitgandhinz> the good thing is that once we get that done, the IP restrictions https://blueprints.launchpad.net/poppy/+spec/ip-restrictions will be exactly the same
19:19:20 <amitgandhinz> just change geo to ip ;-)
19:19:36 <tonytan4ever> The PR is here: https://review.openstack.org/#/c/163598/
19:19:43 <tonytan4ever> Everyone is sitll welcome to review.
19:19:45 <tonytan4ever> Yeah
19:20:01 <tonytan4ever> IP restriction should be similar.
19:20:08 <amitgandhinz> we also need to figure out what geo's we want poppy to accept and then translate to what the providers understand
19:20:14 <amitgandhinz> i think that was my last comment
19:20:19 <tonytan4ever> Yes.
19:20:21 <amitgandhinz> we can discuss that later though when we get to it
19:20:50 <amitgandhinz> and last one - https://blueprints.launchpad.net/poppy/+spec/use-testr
19:20:56 <amitgandhinz> this one we did, and then reverted
19:21:27 <amitgandhinz> we need to figure out how to get the api tests running via testr, and also better jenkins integration with pretty reports
19:21:33 <Obulpath_> yep
19:21:57 <amitgandhinz> also, cpowell told me that testr wasnt actually running the tests using tox, it was just returning success with no tests actually run
19:22:05 <amitgandhinz> this is a low priority for now though
19:22:10 <Obulpath_> We forgot to set some env variables
19:22:20 <Obulpath_> I fixed this in a pr, not sure if it got merged
19:22:24 <amitgandhinz> oh ok
19:22:34 <Obulpath_> the test discovery was failing
19:22:51 <amitgandhinz> ok not going to go through the bugs since they need to be groomed and bathed
19:23:13 * sriram imagines that scene in his head
19:23:32 <Obulpath_> amitgandhinz: Can we add the bp for service enable/disable endpoint?
19:23:43 <Obulpath_> to liberty-1?
19:23:45 <amitgandhinz> yes, please submit a bp for that
19:23:50 <Obulpath_> cool .. thanks :)
19:23:55 <Obulpath_> will do it
19:24:12 <amitgandhinz> any other bp that people are working on that i didnt cover
19:24:19 <sriram> awesome, Obulpath_ once thats done, please update the commit message to say implements bp
19:24:29 <Obulpath_> sure
19:24:51 <amitgandhinz> ok
19:24:56 <amitgandhinz> #topic Open Discussion
19:25:10 <amitgandhinz> anyone from Edgecast here today?
19:25:11 <miqui> amitgandhinz: been and out due conferences/meetups .etc.... how did it go in last summit?
19:25:58 <amitgandhinz> miqui: it went well. you can read some of the summary in last weeks meeting logs http://eavesdrop.openstack.org/meetings/weekly_poppy_meeting/2015/weekly_poppy_meeting.2015-05-28-19.00.log.html
19:26:08 <miqui> great... thanks...
19:26:14 <amitgandhinz> we had some interest from highwinds cdn
19:26:21 <miqui> cool...
19:26:30 <amitgandhinz> also edgecast cdn participated in last week's meeting
19:27:05 <amitgandhinz> i guess slackorama couldnt make it today
19:27:15 <malini> they must be busy building the driver now ;)
19:27:23 <miqui> have there been (or will there be) design meetings regarding the next direction for poppy?
19:27:23 * amitgandhinz crosses fingers
19:27:40 <amitgandhinz> there havent been any design meetings
19:27:45 <miqui> amitgandhinz: k
19:27:51 <amitgandhinz> i have set the areas for liberty cycle
19:27:58 <amitgandhinz> https://blueprints.launchpad.net/poppy/liberty
19:28:04 <miqui> k, thanks
19:28:13 <amitgandhinz> big areas are integrating with swift containers
19:28:28 <amitgandhinz> and then doing a bunch of smaller features we are hearing customers ask for
19:28:45 <Obulpath_> https://blueprints.launchpad.net/poppy/+spec/enable-disable-service
19:28:59 <amitgandhinz> i also want to get our openstack story good to see if we should make a bid for big tent
19:29:08 <Obulpath_> can you please change the target for this bp to liberty-1?
19:29:36 <sriram> amitgandhinz: you mean swift containers as origin right?
19:29:45 <amitgandhinz> ya
19:29:49 <sriram> cool
19:30:23 <Obulpath_> thanks :)
19:30:43 <amitgandhinz> any other topics for discussion?
19:31:23 <miqui> not from me..thanks...just trying to get back in circulation...
19:31:24 <Obulpath_> nothing from me
19:31:33 <tonytan4ever> Nope
19:31:34 <sriram> I'm good.
19:31:41 <malini> me too
19:31:49 <amitgandhinz> ok thanks everyone. was a good meeting
19:31:54 <sriram> see ya
19:31:54 <amitgandhinz> #endmeeting