19:03:22 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:03:23 <openstack> Meeting started Thu Jul 16 19:03:22 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:26 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:03:38 <sriram> o/
19:03:39 <amitgandhinz> #topic Roll Call
19:03:41 <malini> o/
19:03:42 <sriram> o/
19:03:43 <tonytan4ever> o/
19:03:47 <cathR> o/
19:04:34 <amitgandhinz> #link Agenda https://wiki.openstack.org/wiki/Meetings/Poppy
19:04:40 <amitgandhinz> #topic Last Week Update
19:04:48 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-07-09-19.02.html
19:05:02 <amitgandhinz> malini to get the outstanding security patches fixed and merged
19:05:06 * sriram clicks link
19:05:12 <malini> I am working with Henry on that
19:05:17 <malini> its WIP
19:05:22 <amitgandhinz> ok, will keep it rolling over, good stuff
19:05:25 <amitgandhinz> #action malini to get the outstanding security patches fixed and merged
19:05:31 <amitgandhinz> malini to clean up/fix the many test related patches that have been out there for a while
19:05:43 <malini> not there yet :/
19:05:47 <amitgandhinz> #action malini to clean up/fix the many test related patches that have been out there for a while
19:05:52 <amitgandhinz> sriram to review all patches
19:06:07 <sriram> amitgandhinz: have reviewed all except one
19:06:11 <amitgandhinz> =)
19:06:13 <sriram> I'll work on that.
19:06:18 <amitgandhinz> tonytan4ever to hound people to review his stuff
19:06:44 <tonytan4ever> I have been doing that, but I think I will still leave that item on
19:06:44 <malini> he is too good to hound people
19:06:45 <sriram> I'd like to think we were proactive this time ;)
19:06:52 <amitgandhinz> #action tonytan4ever to hound people to review his stuff
19:07:03 <amitgandhinz> amitgandhinz to make mimic fastly the default driver
19:07:11 <amitgandhinz> didnt get much time to work on this
19:07:16 <amitgandhinz> #action amitgandhinz to make mimic fastly the default driver
19:07:41 <amitgandhinz> #topic Liberty Updates
19:07:50 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/liberty-2
19:08:50 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/ip-restrictions
19:08:58 <tonytan4ever> This one is in review
19:09:09 <tonytan4ever> I got hound some people to review it.
19:09:36 <sriram> tonytan4ever: I volunteer to review it lol
19:09:39 <sriram> :)
19:09:47 <tonytan4ever> Thanks
19:10:39 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/geo-restrictions
19:11:15 <tonytan4ever> This one is on hold until Akamai is rolling out their new API support whitelist/blacklist multiple countries
19:11:52 <amitgandhinz> is the code mostly done though (besides testing with multiple countries?)
19:12:27 <tonytan4ever> Yes
19:12:35 <amitgandhinz> cool
19:12:39 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/san-domain-migration
19:12:42 <tonytan4ever> I guess in that sense it could be good for review
19:12:51 <amitgandhinz> anantha isnt on, but this was merged today
19:13:00 <amitgandhinz> miqui: https://blueprints.launchpad.net/poppy/+spec/code-coverage
19:13:13 <sriram> miqui mentioned that he is working on this.
19:13:21 <amitgandhinz> ok cool
19:13:25 <sriram> and that he might not make in today for the meeting
19:13:37 <sriram> s/in/it in
19:13:59 <amitgandhinz> ok anything else to add for liberty?
19:14:07 <amitgandhinz> sriram: do you have a bp for the no-cache enhancement
19:14:24 <sriram> we tested flows? it had a bp associated with it
19:14:39 <sriram> amitgandhinz: nope
19:14:43 <sriram> need to create one.
19:15:26 <obulpathi> o/
19:15:31 <amitgandhinz> i dont see the bp for flows?
19:15:48 <sriram> I definitely know there was one. I was updating it.
19:15:57 <sriram> along every step of the way.
19:16:06 <sriram> did it go away because it was not approved?
19:16:24 <amitgandhinz> no
19:16:32 <sriram> it was definitely there :|
19:17:01 * amitgandhinz thinks sriram had a dream about updating bp's
19:17:10 <sriram> I even had a implements blueprint in my commit message lol
19:17:24 <sriram> amitgandhinz: I have email proof :P
19:17:42 * amitgandhinz thinks sriram may sleeptype
19:18:03 * sriram forwards amitgandhinz the email
19:18:05 <sriram> :P
19:18:23 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1425556 ?
19:18:23 <openstack> Launchpad bug 1425556 in Poppy "dns-exception-handling" [Low,Fix committed] - Assigned to Sriram (thesriram)
19:18:33 <sriram> amitgandhinz: thats fixed
19:18:36 <sriram> commit merged
19:19:21 <amitgandhinz> ok movign on then
19:19:34 <amitgandhinz> anything else for liberty?
19:20:32 <amitgandhinz> #topic Open Discussion
19:20:40 <tonytan4ever> not for me.
19:20:42 <amitgandhinz> so the talks were all submitted for Tokyo
19:20:47 <amitgandhinz> #link https://etherpad.openstack.org/p/poppy_tokyo
19:21:01 <sriram> amitgandhinz: woot
19:21:01 <amitgandhinz> there were a total of 5 talks submitted
19:21:07 <malini> wow!!!
19:21:09 <amitgandhinz> voting should start soon
19:21:28 <amitgandhinz> yeh, cpowell and balajiiyer came in at the last moment and submitted 3 more
19:21:28 * sriram votes for each one of them!! :D
19:21:52 <amitgandhinz> lets hope the votes come in our favor =)
19:22:00 <sriram> I'd like to bring up our commit message conventions
19:22:07 <amitgandhinz> floor is yours
19:22:16 <malini> now dance
19:22:41 <sriram> I have been pointing them out in patches, but ideally we should have a good description of what each patch does.
19:22:57 <malini> sriram: +1
19:23:04 <sriram> lets take that up as an action item to remind ourselves about it.
19:23:09 <malini> I am guilty of tht as well
19:23:22 <amitgandhinz> I agree, at the least it should reference a bug or bp.  and the message should be clear what is being achieved
19:23:37 <obulpathi> +1
19:23:44 <sriram> #action everyone to diligently check their commit messages and make sure they have enough detail
19:23:53 <sriram> thats it from me.
19:24:19 <amitgandhinz> #agreed everyone to diligently check their commit messages and make sure they have enough detail
19:24:28 <amitgandhinz> ok anything else?
19:24:41 <amitgandhinz> i have a hard stop at 330 so this is working out well ;-)
19:24:46 <sriram> ha
19:24:54 <balajiiyer> amitgandhinz: We didnt submit the talk on saltstack, we just have 4.
19:25:14 <amitgandhinz> ok
19:25:19 <amitgandhinz> i;ll remove it from the etherad
19:25:29 <malini> I submitted a couple with few other folks, but those are un-poppy
19:25:41 <amitgandhinz> traitor!
19:25:54 <malini> :-$
19:25:56 <amitgandhinz> bring on the cartel wars
19:26:18 <malini> its abt testing & all the good (??) stuff
19:26:36 <amitgandhinz> everyone knows poppy has the best warez
19:26:47 <amitgandhinz> ok, thanks everyone
19:26:50 <amitgandhinz> #endmeeting