19:01:15 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:01:16 <openstack> Meeting started Thu Jul 30 19:01:15 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:19 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:02:01 <amitgandhinz> #topic RollCall
19:02:21 <sriram> o/
19:03:06 <cathR_> o/
19:03:08 <tonytan4ever> o/
19:03:11 <malini> o/
19:03:16 <anantha> o/
19:03:41 <amitgandhinz> #link Agenda: https://wiki.openstack.org/wiki/Meetings/Poppy
19:03:45 <amitgandhinz> #topic Recap
19:03:52 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-07-23-19.02.html
19:04:03 <amitgandhinz> amitgandhinz to make mimic fastly the default driver
19:04:34 <amitgandhinz> this is still a WIP - i have the mimic driver code working in poppy.  but i found many endpoints were not implemented in the fastly mimic api
19:04:44 <amitgandhinz> so many of the tests failed against it
19:04:57 <amitgandhinz> i should be able to get it passing by EOD tomorrow
19:05:01 <sriram> woot, the mimic driver works!
19:05:18 <amitgandhinz> #action amitgandhinz to make mimic fastly the default driver
19:05:22 <sriram> it will help us in starting to run api tests at the gate.
19:05:32 <amitgandhinz> yup, thats the goal
19:05:46 <amitgandhinz> i also want to add the dns mimic driver that does not exist yet
19:05:57 <amitgandhinz> else we can run the tests at the gate against the Default DNS driver
19:06:10 <amitgandhinz> malini to get the outstanding security patches fixed and merged
19:06:25 <malini> still WIP - we had one patch merged this week
19:06:31 <malini> will continue working with HEnry
19:06:41 <amitgandhinz> #action malini to get the outstanding security patches fixed and merged
19:06:51 <amitgandhinz> malini to clean up/fix the many test related patches that have been out there for a while
19:06:58 <malini> this is going to be an ongoing task - security tests
19:07:04 <amitgandhinz> We should make this more specific
19:07:15 <malini> still messy there :/
19:07:31 <amitgandhinz> #malini to deal with https://review.openstack.org/143720
19:07:33 <amitgandhinz> oops
19:07:38 <amitgandhinz> #action malini to deal with https://review.openstack.org/143720
19:07:47 <malini> thanks - lets do one a week :)
19:07:48 <amitgandhinz> #action malini to deal with https://review.openstack.org/144324
19:07:53 <malini> NOOOOOOO
19:07:56 <amitgandhinz> lets start with these two
19:07:58 <sriram> haha
19:07:58 <amitgandhinz> haha
19:08:01 <malini> ok - not bad
19:08:05 <malini> yelling helps
19:08:08 <amitgandhinz> either fix or abandon
19:08:30 <malini> I can get these tow done in a week :)
19:08:45 <amitgandhinz> cool
19:09:01 <amitgandhinz> #action amitgandhinz to assign more things to malini at next meeting
19:09:05 <malini> grrr....
19:09:09 <amitgandhinz> hehe
19:09:15 <amitgandhinz> tonytan4ever to hound people 4 ever to review his stuff
19:09:22 <tonytan4ever> I have been doing that
19:09:34 <amitgandhinz> and he got his ip merged
19:09:35 <malini> didnt we merge the IP restriction?
19:09:35 <amitgandhinz> yaya
19:09:40 <sriram> yep
19:09:43 <tonytan4ever> To get the IP restrictions merged, but still need to do that get notification driver merged
19:09:44 <malini> I have to add an E2E test
19:09:45 <sriram> hounding worked!!
19:09:54 <amitgandhinz> well hounded
19:10:16 <tonytan4ever> I would say keep this item on as I am rolling out more patches.
19:10:26 <amitgandhinz> #topic Liberty 2
19:10:30 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/liberty-2
19:10:32 <amitgandhinz> guess what !
19:10:39 <amitgandhinz> its release time!
19:10:45 <amitgandhinz> liberty 3 starts tomorrow
19:10:47 <obulpathi> Woot!!!
19:10:57 <amitgandhinz> i'll try to cut a release today after this meeting
19:11:23 <amitgandhinz> these cycles feel like they are too short
19:11:42 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/ip-restrictions
19:11:45 <amitgandhinz> this is merged right
19:11:48 <tonytan4ever> Right
19:12:05 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/geo-restrictions
19:12:23 <tonytan4ever> This one I'd say put it in review
19:12:25 <sriram> wow, time runs by fast.
19:12:37 <amitgandhinz> already is
19:13:00 <tonytan4ever> Cool
19:13:00 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/akamai-ssl-driver
19:13:07 <amitgandhinz> Started?
19:13:07 <tonytan4ever> This one is in progress.
19:13:25 <amitgandhinz> or Good Progress
19:13:31 <amitgandhinz> i'll do good progress
19:13:36 <tonytan4ever> Yes I started it. Good progress.
19:13:56 <tonytan4ever> A notification driver bp is coming along with it.
19:14:23 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/notification-driver
19:14:31 <amitgandhinz> ok let me link them
19:14:35 <tonytan4ever> Woot, it is in review.
19:15:43 <amitgandhinz> https://bugs.launchpad.net/bugs/1433807
19:15:44 <openstack> Launchpad bug 1433807 in Poppy "Reenable shared ssl + add domains/origins PATCH tests" [Medium,New]
19:15:44 <uvirtbot> Launchpad bug 1433807 in poppy "Reenable shared ssl + add domains/origins PATCH tests" [Medium,New]
19:15:49 <amitgandhinz> anyone know the status of this bug?
19:16:01 <uvirtbot> Launchpad bug 1433807 in poppy "Reenable shared ssl + add domains/origins PATCH tests" [Medium,New] https://launchpad.net/bugs/1433807
19:16:26 * amitgandhinz is there an echo in here?
19:16:29 <tonytan4ever> I think I have dealt with it a while back
19:16:44 <tonytan4ever> It should not be an issue anymore.
19:16:44 <malini> good question - I might have added tht when we disabled it for some reason
19:16:59 <sriram> we can try running it, and see if it fails.
19:17:01 <malini> tonytan4ever: do we have those api tests?
19:17:01 <amitgandhinz> malini: can you check, and if so we can close the bug
19:17:08 <malini> ok..checking now
19:17:55 <sriram> https://bugs.launchpad.net/poppy/+bug/1421183
19:17:56 <openstack> Launchpad bug 1421183 in Poppy "PATCH - Adding a second rule to an origin causes the service to go to failed state" [High,New]
19:17:56 <uvirtbot> Launchpad bug 1421183 in poppy "PATCH - Adding a second rule to an origin causes the service to go to failed state" [High,New]
19:17:58 <uvirtbot> Launchpad bug 1421183 in poppy "PATCH - Adding a second rule to an origin causes the service to go to failed state" [High,New] https://launchpad.net/bugs/1421183
19:18:02 <amitgandhinz> cool.  so fyi liberty-3 will start tomorrow, and go on until Sep 3rd
19:18:04 <sriram> we need to look at that as well.
19:18:30 <malini> looks like we have the shared ssl test https://github.com/stackforge/poppy/blob/master/tests/api/services/data_patch_service.json#L307
19:18:33 <amitgandhinz> sriram: i will add that to lib-3
19:18:45 <amitgandhinz> but idk if it still exists
19:18:49 <amitgandhinz> feels like it shouldnt
19:18:54 <sriram> amitgandhinz: I think we fixed that at some point.
19:19:02 <sriram> I can check and report back on that.
19:19:20 <tonytan4ever> malini: line 307-317 in data_patch_service.json should cover that case
19:19:41 <malini> sriram: I dont see a corresponding patch test for the second rule
19:19:46 <malini> Can you add tht?
19:19:53 <sriram> malini: sure
19:19:57 <amitgandhinz> malini: thanks i added the link to the comment and will close the bug
19:20:09 <sriram> I just checked locally, and the bug doesnt seem to exist any more.
19:20:53 <amitgandhinz> ok updated them both
19:21:25 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1420945
19:21:27 <openstack> Launchpad bug 1420945 in Poppy "default ttl not automatically assigned" [Medium,Confirmed] - Assigned to Amit Gandhi (amit-gandhi)
19:21:28 <uvirtbot> Launchpad bug 1420945 in poppy "default ttl not automatically assigned" [Medium,Confirmed] https://launchpad.net/bugs/1420945
19:21:32 <uvirtbot> Launchpad bug 1420945 in poppy "default ttl not automatically assigned" [Medium,Confirmed]
19:21:39 <amitgandhinz> sriram: this is done also right?
19:21:50 <sriram> amitgandhinz: yep
19:22:11 <sriram> I didnt address the bug in the commit message … :'(
19:22:33 <malini> & nobody caught that :-$
19:22:38 <sriram> baah.
19:23:18 <sriram> anyway we can assign that to me, and mark as done.
19:23:28 <amitgandhinz> this is also done: https://bugs.launchpad.net/poppy/+bug/1466908
19:23:29 <openstack> Launchpad bug 1466908 in Poppy "Patch Updates don't appear immediately" [Undecided,New] - Assigned to Obulapathi (obulpathi)
19:23:46 <uvirtbot> Launchpad bug 1466908 in poppy "Patch Updates don't appear immediately" [Undecided,New]
19:23:47 <uvirtbot> Launchpad bug 1466908 in poppy "Patch Updates don't appear immediately" [Undecided,New] https://launchpad.net/bugs/1466908
19:24:48 <amitgandhinz> how bug list is getting shorter =)
19:24:52 <amitgandhinz> i like =D
19:25:22 <obulpathi> I think this one was fixed
19:26:05 <sriram> this one didnt address the bug either..
19:26:11 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1443619
19:26:12 <openstack> Launchpad bug 1443619 in Poppy "restrictions rule with no request_url returns 500" [Medium,Incomplete]
19:26:12 <sriram> we really need to watch for that.
19:26:14 <obulpathi> amitgandhinz:  din't see you message up
19:26:22 <uvirtbot> Launchpad bug 1443619 in poppy "restrictions rule with no request_url returns 500" [Medium,Incomplete]
19:26:23 <uvirtbot> Launchpad bug 1443619 in poppy "restrictions rule with no request_url returns 500" [Medium,Incomplete] https://launchpad.net/bugs/1443619
19:26:37 <sriram> never seen the uvirtbot before.
19:27:28 <obulpathi> sriram: Its the siri of IRC
19:28:00 <amitgandhinz> is that 500 still an issue?
19:28:36 <sriram> there should be some validation in there right?
19:28:44 <sriram> anyway this is easy to investigate.
19:28:56 <sriram> I can take a look a this as well and report back
19:29:33 <amitgandhinz> the patch the bug refers to is abandoned
19:29:59 <amitgandhinz> marking it as invalid unless sriram repro's it
19:30:15 <sriram> roger that
19:30:45 <amitgandhinz> obulpathi: can you explain this bug - https://bugs.launchpad.net/poppy/+bug/1434609
19:30:46 <openstack> Launchpad bug 1434609 in Poppy "PoppyCDN pulls content from origin server by default" [Undecided,Incomplete]
19:30:46 <uvirtbot> Launchpad bug 1434609 in poppy "PoppyCDN pulls content from origin server by default" [Undecided,Incomplete]
19:30:48 <uvirtbot> Launchpad bug 1434609 in poppy "PoppyCDN pulls content from origin server by default" [Undecided,Incomplete] https://launchpad.net/bugs/1434609
19:31:11 <malini> amitgandhinz: IIRC you fixed the 500 bug in another patch
19:31:16 <amitgandhinz> isnt the point of cdn to pull content from an oriign?
19:31:37 <obulpathi> If a user creates a service with no ttl rules
19:31:59 <obulpathi> the content is pulled from the origin server all the times
19:32:08 <malini> obulpathi: if the content is not cacheable, then it always goes to origin (unless it has a caching ttl)
19:32:29 <amitgandhinz> and now we are also adding a default ttl to services (which the user can remove if they want)
19:32:51 <amitgandhinz> delete it?
19:32:56 <amitgandhinz> i will mark it as invalid
19:32:57 <obulpathi> yep
19:33:00 <sriram> this should be addressed by the default ttl
19:33:17 <obulpathi> yep, the default ttl also takes care of this
19:33:30 <obulpathi> amitgandhinz: please mark it as invalid
19:33:49 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1443979
19:33:50 <openstack> Launchpad bug 1443979 in Poppy "API Tests - Negative tests fail for the wrong reason" [Medium,New]
19:33:55 <amitgandhinz> malini: this was fixed right?
19:33:57 <malini> nope
19:34:05 <uvirtbot> Launchpad bug 1443979 in poppy "API Tests - Negative tests fail for the wrong reason" [Medium,New] https://launchpad.net/bugs/1443979
19:34:06 <uvirtbot> Launchpad bug 1443979 in poppy "API Tests - Negative tests fail for the wrong reason" [Medium,New]
19:34:06 <malini> we validate for 400s on the negative tests
19:34:28 <malini> But we had a lot of code changes & now the tests get 400 due to different reasons
19:34:34 <malini> not what the test says it is
19:34:42 <amitgandhinz> ok
19:35:26 <sriram> we rename the test then
19:35:29 <sriram> job over lol
19:35:37 <malini> ideally we shud validate the resp message for 400s
19:36:01 <amitgandhinz> +1 ensure that the 400 is for what we expect the 400 to be and not a different reason
19:36:13 <sriram> yes, +1
19:36:18 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1473193
19:36:20 <openstack> Launchpad bug 1473193 in Poppy "Prevent use of root domains in services" [Undecided,Confirmed] - Assigned to Obulapathi (obulpathi)
19:36:20 <malini> but tht is a lot of work & I am not sure where it fits in the priorities
19:36:21 <uvirtbot> Launchpad bug 1473193 in poppy "Prevent use of root domains in services" [Undecided,Confirmed]
19:36:30 <amitgandhinz> obulpathi: you were working on this right?
19:36:34 <sriram> obulpathi had a patch for this.
19:36:39 <uvirtbot> Launchpad bug 1473193 in poppy "Prevent use of root domains in services" [Undecided,Confirmed] https://launchpad.net/bugs/1473193
19:36:48 <obulpathi> Yep, I had put it on shelve while working on Kafka
19:37:01 <obulpathi> I will unshelve it and finish the failing API tests
19:37:13 <obulpathi> the PR is out tehre tough
19:37:16 <amitgandhinz> cool - i will assign it to lib3
19:37:25 <obulpathi> thanks :)
19:37:50 <malini> obulpathi: I am sure you'll finish it much earlier ;)
19:37:50 <sriram> https://bugs.launchpad.net/poppy/+bug/1408301
19:37:51 <openstack> Launchpad bug 1408301 in Poppy "PATCH Requests for Domains Returns Confusing Error Message" [Medium,New]
19:37:58 <uvirtbot> Launchpad bug 1408301 in poppy "PATCH Requests for Domains Returns Confusing Error Message" [Medium,New]
19:37:59 <uvirtbot> Launchpad bug 1408301 in poppy "PATCH Requests for Domains Returns Confusing Error Message" [Medium,New] https://launchpad.net/bugs/1408301
19:38:08 <sriram> I think I have encountered this as well.
19:38:30 <obulpathi> the error message from jsonpath was confusing?
19:38:35 <sriram> its basically a bad json patch
19:38:35 <obulpathi> jsonpatch
19:38:45 <malini> all of our jsonpatch messages are confusing :/
19:38:54 <sriram> but should we be handling it a bit more gracefully?
19:39:05 <sriram> we need a schema to evaluate schemas!!
19:39:06 <sriram> :P
19:39:11 <amitgandhinz> and we sometimes have verbal diarrhea in the error responses
19:39:12 <malini> :D
19:39:30 <malini> they do look ugly
19:39:56 <sriram> thats because of the embedded traceback right?
19:40:05 <sriram> or do you mean something else?
19:40:16 <sriram> amitgandhinz: ^
19:40:28 <tonytan4ever> this is because jsonpatch validation error messages are ugly
19:40:47 <malini> it makes sense for jsonpatch to return those messages
19:40:52 <amitgandhinz> sometimes its the traceback.  sometimes it the jsonpatch messages dumping a crapload of json to say a key is wrong
19:40:55 <malini> But we probably should use them better
19:41:07 <amitgandhinz> like it will dump the whole json schema to say you can only enter one item of something
19:41:22 <tonytan4ever> It's kind tough to translate those messages to be a prettier form though./
19:41:26 <amitgandhinz> it would be nicer to customize those messages but i dont think you can with jsonpatch
19:41:31 <sriram> tonytan4ever: +1
19:41:51 <sriram> amitgandhinz: looks like thats a separate project all together
19:41:52 <malini> we should convert all those messages to 'ooops -try again later'
19:41:58 <amitgandhinz> ok im done with bugs, any one else want to bug the team about bugs?
19:42:15 <sriram> some kind of egress middleware decorator
19:42:16 * amitgandhinz for some reason i thought malini was singing britney spears
19:42:24 <malini> :D
19:42:25 <sriram> amitgandhinz: 	what?
19:42:31 <sriram> lol
19:42:41 <obulpathi> hahaha
19:43:02 <sriram> amitgandhinz: anyway if we did that, it will be a separate project, we plug into poppy.
19:43:02 <amitgandhinz> #topic Open Discussion
19:43:03 <obulpathi> if we extend out current validations in out code, we can have better error messages
19:43:18 <amitgandhinz> did everyone vote yet?
19:43:23 <amitgandhinz> who hasnt voted?
19:43:27 <sriram> obulpathi: correct, but I think the scope is far broader for this.
19:43:27 <anantha> me
19:43:31 <amitgandhinz> go vote!
19:43:34 <obulpathi> sriram: true
19:43:37 <amitgandhinz> here are the links
19:43:38 <sriram> does stoplight have the functionality?
19:43:39 <obulpathi> I voted!
19:43:44 <sriram> done voting.
19:43:55 <sriram> amitgandhinz: ^
19:44:11 <cathR_> my voting done!
19:44:16 <amitgandhinz> • CDN for your Cloud - Openstack Poppy https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/Presentation/3882
19:44:16 <amitgandhinz> • Getting High with Poppy CDN https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/Presentation/5170
19:44:16 <amitgandhinz> • Money Laundering with Poppy CDN https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/Presentation/5175
19:44:18 <amitgandhinz>19:44:19 <sriram> might need to look into it, long time since I looked at stoplight.
19:44:20 <amitgandhinz> Avoiding the 7 Deadly Sins while engineering your applications on Openstack https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/Presentation/5506
19:44:26 <amitgandhinz> malini:  i dont have your ones handy
19:44:41 <malini> amitgandhinz: I havent voted for anybody's :/
19:44:51 <amitgandhinz> GO VOTE!
19:44:55 <amitgandhinz> GO VOTE!
19:44:55 <sriram> vote vote vote!!
19:44:57 <amitgandhinz> GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!
19:44:59 <amitgandhinz> GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!
19:45:00 <tonytan4ever> I just voted.
19:45:00 <malini> I don't feel so bad since it includes mine :d
19:45:01 <amitgandhinz> GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!GO VOTE!
19:45:19 <sriram> amit213: lol
19:45:23 <sriram> damn it
19:45:31 <sriram> amitgandhinz: heh
19:45:42 <cathR_> GOVOTE is that Italian?
19:45:46 <amitgandhinz> https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/presentation/4463
19:45:49 * sriram must master tab completion
19:46:03 <amitgandhinz> https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/presentation/4470
19:46:29 <malini> I think I voted - but I dont see the count go up
19:46:39 <amitgandhinz> where do you see counts?
19:46:56 <malini> those are dummy counts - nvm :/
19:47:02 <malini> found mine https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/presentation/4470
19:47:09 <amitgandhinz> i linked it above lol
19:47:20 <amitgandhinz> 4463 and 4470
19:47:27 <malini> :D
19:47:38 <sriram> voted.
19:48:13 <amitgandhinz> voting ends today
19:48:16 <amitgandhinz> so go vote!
19:48:43 <amitgandhinz> #topic Highwinds CDN
19:48:51 <sriram> if you did an inverted index on this chat history, i'm sure vote is at No.1
19:48:57 <sriram> :P
19:49:05 <amitgandhinz> so on an unrelated topic, had a great discussion with highwinds yesterday
19:49:09 <malini> intellectual!
19:49:12 <amitgandhinz> they are interested in contributing to Poppy
19:49:18 <amitgandhinz> any questions (lol)
19:49:20 <malini> cymbals!!
19:49:23 <sriram> that is good to know
19:49:24 <obulpathi> yay!
19:49:31 <sriram> will be building the driver?
19:49:32 <amitgandhinz> #topic Akamai CDN
19:49:35 <sriram> timelines?
19:49:41 <amitgandhinz> #topic Akamai and Highwinds
19:49:48 <sriram> s/will/will they
19:49:49 <amitgandhinz> ok lets cover them both
19:49:55 <sriram> ok
19:50:11 <amitgandhinz> so highwinds is interested, they have the resources and will hopefully start working with us to build their own driver
19:50:19 <malini> yayyy
19:50:21 <amitgandhinz> i think they are stil ramping up
19:50:34 <amitgandhinz> so hopefully they engage and participate
19:50:43 <amitgandhinz> lets make sure we welcome them to our channel
19:50:50 <sriram> of course
19:50:56 <amitgandhinz> Akamai is also interested in taking over the akamai driver
19:51:02 <malini> woot..woot
19:51:09 <sriram> tonytan4ever: ^^
19:51:15 <amitgandhinz> i had a 1.5 hour discussion purely focused on Poppy with them today
19:51:20 <malini> so we just sit back & watch everybody work  <:o)
19:51:23 <amitgandhinz> they seemed very keen and really like the idea of it
19:51:25 <tonytan4ever> That sounds good.
19:51:44 <amitgandhinz> they had a few questions around features that others didnt offer and how to integrate that into poppy
19:52:02 <amitgandhinz> but they were happy with my answers around only exposing common features via the api
19:52:14 <amitgandhinz> and anything else are either backend defaults, or we dont offer it
19:52:31 <sriram> poppy exposes only the most common set of features, over different providers right.
19:52:37 <amitgandhinz> we may need to look into flavor settings to enable certain features that some providers have but not all
19:52:45 <sriram> amitgandhinz: +1
19:52:55 <amitgandhinz> ie, lets say akamai, cloudfront, and cloudflare all offer ddos protection
19:53:03 <amitgandhinz> but fastly, maxcdn, and highwinds dont
19:53:24 <amitgandhinz> we could offer a feature in the flavor settings that enables certain features only (or make them as extensions?)
19:53:34 <tonytan4ever> it makes sense.
19:53:36 <sriram> yeah makes sense
19:53:50 <amitgandhinz> so we still prevent vendor lock in or vendor specific features, but its no longer the lowest common denominator
19:53:52 <tonytan4ever> But wouldn't that require us to store some feature info as well ?
19:54:01 <amitgandhinz> maybe
19:54:03 <sriram> thats fine
19:54:08 <sriram> as long as its in a flavor
19:54:09 <amitgandhinz> it almost becomes like feature flags
19:54:17 <obulpathi> +1 for feature flags
19:54:23 <tonytan4ever> K, just probably another field of flavor table
19:54:28 <amitgandhinz> possibly
19:54:28 <sriram> yeah we can switch flavors whenever needed
19:54:31 <amitgandhinz> we need to think about it
19:54:36 <sriram> so dont really see a lock in there.
19:54:49 <amitgandhinz> as long as the api remains compatible we are okay
19:54:55 <sriram> yeah
19:55:05 <amitgandhinz> what we dont want is endpointA is for providerA and endpointB is only for providerB
19:55:27 <malini> hmmmm
19:55:32 <malini> we kinda have tht today :/
19:55:38 <amitgandhinz> where?
19:55:43 <sriram> malini: example?
19:55:55 * amitgandhinz 4 min warning
19:56:00 <sriram> that probably needs to re-thought of then.
19:56:05 <malini> IRC didnt like tht
19:56:11 <malini> admin/provider/akamai/service
19:56:16 <sriram> we can move to openstack-poppy if we exceed timelimit
19:56:20 <amitgandhinz> ah admin specific endpoints
19:56:27 <amitgandhinz> that doesnt really count
19:56:32 <amitgandhinz> those are for operators only
19:56:33 <malini> booo
19:56:43 <amitgandhinz> users would never hit those endpoints
19:57:00 <malini> fair
19:57:12 <sriram> yeah those will probably be shielded from users
19:58:21 <amitgandhinz> ok, great meeting
19:58:21 <sriram> ok anything else to discuss?
19:58:25 <amitgandhinz> thats all folks
19:58:29 <sriram> see ya
19:58:31 <amitgandhinz> #endmeeting