18:59:59 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:00 <openstack> Meeting started Thu Aug  6 18:59:59 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:03 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:12 <amitgandhinz> #topic Roll call
19:01:10 <malini> o/
19:01:45 <ametts> \o/
19:02:39 <ametts> worst. meeting. ever.
19:02:45 <amitgandhinz> wow two people
19:02:55 <amitgandhinz> im going to give it 7 more minutes
19:03:01 <obulpathi1> o/
19:03:33 <malini> if 4 is the quorum, I am leaving :/
19:04:16 <anantha> o/
19:04:54 <amitgandhinz> #topic Last Week Review
19:05:10 <amitgandhinz> #link Agenda https://wiki.openstack.org/wiki/Meetings/Poppy
19:05:19 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-07-30-19.01.html
19:05:31 <amitgandhinz> amitgandhinz to make mimic fastly the default driver
19:05:37 <amitgandhinz> this is done and merged
19:05:56 <amitgandhinz> amitgandhinz to assign more things to malini at next meeting
19:06:08 <amitgandhinz> i will do so after we get malini status ;-)
19:06:13 <malini> :/
19:06:14 <amitgandhinz> malini to get the outstanding security patches fixed and merged
19:06:22 <malini> ongoing :)
19:06:29 <amitgandhinz> specifically malini to deal with https://review.openstack.org/143720
19:06:42 <malini> I resurrected it
19:06:45 <malini> needs reviews
19:07:00 <amitgandhinz> please nag people to review it before it gets stale again
19:07:11 <amitgandhinz> malini to deal with https://review.openstack.org/144324
19:07:16 <sriram> o/
19:07:23 <amitgandhinz> looks like this needs some reviews too
19:07:26 * sriram in a bit late
19:07:29 <malini> amitgandhinz: plz review https://review.openstack.org/143720
19:07:33 <malini> ;)
19:07:49 <malini> & https://review.openstack.org/#/c/144324/
19:07:49 * sriram review everything!!
19:08:36 <amitgandhinz> cool
19:08:46 <amitgandhinz> malini: there are 3 security tests that are red from April
19:09:02 <amitgandhinz> can i assign these to you to focus on the next week (or to nag ppl)
19:09:19 <amitgandhinz> specifically: https://review.openstack.org/164257
19:09:26 <amitgandhinz> https://review.openstack.org/169450
19:09:33 <amitgandhinz> https://review.openstack.org/169611
19:09:59 <malini> I abandoned two now
19:10:02 <amitgandhinz> cool
19:10:15 <malini> third one needs work
19:10:27 <malini> https://review.openstack.org/#/c/169611/
19:10:48 <malini> I vote to abandon https://review.openstack.org/#/c/169611/
19:11:05 <malini> if its https, it will return https -rt
19:11:11 <malini> do we need tht test?
19:11:37 <amitgandhinz> yes, to ensure we do return https
19:11:51 <amitgandhinz> i know a while back we had an issue where location headers didnt return https
19:12:01 <malini> aah..ok
19:12:17 <malini> I didnt know we were capable of tht :/
19:12:35 <amitgandhinz> we generate the urls we render in the json
19:12:42 <malini> we can abandon this too https://review.openstack.org/#/c/157255/ ?
19:12:59 <amitgandhinz> abandoned.
19:13:04 <malini> & this https://review.openstack.org/#/c/169969/ ?
19:13:27 <malini> will we ever run automated test for custom/san?
19:13:33 <malini> tht costs money
19:13:36 <amitgandhinz> sriram: https://review.openstack.org/131556 do we need this, or did you chase the rabbit?
19:13:53 <amitgandhinz> malini: prob not, unless we mimic it
19:14:18 <malini> with mimic, its not really e2e test
19:14:21 <amitgandhinz> we can abandon it
19:14:48 <malini> done
19:15:07 <amitgandhinz> tonytan4ever: is this patchset still valid or should it be abandoned? https://review.openstack.org/168110
19:15:24 <tonytan4ever> It should be abandoned
19:15:29 <tonytan4ever> I will abandon it
19:15:38 <malini> & https://review.openstack.org/#/c/160392/ ?
19:15:40 <amitgandhinz> https://review.openstack.org/160392
19:15:42 <amitgandhinz> =P
19:15:49 <amitgandhinz> tonytan4ever: ^
19:16:06 <tonytan4ever> So does this one.
19:16:10 <obulpathi1> We can drop this one too: https://review.openstack.org/#/c/184514/
19:16:10 <tonytan4ever> I will abandon it
19:16:14 <amitgandhinz> malini: https://review.openstack.org/155119
19:16:19 <amitgandhinz> thats the performance test
19:16:25 <malini> I will resurrect tht
19:16:35 <malini> just triggered a rebase :)
19:16:45 <amitgandhinz> i will assign this to you then ;-)
19:16:52 <amitgandhinz> #action malini to resurrect https://review.openstack.org/155119
19:16:55 <malini> cool
19:17:58 <amitgandhinz> #action malini to resurrect https://review.openstack.org/169611
19:18:17 <amitgandhinz> #action amitgandhinz to resurrect https://review.openstack.org/143192
19:18:36 <amitgandhinz> i will tackle ^ as part of mimic stuff (we need a dns mimic driver)
19:19:04 <amitgandhinz> ok i think we are cleaned up and got rid of a lot of the old cruft thats been hanging around =)
19:19:23 <malini> the queue is already much smaller now :)
19:19:35 <amitgandhinz> yup
19:19:37 <amitgandhinz> less red!
19:19:40 <malini> this has been a productive meeting :D
19:19:43 <amitgandhinz> #topic Liberty 3
19:19:48 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/liberty-3
19:20:07 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/gate-api-tests
19:20:09 <amitgandhinz> this is mine
19:20:22 <amitgandhinz> this is slow progress
19:20:42 <amitgandhinz> i have started setting up the bash script etc to install docker on an image in the infra configs
19:20:56 <amitgandhinz> i am trying to figure out how to run it locally to ensure it works before i submit a patch
19:21:09 <malini> hmm..can you even do that?
19:21:20 <malini> I mean test the infra config change locally
19:21:21 <amitgandhinz> idk
19:21:33 <amitgandhinz> i think there is a way to spin up a server the same way they do
19:21:34 <malini> I don't think so :/
19:21:41 <malini> good luck
19:21:44 <amitgandhinz> i just dont want to blindly submit patches
19:21:48 <amitgandhinz> worst case i do
19:22:01 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/akamai-ssl-driver
19:22:22 <tonytan4ever> I rolled out a PR yesterday,
19:22:39 <tonytan4ever> https://review.openstack.org/#/c/209648/
19:22:49 <tonytan4ever> It is good for review
19:23:04 <tonytan4ever> I would still call it in good progress though.
19:23:04 <amitgandhinz> too much red
19:23:12 <amitgandhinz> tox failed
19:23:18 <tonytan4ever> I will fix that.
19:23:33 <amitgandhinz> does this implement everything?
19:23:55 <tonytan4ever> Not everything, just create the certificate via sps part
19:24:05 <amitgandhinz> it would be good to describe what it does, and what remains in the comment
19:24:17 <tonytan4ever> OK
19:24:25 <tonytan4ever> I will update the comment
19:25:01 <amitgandhinz> thanks
19:25:02 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/mimic-fastly
19:25:04 <amitgandhinz> this is merged now
19:25:25 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/notification-driver
19:25:32 <amitgandhinz> tonytan4ever: this is still in review right
19:25:52 <amitgandhinz> obulpathi1: https://bugs.launchpad.net/bugs/1473193
19:25:52 <openstack> Launchpad bug 1473193 in Poppy "Prevent use of root domains in services" [Medium,In progress] - Assigned to Obulapathi (obulpathi)
19:25:53 <uvirtbot> Launchpad bug 1473193 in poppy "Prevent use of root domains in services" [Medium,In progress]
19:25:55 <uvirtbot> Launchpad bug 1473193 in poppy "Prevent use of root domains in services" [Medium,In progress] https://launchpad.net/bugs/1473193
19:25:57 <tonytan4ever> Yes
19:26:14 <obulpathi1> malini found some bugs that needs to be addressed in that
19:26:22 <obulpathi1> fixed some of them will push the pr out
19:26:33 <amitgandhinz> thanks
19:26:44 <amitgandhinz> any other bugs/bp we need to discuss??
19:27:38 * ametts hears crickets
19:27:40 <amitgandhinz> #topic Open Discussion
19:27:56 <amitgandhinz> ametts needs to stop watch Cricket
19:28:12 <amitgandhinz> s/watch/watching
19:28:41 <amitgandhinz> anything up for discussion?
19:28:56 <amitgandhinz> .........3
19:29:01 <amitgandhinz> ..................2
19:29:06 <amitgandhinz> ....................................1
19:29:15 <ametts> Anything with obupathi1's name on it?
19:29:21 <ametts> that needs to be reassigned?
19:29:37 <amitgandhinz> only one bug which he thinks will be submitted son
19:29:38 <amitgandhinz> soon
19:29:41 <ametts> ok
19:30:08 <amitgandhinz> thanks everyone
19:30:12 <amitgandhinz> #endmeeting