19:09:26 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:09:28 <openstack> Meeting started Thu Dec 10 19:09:26 2015 UTC and is due to finish in 60 minutes. The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:09:30 <sriram> o/
19:09:31 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:09:36 <amitgandhinz> #topic RollCall
19:09:53 <malini> o/
19:10:08 <sriram> o/
19:10:19 <amitgandhinz> #topic Recap
19:10:57 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-11-12-19.08.html
19:11:37 <amitgandhinz> i think i created that story for analytics driver
19:11:41 <amitgandhinz> let me look
19:12:10 <sriram> ok I'll go assign it to myself.
19:12:28 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/analytics
19:12:43 <sriram> oh its already assigned to me :)
19:13:12 <amitgandhinz> mkmad: sriram: you can split this up amongst yourselves
19:13:24 <sriram> amitgandhinz: =1
19:13:26 <sriram> err
19:13:27 <sriram> +1
19:13:38 <mkmad> Yes +1
19:13:40 <malini> atleast wasn't zero :D
19:13:43 <amitgandhinz> #topic Progress
19:13:46 <amitgandhinz> #link https://blueprints.launchpad.net/poppy/mitaka
19:14:26 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/akamai-ssl-driver
19:14:29 <amitgandhinz> can we call this done?
19:15:00 <tonytan4ever> If the scope is just mod-san one, then yes
19:15:13 <tonytan4ever> we still got custom, custom-shared though
19:15:16 <amitgandhinz> yep just changed the scope
19:15:23 <amitgandhinz> i think we have another bp for custom
19:15:32 <tonytan4ever> Okay,
19:15:37 <tonytan4ever> Then that one is done.
19:16:48 <amitgandhinz> malini: https://blueprints.launchpad.net/poppy/+spec/gate-api-tests
19:16:58 <malini> no progress :(
19:17:11 <malini> I probably should unassign tht
19:17:21 <amitgandhinz> ok will unassign
19:17:24 <amitgandhinz> sriram: mkmad: https://blueprints.launchpad.net/poppy/+spec/analytics
19:18:05 <sriram> active work ongoing
19:18:27 <mkmad> Yes, working on it as we speak.
19:18:28 <sriram> pull from provider store, is just logs that are shipped by the provider
19:18:44 <sriram> tonytan4ever has a few stubs out there for the api
19:18:55 <sriram> on poppy's side.
19:19:19 <sriram> the spark functions, and posting stuff on rabbit queue is done.
19:20:04 <sriram> the backing store from which metrics would be pulled, after being posted to from rabbitmq will be generic.
19:20:10 <amitgandhinz> sriram: can you update the WorkItems list in the bp to show the DONE stuff
19:20:19 <sriram> amitgandhinz: sure
19:20:27 <sriram> will update the blueprint
19:20:30 <amitgandhinz> thanks
19:20:37 <mkmad> I am working on parsing the data from rabbitmq and pushing it to buckets in cloud metrics
19:20:55 <amitgandhinz> great
19:22:04 <sriram> tonytan4ever: your patch on stubs for metrics was merged right?
19:22:25 <tonytan4ever> On poppy's side ?
19:22:30 <sriram> yeah
19:22:32 <tonytan4ever> I think not.
19:22:37 <sriram> was it in review?
19:22:48 <tonytan4ever> Should be in review, let me check
19:23:25 <tonytan4ever> Oh, I haven't even made the PR yet
19:23:32 <sriram> lol
19:23:33 <tonytan4ever> Let me roll out the PR first
19:23:35 <sriram> ok
19:23:41 <tonytan4ever> We can call it's started.
19:23:45 <sriram> cool
19:24:13 <sriram> ok lets move on to the next one.
19:24:18 <sriram> amitgandhinz: ^
19:24:26 <amitgandhinz> okie doke
19:24:38 <amitgandhinz> anything else in progress we need to talk about
19:25:23 <malini> nothing from me
19:25:32 <sriram> just bug fixes which went through
19:25:43 <sriram> nothing big on features currently.
19:25:57 <amitgandhinz> which brings me to the next topic
19:26:00 <amitgandhinz> #topic Bugs
19:26:15 <amitgandhinz> #link https://bugs.launchpad.net/poppy
19:26:29 <amitgandhinz> so first, we need to get better at referencing bugs in our patches
19:26:33 <amitgandhinz> we still are not doing that
19:26:38 <sriram> +1
19:26:58 <amitgandhinz> if you fix a bug (documented or not), please add the bug in launchpad and then reference that in your commit
19:27:18 <mkmad> Agreed.
19:27:21 <amitgandhinz> that way when i tag releases, we have bp and bugs that i can bind to the release, and works as release notes
19:27:27 <sriram> yes will do that.
19:27:31 <sriram> on that note:
19:27:33 <sriram> https://bugs.launchpad.net/poppy/+bug/1486103
19:27:33 <openstack> Launchpad bug 1486103 in Poppy "Fix Flaky tests due to Cassandra inconsistency issues" [High,Fix committed] - Assigned to Sriram (thesriram)
19:27:33 <amitgandhinz> everyone needs to enforce this during review time
19:27:41 <sriram> the fix has been released right?
19:28:03 <amitgandhinz> ya
19:28:20 <amitgandhinz> i actually updated its milestone to the 1.0.2 release already ;-)
19:28:20 <sriram> ok, I can change the status on that then
19:28:23 <amitgandhinz> just did
19:28:24 <sriram> oh cool
19:28:25 <sriram> ok
19:28:39 <amitgandhinz> any other bugs we need to sweep up
19:28:52 <sriram> I just added this: https://bugs.launchpad.net/poppy/+bug/1523964
19:28:52 <openstack> Launchpad bug 1523964 in Poppy "Change function mapping to be kwargs instead of args" [Wishlist,New]
19:29:06 <sriram> can be a low hanging fruit
19:29:15 <sriram> for any new contributor to pick up
19:29:30 <sriram> I have seen this be a cause of bugs.
19:29:35 <amitgandhinz> "fruit hanging low" lol
19:29:43 <amitgandhinz> lets use "low-hanging-fruit" instead
19:29:47 <sriram> heh
19:30:00 <mkmad> lol
19:30:32 <sriram> ok changed that :P
19:30:40 <amitgandhinz> cool
19:31:33 <amitgandhinz> #topic OpenDiscuss
19:31:55 <amitgandhinz> so, we are coming up on the holiday period, so the next meeting will be first week of jan
19:32:21 <amitgandhinz> jan 7
19:32:22 <sriram> at some point we need to start discussing about "big tent"
19:32:43 <sriram> malini: ^
19:32:56 <amitgandhinz> yup, i want a discussion around big tent, merits, etc
19:32:58 <malini> sure :)
19:33:06 <sriram> and happy holidays everyone! :D
19:33:19 <amitgandhinz> also, im wondering if we want to change these meetings to biweekly instead of weekly
19:33:23 <malini> will miss everybody for a loong time ;)
19:33:32 <sriram> amitgandhinz: +1
19:33:38 <mkmad> +1
19:33:39 <sriram> lets do that
19:33:51 <amitgandhinz> cool
19:33:53 <malini> depends on the question above
19:34:22 <amitgandhinz> ok anything else?
19:34:32 <sriram> thaaats it from me
19:34:32 <amitgandhinz> #agreed hold meetings every two weeks
19:34:40 <amitgandhinz> #agreed discuss Big Tent in the new year
19:34:55 <amitgandhinz> thats all folks
19:34:58 <amitgandhinz> happy holidays
19:35:06 <amitgandhinz> happy workdays for those without holidays
19:35:10 <sriram> see ya, have a great time :)
19:35:18 <amitgandhinz> #endmeeting