13:33:11 <esberglu_> #startmeeting powervm_ci_meeting
13:33:12 <openstack> Meeting started Thu Dec  1 13:33:11 2016 UTC and is due to finish in 60 minutes.  The chair is esberglu_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:33:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:33:16 <openstack> The meeting name has been set to 'powervm_ci_meeting'
13:33:30 <esberglu_> #topic Status
13:33:48 <adreznec> Darn, I was going to make some joke about prefering thorst_b to thorst_a, but you already changed back
13:34:00 <esberglu_> lol
13:35:13 <wangqwsh> :)
13:35:23 <thorst_> heh, I just noticed it
13:35:32 <thorst_> I need one of those auto _afk things
13:35:38 <thorst_> anyway, that's not CI status
13:35:45 <adreznec> So anyway, status. I assume esberglu_ has some since I've been seeing run failures coming back
13:35:54 <esberglu_> Another CI run went through last night. l can see in the nodepool logs where it picked up the change to devstack
13:36:17 <esberglu_> But it must be getting overwritten at some point
13:36:27 <esberglu_> Because it is still trying to set the public_network_id
13:37:17 <adreznec> Still in lib/tempest?
13:38:09 <esberglu_> Yeah
13:41:15 <esberglu_> I also have the 3 patches from efried for keeping our patched version of pypowervm
13:41:35 <thorst_> esberglu_: could we just use the patches to unwedge us
13:41:42 <thorst_> and validate the devstack stuff in the staging env instead?
13:41:55 <thorst_> we are behind and can't do any powervm nova development until CI is up...
13:42:19 <esberglu_> I just found where the devstack is being overwritten and can change it
13:42:25 <esberglu_> I'm fine with just putting those in
13:43:05 <thorst_> I just want to get us to a stable CI and test out these other things in staging
13:43:29 <thorst_> right now we're swinging the prod CI back and forth a bit...I get so excited when we actually get to run tests  :-)
13:43:52 <esberglu_> Yeah thats fine with me
13:43:54 <adreznec> So wait, those patches from efried somehow solve the network public network issue?
13:44:09 <adreznec> Maybe I'm getting patches mixed up
13:44:14 <thorst_> no, I probably am
13:44:20 <esberglu_> There are 4 patches on the CI right now
13:44:40 <thorst_> I'm just saying, lets only focus on the devstack public network issue, and keep the patches that solve the other stuff for now
13:44:48 <thorst_> and get rid of the patches through testing in staging only
13:45:15 <esberglu_> Well I have a patch that we KNOW works for keeping the correct version of pypowervm
13:45:26 <esberglu_> By removing it from the requirements files
13:45:40 <thorst_> so lets keep that for now.
13:46:07 <esberglu_> So I could put that back on, then test frieds changes in staging. And I see where devstack is being overwritten
13:46:14 <adreznec> Ok
13:46:26 <adreznec> so esberglu_ you're going to take another swing at the public net issue
13:46:28 <esberglu_> #topic
13:46:41 <esberglu_> #topic Action Items
13:47:28 <esberglu_> #action esberglu: Redeploy with public net fix and removal of pypowervm from requirements
13:48:04 <esberglu_> wangqwsh: Do you have anything in the staging environment that you need for the OSA stuff?
13:48:22 <esberglu_> Otherwise I will wipe that and begin testing changes there again
13:48:36 <wangqwsh> no,
13:48:52 <wangqwsh> you can continue your task
13:49:08 <thorst_> didn't we have another system so we could set up two staging envs?
13:49:15 <esberglu_> thorst_: Did we ever get that extra machine that we were going to use for a 2nd Staging Environment (1 OSA, 1 devstack)?
13:49:30 <thorst_> hmm...I thought we already had it
13:49:44 <thorst_> but maybe was stuck in some env setup issue
13:49:57 <thorst_> we can revisit that after we get the CI running again
13:50:10 <esberglu_> Yeah just curious
13:50:20 <thorst_> If I remember right, seems like we have a few systems we need to look at once CI is running again
13:50:28 <thorst_> some were jailed out of the CI for various reasons
13:51:01 <esberglu_> Yeah neo 6 -8 were having ssp issues and neo11 is completely toast
13:51:02 <adreznec> Hmm, yeah I thought wangqwsh was going to be using that other system for a second staging
13:51:09 <adreznec> Maybe that never got set up
13:51:35 <wangqwsh> I am using neo14
13:52:51 <esberglu_> #action esberglu figure out where the system for the second staging is
13:53:27 <thorst_> wangqwsh: you also have neo4.
13:53:33 <adreznec> Solve the case of the mystery disappearing system
13:53:58 <wangqwsh> yes, but i used it. not now.
13:54:29 <thorst_> OK - so really, zone in on system allocation at beginning of year
13:55:20 <esberglu_> Any other items people want to talk about?
13:56:16 <thorst_> I'm good.
13:56:30 <adreznec> Nope
13:56:49 <esberglu_> #endmeeting