13:31:10 <esberglu> #startmeeting powervm_ci_meeting
13:31:10 <openstack> Meeting started Thu Jan 26 13:31:10 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:31:14 <openstack> The meeting name has been set to 'powervm_ci_meeting'
13:31:19 <thorst_> o/
13:31:24 <XiaYan> o/
13:32:48 <esberglu> #topic status
13:34:10 <esberglu> I spent some time yesterday looking through what the OOT CI driver. Other than that I've been working on getting a passing tempest spawn on the IT driver
13:35:20 <thorst_> how close are we with IT?
13:37:18 <esberglu> #topic In Tree CI
13:37:28 <esberglu> I'm at the point where it is requesting a server on the compute api. According to the docs, you can set networks='none'
13:37:38 <esberglu> and it will create a server without networks
13:37:48 <esberglu> But it isn't accepting it as a valid request
13:38:10 <esberglu> It might be a version problem
13:38:14 <thorst_> do you have a pastebin that we can work off of?
13:38:19 <thorst_> I'd like to see that after meeting
13:38:29 <thorst_> but that's good to hear that we are that far along  :-)
13:39:59 <esberglu> And hopefully once we get through the rest api it will spawn successfully
13:40:42 <thorst_> well, it should
13:40:50 <thorst_> I've done it myself...unless it changed recently
13:40:53 <thorst_> but that's good news
13:41:03 <thorst_> good work
13:41:49 <esberglu> Other than that, just creating the white list for IT
13:42:02 <esberglu> #action esberglu: Create In Tree Whitelist
13:42:17 <esberglu> #action: esberglu: Finish the tempest no network spawn test
13:42:40 <esberglu> I think that's pretty much it for in tree unless you had anything
13:43:26 <thorst_> not for in tree
13:44:19 <esberglu> #Topic out of tree driver
13:45:20 <esberglu> I haven't looked into the failures this morning, but there are a decent amount coming through
13:45:31 <thorst_> soooo
13:45:33 <thorst_> I think I know why
13:45:41 <thorst_> I think a lot of them are power_off failures.
13:45:53 <thorst_> good news about that power off change I put in
13:45:58 <thorst_> it's respecting the timeout values now
13:46:07 <thorst_> bad news, a lot of images are using a default timeout of 60 seconds
13:46:17 <thorst_> and I didn't say 'force off after 60 seconds'
13:46:21 <thorst_> which I apparently should have.
13:46:28 <thorst_> well, 'force off after timeout'
13:46:37 <thorst_> I'd like to catch efried today and push that through.
13:47:08 <esberglu> Cool, glad we have a plan on that
13:47:08 <thorst_> before we'd just wait up to 20 minutes...and it'd usually power off.
13:47:21 <thorst_> now, that timing window is small and we have pain  :-(
13:47:22 <thorst_> sorry
13:49:03 <esberglu> That clears up some of the errors.
13:49:07 <esberglu> But we are still seing an occaisional "no valid host found"
13:49:41 <esberglu> Or seeing servers fail to build
13:50:05 <esberglu> I will go through the failures again today and see what we are hitting again
13:51:00 <esberglu> That all I had on OOT
13:51:12 <esberglu> Any other topics you want to do?
13:51:27 <esberglu> Want to talk drivers at all?
13:54:05 <efried> Did I miss the CI meeting?
13:55:05 <esberglu> Yeah
13:55:23 <esberglu> Its still going if you had topics
13:55:25 <efried> Link me to the minutes?
13:55:30 <efried> oh, okay.
13:55:47 <efried> Have you tried 4754 yet?
13:56:26 <esberglu> No I went down the wrong path for a while yesterday trying to get that spawn test working
13:56:30 <esberglu> Almost working now
13:56:47 <esberglu> I then was gonna test that
13:57:00 <esberglu> Test 4754 that is
13:57:09 <efried> cool beans.  Do you need it to be merged before you can try it, or can you pick it up in-flight?
13:57:41 <esberglu> No merge needed. I will just do a manual run on the staging env
13:57:55 <efried> k.  Let me know if you need any help setting it up.
13:58:17 <thorst_> sorry - I had someone stop by.  I didn't have anything else
13:58:39 <thorst_> efried: can you read the eavesdrop logs from about 10-20 minutes ago
13:58:41 <thorst_> about the power off stuff
13:58:44 <efried> The os_ci_tempest.conf for in-tree use the default base regex (all-inclusive)
13:59:34 <efried> thorst_: it stops at 13:44
13:59:46 <thorst_> alright, I'll catch you up after the nova IRC meeting
13:59:50 <efried> Sounds good.
14:00:00 <thorst_> (it'll also be there by then I bet)
14:00:09 <efried> yuh
14:00:33 <efried> Sorry, guys - for some reason Thursday mornings always seem to start slow for me.
14:00:46 <esberglu> No biggie
14:00:50 <esberglu> #endmeeting