13:30:21 <esberglu> #startmeeting powervm_ci_meeting
13:30:21 <openstack> Meeting started Thu Mar  2 13:30:21 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:30:24 <openstack> The meeting name has been set to 'powervm_ci_meeting'
13:31:19 <thorst> o/
13:33:00 <esberglu> #topic OOT CI
13:33:20 <esberglu> Out of tree CI is still looking good
13:33:48 <esberglu> All of the compute nodes are back online, neutron and ceilometer are enabled on the silent pipeline again
13:35:11 <esberglu> I have patches out for a few things
13:35:36 <esberglu> One to only enable CI runs on the branches we want
13:36:00 <esberglu> And one to use the pvc-images server
13:36:29 <esberglu> 4935 and 4923
13:36:35 <efried> o/
13:36:52 <efried> You got that SSP sorted?
13:36:56 <esberglu> yeah
13:36:59 <efried> cool
13:38:00 <esberglu> #topic IT CI
13:38:21 <esberglu> In-tree CI is also looking good
13:38:44 <esberglu> Not much action here until we start getting changes merged
13:39:04 <esberglu> I also have a change up
13:39:05 <esberglu> 4918
13:39:36 <esberglu> Which lets us add additional tests to the whitelist. I want to deploy with that on staging today
13:40:04 <efried> [I +1ed 4935 and 4923 - would like thorst or adreznec to approve.]
13:40:55 <esberglu> And continue work I started determining which tests we can add to the IT whitelist for some of our later changesets
13:41:21 <esberglu> Thanks
13:41:22 <efried> [ditto 4918]
13:41:34 <efried> Why are we patching in the power_opts stuff?
13:41:51 <efried> Is that just needed for cherry-pick compatibility purposes?
13:42:08 <thorst> I thought to help with stability (or a thought that it might help with stability)
13:42:38 <efried> Where did we land on the idea of including that in 1.0.0.4.1?
13:43:10 <esberglu> Yeah what thorst said
13:43:23 <thorst> we didn't...yet...because of the whole hubub getting 1.0.0.4.1 actually working
13:45:12 <efried> I just don't like the idea of piling on some nontrivial subset of the (.5 - .4) delta.
13:45:37 <efried> It may make the CI look better to the outside world, but it reduces my confidence in the sanity of what we're actually testing.
13:46:48 <efried> Do we have any actual evidence or other reason to believe these patches will add stability, or is it just a hunch?
13:47:01 <thorst> adreznec: did the release go out?  Or can we add this bit in?
13:47:20 <esberglu> Release went out I believe
13:47:32 <esberglu> https://pypi.python.org/pypi/pypowervm/1.0.0.4.1
13:48:13 <efried> Have we proposed the global reqs update to pike yet?
13:48:29 <efried> or was tonyb going to do that?
13:51:10 <esberglu> Not sure
13:51:32 <esberglu> Doesn't look like it
13:53:08 <efried> I'll do it.
13:53:19 <esberglu> Cool
13:53:24 <efried> #action efried to propose requirements bump
13:53:55 <esberglu> So do we want to remove the patches we are currently piling onto 1.0.0.4 for in tree?
13:54:13 <esberglu> For the reason efried detailed above?
13:55:27 <efried> Update: requirements project is already done: https://review.openstack.org/#/c/439790/
13:58:59 <efried> esberglu I'd say just kill 4931 and I'll be satisfied.
13:59:10 <efried> Those are straight up .5 changes.
13:59:20 <efried> They're not going to lend stability or fix any bugs.
13:59:40 <efried> And we're already getting burn-in on them with OOT.
13:59:50 <esberglu> Okay that's good with me
14:00:00 <esberglu> Anything have final topics?
14:00:07 <efried> We should try to keep in-tree as close as possible to the version in global requirements.
14:00:33 <esberglu> Yes I agree
14:01:20 <esberglu> Last thing I had was OSA CI. Still working on rebasing the playbooks for that. Nothing else to report
14:08:16 <efried> adreznec note -1 on 4932
14:08:26 <efried> (You can mark that down as me disagreeing with thorst)
14:08:34 <adreznec> Oops, for some reason my calendar invite for this didn't pop up. What's broken on 4932?
14:08:47 <adreznec> The g-r bump already went out btw
14:10:00 <adreznec> They pushed it in last night and bumped pbr to >2 after that
14:10:14 <adreznec> which broke a bunch of other projects thanks to that hacking requirement
14:10:57 <adreznec> We should be good to go on that front with 4932 and the correspoding g-r bumps on the powervm projects
14:11:42 <efried> adreznec Take a look at my comments.  If they're all bogus, feel free to merge.
14:11:51 <adreznec> Will do
14:12:05 <efried> But if we're aligning with g-r, I don't see a reason for our pbr req to be downrev.
14:12:25 <efried> And the lxml thing bugs me.  I think we should be able to keep our floor higher.
14:12:38 <adreznec> Yeah, that wasn't merged yet when I proposed that
14:12:48 <adreznec> and hmm ok, I'll have to look at the other comment
14:13:47 <efried> Any other topics for the CI meeting?
14:14:58 <adreznec> Doesn't sound like it
14:22:12 <efried> esberglu call it?
14:22:44 <esberglu> #endmeeting