13:31:25 <esberglu> #startmeeting powervm_ci_meeting
13:31:26 <openstack> Meeting started Thu Mar  9 13:31:25 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:31:28 <thorst> o/
13:31:30 <openstack> The meeting name has been set to 'powervm_ci_meeting'
13:31:48 <efried> o/
13:32:33 <esberglu> #topic In Tree CI
13:33:44 <esberglu> In tree CI is still looking good. One test that is hitting us every now and then
13:34:05 <esberglu> http://184.172.12.213/85/442685/4/check/nova-in-tree-pvm/54cc6d5/powervm_os_ci.html
13:34:13 <esberglu> Where it can't find an image
13:34:37 <esberglu> Which is something I wanted to debug today
13:34:50 <esberglu> #action esberglu: Debug failing IT CI test
13:34:55 <thorst> hmm...that doesn't seem to be related to our driver
13:35:01 <thorst> :-/
13:35:40 <esberglu> Other than that, I had to redeploy the staging CI. But the plan there is
13:35:51 <esberglu> to have a set of changes to the whitelist
13:36:13 <esberglu> So that as we start getting IT patches approved, we can have the update whitelist ready
13:36:39 <thorst> neat
13:37:06 <esberglu> #topic OOT CI
13:37:55 <esberglu> OOT also has a couple failures I wanted to debug today
13:37:56 <esberglu> http://184.172.12.213/66/443266/1/check/nova-out-of-tree-pvm/c04198b/powervm_os_ci.html
13:38:25 <esberglu> These two tests have been causing problems on and off for a while
13:39:00 <esberglu> It seemed like they were a side effect of another test we disabled, as they stopped showing up
13:39:19 <esberglu> after we disabled another test from that same class
13:39:19 <thorst> but are still an issue now?  Just not as often?
13:40:27 <esberglu> Yeah still an issue now. They seem to have started hitting us more this week
13:41:08 <thorst> hmm....could debug in staging if we're failing >20% or so
13:41:30 <esberglu> #action esberglu: Debug 2 failing rebuild tests for OOT CI
13:42:15 <esberglu> Then we have the newton/ocata failures
13:42:41 <esberglu> The fix has been merged for g-r master, just has to be cherry-picked to the other branches
13:43:02 <esberglu> And the other part of the fix (in tempest) is still under review
13:43:15 <esberglu> But we have a fix incoming
13:44:09 <esberglu> #topic OSA CI
13:44:38 <esberglu> I finally got the OSA CI dev. env. deployed after some struggles.
13:45:16 <esberglu> I need to increase the size of the SSP though, I forgot that OSA requires a larger flavor
13:45:21 <esberglu> And didn't make it big enough
13:45:47 <thorst> staging CI?
13:45:54 <esberglu> No 3rd environment
13:46:05 <thorst> I just got a bunch of capacity for the v7k...so we can make all the SSPs larger at some point if needed.
13:46:48 <esberglu> Cool. I don't think we need to atm. But might have to later
13:47:44 <efried> You can do that without rebuilding the whole SSP, as I'm sure you know.
13:47:53 <thorst> yep, just add new disks
13:48:29 <esberglu> Okay. Might have questions later, I don't think I've done that before
13:49:03 <esberglu> #topic Other Items
13:49:22 <esberglu> At some point I want to move the undercloud from newton to ocata
13:49:34 <esberglu> Just kind of waiting for a lull in the action to get that done
13:50:29 <thorst> heh
13:50:31 <thorst> lull
13:50:44 <thorst> but yeah, agree that'd be a good update to do
13:50:55 <esberglu> Also I've been working with bjayasan as he is trying to get tempest running for an SDE setup
13:51:18 <esberglu> Still just trying to help him understand the flow
13:51:48 <esberglu> What is the plan for that? Is that going to be a whole new CI setup? Or are we trying to integrate that into our CI eventually?
13:52:12 <thorst> esberglu: no, he's just trying to run some tests with systems configured in a different way
13:52:16 <thorst> so right now you run SSPs
13:52:24 <thorst> so we have a coverage gap with anything not SSP
13:52:46 <thorst> he's trying to validate some of the other style configurations - or get to that point really
13:54:05 <esberglu> Oh okay. Sounded kind of like he was trying to get a full fledged CI running when we were working
13:54:13 <esberglu> I'll touch base with him again today
13:54:15 <thorst> esberglu: hmmm...don't think so
13:54:38 <thorst> I am 90% sure he only has one server.
13:54:39 <thorst> :-)
13:55:02 <esberglu> Yeah that's why I brought it up. He was asking about the staging environment and how he could test stuff
13:55:20 <thorst> hmm...I may touch base with him
13:55:24 <esberglu> But staging definitely can't support that
13:55:33 <thorst> the intention is simply to test different flavors of configurations
13:55:54 <thorst> Jay to test the in-tree stuff (initially) with tempest.  That'll eventually move to a SDE style env
13:56:07 <thorst> nbante to test the oot stuff with temptest, on a SDE style env.
13:56:28 <thorst> and we don't know how to bring SDE style env's into CI because they can't do the same tricks we're doing here...
13:57:22 <esberglu> That's all I had today
13:58:21 <esberglu> Thanks for joining
13:58:51 <esberglu> #endmeeting