14:03:12 <esberglu> #startmeeting powervm_driver_meeting
14:03:13 <openstack> Meeting started Tue Dec  6 14:03:12 2016 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:16 <openstack> The meeting name has been set to 'powervm_driver_meeting'
14:03:25 <thorst> \o
14:04:09 <thorst> I know efried is out today, so we won't get him
14:04:17 <adreznec> o/
14:05:18 <esberglu> #topic status
14:05:23 <esberglu> qing wu is out today too
14:05:42 <esberglu> So the CI is looking really good
14:06:47 <esberglu> Out of the last 25ish runs, there have been only 2 patches that have failed tempest and a few more that failed bc they need a rebase
14:07:30 <adreznec> Were those 2 legitimate failures? Anything we need to fix from them?
14:07:44 <esberglu> Well one of them is a WIP
14:07:46 <esberglu> https://review.openstack.org/#/c/319379/41
14:08:05 <thorst> esberglu: does that also include nova runs?
14:08:11 <esberglu> Yeah
14:08:21 <adreznec> That one was a nova run
14:08:31 <thorst> sweet.
14:08:38 <thorst> so, start publishing logs?
14:09:03 <esberglu> I think we are ready
14:09:10 <adreznec> I reckon so
14:09:24 <thorst> Milestone!
14:09:41 <esberglu> I just need to create a new zuul pipeline for non-voting
14:09:54 <esberglu> #action esberglu: Create a non-voting zuul pipeline
14:10:17 <adreznec> Yeah, and disable the current silent one so we're not running things twice?
14:10:23 <esberglu> #action esberglu: Turn log publishing on
14:10:28 <esberglu> adreznec: Yep
14:10:55 <thorst> what about e-mails when nova fails?
14:11:10 <thorst> I'd like to make sure we can react within 12-24 hours to 'things going to hell'
14:11:16 <thorst> and turn off Nova runs when that happens
14:11:20 <thorst> cause things will go to hell
14:11:30 <esberglu> I can just have it send it to the same mailing list that nova-powervm etc. do on failures
14:11:35 <adreznec> Yeah
14:11:38 <adreznec> Should be easy enough
14:11:49 <esberglu> No emails on success though, don't want to spam the inbox
14:11:58 <adreznec> Yep
14:12:02 <thorst> esberglu: can you check daily, when you come in and a few hours before you head out how things look?
14:12:12 <thorst> and maybe get that into qingwu's routine as well
14:12:31 <esberglu> Yep I pretty much do that already
14:12:44 <thorst> cool, then we just need to make it part of qingwu's routine
14:13:21 <esberglu> So that pretty much covers it from the devstack CI side of things
14:13:22 <adreznec> Honestly, at some point here we're going to want an alert system
14:13:30 <esberglu> +2
14:13:42 <adreznec> Something that tracks the run status and reports if failures > some threshold
14:13:45 <thorst> we should ask in openstack-infra on that.
14:13:52 <thorst> cause we're not the only ones that would want that.
14:13:59 <adreznec> +1
14:14:01 <thorst> and maybe not the first to think about doing it
14:14:39 <esberglu> Some people use CI Watch here. Not sure what it takes to get added to that
14:14:41 <esberglu> http://ci-watch.tintri.com/
14:14:46 <adreznec> Agreed. Not that hard to build, but even nicer if we don't have to build our own
14:15:04 <esberglu> I don't know if that has an alert system built in or not
14:15:58 <adreznec> Yeah we'll have to investigate that
14:16:04 <adreznec> Anything that helps us respond to failures more quickly is good
14:16:22 <adreznec> esberglu: the notes/etc you've been putting together for qing wu - are those going on a wiki or something?
14:16:49 <esberglu> Yeah. I was gonna finish them last night, but then I saw he was gonna be out so I'm gonna make sure they are done by thursday when he is back
14:16:55 <adreznec> Just thinking it's always good to have as many references as possible
14:16:56 <adreznec> Ok
14:17:13 <esberglu> Once I put it up I will email you guys so you can take a look
14:17:18 <thorst> +1
14:17:52 <esberglu> #topic OSA CI
14:18:07 <esberglu> So I would like to get working on the OSA CI again
14:18:35 <esberglu> But at this point I would have sacrifice the staging CI system for OSA CI development
14:18:54 <adreznec> thorst: did you ever double check the state of neo4/neo14?
14:18:54 <esberglu> I emailed Anil Kumar about helping to get that other system set up for a 2nd staging env.
14:19:10 <thorst> adreznec: nope.  Got caught up in other bits...seemed like we had enough to go for now
14:19:11 <adreznec> You were thinking Qing wu might have an extra system?
14:19:18 <adreznec> Ok
14:19:27 <thorst> qingwu definitely has ownership of neo4.  I don't think its actively being used
14:19:36 <thorst> so we could either take that for dev or add it to the CI pool
14:20:17 <adreznec> Right ok
14:21:20 <adreznec> esberglu: would that work as a OSA CI system?
14:21:27 <thorst> I think so
14:21:30 <esberglu> Yeah I think so
14:21:53 <adreznec> Awesome
14:22:11 <adreznec> Should give you room to experiment there then
14:22:45 <esberglu> Awesome. Gonna be super nice to be able to do that and have another staging env. to fall back on
14:22:45 <adreznec> I think we left off with the OSA CI at the multiple OVS issue
14:23:07 <esberglu> #action: esberglu Set up OSA CI dev env.
14:23:10 <thorst> qingwu sent me a note on that which I haven't responded to
14:24:09 <thorst> #action thorst to review the OVS OSA setup
14:24:55 <esberglu> I'm also gonna need 3 x86 systems for the new OSA CI env
14:25:04 <thorst> hmm
14:25:12 * adreznec record scratch
14:25:35 <thorst> OK - we'll have to just build you some
14:25:43 <thorst> I made space on a VM host the other day...
14:26:02 <thorst> I might just ask you do the installs if I walk you through how to connect in
14:27:26 <esberglu> OK
14:27:40 <esberglu> #action thorst: esberglu: Get x86 systems set up for OSA CI dev
14:28:35 <esberglu> I know thorst has to run. And thats all I had. So I will close the meeting unless there are objections
14:28:51 <thorst> one more thing
14:28:58 <thorst> driver status...
14:29:05 <esberglu> #topic Driver Status
14:29:05 <thorst> so we have the live migration object in nova
14:29:12 <thorst> we are taking it out of nova-powervm
14:29:28 <thorst> next up is the skeleton that efried proposed, but I'd recommend we do that after we push through some CI log runs
14:29:30 * adreznec party
14:29:43 <thorst> I would simply ask that adreznec, esberglu and myself review efried's change if we hadn't already
14:29:58 <esberglu> Will do
14:30:00 <adreznec> Yeah I'd like probably 25 solid runs there with logging before we start down that path
14:30:15 <adreznec> Just so we have history
14:30:25 <thorst> agree...and even 25 runs isn't 'history'
14:30:33 <thorst> but lets get our ducks in a row before we ask for real reviews.
14:30:44 <thorst> but lets also get our personal reviews in before break
14:30:59 <thorst> that's all I had
14:31:21 <adreznec> Right
14:31:26 <adreznec> But it's better than 0
14:31:27 <adreznec> :P
14:31:53 <thorst> +1
14:32:19 <adreznec> I think the only other piece of driver status is that tjakobs is starting to look at image cache work
14:32:47 <adreznec> It'd be nice to try and land that in Ocata still if we can make it work
14:33:31 <adreznec> That's all I have as well
14:36:24 <esberglu> #endmeeting