14:06:25 <efried> #startmeeting PowerVM Driver meeting
14:06:26 <openstack> Meeting started Tue Feb  7 14:06:25 2017 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:29 <openstack> The meeting name has been set to 'powervm_driver_meeting'
14:06:29 <thorst_> I still owe you a review...I know that
14:06:54 <efried> #topic power on/off module refactor
14:07:03 <efried> #action thorst_ to review
14:07:09 <efried> #action efried to make sonar happy
14:07:14 * thorst_ review all the things
14:07:38 <efried> The UT I put up last night gives me a fairly high degree of confidence that what I have is backward compatible.
14:07:47 <efried> Cause I wrote it against the old code first.
14:08:30 <efried> #action esberglu to pull it into the CI env and give it a spin.
14:09:15 <efried> That'll serve two purposes.  1) Make sure it works at all; and then 2) give us an easier way to make tweaks if we still see those power-off timeouts we were getting.
14:09:41 <thorst_> dig it
14:09:48 <efried> #topic In-tree change sets
14:10:31 <efried> I believe I have the bottom five properly rebased on one another, and I was in the process of going through the ovs-vif one when the power train left the station.
14:10:50 <efried> wow, that was WAY too many metaphors mixed in there.
14:11:02 <thorst_> oook
14:11:10 <thorst_> and the in-tree CI runs against them now?
14:11:34 <efried> Runs, yes.  We still get bitten by new tests seemingly daily.
14:11:48 <thorst_> even though its a white list?
14:11:52 <thorst_> how could we get bit?
14:12:12 <efried> That's a great question.
14:12:21 <efried> Maybe I'm wrong.
14:12:27 <efried> But we need esberglu to answer that.
14:12:39 <thorst_> I bet we got clever with the whitelist
14:12:44 <thorst_> and have some wildcard flags
14:12:49 <thorst_> that pick up new tests
14:12:56 <thorst_> I think mriedem really just wanted a couple tests in there...
14:13:00 <efried> Nope, it's all UUIDs
14:13:06 <thorst_> hmm
14:13:07 <thorst_> OK
14:13:10 <efried> Looking at the latest run, it didn't even get started.
14:13:12 <thorst_> then we'll wait for esberglu
14:13:29 <efried> stack failed
14:13:38 <thorst_> wonder if that's like Jay's
14:13:49 <thorst_> but I haven't been keeping an eye on them
14:15:53 <thorst_> OK - so I think I need to take some time investigating the state of the in-tree.
14:15:57 <efried> Actually, I was looking at the OOT CI for the first in-tree change, which is still failing on duplicate conf options.  I don't see the in-tree having run at all.
14:16:02 <thorst_> #action thorst to look over the in tree stuff a bit more now
14:17:56 <thorst_> what else is there for today?
14:18:18 <efried> wangqwsh Ni you shama?
14:18:37 <wangqwsh> nope,
14:18:52 <efried> Guess we call it early, and fup with esberglu later.
14:19:00 <efried> #endmeeting