14:00:34 <esberglu> #startmeeting powervm_driver_meeting
14:00:35 <openstack> Meeting started Tue Feb 14 14:00:34 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:38 <openstack> The meeting name has been set to 'powervm_driver_meeting'
14:00:39 <thorst_> yo - looks like efried will be out today
14:00:44 <thorst_> he's apparently uber ill
14:01:00 <esberglu> Bummer
14:01:06 <thorst_> yeah
14:01:20 <thorst_> I can give a light status update from his side when we're ready in the meeting
14:01:38 <xia> o/
14:03:16 <esberglu> #topic CI
14:04:10 <esberglu> I have two patches out for neo-os-ci. The first is so OOT doesn't run on IT patches. The second is so all IT runs pick up the IT patches
14:04:30 <esberglu> I wanted to test them concurrently on staging yesterday, couldn't with the network stuff
14:04:47 <esberglu> I've already tested the first one
14:05:17 <esberglu> Once those are both working, we are pretty close to turning on the IT publishing
14:06:14 <thorst_> neat
14:06:20 <thorst_> how bad were you hosed up with the lab issues?
14:06:34 <thorst_> not sure if you saw my note
14:07:32 <esberglu> I just saw it now. Looks like I might be redeploying the environments today
14:07:52 <esberglu> I haven't checked the status of the systems yet today
14:07:57 <efried> o/
14:08:09 <esberglu> You're alive!
14:08:16 <adreznec> Well if the controller got rebooted it's definitely unstacked
14:08:22 <adreznec> So there's that at least
14:08:26 <efried> barely
14:09:19 <esberglu> #action esberglu: Redeploy CI environments
14:09:24 <thorst_> alright.  Too bad that happened...
14:09:25 <thorst_> :-(
14:09:31 <esberglu> #action esberglu: Test 2 CI patches
14:09:33 <efried> Looks like morpheus needs services started.
14:10:06 <esberglu> That's all I had for CI unless there are questions
14:10:14 <efried> oh
14:10:16 <efried> yeah
14:10:22 <efried> What's the scoop with ocata CI?
14:10:40 <thorst_> efried: I sent a note to dom/julio about morpheus
14:10:47 <esberglu> I need to put a patch up. Not everything had a stable/ocata branch for a while
14:10:49 <efried> From last night:  <efried> esberglu When you get a chance (like tomorrow) can you look at https://review.openstack.org/#/c/431583/ ?
14:10:49 <efried> <efried> This is failing OOT consistently.  It might be the first change set we've seen explicitly in the stable/ocata branch.
14:10:49 <efried> <efried> It may be that we need to do something to get that branch working.
14:10:49 <efried> <efried> Yeah - 12:35:23 stable/ocata is not a supported branch for tempest
14:10:49 <thorst_> it was also impacted...they need to make sure it can survive a reboot...
14:11:30 <efried> Okay, esberglu you got an action for that too?
14:11:47 <esberglu> #action: esberglu: Put up a patch for stable/ocata tempest in CI
14:12:03 <esberglu> Yeah, super easy. We can get it in before I redeploy prod.
14:12:20 <efried> sweet
14:13:44 <efried> #topic In-tree change sets?
14:14:16 <esberglu> Yep
14:14:51 <efried> Right now I'm working on refactoring the usage of power on/off in the OOT driver, including consolidating so everything runs through vm.py and synchronizing all those methods on the instance ID.  This may resolve some of the timing failures we were seeing in the OOT CI.
14:15:12 <efried> Once that's done, I'll flush those changes back into in-tree change #2 (start/stop).
14:15:19 <efried> And do the rebase string.
14:15:47 <thorst_> adreznec and I to start reviewing?  Or a day or so yet (two days?  because of illness)
14:16:23 <efried> Yeah, well, I can rebase #1 real quickly and you guys can review that one.  Then yeah, it'll take me a day or two to get #2 piled on top.
14:16:41 <thorst_> yep...that'd be good
14:16:44 <thorst_> assuming you're able
14:17:01 <thorst_> #action adreznec thorst Review new patch set pushed up by efried
14:18:36 <efried> Okay, https://review.openstack.org/#/c/391288/ is rebased, ready for review.
14:19:01 <wangqwsh> yes, just updated the comments from reviewers
14:20:11 <efried> wangqwsh - you put up a couple new patch sets on localdisk - what were those about?  (Haven't looked yet)
14:20:34 <wangqwsh> let me check it
14:21:21 <efried> oh, looks like it may have just been a rebase on the first one.
14:21:35 <wangqwsh> updated the uuid with uuidutils.generate_uuid method to create
14:22:29 <wangqwsh> this is from Ed Leafe review in spawn/destory change set
14:23:28 <efried> The only other thing I have on driver code is mdrabe's change set, which looks like it needs another review from me & thorst_
14:24:19 <efried> done here.
14:24:22 <thorst_> #action thorst to review mdrabe's change set
14:25:11 <efried> #link https://review.openstack.org/#/c/425780/
14:25:21 <efried> That's all I have.
14:27:05 <esberglu> Any one else have topics?
14:27:22 <thorst_> I'm good
14:27:26 <wangqwsh> sorry, the neo4 can not connect
14:27:36 <efried> Looks like morpheus is back.
14:27:38 <thorst_> wangqwsh: can you get to the FSP?
14:27:47 <adreznec> Might have shut off with the power outage
14:27:54 <wangqwsh> no...
14:28:14 <wangqwsh> which fsp?
14:28:28 <thorst_> let me look
14:28:48 <wangqwsh> thanks :)
14:29:04 <thorst_> ooo, yikes.  Yeah, it didn't boot properly
14:29:19 <thorst_> fixing...
14:31:38 <esberglu> Reminder: This week I will be tagging the final Release Candidates (friday). The Ocata release is Feb. 22
14:32:24 <esberglu> Sounds like no one else has any topics. Thanks for joining
14:32:34 <esberglu> #endmeeting