13:01:14 <esberglu> #startmeeting powervm_driver_meeting
13:01:15 <openstack> Meeting started Tue Apr 11 13:01:14 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:19 <openstack> The meeting name has been set to 'powervm_driver_meeting'
13:01:36 <efried> \o
13:02:13 <thorst> o/
13:02:35 <esberglu> #topic In Tree Driver
13:02:35 <thorst> efried: review this in background
13:02:36 <thorst> https://review.openstack.org/#/c/448134/
13:02:39 <efried> ack
13:03:11 <esberglu> efried: Need anything from us in-tree?
13:03:38 <esberglu> Other than reviewing once the rebases all go through?
13:03:45 <efried> esberglu I don't think so.  Assume CI will be a separate topic.
13:03:48 <esberglu> yeah
13:04:52 <esberglu> #topic OOT Driver
13:05:10 <esberglu> thorst: Are there any reviews that we are still trying to push through CI OOT?
13:05:26 <esberglu> I think at least most of them have a CI +1 now
13:05:28 <thorst> esberglu: tons
13:05:41 <thorst> we need to do a full on scrub of things
13:06:14 <esberglu> Yeah I think that's the best bet
13:06:36 <esberglu> Gonna be a pain to redeploy until that packaging stuff while stacking is fixed though
13:07:14 <thorst> well, I think that we have a few things that we should chat through and then once we're relatively solid...we can then go ahead and redeploy OOT
13:07:18 <thorst> OOT CI...
13:07:30 <thorst> net, there are about 6 or so change sets we need to scrub through.
13:09:27 <esberglu> Links? I will keep an eye and try to recheck as soon as any fail
13:09:56 <thorst> well, some will take effort.  But here's a first pass (and they're not just blocked by CI, but also reviews)
13:10:06 <thorst> https://review.openstack.org/448134
13:10:14 <thorst> https://review.openstack.org/448249
13:10:23 <thorst> https://review.openstack.org/447762
13:10:29 <thorst> https://review.openstack.org/453024
13:10:39 <thorst> https://review.openstack.org/452712
13:10:49 <thorst> https://review.openstack.org/447763
13:11:10 <thorst> https://review.openstack.org/416667
13:12:15 <thorst> I think that's it
13:12:18 <thorst> from my end
13:12:28 <esberglu> Okay. I'm kicking off rechecks on the ones that haven't had a run yet
13:14:04 <esberglu> Okay is that it for OOT (CI separate topic)
13:14:12 <thorst> longer term...
13:14:18 <adreznec> The other two that will need reviews are https://review.openstack.org/#/c/452220/ and https://review.openstack.org/#/c/452222/
13:14:21 <thorst> I would like to see us start to look at PCI direct attach
13:14:31 <adreznec> the latter is gated behind those ceilometer changes thorst posted
13:14:33 <thorst> in case anyone has spare cycles.
13:15:01 <adreznec> But the former should be good, though it appears to have failed tempest with different tests than before the recheck...
13:15:41 <esberglu> Are you saying it failed different tests? Or ran different tests?
13:15:59 <adreznec> Failed
13:16:08 <esberglu> Whew okay good
13:16:24 <adreznec> Haha yeah, the latter would definitely be more confusing to deal with
13:17:33 <adreznec> esberglu: Do you know if the CI was down/didn't run on a patch when it first came in and I do a powervm: recheck comment on it, will CI run on that patch?
13:17:44 <esberglu> Yeah it will
13:17:45 <adreznec> Talking https://review.openstack.org/#/c/454506/ in particular
13:17:45 <adreznec> Ok
13:19:29 <esberglu> thorst: You have anything else you wanted to say about PCI direct attach, or just for awareness at this point?
13:20:19 <thorst> just awareness...start thinking about it
13:20:23 <efried> Yeah, that was a bit of a bomb there, thorst
13:20:40 <efried> We talking queens?
13:20:45 <thorst> yeah
13:20:48 <thorst> long term game
13:20:48 <efried> ight
13:21:11 <thorst> I suspect the code for that right now is very kvm centric
13:21:28 <efried> Oh hell yeah.
13:21:35 <thorst> so I'd like our team to build an understanding of what's there...does it fit...do we have changes needed in the core driver...etc...
13:21:40 <efried> #agreed PCI direct attach is a big fish, long term.
13:21:43 <thorst> core driver --> manager
13:22:00 <efried> (been looking for an opportunity to use #agreed)
13:22:15 <thorst> heh
13:22:20 <efried> (oh, it only works for the chair.  Rats)
13:22:27 <thorst> anywho, that's all I had
13:22:39 <esberglu> Okay lets move on
13:22:43 <esberglu> #topic CI
13:22:56 <esberglu> So we already talked about pushing the backlog through
13:23:20 <esberglu> And then at that point I think the plans is to wipe the mgmt node and redeploy from scratch
13:23:34 <esberglu> Cuz this whole saving a sinking ship with a bucket thing isn't working
13:25:14 <esberglu> Other than that we have efrieds local2remote changes
13:25:26 <esberglu> I know you want to have that installed as part of the base image template
13:25:37 <efried> Well, that's open for discussion, but I think that's the right place to do it.
13:25:38 <esberglu> But we would still have to reinstall during the prep_devstack part
13:25:40 <thorst> and we have a long term plan to go 'patchless'?
13:25:58 <efried> We shouldn't have to reinstall it at all then.
13:26:12 <esberglu> We don't know which version of pypowervm we want until then
13:26:35 <efried> You mean because newton and ocata are still on the table at that point?
13:26:37 <efried> Doesn't matter.
13:27:09 <efried> If we diddle /etc/environment in the base image, and have the .py present, pre-1.1.2 will simply ignore, and we'll still have to do the old style local2remote patching if newton/ocata.
13:27:15 <efried> But 1.1.2 will just work.
13:28:09 <efried> To summarize: the new stuff I'm proposing can be part of the base image template; and the old stuff will need to change to be conditioned on pre-pike-only once 1.1.2 is released.
13:28:36 <esberglu> Well we can't pull the version from requirements then
13:28:53 <efried> When requirements says 1.1.2, we can.
13:29:10 <efried> Cause we should be pulling from the requirements of the branch we're testing.
13:29:15 <esberglu> What if requirements changes between the nightly build and the CI run?
13:29:45 <efried> Yeah, we still pull from requirements of whatever branch we're testing.
13:29:57 <esberglu> We don't know which branch we are testing until way after the image build
13:30:03 <esberglu> Maybe I'm missing something here
13:30:06 <efried> Doesn't matter if we flipflop back and forth between 1.1.2 and pre-1.1.2.
13:30:22 <esberglu> Yeah but we still have to reinstall at that point is what I'm saying
13:30:35 <efried> Only if we're testing pre-pike.
13:30:56 <efried> Whole point of this is we don't have to patch pypowervm at 1.1.2.
13:31:29 <efried> ...which should be concomitant with pike.  And pre-1.1.2 with pre-pike.
13:31:56 <esberglu> My point about the reqs changing between the image build and the run still stands
13:32:11 <esberglu> Edge case, but still
13:32:19 <efried> reqs of pypowervm specifically?
13:32:38 <efried> I'm still not seeing the problem.
13:32:39 <esberglu> Yeah, what if we bump the reqs up to 1.1.3? We would then have to wipe all of the nodes out
13:32:44 <esberglu> And build from scratch
13:32:54 <efried> no, we shouldn't.
13:33:04 <efried> Cause 1.1.3 will then get pulled in when we stack.
13:33:18 <efried> And 1.1.3 will still just work when the env var & .py are present.
13:33:18 <esberglu> Ohhh duhhhh
13:33:35 <efried> Whole reason we're doing things this way.
13:33:41 <esberglu> Yeah my b
13:33:55 <efried> Cool
13:34:49 <esberglu> I still owe you a patch / review on that stuff
13:35:16 <efried> Yeah, but this is background work, as there are lulls in the flushing-CI-backlog business.
13:35:40 <efried> As excited as I am about trying it out and getting it working...
13:35:56 <esberglu> Yep. I would like to get it in for when we do the full CI redeploy
13:36:06 <esberglu> So we don't have to redeploy again right after
13:36:59 <efried> For the sake of having it documented, we will ultimately need: o) patches to deploy the .py and /etc/environment change; o) image template rebuild; o) 1.1.2 released; o) g-r and nova project requirements bumps
13:37:47 <efried> I think in that order.
13:38:36 <efried> the image template rebuild & CI redeploy could happen at any point after the neo-os-ci change is merged.
13:39:36 <esberglu> Yeah I think so
13:39:39 <efried> oh, and o) separate neo-os-ci (or powervm-ci?) change to condition manual local2remote patch on pre-pike.  I think that needs to come in sync with the reqs bumps.
13:39:49 <efried> which will be fiddly.
13:40:00 <efried> Cause the manual local2remote patch will simply fail on 1.1.2.
13:40:07 <efried> merge conflict there.
13:40:23 <efried> I guess we could change that right now to condition on the pypowervm version.
13:40:31 <efried> rather than the openstack branch.
13:40:51 <efried> Then no fiddly.
13:41:13 <esberglu> Sure I like that
13:41:19 <efried> Will probably have to use pbr to do version compare, groan.
13:41:25 <efried> Okay, let's move on.
13:41:58 <esberglu> I didn't have anything else base CI
13:42:19 <esberglu> thorst: Did you want to talk OSA CI here? Or separate discussion on that?
13:42:55 <thorst> lets have a separate discussion on that when we stabilize
13:43:08 <esberglu> Okay
13:43:14 <esberglu> That's it from my end then
13:44:12 <esberglu> #topic Other Discussion
13:44:34 <esberglu> nbante: You have anything you are working through?
13:44:37 <efried> #action thorst As able, take a look at https://review.openstack.org/#/c/438729/12..13 (tasks/* bits - the others are rebase) and let's move toward getting this back to nova-powervm for https://bugs.launchpad.net/nova-powervm/+bug/1680947
13:44:38 <openstack> Launchpad bug 1680947 in nova-powervm "Use PrintingDurationListener, get rid of PowerVMTask" [Wishlist,New]
13:44:56 <efried> Low priority.
13:45:39 <nbante> I tried basic tests with tempest  and those are passed successfully. Now working to configure external storage then we can try deploy test cases
13:46:05 <thorst> it looks like I need to figure out how to get our v7k on a private IP address for nbante
13:46:12 <thorst> it'll take some wiring  :-/
13:47:04 <nbante> meanwhile I'll check,what are configuration files need to modify and once all changes done. I'll redploy to get cinder configured
13:48:30 <esberglu> nbante: Cool sounds good
13:48:43 <esberglu> Doesn't look like jay is on
13:48:50 <esberglu> Any final topics before I close?
13:50:50 <esberglu> #endmeeting