13:02:49 <esberglu> #startmeeting powervm_driver_meeting
13:02:50 <openstack> Meeting started Tue Apr 18 13:02:49 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:54 <openstack> The meeting name has been set to 'powervm_driver_meeting'
13:03:10 <thorst> o/
13:03:12 <efried> o/
13:03:36 <esberglu> #topic In-tree Driver
13:03:49 <efried> No movement on reviews.
13:04:02 <efried> Spec freeze was last week, theoretically, but some specs are still being pushed through.
13:04:10 <efried> And we're on a bug triage sweep.
13:04:11 <thorst> typical  :-)
13:04:27 <efried> So - again theoretically - once that stuff dies down a bit, we might expect some more action on reviews.
13:04:50 <efried> I've been staying fairly noisy in #openstack-nova and trying to "help out" as much as possible.
13:04:51 <thorst> here's to hoping
13:05:04 <efried> Squeaky wheel, and all that.
13:05:28 <efried> I even took on a nontrivial thing yesterday - thorst I need to give you a heads-up on that after the meeting.
13:05:35 <thorst> k
13:05:55 <efried> Other in-tree news, I've fixed/rebased up to the SSP change set.
13:06:08 <efried> And all of that is passing CI etc.
13:06:20 <efried> Would like Jay to re-test SSP.
13:06:44 <efried> But I think we should sort out this neutron snafu first (for discussion in OOT topic later)
13:07:22 <thorst> well, maybe the workaround for jay initially is to disable the dhcp agent
13:07:24 <efried> I've been deliberately trying not to do too much on the in-tree stuff, because nova cores have been semi-using it as an excuse not to review.
13:07:25 <thorst> I mean, he's not using it
13:07:40 <thorst> yeah, that seems reasonable
13:07:47 <thorst> something to discuss in more depth at the summit
13:07:58 <thorst> is this in-tree approach working basically
13:08:13 <efried> Yeah, let's queue up a mini-topic about the summit too.  I've got a couple questions there.
13:08:46 <esberglu> k we can do that at the end
13:09:24 <esberglu> Anything else in-tree?
13:11:06 <efried> not from me
13:11:10 <thorst> nada
13:11:21 <esberglu> #topic Out-of-tree Driver
13:12:37 <efried> https://review.openstack.org/#/c/456741/ - thorst I saw that mdrabe reviewed
13:12:46 <efried> Do we need more pvc reviewers?
13:13:07 <thorst> I wanted manas to review...but wasn't able to get a hold of him
13:13:24 <efried> (I'll post a powervm:recheck there)
13:13:27 <thorst> mdrabe: can you see if manas cares?  Otherwise if we don't hear anything, lets just get it through CI and go again
13:13:43 <mdrabe> I'll ping him
13:13:48 <thorst> thx dude
13:14:09 <efried> The only other OOT thing I know of is Jay's issue.
13:14:11 <thorst> I think we're doing pretty well from an overall backlog of reviews...thanks to the CI being back up
13:14:20 <thorst> efried: do we need to port anything else from IT to OOT?
13:14:48 <efried> thorst Possibly.  I think we may want to do periodic sweeps comparing the two and see what we can push back.
13:14:56 <efried> I definitely want to do the TaskFlow thing.
13:15:01 <efried> eventually.
13:15:30 <efried> Question on that subject: we've made quite a lot of improvements to the UT in-tree.  Do we care to flush those back to OOT?
13:15:48 <efried> Quite a lot of work for relatively little reward IMO.
13:15:53 <thorst> efried: I think as time allows, yeah
13:16:16 <efried> Maybe a thing for new team members to look at?
13:16:33 <efried> As a vehicle to help them familiarize themselves with the code.
13:16:36 <thorst> possibly
13:16:51 <thorst> on that thread...
13:16:52 <efried> Which reminds me, I added edmondsw to the in-tree change sets.  He's been reviewing - thanks for that.
13:17:07 <thorst> we also did a spec review yesterday of things that impact us
13:17:13 <thorst> I think a few of us have TODO's there.
13:17:23 <efried> (Is edmondsw on the calendar notice for this meeting?)
13:17:51 <esberglu> He isn't
13:20:09 <edmondsw> efried I'm on another call but I can drop if need be
13:20:29 <efried> edmondsw The meeting is just here in IRC, no call.
13:20:29 <thorst> edmondsw: me too - we may need another time for this
13:20:30 <thorst> :-)
13:20:35 <edmondsw> ah :)
13:21:13 <efried> esberglu Please add edmondsw to this notice - edmondsw attend as able for the near future - recognize you've got other stuff going on.
13:21:21 <esberglu> Will do
13:21:23 <efried> thx
13:21:38 <edmondsw> yep, will try
13:22:30 <esberglu> Sounds like we can move on
13:22:35 <esberglu> #topic CI
13:23:03 <esberglu> CI has been looking pretty solid since coming back up. I still have a handful of failures to go through
13:23:16 <esberglu> But everything so far has been either a bad patch
13:23:48 <esberglu> And I've seen a GnuTLS Error trying to interact with github a few times
13:25:09 <thorst> esberglu: are we using that DNS / HTTP cache server that adreznec set up a few months back?
13:26:17 <esberglu> I think the DNS part isn't working on the ready nodes
13:26:21 <esberglu> And I will need to update
13:26:23 <esberglu> http://morpheus.pok.stglabs.ibm.com/#/c/4707/
13:26:31 <esberglu> To get it running
13:26:38 <thorst> k
13:26:50 <thorst> I'd be curious to see that working...see if we get better perf
13:27:05 <thorst> but no rush
13:27:41 <esberglu> Yeah it's been on my list for a while, just been getting eclipsed by other stuff
13:27:48 <thorst> understood
13:27:57 <thorst> that's the right prioritization
13:29:09 <esberglu> That's all I had for CI
13:29:10 <efried> local2remote - Looks like just adding that flag in 5113 and we can get that going.  But we still need to merge 5112 first.  thorst adreznec esberglu (edmondsw) please review.
13:29:49 <efried> Actually - 5112 needs to be merged _and_ we need to cut 1.1.2 and get it into reqs.
13:30:32 <efried> Otherwise 5113 won't work properly - unless we change it around to always apply that patch (with --keep-redundant), as we started discussing in the review.
13:31:22 <efried> esberglu Do you have a way to test 5112/5113 before we merge 'em?
13:31:43 <esberglu> efried: I applied them and deployed staging yesterday afternoon
13:31:48 <efried> noice
13:31:57 <esberglu> It wasn't working though
13:32:00 <efried> boo
13:32:06 <efried> Okay, let's debug today.
13:32:23 <esberglu> I was getting the "Unable to connect to novalink" or whatever the error is there
13:32:47 <esberglu> efried: Yep sounds good
13:33:12 <efried> indicating that the local2remote-ness wasn't happening.  But at least it compiled ;-)
13:33:22 <efried> #action esberglu efried to debug local2remote stuff
13:33:26 <thorst> compiled...python?
13:34:12 <efried> thorst The assembly code included in the fix.
13:34:27 <thorst> o good, I was thinking you needed more assembler
13:34:34 <efried> really, who doesn't?
13:34:47 <thorst> real programmers only know one language
13:34:47 <efried> moving on
13:35:06 <esberglu> #topic Other Testing
13:35:22 <esberglu> Oh I thought nbante was on
13:35:35 <efried> Do we want to dive into the neutron thing any further here?
13:36:26 <thorst> I think we can after meeting
13:36:28 <thorst> nbante thing
13:36:34 <thorst> I got him an iSCSI device
13:36:46 <thorst> he will be trying to test OSA with it...but OSA doesn't appear to support it
13:36:57 <thorst> with that said, OSA does appear to support a very similar cinder driver
13:37:04 <thorst> so I'm hoping we can just change it to storwize and it works
13:37:08 <thorst> we will see...
13:37:39 <nbante> thorst..look like you discussed on OSA with external storage. I got disconnected
13:38:30 <thorst> nbante: just gave a status update that you'll be trying again with that v7k
13:38:35 <thorst> and we'll see if it actually works
13:38:40 <nbante> sure..thanks
13:40:07 <esberglu> #topic Summit
13:40:54 <esberglu> efried: I believe you had a few things here? Or just wanted to start a discussion?
13:41:14 <efried> I mainly wanted to try to understand when/how/where there would be nova team meetups/unconferences at the summit
13:41:26 <efried> Since the format seems different now in light of PTGs having been added.
13:42:20 <esberglu> I still need to go through the schedule and read up on it
13:42:27 <adreznec> Yeah, this will be pretty different. Not necessarily sure there will be the prototypical unconference from talking with people
13:42:28 <esberglu> So I can't help you much there yet
13:42:56 <efried> Well, I certainly didn't see anything on the schedule.  Maybe I'll ask in IRC to clarify.
13:43:12 <adreznec> Seems like projects are going to have three main things to work with - new contributor intros, breakout rooms, and some dedicated planning sessions
13:44:05 <efried> adreznec I saw the intros on the schedule.  Didn't see the others.
13:44:13 <efried> I'll ask in the meeting on Thursday.
13:44:29 <efried> #action efried to find out about nova dev meetings at the summit.
13:44:43 <adreznec> Let me find the forum schedule
13:45:04 <adreznec> It went out in a mailing list email last week
13:46:36 <adreznec> It looks like they're all in the regular schedule now
13:46:47 <adreznec> Tagged as things like Forum: Project Onboarding and  Forum: Fishbowl Discussion
13:46:49 <efried> adreznec Can you point me to those sessions (offline)?
13:46:51 <adreznec> https://www.openstack.org/summit/boston-2017/summit-schedule/global-search?t=Forum
13:47:54 <adreznec> ^ so those are going to basically be the design summit equilvalent sessions
13:48:14 <efried> okay.
13:48:47 <adreznec> https://www.openstack.org/summit/boston-2017/summit-schedule/events/18738/using-cinder-for-nova-ephemeral-storage-backend?BackURL=https%3A%2F%2Fwww.openstack.org%2Fsummit%2Fboston-2017%2Fsummit-schedule%2Fglobal-search%3Ft%3DForum%23eventid%3D18738
13:48:57 <adreznec> That one for example is pretty interesting
13:49:38 <thorst> ooo, send to gfm
13:50:58 <adreznec> Done :)
13:52:59 <esberglu> Anyone have anything else they want to discuss, summit or otherwise?
13:53:00 <adreznec> Only other thing I had from the summit was that at some point we should probably have a quick discussion on priorities for people to cover
13:53:41 <adreznec> Should be easier than summits of the past since the design summit is toned down into the forum
13:53:48 <adreznec> But still plenty of things to cover
13:53:52 <efried> Is there a way for us to show each other our schedules?
13:54:14 <adreznec> There didn't used to be... not sure if there is now
13:54:18 <adreznec> Something to look at
13:54:22 <efried> I don't see anything obvious.
13:55:06 <adreznec> Yeah
13:55:22 <adreznec> It looks like there's not even a way to just print your schedule
13:55:25 <adreznec> So... probably not
13:55:54 <adreznec> Oh never mind, you can if you toggle that then hit view/print
13:55:57 <adreznec> So I guess we could do that
13:56:11 <adreznec> Or use the export function
13:57:26 <edmondsw> there was another fishbowl about moving resource claims from nova-compute to nova-scheduler (wed @ 4:30)
13:57:41 <edmondsw> not sure if that would impact us?
13:57:43 <adreznec> Yeah, saw that too
13:57:58 <efried> Was just talking to mriedem about that in #openstack-nova
13:57:59 <thorst> I don't know that it impacts the driver
13:58:05 <efried> https://review.openstack.org/#/c/437424/
13:58:05 <thorst> but I think it impacts the PVC folks
13:58:10 <thorst> Charles should probably go to that
13:58:21 <edmondsw> yeah, I think I pinged Charles
13:58:30 <edmondsw> I'd better go make sure I did
13:59:06 <efried> adreznec So wait, toggle what?
13:59:21 <efried> Ah - "My Schedule".
13:59:25 <adreznec> efried: yep
13:59:52 <efried> and export PDF.
14:00:00 <efried> I'll send y'all what I've got flagged so far.
14:00:02 <adreznec> Yeah, or ical
14:00:18 <adreznec> Other option we could do that I just thought of is that you can sync it to a google calendar it looks like
14:00:29 <adreznec> Could set up a shared calendar or something I guess to track sessions we care about
14:01:55 <efried> Bah, the export functions aren't working for me.
14:02:20 <adreznec> Maybe the calendar project is open source
14:02:25 <adreznec> and you could submit a patch to fix it
14:02:25 <adreznec> :P
14:03:37 <adreznec> All right, we're over time here
14:03:39 <adreznec> Anything else?
14:03:48 <esberglu> Nope
14:04:57 <esberglu> #endmeeting