13:00:37 <esberglu> #startmeeting powervm_driver_meeting
13:00:38 <openstack> Meeting started Tue Aug 15 13:00:37 2017 UTC and is due to finish in 60 minutes. The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:41 <openstack> The meeting name has been set to 'powervm_driver_meeting'
13:00:49 <edmondsw> o/
13:00:51 <mdrabe> o/
13:00:59 <thorst> \o
13:02:21 <edmondsw> efried_zzz is not going to make it today
13:02:33 <esberglu> #topic In Tree Driver
13:03:06 <esberglu> Nothing going on IT still I believe
13:03:10 <edmondsw> I wanted to bring up our governance here
13:03:20 <edmondsw> and use of releases for the *-powervm projects
13:03:26 <edmondsw> thorst, did you see my note there?
13:03:42 <thorst> edmondsw: I did, and I started to respond but got distracted
13:03:52 <edmondsw> do you want to discuss here or?
13:04:05 <thorst> let me pull it back up
13:04:20 <thorst> I think a lot of the assumptions we had when we started aren't reality now that we've grown and are going in tree
13:04:33 <edmondsw> yup, that's what I'm hoping
13:04:42 <thorst> we have a "don't rock the boat" approach, but if dims is recommending that, it's obviously worth investigating
13:04:59 <edmondsw> esberglu mdrabe forwarded the note to you...
13:05:02 <edmondsw> sorry for leaving off
13:05:13 <esberglu> np
13:05:24 <thorst> I think a pvm-stackers style group makes sense
13:05:29 <thorst> assuming the community would be on board
13:05:33 <edmondsw> cool, because I was thinking the same
13:05:48 <edmondsw> and maybe even move ceilometer-pvm there instead of under telemetry
13:05:53 <edmondsw> so they're all together?
13:06:02 <thorst> we knew that if we came into the community and asked for something like that early on...it'd have been seen as some agenda we were trying to drive
13:06:13 <thorst> where as our end goal is to just get powervm enablement in the respective projects
13:06:27 <thorst> I think we've demonstrated that to the community now
13:07:23 <edmondsw> #action edmondsw to investigate creation of pvm-stackers project under governance
13:07:50 <edmondsw> that's all I had for IT
13:08:49 <esberglu> #topic Out of Tree Driver
13:09:05 <edmondsw> iSCSI is a mess...
13:09:32 <edmondsw> I've dug into that code some more and have a much better understanding of what we've got ahead of us
13:10:04 <thorst> edmondsw: I think seroyer has someone that was going to be able to dedicate some time as well to that effort
13:10:08 <edmondsw> we've got a meeting later today out of which I hope we'll have direction on priority and can put together a timeline
13:10:15 <edmondsw> thorst awesome
13:10:51 <edmondsw> so probably a bigger update on this next week
13:11:55 <esberglu> Cool. Any other OOT discussion items?
13:12:00 <mdrabe> NVRAM event performance stuff testing yielded some issues. With evacuate itself not the change. I'm wading through them.
13:12:39 <edmondsw> nothing else from my end
13:12:54 <mdrabe> it from me
13:13:09 <esberglu> #topic PCI Passthru
13:13:34 <edmondsw> efried_zzz has started wading through the code there and noting issues
13:14:01 <esberglu> Yep saw that note. Nothing to discuss for the time being?
13:14:20 <edmondsw> yeah, not without him
13:14:36 <esberglu> #topic PowerVM CI
13:15:26 <esberglu> Gonna try to link up with hsien today to look into some rest logs to find out why the compute service is occasionally failing to come up
13:15:57 <edmondsw> ++
13:16:03 <edmondsw> we've gotta figure that out
13:16:15 <esberglu> Other than that I've currently trying to take everything defined in the jenkins jobs and move them to the external scripts
13:16:21 <esberglu> Which should do 2 things
13:16:36 <esberglu> 1) Allow changes to those tasks to take effect immediately
13:16:53 <esberglu> 2) Ease the transition to zuul v3 (no more jenkins!)
13:17:09 <edmondsw> both good things
13:17:22 <esberglu> I want to start that transition to zuulv3 asap after it goes live
13:17:40 <edmondsw> what is the outlook for that?
13:18:08 <esberglu> mdrabe: It's not worth pursuing that jenkins upgrade anymore. We can just stay at the current version until we get rid of it
13:18:24 <esberglu> edmondsw: They are releasing it in conjunction with the PTG
13:18:32 <mdrabe> whew good to hear
13:19:31 <esberglu> mdrabe: If you have any extra time I can always use extra eyes on tempest failures. Not sure how busy you are elsewhere
13:20:12 <esberglu> That's all for CI
13:20:23 <esberglu> #topic Driver Testing
13:20:31 <esberglu> Doesn't look like jay is on
13:20:32 <edmondsw> esberglu I think we learned since our last meeting that we were wrong about the progress we thought we were making on the timeouts issues, right?
13:21:01 <esberglu> edmondsw: Well we made some progress on the REST timeouts, but not the server build timeouts
13:21:26 <esberglu> I'm planning on being 100% tempest failure debug for the rest of the week
13:21:36 <edmondsw> sounds good
13:22:03 <esberglu> unless something else breaks which seems to happen every time I start really digging in
13:22:37 <edmondsw> I think we can move on to the next topic
13:22:48 <esberglu> #topic Open Discussion
13:23:11 <esberglu> Nothing further from me
13:23:57 <edmondsw> I should have raised this under IT, but we should start looking at adding network support there now that master=queens
13:24:21 <edmondsw> and config driver, and vSCSI... once we can free someone up to look at those things
13:24:35 <esberglu> Do we have an order that we would like to do that in?
13:24:36 <edmondsw> so mdrabe, esberglu, if you have any cycles let me know
13:24:49 <edmondsw> esberglu good question... not at the moment
13:25:11 <esberglu> edmondsw: I would like to start getting my foot in the door on that. I can work some time in for it
13:25:11 <edmondsw> I need to look at the changesets we already have up and see what they still need
13:25:31 <edmondsw> yep, that's what I wanted to hear
13:25:47 <edmondsw> I think network is probably the priority, but if config_drive is easier we might tackle it first
13:26:34 <edmondsw> that's it
13:26:42 <esberglu> edmondsw: We can touch base later to figure out a gameplan
13:26:47 <edmondsw> ++
13:26:54 <esberglu> Nice and quick today. Thanks for joining
13:26:58 <esberglu> #endmeeting