14:00:56 <esberglu> #startmeeting powervm_driver_meeting
14:00:57 <openstack> Meeting started Tue Feb  6 14:00:56 2018 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:00 <edmondsw> o/
14:01:01 <openstack> The meeting name has been set to 'powervm_driver_meeting'
14:01:08 <efried> @/
14:01:33 <esberglu> #topic In-tree Driver
14:02:35 <efried> #action esberglu Propose Rocky bp :)
14:02:40 <esberglu> Not much going on here. I'm gonna start looking at what all will be needed for live migration later this week
14:02:45 <esberglu> efried: Sure
14:02:51 <edmondsw> do we need to ping some folks to look at https://review.openstack.org/#/c/533237/ ?
14:03:15 <edmondsw> efried esberglu I was planning to propose the bp
14:03:26 <efried> okay.
14:03:30 <esberglu> edmondsw: ok
14:03:42 <efried> If you don't change it much, it can get approved by one core :)
14:03:53 <edmondsw> have been holding up while we finalize first half resources and such
14:04:09 <efried> Resources schmesources
14:04:30 <edmondsw> shouldn't be significantly different, just include the new goals for Rocky
14:05:05 <edmondsw> just needs to be proposed before the PTG, right?
14:06:12 <efried> Earlier == better.  There's a possibility of someone looking through it now before there's a zillion specs to review.
14:07:21 <edmondsw> I guess it couldn't hurt too much to go ahead and propose it
14:07:26 <edmondsw> #action edmondsw propose Rocky bp
14:07:49 <edmondsw> #action edmondsw seek reviews on 533237
14:07:55 <efried> I did ^
14:08:05 <edmondsw> efried ok, tx
14:08:16 <efried> Looks like spec freeze is usually lined up with release milestone 1, which is in April.
14:08:42 <efried> But yeah, we should be able to have it approved way before that.
14:08:58 <edmondsw> yeah, I figured we have some time, was just shooting to get it in before PTG
14:09:24 <efried> Jay +2ed the feature classification
14:09:30 <edmondsw> cool
14:09:48 <edmondsw> that's probably all for IT
14:10:03 <esberglu> #topic Out-of-tree Driver
14:10:19 <efried> svenkat is ramping up work for SR-IOV max capacity.
14:10:54 <edmondsw> yep, I know of 2 commits there, one I +2d and one with comments
14:10:58 <efried> https://review.openstack.org/#/c/541077/ and 6296
14:11:26 <edmondsw> tjakobs has posted another version of the volume driver refactoring, so I'm looking at that
14:12:14 <esberglu> edmondsw: I started looking at that yesterday, hoping to have some more time today
14:12:15 <edmondsw> esberglu when we're done with this refactor, we should see if it changes anything about our vSCSI IT commit
14:12:21 <svenkat> nova_powervm patchset will be the final work, i will genrate it when pypowervm is merged.
14:12:37 <esberglu> edmondsw: Yep
14:12:56 <edmondsw> like the class name
14:12:57 <efried> svenkat: You've got two +2s on the pypowervm patch; go ahead and merge it.  But you'll need a release before the community patches will pass.
14:13:15 <efried> ...or at least, you should be setting up your tests so that's the case :)
14:13:24 <svenkat> ok..
14:13:26 <efried> with proper autospeccing etc.
14:14:23 <svenkat> efried: I do not have access to merge pypowervm changes..
14:14:34 <edmondsw> yeah, we shouldn't be merging non-defect nova_powervm changes until Queens releases
14:14:38 <efried> svenkat: That's weird.  Done.
14:14:42 <svenkat> thanks
14:15:26 <svenkat> over to networking_powervm patchset - i see Matthew’s comments, i am addressing them.
14:15:48 <esberglu> I'm going to be cutting RC1 and branching queens release for *-powervm later this week
14:16:52 <edmondsw> esberglu ack
14:17:38 <esberglu> That all OOT?
14:17:41 <edmondsw> we have gotten some positive votes on the proposal to create PowerStackers governance project
14:17:56 <edmondsw> but it needs a lot of votes to merge, so I'm not sure if that will go in this week or not
14:18:25 <edmondsw> #action edmondsw probe on how to move the PowerStackers commit along
14:18:56 <efried> [feature matrix patch is +A]
14:19:02 <edmondsw> sweet
14:19:04 <edmondsw> I think that's all for OOT
14:19:37 <edmondsw> oh, esberglu please look at https://review.openstack.org/#/c/540507/
14:19:52 <esberglu> edmondsw: Will do
14:19:58 <esberglu> #topic Device Passthrough
14:20:07 <esberglu> efried: Anything to discuss this week?
14:20:46 <efried> I put up a spec for update_provider_tree
14:21:03 <efried> Representing a lot of work that's already been done, but will be finished up in R.
14:21:20 <efried> It's got Jay's +2 at this point.
14:21:48 <efried> https://review.openstack.org/540111
14:22:09 <efried> Reproposal for Granular also has Jay's +2.  https://review.openstack.org/540179
14:22:48 <efried> I'm *considering* putting up a spec for placement caching by the scheduler.  But that might be a shitstorm.
14:23:24 <efried> See preliminary shitsquall at https://review.openstack.org/#/c/540111/2/specs/rocky/approved/update-provider-tree.rst@223
14:23:55 <edmondsw> ack
14:24:11 <edmondsw> I'll read over that later
14:24:12 <efried> The amount of work remaining for NRP in alloc cands (Jay) is small, so I'm hoping that gets done pretty quickly in R.  Then I can finish granular.  Then we can start implementing update_provider_tree in our driver.
14:24:54 <efried> We can actually start doing that anyway - we just wouldn't have the benefit of nested & granular.
14:25:04 <edmondsw> sounds like the driver-side changes for update_provider_tree are really easy
14:25:08 <efried> So I'm not sure how much we want to invest in that.
14:25:41 <efried> edmondsw: Yes, they should be fairly easy, except we're going to have some brainwork to do to figure out things like allocation ratios and step sizes.
14:26:17 <edmondsw> yeah, I was thinking just move what we already do into the new method
14:26:23 <efried> And what I was getting at above is that we may want to hold off until NRP/granular are locked and loaded so we can jump right to the endgame and model stuff the way we ultimately want to.
14:26:24 <edmondsw> definitely more work to add onto that
14:27:41 <edmondsw> CI?
14:27:59 <esberglu> #topic PowerVM CI
14:28:26 <esberglu> The post_stack_vm_cleaner fix got rid of that vopt issue
14:28:35 <esberglu> We're running OOT with that and efried's naming change
14:28:46 <esberglu> But IT just has the cleaner fix
14:28:56 <esberglu> And the issue has disappeared from both
14:29:05 <efried> So do we want to keep the rename "fix"?
14:29:33 <efried> The cleaner fix obviously only applies to the CI env.  But the probability of hitting this in the field is pretty durn small.
14:29:47 <edmondsw> I'd probably drop the rename... it never merged, just the patch merged
14:29:59 <edmondsw> efried oh, true
14:30:17 <edmondsw> yeah, I still think that is really unlikely to be hit in the field
14:30:37 <edmondsw> I think just abandon the rename and merge a removal from the patch list
14:30:47 <esberglu> Sounds good to me
14:31:33 <efried> If it comes up again, we can resurrect the rename.
14:31:39 <edmondsw> yep
14:32:34 <efried> Abandoned
14:32:39 <esberglu> Still haven't gotten to the bottom of the test_update_server_name test
14:33:40 <edmondsw> how's the move to pike going?
14:34:13 <esberglu> edmondsw: Was planning on jumping back onto that today
14:34:27 <esberglu> Tried a few things last week, didn't really make any progress
14:34:33 <edmondsw> k
14:34:39 <esberglu> Still can't get large snapshots working
14:35:18 <esberglu> That's all from me
14:35:30 <esberglu> #topic Open Discussion
14:35:46 <esberglu> FYI I will be out Thursday and Friday next week
14:36:19 <edmondsw> esberglu ack
14:36:30 <efried> Just got PTG approval.
14:36:52 <edmondsw> yes!!!
14:37:08 <efried> I'm leaving the Friday before, bringing the wife, and extending the stay into the following week.
14:37:26 <edmondsw> have fun!
14:37:39 <efried> Also put up a proposal for a talk on Placement in Vancouver.
14:37:47 <edmondsw> good. I think that's very good
14:38:03 <openstackgerrit> Sridhar Venkat proposed openstack/networking-powervm master: Support maximum capacity for SR-IOV VNIC  https://review.openstack.org/541077
14:38:36 <edmondsw> FYI I may take a day or two off around the 21st
14:39:39 <edmondsw> that all for today?
14:40:11 <efried> Nothing else from me.
14:41:50 <edmondsw> call it
14:42:29 <esberglu> #endmeeting