14:00:40 <edmondsw> #startmeeting PowerVM Driver Meeting
14:00:41 <openstack> Meeting started Tue Mar 13 14:00:40 2018 UTC and is due to finish in 60 minutes.  The chair is edmondsw. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:45 <openstack> The meeting name has been set to 'powervm_driver_meeting'
14:01:14 <edmondsw> #topic In-Tree Driver
14:01:24 <esberglu> \o
14:01:40 <edmondsw> efried?
14:01:46 <efried> Sorry, chaos
14:01:52 <edmondsw> np
14:02:02 <edmondsw> https://etherpad.openstack.org/p/powervm-in-tree-todos
14:02:25 <edmondsw> wanted to talk about what we're doing with the blurb at the top of that
14:03:02 <edmondsw> efried you probably have the best idea of what we should do there
14:03:11 <edmondsw> but if you're still in chaos we can come back to that
14:03:22 <efried> Sorry, guys, any way we can pick this up in 10 minutes?
14:03:34 <efried> otp and at the mercy of the other end
14:03:40 <edmondsw> fine with me
14:03:41 <esberglu> np for me
14:16:21 <efried> I'm back, sorry about that.
14:16:25 <efried> We're talking about the InstanceInfo thing?
14:16:47 <edmondsw> esberglu resuming
14:16:56 <esberglu> ack
14:16:58 <edmondsw> efried yeah... I don't think we have anything more to do there do we?
14:17:10 <efried> Did we flush those changes back to OOT?
14:17:25 <edmondsw> good question
14:17:45 <edmondsw> #action edmonds check whether we need InstanceInfo changes OOT
14:17:59 <edmondsw> I can move to the OOT todo list if need be
14:18:30 <edmondsw> as for Rocky...
14:18:48 <efried> Looks like we did.  So yeah, we can remove that item.
14:18:56 <edmondsw> efried great, tx
14:19:01 <efried> def get_vm_info(adapter, instance):
14:19:01 <efried> """Get the InstanceInfo for an instance.
14:19:01 <efried> :param adapter: The pypowervm.adapter.Adapter for the PowerVM REST API.
14:19:01 <efried> :param instance: nova.objects.instance.Instance object
14:19:01 <efried> :returns: An InstanceInfo object.
14:19:01 <efried> """
14:19:01 <efried> pvm_uuid = get_pvm_uuid(instance)
14:19:02 <efried> pvm_state = get_vm_qp(adapter, pvm_uuid, 'PartitionState')
14:19:03 <efried> nova_state = _translate_vm_state(pvm_state)
14:19:03 <efried> return hardware.InstanceInfo(nova_state)
14:19:10 <edmondsw> I added a couple reviews to https://etherpad.openstack.org/p/rocky-nova-priorities-tracking
14:19:22 <edmondsw> including the spec for virt integration efforts in Rocky
14:19:40 <edmondsw> I'm hoping we can get that approved soon...
14:20:31 <esberglu> I added network hotplug and snapshot as ready for subteam review there
14:20:34 <edmondsw> efried do you have a feel for how long I should wait before pinging melwitt?
14:20:53 <edmondsw> esberglu tx... I think that'll be a good place for us to keep track of things
14:21:05 <edmondsw> and have visibility in the larger nova team to what we're doing
14:21:12 <esberglu> vSCSI is ready too, but I do want to get a stack with that and test again, make sure it still works
14:21:22 <edmondsw> +1
14:21:29 <efried> We need to get subteam +1s first; then we can move 'em to broader review and start pestering people.  Which means I (at least) need to get on those reviews.
14:21:42 <efried> cause I think I'm behind on at least a couple.
14:21:55 <edmondsw> efried yep, that's why their only marked for subteam review except where you/I have already +1d
14:22:02 <edmondsw> they're*
14:22:57 <edmondsw> good call adding the comments on what each link is
14:23:04 <efried> ++
14:23:35 <edmondsw> I will try to take another look at the ones ready for subteam review again today
14:23:51 <edmondsw> esberglu update us on the others that are in-progress but not ready yet?
14:24:12 <esberglu> There are 2 more that I have underway, both related to localdisk
14:24:19 <esberglu> https://review.openstack.org/#/c/549053/
14:24:24 <esberglu> https://review.openstack.org/#/c/549300/
14:24:54 <esberglu> The first adds the DiskAdapter parent class, currently we just have the ssp adapter in tree
14:24:56 <edmondsw> why isn't 053 ready for subteam review?
14:25:19 <esberglu> It is
14:25:51 <edmondsw> ok, so we can add that to the etherpad
14:25:55 <esberglu> I just didn't add it yet in case snapshot changes will require rebasing / modifying
14:26:04 <esberglu> I'll add it
14:26:18 <edmondsw> looks like it is based on an older snapshot ps
14:26:37 <esberglu> edmondsw: Yeah I was holding off on rebasing until you guys +1
14:26:47 <edmondsw> works for me
14:27:33 <edmondsw> I think the only other thing I had to mention IT is that esberglu and I cleaned up the TODO etherpad: https://etherpad.openstack.org/p/powervm-in-tree-todos
14:28:02 <edmondsw> I will add a link to the nova rocky etherpad... tx for pointing that out yesterday efried
14:28:11 <edmondsw> anything else for IT?
14:28:17 <esberglu> nope
14:29:18 <edmondsw> #topic Out-of-Tree Driver
14:29:37 <edmondsw> new etherpad for this: https://etherpad.openstack.org/p/powervm-oot-todos
14:29:55 <edmondsw> efried I added the volume id item we were discussing yesterday
14:30:20 <edmondsw> SRIOV max capacity merged, so I can remove that
14:30:43 <edmondsw> I spent some more time looking at the volume refactor yesterday
14:30:52 <edmondsw> getting close there...
14:31:20 <edmondsw> I'd like to get reviews on that tied up this week, and see if we can get that tested and merged by end of the month
14:32:01 <edmondsw> efried your volume_id change proposal is pretty small, but we should talk about whether it makes sense to do that on top of the refactor rather than have to do it twice
14:32:14 <edmondsw> thoughts?
14:32:40 <edmondsw> Imran said they can wait a couple weeks on the volume id change
14:32:58 <efried> As you say, it's pretty small, the rebase wouldn't be hard, could do it either side.  Since Imran says we want this by end of month, we may want to do the volume ID first.
14:33:06 <efried> oh, if you want to think of it that way :)
14:33:20 <edmondsw> yeah, it is small, so I could go either way
14:33:25 <efried> We need to get the pypowervm side merged and through g-r before it'll pass tests
14:33:33 <edmondsw> was pretty set on it being after the refactor, but then realized how small it is :)
14:33:39 <efried> and core/REST needs more patches before it'll actually work.
14:33:48 <edmondsw> efried yep, I think the g-r change may be the bigger issue
14:33:55 <edmondsw> as far as how quickly we can get this to them
14:34:08 <efried> But those don't really factor into which order we do the n-pvm changes
14:34:09 <edmondsw> and the core/REST changes, of course
14:34:15 <edmondsw> yep
14:34:32 <efried> So - how close are we on The Big Refactor?
14:34:37 <edmondsw> pretty close
14:34:39 <efried> (I of course should review that)
14:34:43 <edmondsw> definitely
14:35:01 <edmondsw> I am doing another pass through the changes, hope to finish that today
14:35:06 <edmondsw> don't expect much more to shake out there
14:35:30 <edmondsw> I did notice something yesterday while digging through... we don't have live migration support for iSCSI
14:35:50 <edmondsw> so I added that to our TODO etherpad after talking to Gerald and confirming that PowerVC will need that
14:36:33 <edmondsw> anything else to talk about OOT?
14:36:56 <esberglu> I have a couple easy reviews out
14:37:06 <esberglu> https://review.openstack.org/#/c/548410/
14:37:11 <esberglu> https://review.openstack.org/#/c/548412/
14:37:22 <esberglu> If efried could get a review on those
14:37:45 <esberglu> And give your thoughts on
14:37:46 <esberglu> https://review.openstack.org/#/c/548721/
14:38:31 <esberglu> that all I had
14:39:46 <edmondsw> looks like someone has raised a docs fix: https://review.openstack.org/#/c/552379/
14:39:49 <edmondsw> I'll look at that after
14:40:04 <edmondsw> #topic Device Passthrough
14:40:08 <edmondsw> efried ?
14:40:45 <edmondsw> any updates from the PTG?
14:40:48 <efried> Heaping pile of blueprints/specs/patches from the PTG, plus the update_provider_tree stuff that's been sitting out there for a while.
14:41:32 <edmondsw> I spent some time thinking through use cases and such while you were out... we need to catch up and go over that when you have a few minutes
14:41:35 <efried> Some changes to UPT came out of the PTG; spec delta almost merged (https://review.openstack.org/#/c/552122/) but I need to write the code accordingly.  That's "first" on my agenda.
14:42:18 <efried> No news on NRP in GET /a_c; I'll bug jaypipes about that soon.  But with those two pieces, we should be pretty free & clear to start proposing our own driver patches to implement UPT.
14:42:38 <edmondsw> I don't think we're going to have that borrowed system for too much longer, so you should probably try to get on that while we can
14:43:01 <efried> Once we have that, we can do generic passthrough.  So edmondsw you have time to figure out the ux so we can walk that back to the code.
14:43:03 <edmondsw> figure out what the card looks like as far as identifiers and such
14:43:17 <efried> Oh, was that on me?  I thought you were on the hook for that.
14:43:50 <edmondsw> yes and yes
14:43:54 <edmondsw> :)
14:44:02 <edmondsw> I figured out what it should look like
14:44:25 <edmondsw> I haven't gotten on the system to confirm that it actually looks like that... I thought you were doing that
14:44:40 <edmondsw> I can try to figure out how to do that
14:44:56 <efried> Wasn't on my radar.  If you have room for it, that would be cool.  So the system has GPUs on it?
14:45:00 <edmondsw> yes
14:45:06 <edmondsw> the really nice kind
14:45:31 <edmondsw> Nicolas has it patched so it should work for us now
14:45:52 <efried> So pvmctl sys list --xml maybe
14:45:58 <edmondsw> k
14:46:36 <edmondsw> efried get together this afternoon and go over things?
14:47:01 <efried> But we still need to figure out the set of devices we'll support, and how we're going to represent it, and how we're going to discover.
14:47:19 <edmondsw> that would be in the "go over things" discussion :)
14:47:20 <efried> Yes, let's
14:47:34 <edmondsw> alright, enough on that for now I think
14:47:46 <efried> Send me a calendar notice, and then send me a message on IRC to let me know you've done that.  I'm only down to 283 unread messages in Notes.
14:47:57 <edmondsw> efried ack
14:48:05 <efried> (432 and growing in my other client - dev ML)
14:48:15 <edmondsw> #topic Open Discussion
14:48:22 <esberglu> edmondsw: CI?
14:48:27 <edmondsw> oh, oops...
14:48:31 <edmondsw> #topic PowerVM CI
14:48:43 <edmondsw> esberglu, you're up
14:48:51 <esberglu> CI has been pretty consistent lately
14:49:06 <esberglu> Even with the updated post stack cleaner and https://review.openstack.org/#/c/540453/
14:49:28 <esberglu> I'm still seeing that vopt issue on occaison on OOT runs
14:49:54 <esberglu> I have some time cut out tomorrow to hop back into that
14:50:01 <efried> Did we try to reinstate the rename patch and see if that kills it?
14:50:14 <esberglu> Yeah the rename patch is being applied to all OOT runs
14:50:22 <edmondsw> I think that's the link above
14:50:24 <efried> Okay, so even with that, we're still hitting it?
14:50:28 <esberglu> yep
14:50:37 <efried> oh, sorry, yeah.
14:50:55 <efried> So hm, curiouser and curiouser.  Good luck with that.
14:51:01 <edmondsw> interesting that we're still seeing it with that
14:51:50 <esberglu> Still working the CI undercloud upgrade, decided to jump from ocata to queens instead of ocata to pike
14:52:08 <esberglu> I have a working queens cloud, but the management services aren't playing nice with it
14:52:35 <esberglu> Because we are on old versions of those that are having some issues with the identity v3 api
14:52:45 <edmondsw> what?
14:53:09 <esberglu> The version of nodepool we are on doesn't work with the new identity api
14:53:16 <esberglu> And needs to be upgraded as well
14:53:23 <edmondsw> that gonna be a problem?
14:53:53 <esberglu> edmondsw: It will also mean updating zuul and jenkins and adding a zookeeper service and maybe some other stuff
14:53:57 <edmondsw> maybe that's a good thing... it'll be nice to be more current on everything
14:54:09 <edmondsw> more work though
14:54:21 <esberglu> edmondsw: I'm trying a queens deploy using identity v2 api for now
14:54:42 <esberglu> Just to verify that queens works otherwise
14:54:56 <edmondsw> huh... I thought v2 was removed in queens
14:55:37 <esberglu> Oh maybe, I thought I saw it in there, could have been looking at the wrong thing
14:56:10 <edmondsw> I wasn't very involved with keystone during queens, though, so I could have gotten that wrong
14:56:17 <esberglu> But yeah, still just trying to get something working there, I'll keep you posted on progress
14:56:22 <edmondsw> tx
14:56:24 <edmondsw> anything else?
14:56:53 <esberglu> I'm starting to look forward into the multinode CI / OVS CI
14:57:02 <edmondsw> +1
14:57:11 <esberglu> Nothing to talk about there yet though
14:58:16 <edmondsw> #topic Open Discussion
14:58:30 <edmondsw> I wanted to note a couple things with the PowerStackers group
14:58:58 <edmondsw> tonyb has proposed renaming to PowerVMStackers, making it PowerVM specific again like my original proposal
14:59:07 <edmondsw> https://review.openstack.org/#/c/551413
14:59:36 <edmondsw> I replied to that this morning
14:59:48 <edmondsw> I suspect it will get renamed, and I'm not sure I disagree with that
15:00:17 <efried> I'm writing up a concurring opinion atm
15:00:30 <edmondsw> he also raised an objection on the meeting proposal: https://review.openstack.org/#/c/552132
15:00:42 <edmondsw> I replied to that as well seeking some clarification
15:01:21 <edmondsw> it sounded like he might be saying we should just meet in our channel because the official meeting channels are being deemphasized? but I'm not sure I got that right
15:01:35 <edmondsw> so we'll see where that goes
15:01:45 <edmondsw> anything else to discuss?
15:02:07 <esberglu> nope
15:02:46 <edmondsw> #endmeeting