23:29:57 <sarob> #startmeeting product-team
23:29:57 <barrett1> There's lots of info in the etherpad that could be a start and then add in the details for the remaining projects
23:29:57 <dttocs> Please do.
23:29:58 <openstack> Meeting started Wed Feb 18 23:29:57 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:29:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:30:02 <openstack> The meeting name has been set to 'product_team'
23:30:42 <sarob> agenda
23:30:46 <sarob> #link https://wiki.openstack.org/wiki/Meetings/product-team
23:31:00 * sarob bad
23:31:02 <dttocs> First proposed agenda topic was socialization tracked at  https://etherpad.openstack.org/p/kilo-product-management-socialization if people don't have it handy
23:31:24 <mscohen> we are making some progress on this front
23:32:00 <mscohen> also have a talk submitted for it for the summit
23:32:08 <sarob> mscohen: i saw that
23:32:29 <sarob> mscohen: so how should we communicate what you have learned?
23:32:44 <dttocs> I don't think we should be presenting this at the summit as a "roadmap" although that's what we've currently called the session https://www.openstack.org/vote-vancouver//Presentation/whats-next-in-openstack-a-glimpse-at-the-roadmap
23:33:05 <mscohen> i can tweak the name.  what do you suggest?
23:33:16 <mscohen> at least i think i still can
23:33:44 <geoffarnold> More about "developing a roadmap"
23:33:54 <geoffarnold> Don't want to claim it's done
23:34:02 <sarob> you could leave the name but
23:34:26 <sarob> report back on what the ptls have given you as the "roadmap"
23:34:53 <mscohen> could also say its a glimpse at “what’s coming next”
23:35:01 <mscohen> or remove word roadmap
23:35:55 <dttocs> I think it's fine for the voting, we can tweak it later based on what we produce.  The text is great.
23:36:22 <mscohen> ok.  i’m not married to any of that at all.
23:36:29 <geoffarnold> +1
23:37:04 <dttocs> I think we should consolidate what we have (or will have over then next week) and share it back with the PTLs so they can see what their peers are sharing
23:37:22 <barrett1> +1
23:37:34 <sarob> i like that
23:38:27 <mscohen> yeah, it makes sense.  should make sure we have enough real material here as well.
23:39:22 <mscohen> i’m willing to be the defacto one to take the first cut unless someone else from teh group wants to.  I’d be MORE than happy to let someone else take the lead.
23:40:09 <dttocs> I'm happy to work on first cut as well, although ideally I'd like to see a few more responses.
23:40:26 <sarob> mscohen: i think its you my friend
23:40:37 <dttocs> @narennh you've reached out to your targets, do you have responses you can share in the Etherpad?
23:40:51 <mscohen> k. i will do it.
23:42:01 <sarob> i like the talk abstract
23:42:28 <dttocs> I'm happy to work with you on it if you wish Mike
23:43:33 <mscohen> great
23:43:55 <sarob> should i go next?
23:44:12 <geoffarnold> sure
23:44:17 <dttocs> +1
23:44:55 <sarob> i have been discussing the "process" with many different types of people
23:45:07 <narenhn> dttocs: i will document keystone today
23:45:15 <narenhn> no response from Mike for Cinder
23:45:56 <narenhn> any ideas on how to reach out to the PTL for a response would be helpful
23:45:58 <sarob> #action mscohen dttocs will take a first cut at explaining the PTL gathered information
23:46:43 <dttocs> narenhn: I had some success ambushing the PTL on IRC - more effective than email.  Or join their weekly meeting and ask afterwards
23:47:02 <clarkb> narenhn: ya just ping thingee
23:47:09 <narenhn> dttocs: got it.. will do
23:47:47 <dttocs> sarob: back to "the process" now?
23:48:06 <geoffarnold> BTW, Shamail is on vacation this week; just sent his apologies
23:48:18 <sarob> there is broad acceptance of the product team filling the gap
23:48:45 <sarob> the board is getting interested in the gap working groups
23:49:25 <sarob> i havent updated the process flow since the meeting
23:49:41 <sarob> i need to create a gdraw and post to the wiki
23:50:01 <sarob> #action sarob update product team roadmap workflow and post to wiki
23:50:31 <shamail> Hi all, sorry for being late.  I am on vacation and forgot about this invite.
23:50:37 <sarob> the board will be discussing
23:50:49 <sarob> shamail:np
23:51:00 * sarob was late too :(
23:51:12 <sarob> at the next meeting
23:51:33 <dttocs> sarob: when you say "the board is getting interested in the gap working groups" do you mean the gap between WGs and projects/PTLs?
23:51:39 <sarob> where openstack fits into the software defined space over the next few years
23:52:06 <sarob> dttocs: interested in that, they want to understand and support
23:53:13 <sarob> as the board starts to talk about that, it will allow the roadmap to have some definition
23:53:30 <sarob> fits and gaps for the strategic direction of the foundation
23:54:32 <sarob> i still see the process as user stories from win the enterprise and others
23:54:52 <sarob> turn into features
23:54:57 <geoffarnold> That's one source
23:54:57 <shamail> Sarob: does this mean that the board will be more involved in the activities of WGs?  Or are they setting the long-term definition and looking for others to determine the necessary steps/changes to align with it?
23:55:44 <sarob> shamail: working groups are by definition not committees so not part of the board
23:55:56 <sarob> shamail: but as the board
23:56:10 <geoffarnold> Or will the board simply encourage WGs to channel their inputs through PM?
23:56:19 <sarob> shamail: is responsible for governace and strategy
23:57:26 <sarob> geoffarnold: much like the board will want to encourage support of various working groups that move openstack forward
23:57:55 <sarob> geoffarnold: but decision making for the working groups doesnt come from the board
23:58:14 <sarob> geoffarnold: board members can still support working groups with time and people though
23:58:38 <shamail> Thanks Sarob.  I was confused because at the mid cycle we chose to collaborate with PTLs + TC and not interact with BoD since they would not be involved in the definition of the roadmap.  I am trying to understand whether your statement has any impact on BoD inclusion in the "cross project solicitation" of the PM readout.
23:59:21 <sarob> shamail: whats "BoD inclusion in the "cross project solicitation" of the PM readout" mean?
00:00:17 <shamail> Do we communicate the feedback from PTLs, and resulting themes, to the BoD directly or do we still communicate with TC and expect them to discuss with BoD (as needed)
00:01:02 <sarob> the later
00:01:08 <shamail> If the BoD is interested in the long-term roadmap then should they be involved directly in the confirmation/communication phase?
00:01:15 <shamail> Got it.  Thanks.
00:01:21 <sarob> the TC owns the technical directin
00:01:34 <sarob> board owns governance and strategy
00:01:57 <sarob> they intertwine at defcore/refstack
00:02:09 <shamail> Makes sense.
00:02:32 <sarob> and the likely where openstack will be in 5 years
00:02:46 <sarob> discussion
00:03:25 <sarob> if openstack isnt likely to make spaceships or electric cars
00:04:01 <sarob> then we should lower the marslander project requirements on the roadmap
00:04:11 <shamail> :))
00:04:33 <sarob> but the marslander project can continue to do their thing
00:04:46 <sarob> openstack on mars
00:04:54 <sarob> its a thing
00:05:15 <sarob> how many people do we still have
00:05:26 <sarob> ?
00:05:28 <shamail> I'm here.
00:05:29 <jrhort> +1
00:05:33 <dttocs> +1
00:05:38 <rolandchan> +1
00:05:54 <sarob> \o/
00:06:24 <sarob> next topic ?
00:06:42 <sarob> news on implement options with the cross project repo
00:06:53 <sarob> implementation options that is
00:07:56 <sarob> geoffarnold?
00:08:05 <sarob> missed him
00:08:13 <geoffarnold_> sorry, i was deferring to shamail
00:08:23 <geoffarnold_> and had a VPN glitchg
00:08:26 <sarob> geoffarnold_ no prob
00:08:29 <shamail> Go ahead geoffarnold_ I think your closer to the topic
00:08:50 <geoffarnold_> we have shamail's submission for the Summit
00:09:04 <sarob> post it
00:09:10 <geoffarnold_> and for me the next big thing will be Philadelphia
00:09:34 <geoffarnold_> since I expect operators to be a big source of cross-project issues
00:09:47 <geoffarnold_> HMT, Ceilometer, Cells, etc.
00:10:13 <shamail> From a xproj comm. perspective, we are trying to meet to discuss path forward.  I will resend an email to ask for an ideal time to meet up.  I have not had a chance to follow up with Geoff or Rocky on the cross project repo.
00:10:25 <geoffarnold_> I'd like to come away from that with a couple of decent representative initiatives
00:10:26 <shamail> Sorry; delayed connection. :(
00:11:16 <geoffarnold_> That's where we are right now
00:11:55 <geoffarnold_> I'm also expecting some useful feedback from the ongoing TripleO meetup in Seattle
00:12:37 <sarob> so we wil gather information at the operator summit
00:13:25 * geoffarnold_ has to drop for another call
00:14:26 <shamail> See ya geoffarnold_
00:14:48 <shamail> How many ppl are confirmed for ops summit and do we have time on the final agenda?
00:14:51 <sarob> im interested in ideas on how to operationalize
00:15:18 <sarob> shamail: 100+
00:15:44 <shamail> I think we have to tabulate the feedback from PTLs first and then determine how we move forward.  Agree?
00:15:51 <shamail> sarob: Nice
00:17:42 <sarob> Devananda
00:17:56 <sarob> had some ideas on how we could
00:18:14 <sarob> create specs or storyboard stories
00:18:25 <shamail> Yeah, I agree.
00:18:28 <sarob> any thoughts on that?
00:18:57 <shamail> We also need a new vehicle though, which will allow us to communicate the status/priorities/stories with the end users directly
00:19:22 <shamail> One aspect is that we have to document the specs/stories and the other aspect is being transparent and making them available
00:19:39 <sarob> #action team needs to figure out ideas on multi-release operations
00:20:15 <sarob> we would need to take in many user stories
00:20:34 <sarob> have the win the enterprise team organize them
00:21:12 <sarob> work with the PTLs and product team to prioritze features and assign them to milestones and releases
00:21:15 <jrhort> Do we have a set of personas to work on the stories?
00:21:22 <shamail> It would be great to take the feedback from PTLs and generate user stories.  Would that be us or WTE?
00:21:51 <sarob> we need to delagate user stories through another group i think
00:22:08 <sarob> wte is already doing that
00:22:15 <sarob> so it fits
00:22:49 <sarob> jrhort: id like wte to work with dneary on personas
00:22:58 <shamail> +1
00:23:14 <sarob> add personas as an attribute of user stories
00:23:45 <sarob> #action put the dneary personas together with WTE
00:24:34 <shamail> I have to leave.  I'll check log afterwards.  Have a great one!
00:24:38 <sarob> anything more
00:24:42 <sarob> im done too
00:24:57 <shamail> Alright, cya.
00:25:09 <rolandchan> no, I'm fully informed now. Thank you.
00:25:19 <sarob> excellent
00:25:24 <sarob> cheers people
00:25:30 <sarob> until next time
00:25:37 <sarob> when i will be on time
00:25:46 <sarob> #endmeeting