23:00:05 <sarob> #startmeeting product-team
23:00:06 <openstack> Meeting started Wed Mar  4 23:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:00:09 <openstack> The meeting name has been set to 'product_team'
23:00:15 <sarob> roll call
23:00:43 <rolandchan> Roland Chan, Aptira
23:00:54 <mscohen> mikec
23:01:03 <NarenNarendra> Naren Narendra
23:01:06 <sarob> morning rolandchan
23:01:12 <NarenNarendra> hey guys
23:01:13 <sarob> afternoon
23:01:32 <sarob> \o/
23:01:45 <Rockyg> o/
23:02:00 <sarob> ello ello
23:02:16 <sarob> carol, shamail?
23:02:47 <sarob> imad, russellb, anyone else
23:02:56 <barrett> Carol's here
23:03:27 <sarob> agenda
23:03:30 <sarob> #link https://wiki.openstack.org/wiki/Meetings/product-team#Agenda.2C_04_March_2015
23:03:42 <sarob> first up
23:04:03 <sarob> we held a f2f openstack board meeting yesterday
23:04:22 <sarob> our work was much discussed
23:05:00 <Rockyg> yay?
23:05:06 <sarob> our group will be folded in as a working group under the user committee
23:05:13 <sarob> everyone was very postivie
23:05:19 <sarob> positive
23:05:29 <barrett> what does that mean? folded under the user committee?
23:05:32 <sarob> and the tc members present very supportive
23:05:41 <sarob> hey barrett
23:05:50 <sarob> the board wants to show support
23:06:00 <sarob> without setting the direction
23:06:04 <barrett> great!
23:06:05 <NarenNarendra> great sign..
23:06:15 <sarob> agreed
23:06:20 <mscohen> are there other WG under the user committee?
23:06:29 <sarob> i answered a lot of questions about what and why
23:07:17 <sarob> #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee#Working_Groups
23:07:49 <sarob> telco, WTE, application ecosystem, api, log rationalization, etc
23:08:10 <mscohen> ok, so then i guess is good :)
23:08:14 <sarob> these are the horizontial teams
23:08:17 <Rockyg> Kewl.
23:08:28 <sarob> mscohen: very good feedback
23:08:44 <sarob> and this will give us a more visability
23:10:05 <sarob> a ran a breakout group on this
23:10:36 <sarob> with imad, eileen evans, robert esker, and  Mark McLoughlin
23:11:15 <barrett> What was the proposal from the breakout?
23:11:15 <sarob> they want us to target the tokyo summit
23:11:24 <sarob> to go public
23:11:32 <sarob> with a multi-release roadmap
23:11:42 <barrett> Excellent!
23:11:46 <NarenNarendra> great!
23:11:49 <Rockyg> ++
23:12:01 <Shamail> Hi all, that's good news
23:12:04 <sarob> i told the breakout group in detail about what we are working on
23:12:20 <sarob> they liked it all
23:12:53 <sarob> Mark McLoughlin, monty taylor, and russel brant were positive
23:12:56 <NarenNarendra> in the meanwhile, the f/b that we are getting from PTLs is how to co-ordinate cross project comm and secondly, they want help to identify what customers are using and interested to use (features) in each of the project.... how do we tackle that
23:13:07 <sarob> good sign for us working with the TC
23:13:53 <sarob> i may lose you all in about 10-15 minutes
23:13:57 <sarob> landing soon
23:14:16 <sarob> so lets run through the first part of the agenda
23:14:28 <sarob> then you guys can do updates when i drop off
23:14:30 <Shamail> I don't think we are ready for cross project comm... It is definitely a need for us to be successful.
23:14:47 <Shamail> Sounds good sarob
23:14:50 <NarenNarendra> shamail:agree
23:15:09 <sarob> #topic operators midcycle
23:15:33 <sarob> id like to only present what data we have gathered
23:15:43 <sarob> and make a request for the missing data
23:16:01 <sarob> i dont want to jump the gun
23:16:03 <barrett> Gathered from whom? PTLs?
23:16:14 <sarob> barrett right
23:16:30 <NarenNarendra> agree
23:16:37 <sarob> we should present our plans to the TC next
23:16:45 <dttocs> For the data from the PTLs, I'm not convinced we should present that - I'd rather share back with PTLs first.
23:16:46 <barrett> OK - I've taken the info in the etherpad and created a draft roadmap
23:16:57 <NarenNarendra> provides a way for us to nudge the other PTLs to spend some time with us
23:16:58 <sarob> i dont want the TC to think we doing an end run with the operators
23:17:13 <mscohen> we actually got feedback from most PTLs I think
23:17:20 <barrett> Agree we need to share with TC - can we do that via email?
23:17:24 <sarob> gathering data and socializing is working
23:17:33 <sarob> lets play that out
23:17:35 <barrett> We're still missing several projects
23:17:52 <sarob> barrett right
23:17:54 <dttocs> Given we're missing Nova, Cinder, Horizon
23:18:01 <NarenNarendra> FYI - i am getting from cinder hopefully by end of next week
23:18:04 <dttocs> as key projects
23:18:08 <barrett> I took the info from the etherpad and worked with Kenny and Shamail to create a draft roadmap and sent the link to the mail list
23:18:11 <NarenNarendra> *getting data
23:18:23 <dttocs> presenting to Operators early next week feels like an end-run to me.
23:18:31 <Rockyg> Thierry will be at midcycle ops meetup.  We can pitch to him....
23:18:36 <sarob> #action barrett, sarob present data gathered highlights, request missing data at operator midcycle
23:18:44 <sarob> rockyg good idea
23:18:46 <Shamail> Who is attending from this team?
23:18:51 <NarenNarendra> With Kilo deadline of March 5th, we should expect more responsiveness from the PTLs next week
23:18:59 <sarob> true
23:18:59 <Rockyg> I am.  Or at least trying to.
23:19:15 <barrett> I am...also wondering if the weather will be an issue
23:19:18 <sarob> #link https://etherpad.openstack.org/p/PHL-ops-meetup
23:19:32 <NarenNarendra> i am attending
23:19:39 <sarob> the agenda is very full, so we may need to do the thing one on one
23:19:45 <sarob> or in breakout group
23:20:04 <sarob> nevertheless, its an opportunity
23:20:09 <barrett> sarob agree
23:20:10 <sarob> moving on
23:20:17 <sarob> cause im going downnnn
23:20:30 <sarob> #topic integration timeline
23:20:41 <Shamail> We should pitch to ttx but line up to be on agenda for a future TC meeting
23:20:41 <sarob> #link https://wiki.openstack.org/wiki/ProductTeam#Timeline_for_Integration_of_the_Product_team_with_other_teams.3B_PTLs.2C_TC.2C_and_other_User_Committee_working_groups
23:20:54 <sarob> shamail agreed
23:20:54 <Shamail> I'm sure the dialog will be interactive
23:21:21 <sarob> so i started to rough out an implementation plan for this group
23:21:37 <sarob> with tokyo nov2015 as our target
23:21:56 <sarob> TC present before vancouver
23:22:23 <sarob> then we can add in more milestones
23:22:48 <sarob> sound like a plan to come up with the plan?
23:23:06 <rolandchan> yep
23:23:11 <barrett> sarob agree
23:23:12 <Rockyg> yup
23:23:13 <Shamail> Need to agree on process/workflow as well
23:23:17 <Shamail> You have my feedback and I agree with your responses.  Some of my comment are still open in doc
23:23:22 <mscohen> works for me.  just need owners...
23:23:44 <Shamail> We can make plans on mailing list
23:23:48 <sarob> lets keep our subteams plugging away
23:24:09 <sarob> shamail: def socialize our plan of plan on the product ML
23:24:17 <Shamail> Lol
23:24:30 <Shamail> So meta
23:24:52 * sarob hearty laugh
23:25:32 <sarob> if i can jump to roadmap since i will be offline soon
23:25:52 <sarob> #topic roadmap process update
23:26:26 <sarob> #link https://docs.google.com/document/d/13JPDDiBGGXf5dtP0u8C-1So2Mjb3yEmGhv_ijVqyEf0/edit?usp=sharing
23:26:52 <sarob> i threw this together last week
23:26:57 <sarob> rough start
23:27:05 <dttocs> Looks like a good start
23:27:08 <sarob> reuses some ideas from defcore
23:27:21 <Shamail> Oops, I remarked too soon.  My comment about the doc was related to this.
23:28:21 <sarob> the basic idea is we use gerrit for technical community review each step of the process
23:28:41 <sarob> we tie our milestones to the release milestones
23:28:45 <Shamail> DefCore needs to be acknowledged but probably out of band to our work for now.  I also want to make sure we get use-cases from other groups (beyond WTE) as well
23:28:51 <sarob> we only use the same tools as the PTLs
23:29:04 <sarob> shamail def
23:29:05 <Shamail> Sarob: +1
23:29:22 * Shamail apologizes for timing being off... I'm on a phone client.
23:29:30 <sarob> i want our companies to start feeding our product user stories into WTE
23:29:37 <barrett> +1
23:29:46 <Shamail> But what about Telco, API, etc?
23:29:48 <sarob> i am working this team process into vmware
23:30:02 <barrett> Telco WG is good place for Telco User Stories
23:30:05 <Shamail> I know OPNFV is trying to enable their liason to OpenStack
23:30:08 <sarob> of course
23:30:11 <Rockyg> Telco is already gathering user stories
23:30:18 <barrett> Seems like we might want to foster the start of other WGs: HPC, CSP..?
23:30:27 <Shamail> barrett: I agree, I just want to make sure they know we exist as well
23:30:37 <sarob> i meant to say other user committee working groups will feed product team
23:30:53 <sarob> user stories through patching to gerrit
23:31:03 <Shamail> barrett: +1 on asking others to build too
23:31:04 <sarob> voting will be public
23:31:25 <barrett> voting on what?
23:31:30 <Shamail> Would announce ML make sense or the community newsletter?
23:31:46 <sarob> barrett on each step in the roadmap process
23:31:58 <sarob> just like any other openstack project
23:32:26 <Shamail> sarob: +1 but where would they land?  Cross project repo?
23:32:29 <barrett> sarob: not quite seeing how that will work, but am sure it will become clear as we move forward
23:34:29 <Shamail> I wonder if his wifi got shut down
23:34:34 <Shamail> He said he was about to land
23:34:43 <barrett> Think so
23:35:10 <Rockyg> Do we need more on this topic?
23:35:36 <rolandchan> I think we have enough for now. There's a doc to provide feedback if needed.
23:35:36 <Rockyg> If not, we should go to the updates
23:35:39 <barrett> As part of the overall plan, we need to address gathering user stories and identifying gaps
23:35:47 <Shamail> I agree with the concept though (let's see how it works) because working on our process, information collection, etc.  needs to be done using the same methods as other projects and needs to be accessible to all.
23:35:55 <Rockyg> And queue the topic change
23:36:08 <Rockyg> #topic update socialize and gather data group
23:36:22 <Shamail> Thanks Rockyg
23:36:34 <mscohen> so it looks like we want to present something at the operator summit?
23:36:39 <mscohen> on socialization
23:36:43 <Rockyg> Yeah.  it won't turn out as a topic, but it will let readers know.
23:36:51 <Shamail> Yep
23:36:59 <mscohen> i won’t be there but anyone from the group can do it.
23:37:12 <Rockyg> We should at least let the Ops know that we exist and what we are working on and towards
23:37:23 <mscohen> i agree
23:37:38 <mscohen> we could show what we have as WIP.
23:37:39 <barrett> Also think we should ask them for use cases and give them a place and format
23:37:51 <Rockyg> ++ on use cases
23:38:10 <Rockyg> We should have a place they can propose them.
23:38:11 <Shamail> I think the plan would be to show what've we've collected so far and ask for others to respond to help us finish collection.
23:38:15 <barrett> here's some slides that could be a starting point for what we'd share...https://docs.google.com/presentation/d/1396hSpQuOYM-XbLenkY1HzNCwiWsk-uN42eofpTbOUY/edit#slide=id.g637b47041_0378
23:38:31 <mscohen> i also made a spreadsheet of it about a week back https://docs.google.com/spreadsheets/d/1kupS0hXh9aA15dJOs2A8XHbrisvnls94F7thJekT4jk/edit#gid=0
23:38:39 <Shamail> Rockyg: +1 goes hand in hand w/ other topic
23:39:10 <barrett> mscohen - nice!
23:39:21 <Rockyg> Spreadsheet might be the right way to present at the moment.
23:39:32 <mscohen> let me update it again.  i think some new data came in
23:39:34 <Shamail> Ops summit is show current feedback from PTLs, ask others to help, and show where use cases can be submitted?
23:39:42 <Rockyg> It shows data collected but makes no judgements/presents no opinions yet
23:40:04 <mscohen> there are a few things you can show…like data for M is very thin
23:40:06 <Shamail> Bingo.
23:40:08 <Rockyg> So, we need to determine how to collect use cases by Monday, then.
23:40:29 <Shamail> I think that's probably a stretch goal Rockyg
23:40:36 <Shamail> Sharing current feedback would be P0
23:40:43 <Rockyg> shamail: agree;-)
23:40:50 <barrett> Is the call to action for the Operators: Provide Use cases to shape M?
23:41:23 <mscohen> we could do something else simple like create a google form for operators to input use cases.  Get someone to pop it up in front of everyone in one of the sessions
23:41:24 <Rockyg> And maybe adjust priorities on L?
23:41:25 <Shamail> + use-cases for "verticals" to respective group (WTE, Telco, etc)
23:41:46 <rolandchan> +1 for semi-structured data.
23:41:53 <rolandchan> and the google form.
23:42:06 <barrett> +1 on structure and form
23:42:08 <Shamail> I think we shouldn't ask ops for that yet Rockyg.  It might be seen as going to end run again.
23:42:21 <Rockyg> And a good example use case or two?
23:42:43 <Shamail> We should just ask for submissions, prioritization can't be done until we have spoke with TC.
23:42:44 <Rockyg> k.
23:43:06 <barrett> Shamail: If we ask for Use cases and their view on gaps, I think we're OK. We have this dialog periodically with Operators (like San Antonio in August)
23:43:18 <Shamail> My guess would be they (and PTLs) will own prioritization initially (IMHO only)
23:43:20 <Rockyg> Well, we could report back what the ops think are fires....
23:43:34 <Rockyg> As part of the preso to them.
23:43:35 <Shamail> Agreed Barrett.  I was referring to prioritization
23:43:49 <Shamail> True.
23:44:27 <Shamail> We just have to be careful to make sure people understand we are collecting feedback (including importance) but not actually taking action on that data yet
23:44:40 <barrett> Shamail: Agree
23:44:48 <Rockyg> So, socialize and gather data active at meetup.  Provide info on what we are doing and gather hot topics from Ops
23:45:10 <Shamail> Rockyg: +1 AND CORNER TTX
23:45:15 <Shamail> :-)
23:45:22 <Rockyg> Aye, aye!
23:45:25 <barrett> From reading the PTL answers to "what can Product WG do to help" seems like providing feedback and helping to prioritize is what some want
23:45:53 <Shamail> Agreed, but we want TC to weigh in first before we help with that
23:46:48 <barrett> So can we use the info from the Operators next week, along with the form that we come up with to capture it, in the conversation with the TC?
23:46:51 <Rockyg> Just an FYI, I think TC would *love* if we could provide some data on gap analysis
23:46:53 <Shamail> We can help, for now, by collecting importance from ops, our companies, and customers
23:47:07 <Rockyg> not immediately, but work with them to see what they need.
23:47:23 <Shamail> I would think so and agree rockyg
23:47:29 <Rockyg> Shamail:  ++
23:48:07 <Shamail> By the way, NarenNarendra mentioned cinder by end of week
23:48:15 <Rockyg> Enough on S&G?  Next up wourd be roadmap process update
23:48:24 <barrett> Do we have a volunteer to draft the feedback form?
23:48:26 <Shamail> Any updates on other missing ones?  Can anyone from the team help?
23:48:50 <dttocs> I'm still working on Ironic - hopefully soon.
23:48:50 <mscohen> if naren has trouble with cinder, i can def help there
23:49:01 <Shamail> Sorry again, phone is delayed :(
23:49:02 <Rockyg> If we don't get the form before, those of us at the meetup can throw something together there....
23:49:14 <barrett> What about Nova input?
23:49:35 <mscohen> nova is a big gap.  Steve had said he’d do that it looks like
23:50:02 <Rockyg> That's Mikal Still, John Garbutt, Joe Gordon.  We'll need to clear what we get from last two with Mikal
23:50:10 <dttocs> Also for Infra and Release cycle, I don't think Stefano asked the "what are your current priorities" questions.  If no one else has done so I'll follow up with him.
23:50:36 <Shamail> We shouls put some milestone around collection so we know when to start asking for help.
23:50:41 <Shamail> Should*
23:51:52 <Shamail> I'm sorry everyone.  I have to drop off as well.  I have to start driving.
23:52:08 <Rockyg> #topic update product roadmap process
23:52:16 <Rockyg> Do we have anything on that?
23:52:28 <Shamail> Good luck at the ops summit!!!  I will see you next time.
23:52:33 <Rockyg> We've got spreadsheet:
23:53:07 <Rockyg> We've got spreadsheet:#link https://docs.google.com/spreadsheets/d/1kupS0hXh9aA15dJOs2A8XHbrisvnls94F7thJekT4jk/edit#gid=0
23:53:29 <rolandchan> sarob put up a doc earlier for comment.
23:53:35 <Rockyg> and first draft preso:
23:53:46 <Rockyg> #link https://docs.google.com/presentation/d/1396hSpQuOYM-XbLenkY1HzNCwiWsk-uN42eofpTbOUY/edit#slide=id.g637b47041_0141
23:54:43 <Rockyg> and the process doc from sarob:
23:55:04 <Rockyg> #link https://docs.google.com/document/d/13JPDDiBGGXf5dtP0u8C-1So2Mjb3yEmGhv_ijVqyEf0/
23:55:40 <Rockyg> So, got that rolandchan....
23:56:22 <Rockyg> If we just want to note those docs, that could be enough for the update and we could move to open discussion for 4 minutes
23:56:36 <barrett> Sounds good
23:56:37 <Rockyg> #topic open discussion
23:57:16 <Rockyg> Anything?
23:57:47 <barrett> I think it would be valuable to create a timeline for deliverables to guide our actions
23:57:58 <barrett> don't see that in the doc that sarob started
23:58:30 <rolandchan> There's a small timeline on the wiki page.
23:58:54 <rolandchan> I think we have a plan to flesh out the plan.
23:59:06 <Rockyg> rolandchan:  ++
23:59:33 <barrett> Do you think we should try to setup a F2F session on some of this to move it forward?
00:00:07 <barrett> got to run to my next meeting...
00:00:14 <Rockyg> Let's put that on the next agenda?  That will also include reports from the Ops meetup
00:00:31 <Rockyg> And, it's a wrap.  I might not be able to end this.  Lemme try.
00:00:34 <Rockyg> #endmeeting