23:04:31 <sarob> #startmeeting product-team
23:04:31 <Shamail> Sure. I was going to wait until 4:05P
23:04:31 <openstack> Meeting started Wed May 27 23:04:31 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:04:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:04:35 <openstack> The meeting name has been set to 'product_team'
23:04:47 <sarob> Just on the wire :)
23:04:52 <sarob> Under
23:05:01 <Shamail> Indeed
23:05:06 <Shamail> Before we begin
23:05:30 <sarob> #topic summit feedback
23:05:33 <Shamail> I'd like to extend a warm welcome to all of the new people that have joined IRC today.  It was great to see you participate last week and join the bi-weekly meeting
23:05:53 <sarob> \o/
23:06:06 <Rockyg> ++
23:06:08 <Shamail> hi barrett
23:06:19 <barrett> Hi Shamail - Sorry I'm late!
23:06:26 <barrett> Who else is on?
23:06:30 <Shamail> Please continue to be active on IRC and ML!  We need as much help as we can get.
23:06:38 <Shamail> Sorry to derail sarob... let's proceedd
23:06:42 <Shamail> NP barrett
23:06:58 <Rockyg> We all are!!!
23:07:07 <Shamail> barrett: The usual suspects + a lot more :)
23:07:16 <barrett> Excellent!
23:07:48 <barrett> Where are we in the agenda?
23:08:00 <Shamail> The first item
23:08:01 <sarob> Just started
23:08:44 <sarob> Summit recap
23:08:55 <barrett> Can everyone access the summary in the Google folder?
23:09:00 <barrett> #link https://drive.google.com/folderview?id=0BxtM4AiszlEyfkJOeEFGaVEwZVk2ZHU5NHR6My1idmVLcEd0aXc1Vy1jVzhvb0tvWm9QV1U&usp=sharing
23:09:06 <cloudrancher> I'm good
23:09:30 <Shamail> I can.
23:09:32 <MeganR> I can
23:09:47 <geoffarnold> o/
23:09:59 <bear_field> i can
23:10:14 <barrett> Is there anyone on the meeting who wasn't at the Summit?
23:11:43 <barrett> Any questions on the Sessions or Feedback we got on Roadmap or Process?
23:13:12 <sarob> good progress from everyone i spoke with
23:13:16 <sarob> very positive
23:13:36 <Shamail> The response seemed very positive to the concept but also a lot of "let's see the details" type comments.
23:13:52 <jimhaselmaier> I thought the roadmap views were OUTSTANDING
23:14:01 <barrett> ++
23:14:08 <Rockyg> but also a lot of "where has this group been the last 4 years"
23:14:09 <jimhaselmaier> And I heard good feedback from others on them.
23:14:41 <Shamail> everyone should pat themselves on the back and then get back to work >:]
23:14:57 <sarob> i thought i was working :(
23:14:59 <Rockyg> Also, a lot of people are looking to address gaps through product wg use cases then populating the developers to address them
23:15:10 <barrett> My take-away was people want us to help consolidate input to the technical planning work; but want us to align with the current processes and timing is important.
23:15:30 <Rockyg> sarob - a small voice in the wilderness often goes unheard by the masses
23:15:31 <barrett> RockyG: +1
23:15:38 <sarob> peep
23:15:43 <cloudrancher> The feedback seemed good, but I sensed a bit of concern from some people that the product team might be trying to usurp some PTL power
23:15:46 <barrett> RockyG: I got that message consistently from PTLs
23:15:51 <Shamail> barrett: +1, I think changes can be made but we should make them/ask for them unless absolutely necessary
23:16:02 <Shamail> should not*
23:16:09 <geoffarnold> The Users Group committee meeting was interesting. Small turnout. Interested in Product WG, but lots of "so what should I do net?"
23:16:21 <geoffarnold> next
23:16:28 <cloudrancher> The cross product coordination seemed to be a really useful service
23:17:00 <barrett> Geoffarnold: I think we've got a work plan to set that out, but probably need to add a few things to make sure we cover all interested parties
23:17:01 <cloudrancher> from the product team to the project teams
23:17:06 <sarob> i think at this point, actions will decide for the ptls if we are help or hindrance
23:17:32 <Shamail> sarob: +1
23:17:32 <barrett> Cloudrancher: +1; Think there is also the desire from project team to project team
23:17:35 <geoffarnold> I think we should make sure that our company reps on the Users Group are plugged in. (Unless that's us.)
23:17:37 <cloudrancher> right - that's why I brought up the cross product thing - seems to be underserverd
23:17:38 <sarob> we have a pretty good idea on how to move forward
23:17:42 <barrett> sarob +1
23:17:46 <cloudrancher> ok. great
23:17:48 <sarob> cloudrancher: +1
23:17:48 <Rockyg> also, there is a *great* need for a cloud service provider wg to address their needs
23:17:57 <cloudrancher> you guys know the personalities
23:18:18 <barrett> RockyG: Is there someone who you think will champion this?
23:18:58 <Rockyg> I know a couple of people, I think.  I think we can get HP, Rackspace, likely DreamHost and a few others onboard.
23:19:20 <barrett> RockyG: Are you working on that?
23:19:39 <Rockyg> sure.  I'll take that up.
23:19:52 <jimhaselmaier> When we say "Cross project coordination" - is there a specific example we use to get an idea what that is?
23:19:53 <sarob> i can help with the dh person
23:20:03 <Rockyg> Once started, it will power itself
23:20:14 <sarob> jimhaselmaier: there is a cross project team
23:20:16 <Rockyg> thanks, sarob
23:20:25 <Rockyg> That's one I didn't have
23:20:39 <Rockyg> Got one in India, too.
23:20:42 <sarob> jimhaselmaier: https://wiki.openstack.org/wiki/CrossProjectLiaisons
23:20:46 <Shamail> #link https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
23:21:15 <sarob> they meet once a week
23:21:16 <barrett> Jimhaselmaier: The example I heard was that when there is a cross project capability, like Versioned Object,it would be useful to for Projects to know the status of Oslo, since it's a gate for other projects to implement
23:21:19 <sarob> mostly ptls
23:21:43 <cloudrancher> jimhaselmaier - the example I heard was on the shared volume capability that Cinder did most of the work but the Nova work fell out of Kilo
23:21:53 <jimhaselmaier> OK.  Thx.
23:22:02 <cloudrancher> more of a visibility issue is seemed
23:22:05 <barrett> Jimhasselmaier: And if Oslo is trending behind, then the other projects can prioritize other features/bugs/etc higher to make an impact in the release.
23:22:25 <barrett> cloundrancher: +1
23:22:26 <Shamail> I think some of the next steps we will discuss will change the meaning of cross project work for us, but that part of the agenda is yet to come.
23:22:37 <cloudrancher> Thx
23:22:52 <Shamail> overall, there is a group responsible for cross project work but a lot of it is focused on functionality and not cross project use-cases.
23:23:00 <barrett> Speaking of which, are we ready to move on?
23:23:07 <Shamail> I believe so.
23:23:23 <sarob> yup
23:23:25 <Rockyg> Shamail: ++
23:23:28 <barrett> #topic Work Plan Review
23:24:16 <sarob> #topic Work Plan Review
23:24:24 <sarob> i can take a hint
23:24:26 <Shamail> :D
23:24:28 <barrett> :)
23:24:45 <sarob> somebody borked the root meeting page
23:25:05 <sarob> trying to find the meeting page
23:25:12 <barrett> https://wiki.openstack.org/wiki/Meetings/product-team#Team_Meeting_27_May_2015
23:25:16 <Shamail> https://wiki.openstack.org/wiki/Meetings/product-team
23:25:27 <Shamail> It worked for me
23:25:43 <Gavin_Pratt_HP> me too :)
23:25:44 <sarob> got
23:25:45 <sarob> it
23:26:06 <barrett> I think we want to walk through the Action Plan and talk about the use case selection approach for this cycle - walk before we run
23:26:13 <sarob> #link https://etherpad.openstack.org/p/ProductWG_TokyoActionPlan
23:26:16 <sarob> action plan
23:26:27 <Shamail> barrett: shall we give some context about overall direction between L and M?
23:26:41 <jimhaselmaier> +1
23:26:47 <sarob> i have no sockets :(
23:26:48 <jimhaselmaier> That would help
23:26:53 <barrett> Shamail: Pls go ahead
23:26:56 <Shamail> thx.
23:27:02 <sarob> go for it
23:27:21 <Shamail> So, as everyone knows, after our midcycle we decided to focus on athering PTL feedback and eventually presenting it in the form of a roadmap
23:27:47 <Shamail> the form we presented was not the final one but it got our intentions across and, more importantly, let us socialize the concept with the PTLs
23:27:58 <Shamail> this work was essential and helped us gain awareness
23:28:31 <Shamail> however, while that work was focus on aggregating feedback... most of the community wants to see how the other side of product WG will work
23:28:48 <Shamail> namely, how can we help get requirements (in project, cross project) from WGs to the project teams
23:29:02 <Shamail> Just like we focus on aggregating feedback in our last phase
23:29:38 <Shamail> we believe that doing the other task of collecting requirements and working with project teams to start building a requirements pipeline is the next step needed for our group
23:29:44 <Shamail> to establish some experience with
23:30:17 <Shamail> This is why we are asking for "use case selection", we want to try and send a few requirements/use cases through the top of the funnel to the project teams using a standard workflow
23:30:21 <Shamail> back to you barrett!
23:30:27 <Shamail> (please let us know if you have questions)
23:30:45 <jimhaselmaier> Great summary.....and very clear.
23:31:41 <barrett> The plan is to establish a repo, and ask people across the community to use our template and post their use cases
23:31:47 <bear_field> great overview. thanks Shamail
23:32:01 <geoffarnold> Have we identified a liaison person in each WG that will work with Product? Enterprise is obvious(?), but the others....?
23:32:28 <Rockyg> One of the things we may see (I hope) is that the devs will break out the work into specs and determine short term work that is possible, and what the longer view work would look like
23:32:37 <geoffarnold> Ideally each WG meeting agenda will include a status check on Product interaction
23:32:57 <Rockyg> geoffarnold: ++
23:33:02 <jimhaselmaier> Will there be one repo?  Or one per WG?  Or one per project?  Or something else?
23:33:14 <barrett> GeoffArnold - We didn't establish WG Liasons yet or Project liasons.
23:33:35 <geoffarnold> Project liaisons are probably in the gift of the PTLs
23:33:40 <Rockyg> I would think one repo for use cases that might break down into WG directories
23:33:56 <barrett> We'd like the use cases posted by 6/14 and then will use this meeting on 6/24 to vote and identify the top 5.
23:34:01 <bear_field> Rockyg: +1
23:34:04 <Shamail> barrett: +1
23:34:10 <geoffarnold> The feedback from Nova was interesting - they're moving to a real backlog model that should fit well
23:34:13 <Rockyg> This would allow us to pull cross wg use cases/requirements into either another dir, or the top dir
23:34:40 <jimhaselmaier> Rockyg:  +1
23:34:51 <Shamail> For this specific phase, let's build out the repo to support use-cases from across the WGs... however this is an experiment (to check/refine our workflow) so it will not be an all encompassing run through
23:34:55 <barrett> RockyG: I wonder about separating the use cases - we're hoping that there's a lot of common requirements across them. Is it easier to get people to look across them by having them all in 1 or in separate directories?
23:35:22 <barrett> Shamail: +1, try an approach, learn, evolve
23:35:28 <Shamail> barrett and Rockyg, I would prefer them in one directory but have a tag identifying which group they came from
23:35:35 <geoffarnold> Who owns each use case? Probably a WG, or a WG subteam
23:35:50 <geoffarnold> Domain expertise FTW
23:35:52 <barrett> geoffarnold: I think individuals own Use Cases
23:35:58 <Rockyg> Shamail: , barrett +1 start that way.  Once we get lots, we'll need to further categorize
23:36:00 <Shamail> it is useful data to know which WG submitted it but having them in one directory is useful that way we can just add other groups to the same requirement/use-case
23:36:27 <Shamail> adding a WG to a use-case basically becomes a +1 from them
23:36:27 <barrett> We can add a field in the use case template for the name of the work group and individual
23:36:29 <Rockyg> So, WG might be added to template
23:36:45 <jimhaselmaier> While I massively agree with do it fast to try it and evolve - tags for the source (which WG) as well as impacted projects might be helpful.
23:36:50 <barrett> RockyG: +1
23:37:08 <Rockyg> And if more than one wg has same usecase, they just add that wg to the existing list of wgs in the use case
23:37:15 <Shamail> Rockyg: +1
23:37:27 <jimhaselmaier> Rockyg:  +1
23:37:34 <Rockyg> jimhaselmaier: +1
23:37:36 <bear_field> Rockyg: +1
23:37:41 <barrett> jimhaselmaier: In many cases I don't think the use case author knows all of the projects it impacts. There is a section in the template to capture what they do know
23:38:00 <jimhaselmaier> barrett:  +1
23:38:10 <Shamail> geoffarnold: we might not have liasons for this phase, but we should make sure each WG knows that the window for submitting use-cases is open
23:38:16 <sarob> im not sure i follow the workflow
23:38:17 <Rockyg> Which means, that we should schedule cross wg reviews to capture other possible users
23:38:20 <geoffarnold> +1
23:38:31 <Shamail> Does anyone want to own drafting an email we can use to notify each WG?
23:38:36 <Shamail> sarob: which worklfow comment?
23:38:41 <cloudrancher> Is there a place for versioning use cases to identify past changes and decisions. Sorry I'm not familiar with the options available
23:38:42 <sarob> one dir for all use cases
23:38:47 <sarob> all wg
23:38:53 <geoffarnold> I just want to make sure that each WG is actively thinking "how's our Product pipeline going?"
23:38:59 <barrett> RockyG: Once we get our repo set, I wonder if we should assign people from this group to attend the other WG meetings and give an overview?
23:39:04 <sarob> is that what y'all agreeing to?
23:39:19 <Rockyg> sarob: to start with
23:39:22 <barrett> sarob: yes
23:39:27 <jimhaselmaier> I'm happy to draft an email explaining the process.
23:39:30 <sarob> okay, im good then
23:39:42 <sarob> so my high level idea on tags
23:39:43 <bear_field> barrett: i think that's critical
23:39:48 <jimhaselmaier> (process re:  submitting use cases.......why and how.)
23:39:49 <sarob> would be the same
23:39:56 <Rockyg> sarob:  I heard your voice ring in my head with that "okay" statement
23:40:00 <sarob> one dir with hundreds of use cases
23:40:10 <Shamail> sarob: We were thinking that all use-cases could be in a single directory and the template would contain a "WG:" section... instead of entering a use-case per WG in a separate folder
23:40:15 <barrett> Jimhaselmaier: If you could send a draft to our ML for feedback that would be great!
23:40:24 <Shamail> sarob: this way we can just add multiple WGs to the same use-case if they have a common interest
23:40:36 <sarob> Shamail: ah, right
23:40:38 <Shamail> jimhaselmaier: thanks! look forward to the draft
23:40:40 <sarob> got it
23:40:54 <sarob> good starting point
23:40:59 <barrett> Sarob: Having watched the use case development prococess on WTE and Telco WG, I think that would be a great problem to have...though unlikely
23:41:03 <jimhaselmaier> barret:  I most definitely can.  However I think we need the repo set up and finalized how we want people to use it.
23:41:14 <Shamail> jimhaselmaier: +1
23:41:26 <bear_field> jimhaselmaier: +1
23:41:29 <barrett> jimhaselmaier: +1
23:41:39 <Rockyg> +1
23:41:43 <Shamail> Rockyg and sarob, I think you own getting the repo created.
23:41:45 <Shamail> No pressue.
23:41:47 <Shamail> pressure*
23:41:48 <Shamail> :)
23:42:08 <Rockyg> So, how does a wg or person get to the merge point with a use case?
23:42:09 <barrett> RockyG and Sarob are driving the repo setup and template validation for reviewing and comments
23:42:10 <sarob> Rockyg: lets confer right after this meeting for 5
23:42:30 <Rockyg> sarob: will do
23:42:35 <barrett> RockyG: Don't understand your question
23:43:16 <Rockyg> user submits usecase for review.  It needs comments to flesh out, then somehow it gets merged and voila!  It appears in the git repository
23:43:34 <sarob> barrett: we will need a few people to have core reviewer rights
23:43:42 <Rockyg> It won't appear until merged, which means  +2s and +workflow
23:43:50 <sarob> barrett: we need to set the standard to when the use case gets merged
23:43:56 <Shamail> barrett: yeah, but is the repo our own or will we be sharing with cross project?
23:44:09 <sarob> Shamail: sharing
23:44:15 <Shamail> sarob: you were going to build the tox tests too right?
23:44:23 <sarob> thats part of use creating the dir
23:44:27 <sarob> Shamail: right
23:44:42 <barrett> RockyG/Sarob: Can you work this out as part of your action item or do you need more discussion or help?
23:45:12 <Shamail> barrett: +1, let's come up with a plan and share it via ML.
23:45:22 <sarob> Shamail: good plan
23:45:33 <Rockyg> lots of it, yeah.  We can circle back next week for acl stuff if it's not answered
23:45:47 <barrett> I/m concerned that creating Core Reviewers could be an issue and delay
23:46:06 <barrett> RockyG: +1
23:46:13 <sarob> barrett: could be
23:46:32 <Shamail> barrett: +1, but I think we will need them unless the cross project team is fine with +2 and workflow
23:46:34 <Rockyg> We need a dashboard, too, so we can see reviews of usecases in flight
23:46:40 <jimhaselmaier> What's the goal of approving?  That the use case is understandable?  Or that it's important enough to work on?  Something else?
23:46:42 <sarob> barrett: if it is a big blocker, then we may need to consider a seperate repo
23:46:51 <Shamail> Rockyg: I think that will be useful but can probably wait past the 6/24 deadline
23:46:52 <jimhaselmaier> I'm asking a bit rhetorically.
23:46:53 <sarob> barrett: id rather not if we can help it
23:46:56 <jimhaselmaier> We just need to be sure.
23:47:14 <Shamail> jimhaselmaier: making sure it is understandable and has the necessary fields populated
23:47:17 <sarob> jimhaselmaier: id like the bar to merge be very low
23:47:23 <geoffarnold> "core reviewers" isd OpenStack culture code for "quality process"
23:47:26 <barrett> So the short term Action Items beyond the repo is the sarob: +1
23:47:29 <Rockyg> jimhaselmaier: turning a draft use case into a more polished one
23:47:39 <Shamail> sarob: +1, but we have to make sure that we don't omit information... there is a line between low bar and missing info
23:47:43 <barrett> Ooops
23:47:48 <sarob> Shamail: right
23:47:56 <bear_field> Shamail: +1 prioritization should be separate from use case merge
23:48:07 <sarob> bear_field: +1
23:48:09 <barrett> bear_field: +1
23:48:10 <jimhaselmaier> bear_field:  +1
23:48:15 <geoffarnold> +1
23:48:25 <Shamail> bear_field: Prioritization is a topic we are deferring for now
23:48:30 <Shamail> for this initial run
23:48:36 <bear_field> understood
23:48:39 <sarob> id like the cores to review if there is extreme use case over lap and if the content is complete
23:48:43 <sarob> thats it
23:48:59 <Shamail> sarob: care to do an #action for you and Rockyg
23:49:22 <sarob> noooo
23:49:26 <Shamail> hahaha
23:49:36 <Rockyg> nooo mr. billllllll!!!!!!!
23:49:44 <sarob> #action sarob, rockyg post product-team repo plan to ML
23:49:59 <Shamail> ty
23:50:16 <Shamail> barrett: we have 10 min left, how do you want to proceed with the remaining time?
23:50:36 <jimhaselmaier> #action jimhaselmaier to draft email and send to ML after repo plan established.
23:50:48 <Shamail> only sarob wields the power :D
23:50:54 <jimhaselmaier> :-)
23:51:07 <bear_field> :)
23:51:33 <Rockyg> mra ha ha!
23:51:41 <Shamail> barrett, are you here?
23:51:46 <barrett> yup
23:52:05 <barrett> Walk through the upcoming Action Items?
23:52:05 <Shamail> What should we cover?  We will run out of time soon.
23:52:10 <Shamail> barrett: +1
23:52:39 <barrett> Internal Communications: Develop Terminology, backgrounder and updatewiki, Community Socialization Plan (user groups, mid-cycle meet-ups)- Owner Shamail and Hugh
23:52:56 <barrett> Due 6/10
23:53:25 <barrett> We talked about the repo: That's owned by Rocky and Sean due 6/10
23:53:55 * sarob crushing pressure
23:54:07 <barrett> Recruit new members: Goal is to have 80% of theOpenStack contributions represented in this team. IBM, VMWare, SUSE - Owners: Shamail and Carol - due 6/14
23:54:08 <Shamail> lol
23:54:21 <barrett> Shamail: We should talk about our plan for this one
23:54:30 <Shamail> barrett: +1
23:54:34 <Shamail> i'll email you
23:54:43 <barrett> Shamail: Thanks
23:54:59 <Rockyg> rackspace?  barrett:  talk to Van about someone from there.
23:55:11 <Shamail> Hugh is from Rackspace
23:55:15 <barrett> RockyG: Good point!
23:55:33 <Rockyg> Shamail: oh, good!
23:55:41 <geoffarnold> barrett: +1 - and add Red Hat, Mirantis, if 80% is the target
23:55:52 <barrett> Shamail: Even better point: :-)
23:56:00 <sarob> 5 mins
23:56:23 <barrett> Everyone has the action to create and post their use cases between 6/10 - 6/14. Even though the repo is WIP, we can all start working on this now.
23:56:40 <barrett> Think that's the upcoming Action Items
23:56:58 <bear_field> where can we review use cases until repo is ready?
23:56:59 <Shamail> PS: If any of these action items are interesting to you.  Please chime in... anyone can help with any items that feel strongly about
23:57:12 <Shamail> that they*
23:57:26 <barrett> We can put them in the google directory here: https://drive.google.com/folderview?id=0BxtM4AiszlEyfllFelZYR2RqNDFfWVRvWWtlb09laGxwR2ljc3UxVEl5VEpfMEhicnlxUFk&usp=sharing&tid=0BxtM4AiszlEyfkJOeEFGaVEwZVk2ZHU5NHR6My1idmVLcEd0aXc1Vy1jVzhvb0tvWm9QV1U
23:57:34 <bear_field> thumbusp
23:57:45 <barrett> Same area where I posted the rest of the info for this meeting
23:58:01 <Shamail> Thanks barrett, great summary!  Lots to do... the fun will begin after we have collected use-cases
23:58:15 <barrett> Sarob: Can you #link that?
23:58:29 <sarob> #link https://drive.google.com/folderview?id=0BxtM4AiszlEyfllFelZYR2RqNDFfWVRvWWtlb09laGxwR2ljc3UxVEl5VEpfMEhicnlxUFk&usp=sharing&tid=0BxtM4AiszlEyfkJOeEFGaVEwZVk2ZHU5NHR6My1idmVLcEd0aXc1Vy1jVzhvb0tvWm9QV1U
23:58:46 <Rockyg> cool
23:58:48 <Shamail> Can I make a brief, un-related, but relevant to this audience type of an audience comment?
23:58:53 <barrett> Sarob: Thanks
23:59:04 <barrett> Shamail: go for it
23:59:32 <Shamail> You may have seen the message from Egle regarding DefCore on our mailing list... I think as product management function representatives of our orgs, we should also distribute information internally
23:59:34 <sarob> 1 min
23:59:38 <Shamail> to that extend, please see http://lists.openstack.org/pipermail/product-wg/2015-May/000421.html
23:59:56 <Shamail> share this message inside your orgs so people can become familiar with defcore/interop
00:00:09 <Shamail> We are a bi-directional communication pipeline :)
00:00:22 <Shamail> That was it from me barrett
00:00:23 <sarob> say goodnight rosie
00:00:23 <Rockyg> Yup!  thanks for the heads up!
00:00:27 <barrett> +1
00:00:36 <Rockyg> goodnight, Rosie
00:00:36 <barrett> goodnight rosie
00:00:42 <cloudrancher> Goodnight Rosie
00:00:43 <Shamail> goodnight rosie
00:00:46 <MeganR> goodnight rosie
00:00:49 <sarob> :)
00:00:57 <jimhaselmaier> It appears I'm supposed to say goodnight Rosie
00:00:57 <Shamail> boom. on time.
00:01:01 <sarob> #endmeeting