23:06:32 <barrett1> #startmeeting Product-Team
23:06:33 <openstack> Meeting started Wed Jun 10 23:06:32 2015 UTC and is due to finish in 60 minutes.  The chair is barrett1. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:06:33 <dhellmann> ++
23:06:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:06:36 <openstack> The meeting name has been set to 'product_team'
23:06:47 <barrett1> #topic Action Plan Status and updates
23:06:53 <barrett1> OK -  Item #1: Internal Communications
23:07:03 <barrett1> Owners: Shamail and Hugh
23:07:14 <barrett1> How are things coming on terminology definitions, backgrounder and socialization plan?
23:07:21 <hughhalf> I'm not sure if Shamail is here, we've tried to line up a time to discuss but I've been off sick unfortunately
23:07:36 <hughhalf> we've both done bits independently, but nothing ready for discussion further sorry!
23:07:39 <mscohen> shamail is on vacation.  he said he will not be joining
23:07:42 <barrett1> Shamail is on vacation this week
23:07:50 <hughhalf> Suggest we push due date to next week and we'll pick up then
23:07:57 <barrett1> Will do
23:08:01 <hughhalf> Thanks barrett1
23:08:11 <barrett1> Next up: Repo & Use Case Template
23:08:17 <barrett1> Owners: Rocky and Sean
23:08:24 <barrett1> What have you all learned and what are your thinking?
23:08:51 <barrett1> RockyG - You here?
23:09:01 <barrett1> Sarob - Anything to share?
23:09:45 <barrett1> OK - I'll use the ML to follow-up on that one or the next meeting.
23:09:59 <barrett1> Next up Item #3: Use Case Development & Selection
23:10:10 <barrett1> Owners: All of Us!
23:10:22 <barrett1> Our goal  is to have all use cases that we want to consider for the M-cycle posted by 6/14.
23:10:54 <barrett1> Until we have an OpenStack repo, we are using:
23:11:00 <barrett1> #link: https://drive.google.com/folderview?id=0BxtM4AiszlEyfllFelZYR2RqNDFfWVRvWWtlb09laGxwR2ljc3UxVEl5VEpfMEhicnlxUFk&usp=sharing
23:11:26 <barrett1> We are targeting to consolidate & selecting  top 5 use cases in the 6/24 meeting
23:11:35 <barrett1> How is it going for each of you in developing use cases?
23:11:49 <nateziemann> Nate here, first meeting attending.  I'd like to propose we move out another week on use cases.  I'll review w/ my Product Managers of IBM offerings between now and then.
23:12:03 <barrett1> Hi Nate - Thanks for joining.
23:12:12 <nateziemann> glad to be here !!
23:12:58 <geoffarnold> That would work for me, bc most of the Cisco PMs are tied up at CiscoLive right now
23:13:05 * hughhalf nods
23:13:27 <barrett1> OK - so no issues? Folks on track to 6/14?
23:14:11 <hughhalf> Err, I may have misunderstood but I think the nods etc. were in favour of shifting to 6/24 per nateziemann suggestion ?
23:14:31 <barrett1> Sorry, missed that.
23:14:37 <stephenwalli> That was my understanding too.
23:14:38 <hughhalf> np
23:14:45 <geoffarnold> Ditto
23:14:50 <Zucan> Are we expecting more use cases to be posted?  Or basically, we will be selecting 5 out of the 7 there?
23:14:54 <barrett1> Is the proposal to push the deadline for publishing use cases to 6/24?
23:15:01 <Zucan> 6/24: sounds fine to me
23:15:27 <barrett1> Anyone have an issue with this?
23:15:39 <hughhalf> 6/24 is fine with me
23:15:50 <Gavin_Pratt_HP> 6/24 works for me
23:15:57 <nateziemann> It would be great to gather more use cases and find a couple that really align across multiple companies we can get behind as a workgroup.  6/24 works for me.
23:16:04 <MeganR> Sounds good to me
23:16:12 <barrett1> If not, do we want to push the date for reviewing, consolidating and selecting top 5 to July 8th?
23:17:23 <barrett1> I'll take silence for agreement :)
23:17:35 <barrett1> #agreed Change the due date for Use Cases to 6/24 and meeting for selecting top 5 to 7/8
23:17:47 * hughhalf nods
23:17:52 <barrett1> I'll update our tracker to reflect the changes
23:18:00 <nateziemann> not sure what peoples schedules will be like with July 4th holiday week.  but I say shoot for July 8 and adjust as needed.
23:18:15 <barrett1> nateziemann: +1
23:18:25 <MeganR> I agree
23:18:31 <barrett1> Next Up is  Item #4: Integration and Test Capability
23:18:45 <barrett1> Owner is Me
23:18:55 <barrett1> This is due late July and I’m getting more info to have some thoughts for a team discussion in early July
23:19:08 <barrett1> Stay tuned...
23:19:35 <barrett1> Next  Item is #5: Recruit New Members
23:19:43 <barrett1> Owners: Shamail and I
23:19:52 <barrett1> Here's our status:
23:19:59 <barrett1> IBM: Welcome Nate Ziemann
23:20:07 <nateziemann> :-)
23:20:08 <sarob> im baaaack
23:20:18 <Zucan> I am new too.  Comcast. :)
23:20:24 <MeganR> I would also like to introduce Scott Akins with Comcast
23:20:26 <barrett1> SUSE: Welcome Pete Chadwick  - Couldn't amke this meeting, but used the doodle to indiate what times work.
23:20:26 <MeganR> :)
23:20:36 <barrett1> Welcome All!
23:20:48 <barrett1> VMWare: Shamail is working this one
23:21:03 <stephenwalli> I’m new to this group as well.
23:21:18 <Gavin_Pratt_HP> Welcome Scott
23:21:20 <hughhalf> I should note perhaps this is the first IRC meeting he's been able to attend.  I'm from Rackspace Private Cloud
23:21:26 <stephenwalli> although I do recognize a few folks :)
23:21:28 <Gavin_Pratt_HP> & others :)
23:21:31 * hughhalf was in several sessions at the summit.
23:21:33 <hughhalf> Welcome all :)
23:21:41 <barrett1> NEC: I am working with Shibata-san on this
23:22:01 <barrett1> Last but not least, we wanted to get someone from Yahoo! to join
23:22:15 <barrett1> We need a contact – can anyone help?
23:22:46 <hughhalf> I'll ask around my colleagues, I've an idea we've someone that's had dealings
23:23:00 <barrett1> hughhalf: Thanks!
23:23:08 <barrett1> sarob: Can you help?
23:23:08 <stephenwalli> I’ll ask Gil Yehuda.
23:23:18 <barrett1> stephenwalli: thanks
23:23:46 <sarob> yes
23:24:01 <barrett1> sarob: Thanks
23:24:41 <barrett1> With these additions I think we're close to our goal of having representation from the companies that are responsible for ~80% of the OpenStack contributions!
23:24:52 <hughhalf> \o/
23:24:56 <MeganR> that's great!
23:25:28 <barrett1> Next Up Item #6: Tags
23:25:35 <barrett1> Owner: Sean
23:25:44 <barrett1> This one is due late July. Any update for now Sean?
23:26:31 <barrett1> sarob: you still with us?
23:27:28 <barrett1> Ok, moving on -   Item #7: Plans for Tokyo
23:27:57 <barrett1> Owner: All of us! John Garbutt is interested in helping us too around Nova
23:28:09 <barrett1> This due in September and expect it will be a topic in our mid-cycle meetup
23:28:21 <barrett1> Any comments on this one?
23:28:30 <hughhalf> Please forgive my poor memory, when/where is the mid-cycle ?
23:28:57 <barrett1> hughhalf: Excellent question - we haven't decided that yet, but it's on today's agenda to discuss!
23:29:14 <hughhalf> I can confirm John remains interested in assisting though - we've been discussing how best to contribute and engage with the WG in the office and he's a part of those conversations
23:29:35 <hughhalf> Ah, no probs re mid-cycle, apologies that I missed that
23:29:53 <barrett1> No problem.
23:29:54 <geoffarnold> We should ask the PTLs to put all the proposed midcycle dates in a wiki page or etherpad. scheduling will be challenging
23:30:24 <barrett1> geoffarnold: I've seen mailings from many of the projects on the dev list
23:30:55 <geoffarnold> so have i... just not all of them
23:31:33 <barrett1> Tom Fifeld, Thierry or others - can you comment on plans to create a central list for this?
23:32:25 <hughhalf> ttx ^^^
23:32:43 <barrett1> geoffarnold: Can you follow-up on this. Think it would be appreciated by many!
23:32:59 <geoffarnold> i will do so
23:33:06 * hughhalf notes that for heavy IRC users it's often better to refer to them by their nick as it will trigger an alert in their IRC client where their real name may not
23:33:20 <geoffarnold> Tell the bot to give me an action, please
23:33:27 <barrett1> hughhalf - Thanks for the tip!
23:33:47 <hughhalf> np :)
23:33:52 <barrett1> #action geoffarnold to follow-up on midcycle meetup central calendar
23:34:14 <barrett1> That's it for our action plan review. Any last comments before we go to the next agenda item?
23:35:14 <barrett1> #topic Roadmap Update Next Steps
23:35:26 <barrett1> Mike - can you lead this?
23:35:33 <mscohen> discusion yes
23:35:43 <barrett1> Thanks
23:36:10 <mscohen> there’s a lot of interest in keeping up the roadmap we started in the summit
23:36:24 <mscohen> so we need some volunteers to help with this
23:36:57 <stephenwalli> Is there a link to the roadmap as it is today?
23:37:02 <mscohen> not deciding the roadmap at all…but understanding what the current PTL plans are and trying to make them easily digestible
23:37:10 <mscohen> we only have our previous preso from the summit
23:37:29 <mscohen> Shamail should have a link for it…and we have the video of the session
23:37:33 <MeganR> mscohen: I will be happy to help on the roadmap
23:37:44 <mscohen> ok, great!
23:37:50 * hughhalf will be able to assist with a couple of PTLs he knows too
23:38:13 <barrett1> I'll help too
23:38:17 <hughhalf> May I ask a meta question briefly on the roadmap before we leave the topic ?
23:38:22 <mscohen> is anyone interested in actually running point on this for our group
23:38:57 * hughhalf volunteers Shamail on basis of his absence
23:39:03 <MeganR> +1  :)
23:39:13 <barrett1> hughhalf: +1 :)
23:39:14 <stephenwalli> Remind me to never miss a meeting
23:39:16 <mscohen> well Shamail would be perfect if he wants to do it
23:39:40 <hughhalf> mscohen - jokes aside, we can probably just leave that as a homework question, see if he'd be up to doing it
23:39:57 <hughhalf> I'm happy to assist but don't know I have the depth of expertise yet to be point soley
23:40:07 <mscohen> yes, i can check with him and also start a thread on ML for it.
23:40:19 <hughhalf> Perfect
23:40:25 <mscohen> whoever takes this on will have lots of help.  I’m happy to help too.  Its just a lot to organize
23:40:33 <mscohen> so we need someone to sign up for that.
23:40:45 <barrett1> #action: Mschohen to check with Shamail on leading the Roadmap update process
23:41:59 <barrett1> Do we want to possibly focus on a subset of projects to make this more managable? Like: nova, keystone, glance, horizon, cinder, neutron?
23:42:23 <mscohen> thats not a bad idea
23:42:25 <hughhalf> barrett1Yes, I think that has some merit
23:42:35 <Zucan> Like all the core projects, or a subset?
23:42:36 <hughhalf> focus on the core bits
23:42:40 <stephenwalli> barrett1: +1
23:43:16 <nateziemann> core continues to get expanded.  I like the idea of starting w/ something more managable and when successful, expand it.
23:43:23 <barrett1> hughhalf: that's what I was thinking. We can scale this as we go, but start walking now.
23:43:37 <hughhalf> nateziemann yes fair point
23:43:44 <barrett1> nateziemann: +1
23:43:49 <Zucan> So, we could do "cores from 3 cycles ago" :)
23:43:56 <Zucan> (jk)
23:44:10 <mscohen> i’m liking this idea more and more though.  i think barrett1’s list is pretty reasonable.
23:44:21 <Zucan> +1 on the list above
23:44:30 <Zucan> maybe add ceilometer?
23:45:31 <barrett1> Ceilometer adoption by Operators appears low. What's your thinking around adding them Zucan?
23:45:49 <stephenwalli> What about swift?
23:45:52 <geoffarnold> interesting how we always omit Swift.
23:46:23 <Zucan> My opinion is that adoption is low because of Ceilometer's own issues, but interest is high and project is suffering under its own weight.  By that is my perspective.
23:46:23 <barrett1> I ommitted them for the same reason as Ceilometer - but the Swift adoption appears to be higher
23:46:37 <geoffarnold> the most stable project in the portfolio
23:46:58 <barrett1> Zucan: I think that is a good reason to include Ceilometer.
23:47:19 <barrett1> geoffarnold: Swift or Ceilometer?
23:47:32 <nateziemann> the one question I have is do we include projects that seem to have lots of momentum and visibility right now.  Magnum and Ironic come to mind.  people will want to see what's happening there.
23:47:39 <geoffarnold> swift. nobody would call ceilometer "stable"
23:47:48 <hughhalf> Yes, I'd lean towards including Ceilo* too as there's a bit of a chicken and egg problem, low adoption due to some technical issues, but it (or something like it) seems be needed by all
23:47:50 <Zucan> heh heh. :)
23:48:00 <stephenwalli> From my perspective: As a group of product managers, how would we define the minimum product?
23:48:11 <mscohen> well, lets remember the previous comments about starting smaller.  we should include several more.  the issue is the amount of work to do it
23:48:25 <barrett1> mscohen: +1
23:48:27 <stephenwalli> I like barrett1 list a lot.
23:48:28 <geoffarnold> projects that have few cross-functional dependencies don't need our help so much
23:48:29 <Zucan> Agree with that one
23:48:36 * hughhalf nods
23:48:42 <barrett1> geoffarnold: +1
23:48:43 <geoffarnold> on the other hand, they're low-hanging fruit
23:48:48 <hughhalf> yeah, small is good, let's do an excellent job on a smaller set, and go from there
23:48:56 <geoffarnold> +1
23:48:57 <hughhalf> my $0.20 :)
23:49:04 <Zucan> No reason not to start small and work out from there.
23:49:10 * hughhalf nods at Zucan
23:49:38 <barrett1> So are we good with: #agree Focus roadmap update on: nova, keystone, glance, horizon, cinder, neutron? Or do we want to add swift and ceilometer because of their cross-project invovlement  and overall Operator interest?
23:49:51 <Zucan> I am fine without swift and ceilometer being in the initial list
23:49:53 <barrett1> oops - didn't mean #agree....
23:49:54 <geoffarnold> don't add either
23:50:11 <barrett1> #agree Focus roadmap update on: nova, keystone, glance, horizon, cinder, neutron, swift, celiometer cycle.
23:50:31 <barrett1> Do we want to try and set a timeline for completing the update?
23:51:01 <mscohen> i’m confused.  so we are adding swift / ceilometer?  i just saw several no votes
23:51:21 <geoffarnold> I'd prefer just nova, keystone, glance, horizon, cinder, neutron
23:51:25 <barrett1> mscohen: you're right, my mistake.
23:51:33 <Zucan> heh.  I didn't even notice :)
23:51:47 <barrett1> #agree Focus roadmap update on: nova, keystone, glance, horizon, cinder, neutron this cycle
23:51:48 <mscohen> i’m just trying to save Shamail some work :)
23:51:54 <hughhalf> yes, shorter list fine with me too, lets keep swift and ceil* as stretch goals if we do a good enough result with shorter list
23:52:08 <barrett1> mscohen: nice guy! :)
23:52:17 <barrett1> hughhalf: +1
23:52:17 <mscohen> right, if we want to do a summit session  again we may need to broaden this
23:52:31 <mscohen> but that can be discussed at mid cycle maybe
23:52:36 <barrett1> mscohen: agree.
23:53:05 <barrett1> we're getting short on time, I'm going to move us on....
23:53:48 <barrett1> I'd like to defer the mid-cycle meetup til next week when we have more info
23:53:55 * hughhalf nods
23:54:11 <barrett1> #topic Doodle outcome for new Meeting time
23:54:17 <hughhalf> is the general assumption it will be in North America ?  merely ask so I can set the tone with my management of upcoming travel recs.
23:54:37 <geoffarnold> I hope so (with Tokyo looming)
23:54:37 <Zucan> hughhalf: yes, very very very likely
23:54:41 <barrett1> hughhalf: that's been my assumption...
23:54:43 <hughhalf> apologies Carol, didn't mean to gazump, please continue
23:54:47 * hughhalf nods
23:54:51 <barrett1> NP
23:54:51 <Zucan> Word on the street is that it is west coast this time
23:55:10 <barrett1> Thanks for everyone who responded to the Doodle from Shamail
23:55:19 <barrett1> There is a tie for votes: Monday @ 12P PT and Thursday @ 12P PT
23:55:42 <barrett1> Does anyone here have a strong preference?
23:55:57 <geoffarnold> Slight pref for Monday
23:56:05 <MeganR> I would prefer Monday, please
23:56:10 <mscohen> i prob have a slight pref for monday too
23:56:13 <Zucan> I am good with either.
23:56:16 <hughhalf> slight pref for Monday, 5am Tuesday sounds nicer than 5am Friday somehow :)
23:56:32 <barrett1> Sold, Monday it is!
23:56:44 <hughhalf> Kaching!
23:56:48 <barrett1> #agree Move our team meeting to Mondays at Noon Pacific
23:57:02 <barrett1> Next decision we need to make is IRC or voice
23:57:14 <Zucan> IRC will always be easier for me.
23:57:26 <barrett1> We are planning to meet weekly from here on out too
23:57:35 <MeganR> I am fine with either
23:57:50 <barrett1> Our options are:   IRC-only,  Alternate IRC and Voice, or  Voice only
23:58:04 <sarob> im really back
23:58:27 <sarob> emergency meeting, sorry about that
23:58:36 * hughhalf is comfortable with any of those meeting options
23:58:37 <barrett1> We could stick with IRC as our primary and then setup voice calls as needed...?
23:58:42 <barrett1> sarob: NP
23:58:43 <geoffarnold> +1
23:58:47 <Zucan> +12
23:58:49 <MeganR> +1
23:58:50 <hughhalf> +1.1
23:58:51 <Zucan> I mean +1 :)
23:58:59 <barrett1> OK - that settles it!
23:59:07 <sarob> rockyg and I worked out her part
23:59:14 <barrett1> #agree we will meet via IRC.
23:59:17 <sarob> i can commit it if she is unable
23:59:48 <barrett1> Can someone check the Meetings schedule and see if this channel is open at that time?
00:00:09 <barrett1> sarob: can you send via ML?
00:00:40 <barrett1> We're out of time!
00:00:52 <sarob> 12pm pdt mondays is free
00:01:00 <barrett1> sarob: Thanks!
00:01:07 <sarob> want me to summit the patch to change the time?
00:01:23 <barrett1> sarob: yes, pls
00:01:24 <hughhalf> sarob yes please
00:01:29 <sarob> will be done
00:01:42 <sarob> cheers
00:01:48 <hughhalf> Thanks all
00:01:54 <barrett1> Ok, we'll meet next on 6/15 at Noon Pacific.
00:01:56 <barrett1> Thanks all!
00:01:59 <stephenwalli> ciao
00:02:07 <Zucan> Thanks.  Have a great week!
00:02:09 <MeganR> Bye!
00:02:11 <barrett1> #endmeeting