19:02:14 <barrett> #startmeeting product_team
19:02:15 <openstack> Meeting started Mon Jun 29 19:02:14 2015 UTC and is due to finish in 60 minutes.  The chair is barrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:18 <openstack> The meeting name has been set to 'product_team'
19:02:36 <barrett> Let's start by taking role call
19:02:45 <geoffarnold> o/
19:03:06 <barrett> o/
19:03:19 <Rockyg> o/
19:03:21 <MeganR> o/
19:03:36 <barrett> Shamail - are you on?
19:04:02 <barrett> I think it could be a light meeting given the upcoming 4th of July holiday.
19:04:19 <geoffarnold> One action I had
19:04:39 <geoffarnold> I reached out to Tom to see if there was going to be an Operators Midcycle
19:04:44 <geoffarnold> no response
19:05:00 <geoffarnold> checked a couple of the other regulars: they hadn't heard anyhing
19:05:23 <barrett> Hmmm, not sure what else we can do to get that one rolling...
19:05:25 <Rockyg> yeah.  Nothing yet.  The size might be a problem
19:05:39 <sarob> o/
19:05:46 <barrett> Maybe we should plan to not try and align with that and set a date for us to meet...?
19:05:53 <barrett> Hi sarob
19:06:01 <geoffarnold> Do we want to meet f2f?
19:06:15 <geoffarnold> Ah, good. sarob might know
19:06:18 <sarob> barrett: hi!
19:06:32 <Shamail> hi everyone
19:06:37 <sarob> Shamail: hi
19:06:40 <geoffarnold> sarob, hae you heard anything about an ops midcycle?
19:06:42 <barrett> geoffarnold: I'd like to do that if we have can find a time/place that gives us critical mass.
19:06:49 <barrett> Hi Shamail
19:07:37 <geoffarnold> Based on https://wiki.openstack.org/wiki/Sprints we're probably looking at mid-Aug
19:08:14 <geoffarnold> Shall I send out a Doodle poll?
19:08:53 <cloudrancher> Hi
19:09:00 <barrett> Geoffarnold - Pls do. We're looking for meeting area and dates I think.
19:09:16 <sarob> geoffarnold: i havent
19:09:21 <Shamail> Are we giving up on co-location with ops (since we don't know when they are meeting)?
19:09:26 <Shamail> hi cloudrancher
19:09:34 <barrett> shamail: I think we should consider that.
19:09:43 <geoffarnold> OK, Doodle can do dates, and I'll ask for preferred locations in the comments
19:10:13 <Shamail> geoffarnold: Can you also make one of the options 'co-locate with date/place for ops midcycle'?
19:10:19 <Shamail> or will doodle not allow that
19:10:26 <barrett> Geoffarnold: Sounds good; If there's an Intel facility in the area where people want to meet, we can probably host it.
19:10:50 <Shamail> Ditto for EMC locations as well barrett
19:10:50 <barrett> Shamail - I think the question is how long do we want to wait for the Ops midcycle to get set?
19:11:04 <sarob> if y'all want to meet in livermore
19:11:06 <geoffarnold> Let's not wait. Aug scheduling is a pain
19:11:17 <sarob> my office is always available
19:11:19 <Shamail> Makes sense barrett
19:11:24 <barrett> geoffarnold: +1
19:11:31 <geoffarnold> Livermore is suppoosed to break 100F tomorrow
19:11:34 <Shamail> sounds goood geoffarnold
19:11:47 <barrett> OK - anything else on this topic?
19:12:05 <barrett> If not we'll move on
19:12:13 <geoffarnold> OK, I'll send out the poll today, look for responses by end of week
19:12:22 <natez> while I'm new here, I have to agree waiting until August will impact the time we have available to plan something impactful for Tokyo.
19:12:58 <natez> I'm very interested in meeting f2f if we can get a center of mass.  with or without the operators meetup.
19:13:03 <barrett> natez: Are you thinking second half of July?
19:13:48 <geoffarnold> The trouble with 2nd half July is this: https://wiki.openstack.org/wiki/Sprints
19:14:17 <Shamail> Yeah...second half of July is already tight between sprints, OSCON, and BoD meeting.
19:14:19 <natez> when I look at August openstack events, it's filling up.  July is more condusive for me beyond the week of OSCON.
19:14:26 <Rockyg> Early August...
19:15:05 <Rockyg> DefCore is in Austin week after OSCon, with board meeting right before
19:15:10 <barrett> I think it would be hard to make it happen before OSCON.
19:15:34 <Shamail> geoffarnold: to the bat mobile! I mean doodle poll!
19:15:40 <natez> how about somewhere August 1-14?
19:15:51 <barrett> natez: +1
19:16:05 <Shamail> Let's conduct the poll
19:16:10 <sarob> maybe
19:16:13 <barrett> Geoffarnold: We'll leave the doodle in your capable hands. Thanks
19:16:20 <barrett> Let's move on
19:16:32 <sarob> yes, plz
19:16:42 <Shamail> Date ranges look good natez, please vote on the poll.
19:16:44 <barrett> We'll revisit in next week's meeting with the poll results inhand.
19:16:45 <barrett> #topic Use Case Repo
19:17:01 <barrett> RockyG: Do you have any news on this one?
19:17:19 <Rockyg> Should have patch before TC tomorrow.
19:17:40 <barrett> Excellent!
19:17:59 <barrett> How long after that til it could go live?
19:18:25 <Rockyg> This week.  Since it's new, it doesn't need to wait for a repo migration.
19:19:08 <barrett> All sounds good, sounds like we can target posting our use cases next week.
19:19:40 <Rockyg> I have a question on format. We have user stories and use cases.
19:20:05 <Rockyg> User stories tend to be a workflow.  Use cases are generally a single action?
19:20:20 <barrett> Shamail: Do you want to take that one?
19:20:23 <Shamail> sure
19:20:40 <Rockyg> If Use cases are really small, we'll have hundreds to thousands.
19:20:55 <Shamail> User Stories tend to reflect the purpose of why we are doing something, whereas use case generally implies how it is done/leveraged
19:21:16 <Shamail> User Stories tend to be small but get broken into tasks (one user story could generate a lot of tasks)
19:21:46 <Rockyg> Right.  and each task is a use case? Or....?
19:21:49 <Shamail> I think what you are describing would be a task (versus a use case) Rockyg
19:21:58 <Rockyg> Ah.
19:22:14 <barrett> And is a task equal to a BP?
19:22:22 <Shamail> Use Case is similar to User Story but User Story leaves more autonomy
19:22:34 <Rockyg> Hmm.  Ok.
19:22:40 <Shamail> Each task is equal to a unit of work, so yeah
19:22:45 <Shamail> Example might be easiest
19:22:59 <geoffarnold> Wiki page, please, with approved taxonomy. We keep going over this.
19:23:09 <barrett> geoffarnold: +1
19:23:10 <Shamail> working on it geoffarnold! sorry for the delay :(
19:23:13 <Rockyg> Just an FYI.  We'll need to track BPs, Specs, and RFEs (bugs that are new feature requests)
19:23:22 <Shamail> Rockyg: +1
19:23:24 <Shamail> User Story: "As a operator, I want to be notified when my instances are offline"
19:23:42 <Shamail> Task: Make UI for showing instance status
19:23:57 <Shamail> Task: Conduct polling to check instance availability
19:24:10 <Shamail> Task: Configure email capabilities for notification
19:24:11 <Shamail> etc
19:24:16 <Shamail> This is just an example
19:24:29 <Shamail> but I am hoping it shows the domain of user story versus tasks
19:26:02 <barrett> Works for me
19:26:03 <Rockyg> So, here is some large site operators' use cases.  I'd love to get your breakdown of what is and isn't and how to convert it to use cases:  https://etherpad.openstack.org/p/Network_Segmentation_Usecases
19:26:24 <Shamail> I'll try to update the team on the progress of building common taxonomy (we can discuss the initial draft as a team)
19:26:36 <Shamail> Thanks Rockyg, i'll give it a shot
19:26:43 <Shamail> barrett: Can you please assign an action?
19:27:01 <Rockyg> It's a great start and we can use your work to inform Ops how to better write these up.
19:27:39 <Rockyg> FYI a couple of ops will be taking these to the Neutron midcycle for discussion on how to implement
19:27:47 <barrett> #action Shamail to review Large Site Operators use cases and map to our User Story/Task taxonomy
19:28:33 <Shamail> The goal is to hopefully make it easier to capture the high-level request while leaving the architecture/implementation up to the dev teams.  This way the burden is reduced on the user story generators and dev teams have full control of how/what they see as its manifestation.
19:28:44 <Shamail> I think we're good with this topic for now.  Agreed?
19:28:50 <barrett> Shamail - Do you want to discuss the email you sent about Themes/Epics & User Stories?
19:29:05 <barrett> Or are you good with this?
19:29:26 <Shamail> Let's put that on the schedule for next week please.  I want to send it out to the ML (after a few of you have had a chance to modify the draft)
19:29:35 <Shamail> We can then answer questions next week versus explain it
19:30:08 <Shamail> I'll make sure to send it out to the ML by Thursday.  It would be good to get the information out there before the repo.
19:30:09 <barrett> #action Carol to add topic on Epics/Themes/User Stories to Agenda for next week's meeting with  Shamail to lead
19:30:11 <Rockyg> +1
19:30:17 <sarob> +1
19:30:23 <geoffarnold> +1
19:30:53 <barrett> OK next topic
19:31:00 <barrett> #topic Work FLow
19:31:19 <barrett> Shamail - you have this one too
19:31:32 <Shamail> Do you recall what this topic was about?  Sorry :\
19:32:03 <Shamail> Is this tied to the other topic of workflow of themes -> user stories -> BP etc?
19:32:41 <barrett> Yes, I think it is how they get gathered, turned into design summit input, and how roadmap is generated as outcome
19:32:47 <Shamail> Ah got it!
19:33:08 <barrett> Do you want to discuss now or defer?
19:33:27 <Shamail> I can discuss it briefly and then take away an action item after the groups feedback
19:33:33 <barrett> ok
19:34:25 <Shamail> As everyone is aware, we want to be able to aggregate feedback from the various working groups and then share that feedback with the project teams by the design summit.  Finally, we want to also ensure that the future intentions/directions of projects are also available to the community in an easy to consume manner.
19:35:59 <Shamail> To support this workflow: We have five main tasks that must be completed... 1) obtain user stories from WGs in a standard format 2) aggregate the user stories in a common location/format and allow other groups to "show support" for the user story 3) prioritize the user stories
19:36:51 <Shamail> 4) work with the project teams at the design summit to share the user stories and the calculated priorities.  We also need to capture the outcome from the design summit (as it pertains to the user stories) in this step as well
19:37:50 <Shamail> 5) Once we know which user stories are being worked on for a release, we need to be able to show them on a standard roadmap (working with Lauren on this one) as well as dashboards that show status for the user stories and one for the epic as well
19:38:26 <Rockyg> OK.  small question.  Do we want to call the repo use-cases or user-stories?  We have time to change it, but just barely
19:38:31 <Shamail> Stretch goal: We should revisit the "top 10 prioritized user stories" against the items worked on and report out the percentage to the TC/BoD
19:38:36 <barrett> Shamail: Do the epics get defined as part of step #3 or ahead of it?
19:38:50 <Shamail> Epics would be defined at step 2 (as we aggregate)
19:38:59 <Shamail> Good point Rockyg
19:39:10 <Shamail> I personally vote for userstories but usecases works too.
19:39:12 <barrett> Gotcha
19:39:24 <barrett> shamail: +1
19:39:49 <Rockyg> userstories or user-stories?
19:39:59 <Shamail> So this is the high-level flow, if we agree with the premise and function of our group in this workflow then I can write up something a bit more detailed for review
19:40:17 <barrett> user-stories is good for me
19:40:18 <Shamail> openstack-userstories or openstack-user-stories, hmm...
19:40:25 <Shamail> barrett: +1
19:40:59 <barrett> rockyg: OK?
19:41:53 <Rockyg> Yup.  Action item it, please?
19:41:56 <Shamail> Once we come up with a standard template, we can email the various working groups and user committee to let them know about the format and ask for their help in capturing the requirements in a standard manner
19:42:26 <barrett> #action Rockyg to use the name user-stories for the repo name
19:42:56 <Shamail> The challenge with this workflow is two-fold... 1) The aggregation and formatting task might fall on us and we don't have that many active people yet so it could be quite a burden (depending on demand)
19:42:59 <Rockyg> Thanks!
19:42:59 <cloudrancher> barrett: +1
19:43:01 <barrett> shamail: We were working toward a deadline for user stories of last week/this week....
19:43:29 <Shamail> 2) For the design summit, we will need people that already have working relationships with the project teams and we would need to request about 20-30 minutes of team to present
19:43:35 <Shamail> this will also require people
19:44:26 <Shamail> barrett: agreed, but I don't think we are following the top half of this workflow for the pilot right?  The user stories in the pilot are being created/submitted by us
19:44:52 <barrett> Shamail - Yes, that's true
19:44:54 <Shamail> for this go-around, we probably need to pick up the workflow at #2
19:45:12 <Shamail> so external groups formatting properly will be something we need to engage on M+
19:45:35 <Shamail> The aggregation will be simpler to since we only need to work with 5-10
19:45:36 <barrett> Shamail: For the M-design summit and the Pilot process we're running now, I think we'll need to have an owner for the top user stories we want to move through the design process and that owner will need to assemble a team of folks to engage with the appropriate teams
19:45:38 <Shamail> user stories
19:45:46 <Shamail> barrett: +1
19:46:22 <Shamail> the owner of the user stories and the person that engages at the summit can be different people
19:46:48 <barrett> OK, I think we can change topics which is to talk about how to run Steps 2&3 for the Pilot
19:46:52 <Shamail> The owner of the user story will effectively be the source for clarifying any questions that may come up as well as leading the BP creation process
19:47:06 <Shamail> Sounds good
19:47:16 <barrett> #topic User Story Review/Consolidation/Prioritization
19:47:18 <Rockyg> There are also a number of use cases coming out of the DefCore discussion right now.  Mostly Nova/Glance with a touch of Neutron related
19:47:24 <Shamail> Time check: 13 minutes
19:48:09 <barrett> Gotcha
19:48:13 <barrett> Consolidating Use Cases into Epics
19:48:32 <barrett> Sorry, User Stories... Consider an Epic the same as a Theme
19:49:27 <barrett> The proposal is to start with the Themes we used in Vancouver
19:50:04 <barrett> consolidate User Stories as it makes sense around these, and then identify the themactic groupings for the remaining User Stories
19:50:41 <barrett> For the Criteria for Selecting the top User stories for this Pilot Phase
19:50:55 <barrett> I'm proposing 3
19:51:11 <barrett> Cross Project User Stories  (requiring BPs in multiple projects)
19:51:26 <barrett> Addresses needs of multiple market-segments (Enterprise, HPC, Telco, etc)
19:51:44 <barrett> Can be implemented in M-development cycle   - Though I have some concerns about this one...
19:52:18 <Shamail> barrett: +1 on all three criteria
19:52:34 <barrett> With this work completed, we'd take the ordered list to the Cross-project team meeting for review and input to enable us to finalize
19:53:30 <barrett> Comments? Suggestions?
19:54:04 <Shamail> barrett: I agree with it all
19:54:22 <cloudrancher> Would the themes allow split into minimum viable, and stretch or are they the bare mininum to be usable
19:54:23 <Shamail> what are your concerns with implemented in M?
19:54:51 <barrett> cloudrancher: I think they would span the entire spectrum
19:55:13 <barrett> Shamail: Too small of a feature to move the needle...
19:55:21 <barrett> I'm impatient... :)
19:55:39 <Shamail> I agree with barrett, the themes would allow for coverage of all areas and we can add a new one if we are missing some
19:55:42 <Shamail> gotcha barrett
19:55:50 <Rockyg> That's where the defcore use cases might work.  Small work in three projects with big impact
19:56:12 <barrett> Rockyg: I like it!
19:56:18 <Rockyg> The theme for those are usability/compatibility
19:56:21 <Shamail> Rockyg: +1
19:56:45 <Rockyg> 1) i want to know what my external IP address is
19:57:05 <barrett> I'll take the action item to send this out to the ML, and try to assign a timeline or event for the steps..
19:57:25 <Rockyg> 2) I want to just Upload an image (glance v2 api work)
19:57:46 <Rockyg> 3) I forget, but it may be images across clouds
19:57:47 <barrett> #action Carol to send info to ML on consolidation/prioritization/review next steps and time for this Pilot phase
19:57:49 <Shamail> Sounds good barrett
19:58:07 <barrett> Rockyg: Is there a place where we can find these?
19:58:19 <Shamail> Should I focus on capturing defcore ones before the network segmentation ones?
19:58:50 <Rockyg> there are two ML discussions between Monty and John Garbutt.  I'll post the links to the ML list
19:59:06 <barrett> We're almost out of time, I want to remind everyone that the Tokyo session proposals are due 7/15. Let's cover that next week.
19:59:16 <geoffarnold> OK
19:59:26 <barrett> Any other opens/reminders before we wrapup?
19:59:47 <Shamail> nope
20:00:06 <barrett> going, going...
20:00:09 <Shamail> take care everyone!
20:00:13 <barrett> #endmeeting