23:03:34 <barrett> #startmeeting product work group
23:03:35 <openstack> Meeting started Wed Apr 29 23:03:34 2015 UTC and is due to finish in 60 minutes.  The chair is barrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:03:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:03:38 <openstack> The meeting name has been set to 'product_work_group'
23:04:20 <barrett> #topic A Glimpse at the Roadmap session content
23:04:32 * geoffarnold mostly read-only mode
23:05:20 <barrett> Here's a link to the slides: https://docs.google.com/presentation/d/1sbTSRX14_rDLnX8HAerNi3J2Oo9GpbH8I9OxBZIWasA/edit#slide=id.p
23:05:44 <barrett> are there any comments or discussions on the content?
23:06:46 <rolandchan> Not from me
23:07:10 <barrett> When I read the mission on slide 3, and on the wiki page, the thing that seems missing to me is the mission to create a roadmap that aligns our community
23:07:21 <sgordon> sorry, was running late
23:07:31 <barrett> NP, just getting started
23:07:38 <sgordon> (literally)
23:08:01 <barrett> have you had a chance to look at the slides for the 1st vancouver session?
23:09:10 <sgordon> yeah
23:09:12 <sgordon> so slide 14
23:09:13 <sgordon> nova
23:09:37 <barrett> The nova content needs to be integrated in. The summary is in the socialization etherpad
23:09:45 <sgordon> i feel like in some ways that was the most honest answer given
23:09:59 <barrett> LOL
23:10:04 <sgordon> in that michael didn't attempt to gaze into the crystal ball for liberty/m
23:10:14 <sgordon> wondering if we want to call that tension out
23:10:19 <sgordon> (the one he cites)
23:10:46 <sgordon> i guess we kind of do on 18
23:10:51 <sgordon> will depend on speaker emphasis
23:12:04 <barrett> Michael did provide some views when he talked to MikeC.
23:12:16 <barrett> You can find the info here: https://etherpad.openstack.org/p/kilo-product-management-socialization
23:12:22 <barrett> starts at line 633
23:12:29 <sgordon> yeah i know
23:12:32 <barrett> high level and directional
23:12:33 <sgordon> that is what i am referring to
23:12:37 <barrett> gotcha
23:13:23 <barrett> Is the tension you're referring to the challenge in projecting beyond the current release? Or the tension between new features vs bug fix?
23:13:34 <sgordon> the former
23:13:37 <sgordon> though the latter is fun too
23:13:41 <Shamail> Hi all.
23:13:45 <barrett> Hi
23:14:24 <barrett> I think the tension is really the problem statement that this group is trying to address.
23:14:48 <barrett> Shamail - Any comments on the slides for the Monday session?
23:14:54 <Shamail> Is anyone else on who can give an update on this session or should I?
23:15:11 <Shamail> Mscohen is driving it but I can provide an update since he can't make t.
23:15:13 <Shamail> It*
23:15:35 <barrett> go ahead Shamail
23:15:56 <Shamail> The team made great progress last week, I volunteered to do cosmetic enhancements once we nail down the content.  We will be meeting again next week to lock down the draft.
23:16:32 <barrett> Thanks - how do you want people to give comments?
23:16:33 <Shamail> Our thought right now is to spend time on the group charter, what we've accomplished so far, and how the initiative will work with the community
23:16:55 <barrett> Comments on slides or notes or email or ?
23:17:19 <Shamail> We are not planning to spend too much time on the actual feedback from the PTLs since the content is self-explanatory and will be published.
23:17:46 <Shamail> The best way is to review the slide deck and make comments through the comment function or in slide notes.  Please identify yourself so that we know who to contact for more details.
23:17:58 <Shamail> The content is hosted on Google.  I will be glad to resend a link later tonight.
23:18:27 <barrett> I posted in earlier in this session
23:18:56 <Shamail> All in all, most slides are complete from a content perspective so a review by the team will be greatly appreciated before our next meeting.
23:19:02 <Shamail> Thanks barrett
23:19:42 <barrett> Anything else on this?
23:19:53 <Shamail> Last I checked, the session had 100+ people registered.
23:19:57 <Shamail> That's it.
23:20:04 <barrett> Great!
23:20:57 <barrett> Let's move to the next topic
23:21:02 <Shamail> Hi Rockyg
23:21:21 <Rockyg> o/ sorry I'm late.  mail -in tax audit prep  grrr!
23:21:30 <barrett> #topic 2nd Session at the Summit
23:21:38 <barrett> Hi Rocky
23:21:41 <Shamail> Ouch.
23:22:14 <barrett> Shamail - do you want to give an update on the Tuesday session at the Summit?
23:22:19 <Shamail> I want to apologize for the late notice on the second session.  I had forgotten about it until earlier this week.
23:22:59 <Shamail> Sure. The current presenters are Sean R., Allison R., Stefano M., and Rob H.
23:23:21 <Rockyg> Title?
23:23:25 <Shamail> We had originally proposed to sessions to divide education about the group and to share our findings this far
23:23:30 <Shamail> State of Product Management
23:23:38 <Rockyg> thanks
23:23:56 <barrett> I'm not sure those folks have the best info
23:23:58 <Shamail> The first session actually touches on both of these topics so I wanted to discuss if we could re-purpose the second session and validate presenters.
23:24:08 <barrett> +1
23:24:16 <Rockyg> +1
23:24:36 <sarob_> Hello my friends
23:24:40 <Shamail> I hope everyone had a chance to review the email.  I would like to discuss the options, identify presenters, and start working on this asap.
23:24:48 <Shamail> Hi sarob_ , perfect timing
23:24:50 <barrett> Hi sarob
23:24:55 <sarob_> ;)
23:24:57 <Shamail> We are just starting the discussion on the second session
23:25:05 <sarob_> Excellent
23:25:13 <barrett> The more I've thought about it, the more I like option 3
23:25:18 <sarob_> Barrett by
23:25:20 <sarob_> Hi
23:25:22 <Shamail> From the ML, it seems like option #3 is preferred.
23:25:47 <sarob_> We have the Monday sessions
23:25:58 <Shamail> I stated my opinion as well.  I like both option 2 & 3 but our selection will achieve different objectives.
23:26:09 <sarob_> I'm hoping that we learn more about
23:26:22 <sarob_> What the rest of the community wants Monday
23:26:28 <Shamail> +1
23:26:30 <Rockyg> hi, sarob ;-)
23:26:31 <sarob_> Apply that to the second meet
23:26:43 <barrett> +1
23:26:48 <sarob_> Rockyg hi
23:26:53 <Shamail> That would mean an intense planning session on Monday evening. :)
23:27:01 <Shamail> but I like that.
23:27:08 <sarob_> That how I roll
23:27:18 <Shamail> I would also like us to touch base with cross project rather soon.
23:27:34 <sarob_> How about next week
23:27:36 <barrett> +1
23:27:36 <Shamail> If we work with them on the session then that could account for 50-80% of the content
23:27:42 <Rockyg> ++
23:27:45 <Shamail> And we amend it with community feedback
23:27:47 <sarob_> With some email prep with them this week
23:27:57 <Shamail> ++
23:28:09 <sarob_> Cool
23:28:16 <Shamail> Anyone else have preference on the options or alternate suggestions?
23:28:32 <sarob_> Any amendments to the workflow as in the gdoc?
23:28:54 <Shamail> Not yet but I think we should share that with the xproj team.
23:29:04 <Shamail> They might have ideas too
23:29:06 <sarob_> I'm pretty sure xproject is going want nuts
23:29:08 <sarob_> And bolts
23:29:22 <barrett> I made edits to the work flow
23:29:27 <sarob_> Who what where when
23:29:29 <Shamail> Ah, so should we schedule a meeting later this week to review the flow?
23:29:40 <barrett> Is this the Doc you were referring to sarob? https://docs.google.com/document/d/13JPDDiBGGXf5dtP0u8C-1So2Mjb3yEmGhv_ijVqyEf0/edit#heading=h.gj9mj9q4cejx
23:29:56 <sarob_> Yup
23:30:36 <barrett> I think it would be good to have a call to walk through it - might be other ways we can simplify it.
23:30:37 <Shamail> I agree sarob, we should have more details.
23:30:55 <sarob_> The bit that we should
23:30:58 <sarob_> Figure out
23:31:05 <Shamail> I'll schedule something.  Any preferences or should I use doodle?
23:31:11 <sarob_> Laurensell wants to publish
23:31:19 <sarob_> The next release
23:31:25 <sarob_> Roadmap
23:31:32 <sarob_> With the multi release
23:31:36 <Shamail> Definitely want a review before publish.
23:31:46 <Shamail> And buy-in
23:31:50 <sarob_> So we should have either a way to integrate
23:31:55 <sarob_> Quickly
23:32:02 <barrett> Is there something ready for publication?
23:32:07 <sarob_> Or the multi relase
23:32:09 <Rockyg> Definitely want a summit session with input from the xprojects before publish
23:32:17 <barrett> +1
23:32:19 <sarob_> Needs to be ready mostly before
23:32:22 <sarob_> The summit
23:32:30 <Shamail> Can someone put an action for me to schedule review call?
23:32:36 <Shamail> Bad memory :(
23:32:46 <barrett> At the last board meeting I thought there was agreement on Tokyo being the target for publishing a multi release roadmap
23:33:09 <barrett> #action Shamail to schedule call to review work flow
23:33:20 <Shamail> Thanks.
23:33:21 <sarob_> Barrett yup
23:33:40 <Shamail> Is Lauren going to join our summit meet up?
23:33:43 <sarob_> Starting with m summit let
23:33:54 <barrett> sarob: What would Lauren want to publish at Vancouver?
23:34:19 <sarob_> Multi release and m release get together
23:34:35 <sarob_> Barrett. I meant about workflow timing
23:34:41 <sarob_> Not this summit
23:34:49 <sarob_> Sorry that
23:34:54 <sarob_> Wasn't clear
23:34:54 <barrett> gotcha
23:34:59 <Shamail> Ah; that clarifies it.
23:35:05 <barrett> That seems doable
23:35:12 <sarob_> Xproject is going to very
23:35:20 <sarob_> Focused on
23:35:22 <sarob_> How we
23:35:30 <sarob_> Make things
23:35:35 <sarob_> Eazier
23:35:38 <Shamail> I agree that we should have that pretty much close to nailed before the summit.
23:35:48 <sarob_> Not worse like in summit lead up
23:36:12 <Shamail> How we make things easier + help execute.
23:36:14 <sarob_> Shamail cool
23:36:15 <barrett> I think we have a good story to tell, but it will only work if we can collaborate with the PTLs
23:36:28 <sarob_> Barrett right
23:36:33 <Shamail> Agreed barrett
23:36:41 <sarob_> Some will be our devs
23:37:01 <sarob_> And others will be collaborators
23:37:14 <sarob_> So balance will be important too
23:37:18 <Shamail> Has anyone run this process by their internal teams yet?
23:37:35 <barrett> Can we use the call Shamail is setting up to walk through the flow and prep for cross-project meeting?
23:37:36 <Shamail> I'd be curious to hear feedback (organizational perspective)
23:37:38 <sarob_> I started to with EMC folks
23:37:48 <sarob_> Member?
23:37:50 <Shamail> I remember :)
23:38:05 <sarob_> I'm going to adopt it for Akanda
23:38:09 <Shamail> But I'd like to run it by our actual contributors too not mgmt.
23:38:23 <sarob_> Sure
23:38:36 <sarob_> Both will be important
23:38:41 <sarob_> Ptl and devs
23:38:42 <Shamail> I'm going to continue the work you had started at EMC
23:38:43 <sarob_> First
23:38:50 <sarob_> Sweet
23:38:59 <Shamail> barrett: +1
23:39:07 <sarob_> Carry my torch
23:39:24 <Rockyg> ouch! ouch! ouch!  Dang thing gets hot!
23:39:25 <barrett> I'm meeting with Intel PTLs and devs this week
23:39:26 <sarob_> Ugh
23:39:30 <Shamail> Lol
23:39:35 <sarob_> Nice
23:39:45 <Shamail> I'm meeting with my team a week before the summit.
23:39:46 <sarob_> I think if the devs
23:39:50 <sarob_> Dig it
23:39:50 <Rockyg> Huawei devs and core don't talk to me.
23:40:03 <sarob_> Then the product and Dev mgmt will follow
23:40:08 <Shamail> Rockyg: 😕
23:40:17 <Shamail> sarob_: +1
23:40:32 <sarob_> Rockyg I'll talk to you ;)
23:40:34 <Rockyg> Yeah.  I had to get the report on the China bugfest from Intel.
23:40:42 <Shamail> I'll try to find one hour. That should be enough to get a good start right?
23:40:59 <Rockyg> sarob:  thanks you!  I promise not to be too needy
23:41:09 <Rockyg> Hous is a good start
23:41:15 <Rockyg> hour
23:41:24 <Shamail> Perfect
23:41:26 <sarob_> Rockyg keep plugging
23:41:29 <Shamail> Shall we move on?
23:41:30 <sarob_> Away
23:41:35 <sarob_> I'm good
23:41:39 <Shamail> Lock in option #3 for second session?
23:41:47 <Rockyg> Oh, I am.  With contributors ;-)
23:41:51 <Shamail> Presenters?
23:41:52 <barrett> Yes
23:41:59 <sarob_> +1
23:42:16 <barrett> #agreed Option #3 from ML thread, for Session #2 at Summit
23:42:26 <Rockyg> So, we should have at least one PTL as presenter
23:42:31 <Shamail> I'd like to have people from both Product and Xproj on stage.
23:42:37 <sarob_> I like
23:42:41 <barrett> +1
23:42:52 * sarob_ like too
23:43:36 <Shamail> Let's start an outline and refine workflow.  We can identify presenters after discussion with xproj.
23:43:41 <Shamail> That work?
23:43:44 <sarob_> Good plan
23:43:58 <Rockyg> ++
23:44:21 <barrett> +
23:44:31 <barrett> Ready for next topic?
23:44:39 <Shamail> Yep
23:45:01 <barrett> #topic Product WG F2F Plans at Vancouver
23:46:03 <barrett> We're set for 2 sessions, both on Monday
23:46:04 <Shamail> I think sarob_ and you are leading this topic.
23:46:27 <barrett> The 1st is for a team work session from 2:00 - 3:30
23:46:27 <Shamail> Do you have the necessary info to send out the email?
23:46:41 <barrett> Shamail - Yes, I do
23:46:51 <barrett> Will send it out tomorrow
23:47:03 <Shamail> Awesome.  Sorry for the interruption.
23:47:19 <barrett> np
23:47:59 <barrett> We could use some of that session to work through what we heard in the 11:15 session....?
23:48:24 <Rockyg> sounds good.
23:48:32 <Shamail> barrett: +1 and also coordinate next steps between Vancouver and Tokyo.
23:49:39 <barrett> We could probably take on 1 other topic...thoughts?
23:50:08 <Rockyg> circle back on all the PM type efforts -- WTE, Log, Telco
23:50:09 <Shamail> Possibly use case generation from PTL feedback?
23:50:35 <Shamail> Actually I like Rockyg's idea. We can work on the use-cases outside of the summit.
23:50:48 <barrett> RockyG: There's a session after this one that will include the other groups
23:50:57 <sarob_> Use case
23:51:00 <barrett> It goes from 3:40 - 4:40
23:51:06 <Rockyg> Ah
23:51:32 <Shamail> 😟 I'm going to miss that one due to a breakout session.
23:51:50 <barrett> Shamail: bummer
23:51:53 <Rockyg> Maybe working through stuck places.  How to fill the gaps
23:52:18 <Rockyg> I'm boging to be toast Monday night
23:52:30 <Shamail> Will we be at a point where we could try to mock flow something through the process as a team?
23:52:35 <barrett> Why don't we include Use Cases and Issues in the planning for tokyo topic
23:52:46 <Rockyg> boging/going/
23:52:59 <Rockyg> barrett: ++
23:53:01 <Shamail> barrett: +1
23:53:27 * sarob_ like
23:53:34 <barrett> OK
23:54:24 <barrett> Then for the xproject session - do we want to talk through the flow and how they can feed use cases and get involved in the group?
23:54:54 <Rockyg> ++
23:55:00 <barrett> Would be interesting if each group came with their top 3-5 use cases and we could look at how much or little synergy there is...
23:55:36 <Shamail> I think that will work.  That's the best way to show the process and what we are trying to achieve.
23:55:39 <sarob_> We should have them submit through gerrit
23:55:46 <Shamail> It will also let everyone come up with the best way to interface
23:56:07 <barrett> Shamail +1
23:56:17 <sarob_> Be loose on formating
23:56:41 <sarob_> That way everyone can see them
23:56:52 <barrett> sarob: I'd actually propose that we give a template. The PTLs have said that consistent format would be helpful
23:56:54 <sarob_> Maybe even post comments
23:57:03 <sarob_> Agreed
23:57:08 <Shamail> Agreed
23:57:12 <sarob_> But not be too picky
23:57:18 <sarob_> First go around
23:57:26 <Shamail> Gerrit is the right way and being loose on the format is okay.
23:57:27 <sarob_> Get ideas out there
23:57:28 <barrett> Use the one the Telco work group is using? The WTE folks have started using this too
23:57:29 <sarob_> First
23:57:39 <Shamail> We do want to at least identify the type of information that should be included
23:57:43 <sarob_> Where is it?
23:57:47 <Shamail> Can't make things happen with incomplete data
23:57:49 <sarob_> Yes
23:58:07 <sarob_> Just not tox test on it yet
23:58:17 <barrett> https://docs.google.com/document/d/1mO6fjmvDRvppoRqDSfWdDW2p3G9ESKSgI9cxRP4mvB4/edit
23:58:21 <Shamail> You're no fun!  JK
23:58:58 <barrett> What repo should we ask people to post to?
23:59:23 <Shamail> I would ideally like to leverage cross project but will they be able to give some of us core?
23:59:28 <sarob_> Xproject
23:59:38 <sarob_> Up to them
23:59:46 <sarob_> not required
23:59:59 <Shamail> Makes sense.
00:00:01 <Rockyg> xproject is actually openstack/openstack-spec
00:00:46 <barrett> Thanks Rocky
00:00:52 <Shamail> So let's make a note that our preferred location is openstack-spec?
00:01:04 <barrett> +1
00:01:16 <barrett> Will include in email
00:01:25 <sarob_> +1
00:01:25 <Rockyg> There is already a template there for specs.  Do we need a modified one?
00:01:27 <Shamail> Great
00:01:40 <sarob_> We would need some new dir
00:01:42 <Rockyg> or can we live with what the developers have already devises.
00:01:46 <sarob_> But that's the place
00:02:08 <barrett> a new dir would make it easier. How do we get one created?
00:02:25 <sarob_> We work with the xproject team to get
00:02:30 <Rockyg> xproject meeting on tuesday.  If we have a name for the dir, then we can ask for it
00:02:30 <sarob_> Buy in
00:02:39 <sarob_> Then I will create
00:02:42 <sarob_> A patch
00:02:47 <sarob_> To update the repo
00:02:48 <Shamail> Sounds good.
00:03:10 <Rockyg> xproject hasn't met the past two weeks, so we could probably get an hour IRC with them in their meeting time slot
00:03:11 <barrett> Who will make the request?
00:03:30 <Shamail> sarob_: are you up for taking this AI?
00:03:35 <sarob_> Yup
00:03:49 <Shamail> Thanks.
00:03:51 * sarob_ accepts the wand
00:04:07 <barrett> #action Sarob request a directory from xproject team in Tuesdays' meting
00:04:10 <barrett> We're almost out of time and still have a couple of items that I think we need to cover before the summit - Like Ops Summit coverage -can people meet again next week? Or sooner?
00:04:32 <Shamail> I would prefer this week or the week before the summit.
00:04:44 <Shamail> Next week will be a blur for me personally. :(
00:05:03 <barrett> Shamail - bummer again
00:05:11 <Shamail> Yeah
00:05:31 <barrett> How about tomorrow at 10:00 AM Pacific?
00:05:47 <Rockyg> works for me
00:06:02 <sarob_> I can't
00:06:05 <Shamail> Works for me.  I could also make some time next week work as long as it's afternoon PT.
00:06:11 <sarob_> But I'm not critical
00:06:14 <sarob_> For this
00:06:17 <Rockyg> I even think this room is available
00:06:40 <barrett> Would be good to have you sarob - is there another time that works?
00:07:26 <sarob_> 11am is better
00:07:58 <Rockyg> Also works and room is still available, I think
00:08:00 <Shamail> That works for me too
00:08:13 <sarob_> Can still use this channel
00:08:13 <barrett> I can't make 11
00:08:18 <barrett> How about Noon?
00:08:46 <Shamail> I can't make noon, I can make most times after 1:30P PT.
00:08:49 <sarob_> I can do that too
00:09:10 <sarob_> Earlier like 8am pdt?
00:09:28 * Rockyg shudders
00:09:29 <barrett> I'm booked at 8, but could do 7
00:09:36 <Shamail> We have a WTE meeting
00:09:53 <sarob_> Geez Louise
00:09:56 <barrett> How about Friday at 9AM Pacific?
00:10:19 <sarob_> 6-8am is bad
00:10:22 <Shamail> 7-8, 10-12P, and 1:30P+ PT
00:10:37 <Shamail> Friday noon will work for me
00:10:43 <Shamail> Err, 9A PT
00:10:49 <sarob_> I can do that
00:10:59 <Shamail> Rockyg: ?
00:11:15 <Rockyg> 9am pdt works for me
00:11:22 <Shamail> Sweet!
00:11:24 <sarob_> Omg
00:11:31 <sarob_> Works for me 2
00:11:34 <barrett> Friday at 9AM Pacific it is! I'll send an email to the ML and let folks know we'll meet again this week.
00:11:40 <Rockyg> but, Carol, what about the monitoring meetin?
00:11:41 <Shamail> Great.
00:11:57 <Shamail> I can already tell the doodle for workflow planning is going to be interesting.
00:11:58 <barrett> Rocky - That's at 8AM
00:12:12 <sarob_> Jeez keep up
00:12:30 <Rockyg> Ah, right.  See, I'm already thinking the way I do at that time of day....
00:13:03 <sarob_> Ten lashes
00:13:16 <barrett> LOL
00:13:18 <Shamail> Are we calling it a wrap for today then?
00:13:23 <barrett> +1
00:13:29 <Shamail> It's 8PM and my stomach is grumbling.
00:13:37 <barrett> Type with you all on Friday!
00:13:46 <Shamail> Hah, type to you soon!
00:13:52 <Rockyg> ttfn!
00:13:55 <sarob_> Which channel?
00:14:11 <sarob_> Looks like alt is open
00:14:17 <Rockyg> #openstack-meeting-alt
00:14:19 <Shamail> Can you book it?
00:14:27 <sarob_> Not really
00:14:37 <sarob_> It more of a perm thing
00:14:43 <Shamail> Ha okay.
00:15:00 <sarob_> It's open
00:15:08 <Shamail> We can show up and use it.  If it's taken then we can just create a new #openstack-product channel. :)
00:15:35 <Rockyg> ++
00:15:39 <Shamail> Cya on Friday!
00:15:57 <sarob_> Cheers
14:00:33 <openstack> johnthetubaguy: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:00:40 <bauzas> arh
14:00:43 <jaypipes> o.
14:00:44 <johnthetubaguy> #endmeeting