19:03:20 <barrett1> #startmeeting Product Working Group
19:03:21 <openstack> Meeting started Mon Jun 22 19:03:20 2015 UTC and is due to finish in 60 minutes.  The chair is barrett1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:25 <openstack> The meeting name has been set to 'product_working_group'
19:03:41 <barrett1> let's start with roll call - who's here?
19:03:49 <Shamail> Here.
19:03:49 <Rockyg> o/
19:03:56 <geoffarn_> o/
19:03:59 <MeganR> o/
19:04:42 <jimhaselmaier> Here
19:04:49 <geoffarnold> (re-nicked)
19:04:55 <barrett1> You can find the agenda for today here: https://wiki.openstack.org/wiki/Meetings/product-team
19:05:16 <barrett1> #topic Roadmap Update
19:05:29 <barrett1> Shamail - you want to take this one?
19:05:32 <Shamail> Sure
19:06:50 <Shamail> I plan to email Lauren early this week to schedule a quick conversation around the Product WG roadmap initiative and brain-storm on A) how we can work together to help her deliver the roadmap and B) whether she would be interested in working directly with Product WG members and lead our roadmap sub-team
19:07:01 <Shamail> I can probably do a read-out by next week (pending her availability)
19:07:25 <Shamail> I also need to email the WG mailing list.... We don't have any volunteers for this sub-team besides mscohen at this point.
19:07:40 <Shamail> We need some people to help since we have to re-engage with the Project leads
19:07:47 <barrett1> I'll help with the roadmap update
19:07:55 <Shamail> Thanks barrett1!
19:08:12 <Shamail> That is the status of where we are, what we plan to deliver (hopefully) for this release is:
19:08:16 <MeganR> I'm available to help with the roadmap update as well.
19:08:18 <jimhaselmaier> I can help as well.
19:08:27 <Shamail> A) An updated "roadmap" breakout session
19:08:52 <Shamail> B) A workflow to pass aggregated information to the OpenStack Foundation to update the actual roadmap page
19:09:18 <Shamail> C) define a repeatable process for this sub-team (stretch goal this cycle) since we will probably need to be A and B every release
19:09:28 <Shamail> Thanks MeganR and jimhaselmaier
19:09:53 <Shamail> I'll make sure to say that we have 4 volunteers (including myself) int the message to the ML
19:10:10 <Shamail> Does what we plan to deliver sound in-line w/ everyone's expectations of this sub-team?
19:10:29 <barrett1> It sounds good to me.
19:10:43 <Shamail> Naturally, aggregating (and sharing) PTL feedback is a sub-task in task B
19:10:50 <Rockyg> ++
19:10:56 <Shamail> thanks barrett1... That's all I had from a roadmap perspectiave
19:10:59 <Shamail> perspective*
19:11:18 <barrett1> Any questions or comments from others?
19:11:20 <Shamail> Can you give me an action to talk with Lauren?
19:11:23 <barrett1> I'll leave this on the agenda for next week's meeting.
19:11:26 <barrett1> Yes.
19:11:26 <Shamail> and send out the message to ML
19:11:54 <barrett1> #action Shamail to contact Lauren about collaborating on the Roadmap process and content
19:12:23 <Shamail> Thx
19:12:27 <barrett1> #action Shamail to send email to ML requesting volunteers to help with roadmap update
19:13:17 <barrett1> OK next topic
19:13:27 <barrett1> #topic Action Plan Status Updates
19:13:44 <barrett1> The tracker is located here: https://docs.google.com/spreadsheets/d/1mpOPVWESpmUsgh69EmACygJZX3dRQ5zTnCi04tPnNBI/edit#gid=0
19:13:47 <barrett1> #link https://docs.google.com/spreadsheets/d/1mpOPVWESpmUsgh69EmACygJZX3dRQ5zTnCi04tPnNBI/edit#gid=0
19:14:25 <barrett1> Let's start at the top: Shamail & Hugh: Internal Comms - What's the latest?
19:15:27 <Shamail> Hugh and I met last week
19:15:55 <Shamail> We are planning to start our action item by first identifying slides that we can re-use from the existing Product WG decks
19:16:23 <Shamail> We think that our best way forward is to build a standard Product WG overview deck that can be used by the entire team
19:16:46 <Shamail> This will allow all of us use common messaging and definitions of what the group is planning to do and what it is currently working on
19:17:05 <Shamail> We will send out a draft to the ML once we are far enough along and schedule a review during one of our weekly meetings
19:17:42 <barrett1> Do you have a target date for the draft?
19:18:13 <Shamail> Let's target 7/13
19:18:19 <Shamail> I'll update the team if that changes
19:18:43 <barrett1> Sounds good - Thanks
19:19:00 <Shamail> Thanks
19:19:33 <barrett1> Next one - Repo and Use Case Template - RockyG - What's the latest?
19:19:40 <barrett1> Sarob: Are you on?
19:19:51 <Rockyg> yup.  Bouncing between two meetings
19:19:56 <Rockyg> New repository:  have all the file mods.  Need to submit patch to TC
19:20:17 <barrett1> what will be the repo name & location?
19:20:39 <Rockyg> The question is wether we should have a file defining our wg repos as separate from openstack projects and tc
19:20:56 <Rockyg> Repo will be openstack/openstack-usecases
19:21:11 <Rockyg> But we can change that if you like ;-)
19:21:20 <Rockyg> So, top level
19:21:26 <barrett1> the name works for me
19:21:33 <Shamail> +1
19:21:47 <Shamail> so who are the proposed core reviewers?
19:21:51 <Shamail> since it's top-level
19:22:15 <Shamail> (original plan was a sub-location in cross project I think)
19:22:20 <Rockyg> cbarrett, sarob, shamail, rockyg to start
19:22:27 <Rockyg> Can be changed later
19:22:45 <Shamail> Sounds good, thanks for the information.
19:22:52 <Shamail> Thanks for making this happen Rockyg and sarob!
19:23:10 <Rockyg> Hopefully have it up after next week's TC meeting
19:23:25 <barrett1> That sound great!
19:23:38 <barrett1> Do you want to discuss whether or not rep should be separate from openstack projects and tc?
19:24:23 <Rockyg> I'll take that up with the TC.  It's simply a structural issue
19:25:39 <barrett1> ok
19:26:02 <barrett1> Do you need any backup/support for the TC meeting?
19:26:18 <Rockyg> But, I got the large prod wg to create some use cases in an etherpad.
19:26:35 <Rockyg> We'll be able to add once we figure out the repo structure itself.
19:26:37 <barrett1> +1
19:26:43 <Shamail> +1
19:26:44 <Rockyg> That might be worth talking about
19:27:03 <barrett1> Go ahead - what do you think would be helpful?
19:27:11 <Rockyg> We have verticals that matrix into horizontals.
19:27:42 <Rockyg> The verticals create their use cases, but defcore and other ops are also creating smaller, more horizontal use cases
19:28:33 <Rockyg> I'm thinking a vertical structure on one side to capture the use cases, then another branch to distill out the horizontal this is what everyone needs
19:28:48 <Rockyg> That allows rapidly adding use cases then filtering later
19:28:49 <Shamail> Didn't we discuss adding the supporting-wgs as a tag within the use case?  This will allow the repo to be flat but use cases still can be associated with supporting groups (whether horizontal or vertical)
19:29:48 <Rockyg> I think we need the tags on the horizontal to identify who the use case affects, but I think we need the vertical because the use cases will break down into many smaller cases
19:30:10 <Shamail> makes sense
19:30:50 <Rockyg> It will also help with defcore in identifying needed interop stuff at the capability level
19:31:25 <barrett1> Just to make sure I get it - Verticals are Market Segments (ex. Enterprise, Telco) and Horizontals are Projects?
19:32:35 <Rockyg> Horizontals may be single projects or multiple, but pretty much a single unit of operation, i.e. instantiate a VM for a user with all necessary acls
19:33:03 <Rockyg> So, one of the steps to realize the full workflow the vertical has defined.
19:33:32 <barrett1> makes sense
19:33:48 <Shamail> Rockyg and barrett1, but couldn't (or shouldn't) we revisit the actual use case format too (to make sure it's adjusted to capture the necessary data)...
19:33:55 <Shamail> I view use cases as providing five types of information: 1) Supporting work groups/user communities 2) The epic it falls under 3) The user story 4) The actual description of the use case 5) the list of blueprints (across projects) that need to be implemented to make it work
19:34:22 <jimhaselmaier> I'm not quite following re: definition of vertical.  Is a vertical, by definition, something that has components in multiple horizontals
19:34:23 <jimhaselmaier> ?
19:34:25 <Shamail> It still aligns with what you described Rockyg but makes the "use case" the single source for all necessary information for reasoning and implementation status
19:34:40 <jimhaselmaier> Or is a vertical focused on a market segment as asked earlier - such as Telco?
19:35:53 <Rockyg> jimhaselmaier: it tends to be a work flow.  So when you break it down into individual use cases, multiple verticals can need the same  individual use case to accomplish the flow
19:36:20 <jimhaselmaier> ok
19:36:21 <geoffarnold> Related point: where are the epics defined?
19:36:42 <Shamail> This is probably a broader discussion and one that needs a workflow diagram possibly...
19:37:17 <Rockyg> +1!
19:37:20 <Shamail> geoffarnold: The thought was that maybe an epic is a theme and it is also stored in the same repo but under a sub-group called "themes" or something.... just brainstorming here since we haven't discussed this as a team yet
19:37:39 <barrett1> Shamail: Yes, I think you're right.
19:38:12 <geoffarnold> I see epics as part of a hierarchical decomposition of use cases
19:38:21 <Shamail> geoffarnold: +1
19:38:34 <geoffarnold> one person's epic is another person's colection of specific use cases
19:38:43 <Rockyg> It's quite matrixed or graphed, however you want to call it ;-)
19:39:07 <barrett1> Does someone want to create a work flow picture or text description for the epic/use case/horizontal/vertical/tag?
19:39:16 <Shamail> I can take the first cut
19:39:26 <barrett1> Maybe start by socializing on ML and then we can cover in next week's meeting?
19:39:27 <Rockyg> And I can comment!
19:39:32 <Shamail> anyone else?
19:39:37 <geoffarnold> o\
19:39:38 <Rockyg> +1
19:39:46 <barrett1> Thanks Shamail
19:39:51 <barrett1> o\
19:39:59 <jimhaselmaier> I'd be happy to comment on your first pass.
19:40:01 <Shamail> sweet, i'll keep you in the loop Rockyg, geoffarnold, and barrett1
19:40:04 <Shamail> and jimhaselmaier
19:40:21 <Shamail> we can exchange comments and co-present the topic in the next meeting
19:41:12 <Shamail> (can I get another action barrett1) lol...
19:41:27 <barrett1> Given that we're asking for all use cases to be published by 6/24 - I think a goal for next week's meeting is to get everyone up on the use case repo and template.
19:41:41 <Shamail> barrett1: +1
19:42:03 <Rockyg> +1
19:42:12 <Rockyg> Where is the template currently?
19:42:20 <Rockyg> Could you do a #info?
19:42:22 <barrett1> #action Shamail to draft workflow picture or text description for the epic/use case/horizontal/vertical/tag and socialize on ML
19:42:33 <DericHorn-HP> Where can we view the existing use cases?
19:43:00 <barrett1> #action Barrett1 Add Repo and work flow discussion to next week's team meeting
19:43:39 <barrett1> They are here: https://drive.google.com/folderview?id=0BxtM4AiszlEyfllFelZYR2RqNDFfWVRvWWtlb09laGxwR2ljc3UxVEl5VEpfMEhicnlxUFk&usp=sharing
19:43:47 <barrett1> There's a template file in there too
19:44:05 <barrett1> Next Topic: Use Cases
19:44:11 <barrett1> # Topic Use Cases
19:44:18 <barrett1> #Topic Use Cases
19:44:29 <barrett1> How is everyone doing in drafting these?
19:44:48 <barrett1> We had targeted Wednesday to have them posted
19:45:32 <Shamail> I haven't submitted any myself but I will be adding information to some of the ones that are already posted
19:46:14 <Rockyg> I'll see about addingg the two from the LS_wg
19:47:09 <barrett1> I think we're missing HA use cases
19:47:51 <barrett1> RockyG: Did that come up with the LS WG?
19:48:09 <Rockyg> Lemme check.
19:48:14 <Shamail> barrett1: agreed, but since this is the pilot I am not too concerned
19:48:31 <Rockyg> #link https://etherpad.openstack.org/p/Network_Segmentation_Usecases
19:48:48 <Rockyg> No, that was a discussion on subdividing networks
19:48:49 <Shamail> I'm personally more interested in use cases that can stress/test the overall workflow for now
19:49:58 <Rockyg> Monty provided a horizontal that is really ugly as implemented that makes for a very clumsy flow as implemented with lots of tests/branches for three different ways of doing it.
19:50:37 <barrett1> Shamail - Understand, but I'm also interested in addressing barriers to OpenStack adoption
19:50:58 <barrett1> RockyG: Are you going to extract the use cases from that etherpad?
19:51:06 <Rockyg> Yes
19:51:26 <barrett1> excellent!
19:51:38 <Shamail> Yep, makes sense.  I guess the way I should re-phrase is that HA use-cases would be desired but not showstoppers for now.
19:51:43 <Rockyg> I get ops to put cases in etherpad, then we can extract
19:51:58 <barrett1> For next week's meeting I'll also add a discussion on review/consolidation/prioritization of use cases. will send some thoughts out on the ML ahead of time
19:52:13 <Shamail> barrett1: +1
19:52:31 <Rockyg> I'll talk with fifieldt about some standard naming for ops use case etherpads
19:52:39 <barrett1> #action Barret1 to send proposal for usecase review/consolidation/prioritization to ML and add to next team meeting agenda
19:52:53 <barrett1> rockyg: +1
19:53:09 <barrett1> next topic
19:53:23 <barrett1> #topic Recruit new members
19:53:56 <barrett1> I'm still exchanging emails to find the right person from NEC to join the group
19:54:11 <barrett1> I don't have a contact at Yahoo! Does anyone else?
19:54:20 <Rockyg> sarob might
19:54:27 <Rockyg> I only have devs
19:54:33 <Shamail> yeah, sarob is a good bet for Yahoo
19:54:56 <barrett1> I've pinged him for this, will followup again
19:55:19 <barrett1> Shamail - How are things going with VMware?
19:55:27 <Shamail> VMware and I have exchanged a few emails... I have asked to schedule a meeting this week to discuss the work group (I don't foresee them not participating so far).  I have sent an email to Mirantis but no response yet.  I might try another contact over there.
19:55:46 <Shamail> I think they are "in" but want to discuss the WG so they can identify the right person
19:57:09 <geoffarnold> Getting back to the agenda: Midcycle planning: list of meetups is here: https://wiki.openstack.org/wiki/Sprints  Note there's no Operators meetup scheduled as yet (AFAIK)
19:57:24 <barrett1> OK - Let me know if you want me to help on Mirantis
19:57:45 <Shamail> Thanks barrett1
19:57:59 <barrett1> #Topic Midcycle  Planning
19:58:22 <barrett1> geoffarnold: Is there a location and date emerging from the info?
19:58:32 <barrett1> For us to have our midcycle that is.... :)
19:58:47 <geoffarnold> Not really. MIdcycles are spread across July/August
19:59:03 <Shamail> I liked the suggestion you made at the last meeting about co-location with the ops meet-up geoffarnold.
19:59:21 <Shamail> It's too bad that's one of the few that hasn't indicated a schedule yet.
19:59:21 <Rockyg> If we want it to be a heavy working midcycle, we should schedule it after ops.  Maybe in the same area?
19:59:22 <geoffarnold> But there isn't an ops metup scheduled iyet
19:59:30 <geoffarnold> :-(
19:59:36 <barrett1> geoffarnold: can you ping Tomfifeld and see when the Ops meetup will get defined?
19:59:39 <Rockyg> Ops is usually a lagging indicator.
19:59:42 <geoffarnold> Wilco
19:59:54 <barrett1> RockyG: lol
19:59:56 <geoffarnold> I'd expect it to be mid/late Aug
20:00:00 <barrett1> geoffarnold: Thanks
20:00:35 <Shamail> Here's hoping to mid (rather than late)!
20:00:41 <barrett1> OK, we're out of time for this week. Next week we'll talk about use cases, work flow, Tokyo Plans and hopefully mid cycle meetup plans
20:00:41 <Rockyg> Time!
20:00:48 <Shamail> barrett1:
20:00:52 <Shamail> Can I share one link
20:00:56 <Rockyg> please
20:00:58 <barrett1> of course
20:01:27 <Shamail> We didn't get to the Tokyo Breakout Session planning topic but for those of you who are thinking of topics that we can propose as a WG, please update this spreadsheet: https://docs.google.com/spreadsheets/d/1fwAKjAFEw3jVW8NcDxkfzh0TMmMcftyoQEx5bjFJTxc/edit#gid=0
20:01:36 <Shamail> We can discuss at the next meeting hopefully
20:01:44 <Shamail> That's all I had barrett1
20:02:03 <barrett1> Thanks
20:02:07 <barrett1> #endmeeting