19:01:00 <barrett1> #startmeeting Product Working Group
19:01:00 <Shamail> Dallas in August... bring t-shirts.
19:01:00 <openstack> Meeting started Mon Jul  6 19:01:00 2015 UTC and is due to finish in 60 minutes.  The chair is barrett1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:04 <openstack> The meeting name has been set to 'product_working_group'
19:01:17 <janonymous> o/
19:01:29 <barrett1> Let's start will roll call, for the record.
19:01:34 <geoffarnold> o\
19:01:34 <Shamail> Hi
19:01:37 <janonymous> o/
19:01:44 <jimhaselmaier> Hello
19:01:51 <cloudrancher> Hi
19:01:54 <DericHorn-HP> Hi
19:02:22 <Rockyg> o/
19:02:31 <barrett1> 1st agenda item is Tokyo Session Proposals
19:02:32 <MeganR> o/
19:02:38 <barrett1> #topic Tokyo Session Proposals
19:02:52 <barrett1> #link https://docs.google.com/spreadsheets/d/1fwAKjAFEw3jVW8NcDxkfzh0TMmMcftyoQEx5bjFJTxc/edit#gid=0
19:03:02 <barrett1> You can find the google doc at the link.
19:03:32 <Shamail> I have a few questions...
19:03:44 <barrett1> Go for it
19:03:57 <Shamail> 1) Are the two that I proposed ones that the team wants to move forward with?  Any questions on the concepts?
19:04:08 <Shamail> 2) Anyone else want to volunteer to co-present/create material
19:04:39 <Shamail> 3) Do we want to at least add one more session that we can use to show PTL support?  A follow-up to state of PM if you will.
19:04:50 <Shamail> End of my list :)
19:05:17 <geoffarnold> Interesting q. I was thinking of two possible additions (1) at the PTL interface, (2) at the user WG interface
19:05:19 <jimhaselmaier> Re Shamail's #2:  I'd be more than willing to be a co-presenter on the "Contributing as an OpenStack User" topic.
19:05:41 <Shamail> geoffarnold: I was hoping session #2 would cover user WG interface
19:05:49 <barrett1> Shamail: I added a working session for this team, meant to be similar to Thursday's meeting in Vancover.
19:06:00 <Shamail> along with which work groups exists, user story template, repo submission instructions etc
19:06:12 <Shamail> Thanks barrett1!
19:06:30 <Shamail> Thanks jimhaselmaier
19:06:47 <Shamail> Anyone willing to co-present roadmap?  Should I reach out on the mailing list instead?
19:06:49 <geoffarnold> OK, as long as there's a rep from a user group to talk about their experience of the interface
19:06:59 <barrett1> Shamail - I'll join you for What's Next on the Roadmap session and content prep
19:07:05 <geoffarnold> Of course with Win The Enterprise we have that covered
19:07:08 <Rockyg> Roadmap title needs to be xexxed up
19:07:16 <Shamail> geoffarnold: user WG = user committee right?  I just want to make sure we are talking about the same thing
19:07:22 <Rockyg> ^xexxed^sexxed
19:07:36 <Shamail> Agreed Rockyg, definitely need to re-work both title and abstract
19:07:40 <mscohen> sorry, late to the party. i’m happy to help with the roadmap presentation as well
19:07:41 <geoffarnold> yes - well, user committee and/or vertical
19:07:49 <Shamail> thanks geoffarnold
19:07:53 <Shamail> welcome mscohen and thanks.
19:08:04 <barrett1> Shamail: I'm not following the PTL thread...?
19:08:32 <MeganR> Shamail: I am happy to help with the presentation, not certain if I'll be available to help with the presenting part.
19:08:32 <Shamail> We had spoken about doing a session where we would ask PTL(s) to get on stage with Product WG
19:08:48 <Shamail> to discuss how this WG/process is meaningful/helpful to their design cycles
19:08:51 <Rockyg> Me too.  I can present
19:09:01 <Shamail> MeganR: which one?  #2?
19:09:20 <MeganR> sorry - yes, #2
19:09:25 <Shamail> MeganR: Thanks
19:09:29 <geoffarnold> Right. People understand how PTLs operate (well.....), so they need to understand how PTLs consume our work
19:09:50 <barrett1> Shamail - Gotcha, it's the process part of things where we want to include PTLs and User Committee folks (though from the email thread, I'm not sure this makes sense)
19:10:20 <Rockyg> How we glue the two together
19:10:31 <barrett1> rockyg: gotcha
19:10:33 <Shamail> Ah, process part we can discuss next week (when workflow is further along)
19:10:46 <Shamail> So we don't need a session anymore to have P-WG and PTLs on-stage together?
19:11:10 <geoffarnold> Not all together
19:11:10 <Shamail> The high-level jist will be covered in #2 anyway
19:11:21 <barrett1> Shamail: I think we do want to have a session that talks about how User Stories are created, posted, reviewed and feed into Design Summits
19:11:49 <Shamail> Yes, that is #2
19:12:16 <barrett1> Shamail: Understand..think that's where we want the PTLs, User Committee participation
19:12:50 <Shamail> To expand on #2: It will provide an overview of UC, the WGs that exist currently (to let users know others share their interest and hopefully spark additional members), overview of user story template, our repo (how to contribute), and how the process works to get their user stories to the devs
19:13:16 <Shamail> Got it... I'll make sure to reach out to UC and a few PTLs so they can be there and provide a quote or two.
19:13:27 <jimhaselmaier> I hope we can get at least one PTL to participate in that session.
19:13:35 <jimhaselmaier> It will be so much more powerful if we do.
19:13:52 <Shamail> I think johnthetubaguy has already expressed support/interest... I will follow-up with him.
19:14:10 <barrett1> Shamail: +1
19:14:24 <barrett1> Anything else on Tokyo Sessions?
19:14:39 <Shamail> Is there one that we mentioned but didnt document?
19:15:00 <Shamail> Can everyone take a quick look at the spreadsheet and see we got everything before we move on please?  We will have to work on submission this week.
19:15:12 <Rockyg> We'll think about it.  We still have time but need to start on these
19:15:39 <Shamail> Thanks barrett1, I think we are done with this topic.
19:16:01 <barrett1> Shamail: I'll write up the submission for #1, if you want... Are you going to write-up #2?
19:16:31 <Shamail> Sure.  Sounds like a plan barrett1
19:16:59 <barrett1> #action: Carol to draft submission for Session #1
19:17:11 <mscohen> barrett1.  happy to help on #1 if you’d like (or i can just review)
19:17:12 <barrett1> #action Shamail to draft submission for session #2
19:17:23 <barrett1> mscohen: Great!
19:17:24 <Rockyg> I can help on 3
19:17:37 <barrett1> RockyG: Thanks
19:18:18 <barrett1> #topic User Story Repo Update
19:18:31 <barrett1> Rocky - Can you give folks an update on this?
19:18:37 <barrett1> Or Sean
19:18:52 <Rockyg> So, the reviews have been filed, but I need to update the one for infra (repository creation).
19:19:32 <Rockyg> and, I want to put forth this idea:  it seems it would be easier for us to be a "project" as the Product working Group because the repositories are all tied to projects
19:19:55 <Rockyg> So, if that's ok, I'll modify the review commit message to TC for that
19:20:48 <Shamail> Rockyg: I read the comments by ttx
19:21:02 <Rockyg> Did I mention I hate git?  Gotta amend the infra files, but git merges backward from what I consider intuitive, so my local repository is all messed up.  I'll get Doug Hellmann to help straighten it out.
19:21:12 <Shamail> It seems that he was saying if we want to be under TC, we should consider applying as a project OR we can add the repo to the existing user committee file.
19:21:19 <Rockyg> Shamail: Oh, haven't seen theirs yet
19:21:41 <Rockyg> Kewl.  So, how do we want to go?
19:21:49 <Shamail> https://review.openstack.org/#/c/187767/1/reference/user-committee-repos.yaml
19:21:54 <barrett1> Shamail: Thanks
19:22:03 <Shamail> The question I have is can we have openstack repos under UC?
19:22:20 <Shamail> If so then my vote would be going that route (since we are already aligning with UC)
19:22:31 <Shamail> If not then we might want to consider a project proposal....
19:22:52 <Shamail> I think the repo should be under "openstack" and not "stackforge" to help it be perceived as more official.
19:23:11 <barrett1> I've been assuming that the Operators Tag info would be posted under the User Committee...
19:23:11 <sgordon> i assume you can
19:23:16 <sgordon> otherwise they wouldnt be in governance
19:23:22 <Rockyg> Oh, we've appliled under openstack, with it to reside at openstack/openstack-user-stories
19:23:23 <barrett1> Agree with openstack instead of stackforge
19:23:24 <sgordon> the stackforge repos are handled separately atm
19:23:33 <Shamail> sgordon: true
19:23:34 <Rockyg> stackforge is going away
19:23:36 <sgordon> (that is why you wont find telco in that governance repo)
19:23:51 <Shamail> thanks sgordon
19:23:59 <Shamail> didn't know that Rockyg
19:24:01 <sgordon> if by going away
19:24:02 <barrett1> sgordon: What repo does the telco wg use?
19:24:06 <Shamail> stackforge
19:24:09 <sgordon> you mean most things will become openstack namespaced
19:24:10 <sgordon> then yes
19:24:15 <Shamail> http://git.openstack.org/cgit/stackforge/telcowg-usecases/tree/template.rst
19:24:15 <Rockyg> infra is trying to  get rid of it and have a review up.
19:24:23 <sgordon> going away is a bit incendiary ;)
19:24:34 <geoffarnold> The big tent is getting VERY big
19:24:49 <Rockyg> They want everyone interested to just migrate to OpenStack.  and if not, to find another host.
19:24:51 <Shamail> So Rockyg, if we can talk to UC and get an openstack repo added for user-stories under their file then that's ideal
19:24:56 <sgordon> barrett1, per the link - on stackforge
19:25:02 <Shamail> if not then we might have to make a case for a separate file/project
19:25:14 <geoffarnold> It's not a bad way to weed out the moribund projects, though
19:25:30 <Rockyg> I'll contact a few UC folks and ask them to be at the TC meeting tomorrow.
19:25:36 <Shamail> Rockyg: You're on the agenda tomorrow for the TC meeting to discuss this
19:25:40 <Rockyg> Then we can get it done tomorrow.
19:25:46 <Shamail> Awesome, thanks Rockyg
19:25:52 <Rockyg> firgured I would be;-)
19:26:06 <barrett1> Thanks Rockyg
19:26:13 <Rockyg> NP
19:27:15 <barrett1> One Q: do we want to wait for the repo to be created to post, review & comment on User Stories? Or do we want to use a temp location to get going on this part of things?
19:27:57 <MeganR> will there be any difference between a temp location and the repo?
19:28:04 <MeganR> don't want to create additional work
19:28:04 <Rockyg> If we use a temp location, then we'd have to migrate.  If you're ok with moving the files without the histories, that would be easy.
19:28:27 <Rockyg> Oh, and if we become a project, or go under UC, we still need a Lanuchpad site.
19:28:38 <geoffarnold> Need that either way
19:28:39 <sgordon> barrett1, depends what your proposal for a temp location is
19:28:46 <barrett1> Rockyg: I think that's the basic challenge, tracking comments aside from the gerrit system
19:28:48 <Rockyg> I can get that started as soon as the TC vote.  It will inform us where to build the LP site
19:28:48 <Shamail> barrett1: I think that is the main question: do we want history?
19:28:52 <sgordon> barrett1, we found with the telco stuff most other solutions become unweildy
19:29:00 <sgordon> as you need version control and comment tracking
19:29:02 <barrett1> sgordon: google docs directory - but open to other options
19:29:06 <Arkady_Kanevsky> do we have a pointer to a template for usecases? to review and vote on the format?
19:29:09 <Shamail> sgordon: +1
19:29:10 <Rockyg> sgordon: good info
19:29:18 <Shamail> That is one of the topics later today Arkady_Kanevsky
19:29:24 <sgordon> that is what made us explore gerrit
19:29:26 <Arkady_Kanevsky> I have a simple usecase I got from Vancouver I would like to use for test drive.
19:29:29 <sgordon> as we were quickly going insane
19:29:31 <Arkady_Kanevsky> cool
19:30:00 <barrett1> Ok, sounds like waiting for the repo is the way to go
19:30:26 <Arkady_Kanevsky> +1 on gerrit
19:30:33 <barrett1> I'm just watching time go by... our original plan was to complete the prioritization by July 8...
19:31:21 <geoffarnold> To get people to move from stackforge there will have to be tools that preserve history. So we can go for stackforge now and wait for the tools.....
19:31:21 <geoffarnold> I'm not moving my project until the tools exist
19:32:01 <sgordon> geoffarnold, indeed - it will be if thousands of voices cried out at once and were suddenly silenced... ;p
19:32:02 <Shamail> that's a good idea geoffarnold
19:32:25 <geoffarnold> Waiting for a controversial decision with no natural deadline seems risky
19:32:35 <Shamail> Start w/ StackForge and move to OpenStack once the new repo is available.  We can keep the old one for history until migration tools exist.
19:32:39 <barrett1> geoffarnold: Has someone committed to creating the tools?
19:32:57 <Shamail> essentially, our stackforge will become archive once openstack repo is up.
19:33:03 <geoffarnold> Not yet. But then they haven't committed to the mandatory move yet, AFAIK
19:33:08 <Rockyg> geoffarnold: so, the repo can be up within a day of the TC vote if there is no repository to move from Stackforge.  If a move is required, they have to schedule it for a weekend.
19:33:08 <sgordon> indeed
19:33:15 <sgordon> i cant actually find the patch proposal
19:33:25 <sgordon> and there are in fact new project requests in the review queue still
19:34:00 <barrett1> Rockyg: the TC vote is for a stackforge repo?
19:34:06 <Arkady_Kanevsky> can you post a pointer to stackforge repos?
19:34:10 <geoffarnold> https://github.com/stackforge
19:34:18 <geoffarnold> There are LOTS of them
19:34:20 <Rockyg> No TC needed for stackforge.  TC vote tomorrow for OpenStack
19:34:32 <geoffarnold> Agreed
19:34:50 <sgordon> here is the proposal for stackforge going away https://review.openstack.org/#/c/192016/
19:34:57 <Shamail> How about we wait until Wednesday (after TC meeting)?
19:34:59 <sgordon> not exactly unanimous just yet ;p
19:35:06 <barrett1> Rockyg: Thanks. How about you send out an update on the ML after the TC meeting and give folks a pointer to where they can post?
19:35:08 <Shamail> If there is no progress on actual repo then we proceed with stackforge for now
19:35:39 <geoffarnold> Hmmm  Even more -1's than the last time I looked
19:35:44 <Arkady_Kanevsky> no product repo there
19:35:47 <Rockyg> barrett1: will do.  And if it's under the UC, it will be even easier to get the rest done.
19:35:56 <barrett1> #action Rockgy to send out an update on Repo after TC meeting on the 7th
19:36:01 <Arkady_Kanevsky> See telcowg
19:36:03 <barrett1> Thanks Rockyg
19:36:39 <barrett1> Anything else on this topic?
19:37:29 <barrett1> Ok moving along
19:37:46 <barrett1> #topic Taxonomy & User Story Template
19:37:56 <barrett1> Shamail - pls take it away!
19:37:58 <Shamail> Thanks!
19:38:07 <Shamail> Let's discuss the user story template first... I posted some ideas to the ML and got great feedback from sgordon.
19:38:14 <Shamail> I didn't realize that telco had an updated template and it looks like the new template aligns better to the sections that we would want to use as well.
19:38:29 <sgordon> i believe the revision was after the ops midcycle
19:38:29 <Shamail> My take-away from the discussion on the ML is that product WG is aiming to create a normalized template for capturing user stories but certain WG (e.g. telco) might have additional details that are needed due to the complexity of the space/apps they are dealing with.  In this sense, sgordon raised the question of whether something would be getting lost if telco-wg submits user stories to product-wg.
19:38:41 <Shamail> It looks good :)
19:38:47 <Shamail> The main dilemma is how do we normalize (because not all WGs will have the same amount of detail as a telco-wg user story) while accommodating groups that have additional information.
19:38:58 <Shamail> Updated Proposal:  Can we use the new telco-wg template and make sections that might constitute too much detail as optional.  This will allow teams to add a minimum amount while other teams can add more details (and not have them get lost as we move the user story forward).  Can we still add meta-data fields as mentioned in ML to track WGs supporting the user story and rename some items (e.g. rename examples
19:38:58 <Shamail> to scenarios)?  If this sounds reasonable, I can craft another ML reply with more details about this updated proposal.
19:39:01 <sgordon> indeed, that is what i am getting at
19:39:06 <sgordon> telco happens to have a template
19:39:15 <sgordon> product wg will have a template which will likely be loosely aligned
19:39:20 <Shamail> The template fits well sgordon, does the updated proposal sound like a good compromise?
19:39:25 <sgordon> but we will invariably have some differences
19:39:47 <sgordon> yes, i also took a note that i need to make it clearer they are optional in the telco template
19:39:52 <Shamail> Essentially, we leverage the same template as you (I will be asking for certain sections to be renamed) but then make most of the more detailed sections optional
19:39:59 <sgordon> so thats all good
19:40:07 <sgordon> next question is if we have other WGs engaged to do same
19:40:08 <Arkady_Kanevsky> we need a section on known project impacted/requierd for the usecase
19:40:22 <barrett1> Shamail: I like the updated proposal. Having a common format would make it easier for all of us.
19:40:33 <Arkady_Kanevsky> +1 on common format
19:40:43 <geoffarnold> +1
19:40:52 <Rockyg> +1
19:40:53 <Shamail> That will be a part of the "gaps" sections but maybe its a separate section altogether
19:41:04 <geoffarnold> Link?
19:41:06 <Shamail> We basically leave gaps as is and add "Projects Impacted"
19:41:11 <Shamail> http://git.openstack.org/cgit/stackforge/telcowg-usecases/tree/template.rst
19:41:12 <Arkady_Kanevsky> strongly recommend that we us standard openstrack process to submit format proposal and review/vote on it
19:41:20 <barrett1> sgordon: do you know if other wgs are drafting user stories?
19:41:20 <Shamail> Arkady_Kanevsky: +1 thats the plan
19:41:27 <Rockyg> Shamail: so the telco case is the reason I originally thought we needed WG subdirs
19:41:27 <Arkady_Kanevsky> But we need one for our group not telco one.
19:41:40 <sgordon> barrett1, negative
19:41:49 <Arkady_Kanevsky> We do not them or us to be confused what we are rvewing and asking to change. We are no asking to change teloc format
19:41:54 <Rockyg> But, if we link to the WG repos, then we bring *together* the parts that cross WGs
19:42:06 <jimhaselmaier> I'm a little concerned about Product WG specifying projects impacted.  The projects, in some cases, may know better what is impacted.
19:42:09 <Shamail> Rockyg: If we can get everyone on the same format then we can get other teams to support the same user story.  The reason I was against seperate dirs is because then if telco and enterprise share a user story
19:42:25 <Shamail> they will be forced to submit two different files for the same story (because they will land in diff. dirs)
19:42:43 <geoffarnold> +1 Shamail
19:42:44 <Shamail> jimhaselmaier: this is high-level... e.g. nova, cinder, glance, etc.
19:42:46 <Arkady_Kanevsky> We are not speciyfing. We arsk asking submitter ot use case to list project he/she knows about that are/willbe impcated by the use case
19:42:55 <jimhaselmaier> I don't have a problem having impacted projects in our Use Case template, but determining which projects are impacted needs some project assessment I would think.
19:42:59 <Rockyg> Right.  Which is addressed by just linking to the WGs' repos and creating a "merged" story
19:43:03 <Shamail> It is so the teams know which projects they need to contact INITIALLY.  The project team could redirect us after hearing the user story.
19:43:17 <geoffarnold> The user stories will often be cross-project, though - can't align with existing OpenStack projects
19:43:40 <jimhaselmaier> @Shamail:  Got it.
19:43:56 <Shamail> Rockyg: If they are using the same format then what value will dirs provide?  It just increases the number of steps to create a merged user story.
19:43:58 <geoffarnold> E.g. service federation touch identity, quotas, policy....
19:44:07 <Arkady_Kanevsky> I think it will be to use to generate blueprint(s) for peoject based on use case once it is voted in
19:44:32 <Shamail> Arkady_Kanevsky: This brings up a good point about the workflow we have to discuss
19:44:36 <Rockyg> Shamail:  i'm also saying no dirs.  The already exist.  The other WG's repos *are*those dirs
19:44:52 <Shamail> Rockyg: Ah, got it.
19:45:10 <Arkady_Kanevsky> geoffarnold: which repo in sourceforge you are using for productWG usecase stories or proposals?
19:45:15 <Shamail> Rockyg: So you're saying that each WG get a folder in the repo... they work against that folder as their active location...
19:45:25 <Shamail> Arkady_Kanevsky: doesn't exist yet
19:45:58 <Shamail> I will move the updated proposal through the ML again.  Sounds good?
19:46:00 <geoffarnold> What shamail said - waiting to find out!
19:46:15 <Arkady_Kanevsky> Rockyg: I suggest we do not have directories in our repo for other WG. we just create links in use case to bluepritns/ specs in outher projects
19:46:18 <Shamail> We can discuss the repo structure and workflow impact as a part of the workflow discussion.
19:46:19 <barrett1> arkady_kanevsky: I'm using this directory to collect enterprise user stories right now: https://drive.google.com/folderview?id=0BxtM4AiszlEyfllFelZYR2RqNDFfWVRvWWtlb09laGxwR2ljc3UxVEl5VEpfMEhicnlxUFk&usp=sharing
19:46:39 <Rockyg> Shamail: Actually, no.  Either they work in the general folder, as the Product_wg has set up, or if they have their own repo, they work there, and build a cross wg user story in the Product WG repo
19:46:42 <Arkady_Kanevsky> Barrett1 - thank you
19:47:09 <Shamail> Rockyg: I'll follow up with you on email to better understand.
19:47:35 <Shamail> Can you make a proposal that captures your thoughts and send it to the ML?
19:47:43 <Rockyg> Arkady_Kanevsky: What geoffarnold said:  There will most likely be cross-project spec that will lead to project specs and/or bps
19:47:54 <Shamail> barrett1: Can you give me an action item to send updated template proposal?
19:48:14 <Shamail> So this is probably a good segue to taxonomy (as we are getting into cross project stuff)
19:48:18 <Arkady_Kanevsky> do we go top down starting from use cases or bottom up from spec/blueprints per project?
19:48:18 <barrett1> #action Shamail Create an updated proposal for Repo & User Stories and send out to ML
19:48:20 <Rockyg> Shamail: +1 on AI and talk
19:48:38 <Shamail> Please give Rockyg an AI too barrett1 :)
19:48:55 <barrett1> Shamail: Gladly..
19:49:20 <barrett1> #action RockyG work with Shamail to send out an updated Repo plan that addresses cross WG and cross Project needs
19:49:22 <Shamail> Okay, moving on to taxonomy which might help with this cross-project discussion we were just having...
19:49:25 <geoffarnold> Arkady_Kanevsky strongly prefer top down
19:49:31 <Shamail> #link https://docs.google.com/document/d/1WXGImWTvjaT6BzAtbakKUazRr6hcZBtv90P7ke8qYrw/edit?usp=sharing
19:49:47 <Shamail> I have started creating the basis of a page that will eventually be on our wiki.
19:50:01 <Rockyg> geoffarnold: ++ top down
19:50:13 <Shamail> I have gotten as far as explaining what the terms/hierarchy looks like in agile
19:50:26 <Arkady_Kanevsky> me too in favor of top down starting from use case
19:50:30 <Shamail> I will be working on mapping those terms to our stuff next
19:51:14 <Shamail> If you scroll to the bottom of that document that I linked. It has a starting proposal for how the requirements might be categorized/collected and what each contains
19:51:30 <Shamail> At the very top, we will have a theme
19:51:52 <Shamail> the theme, for us, will be definitions that we and the foundation have agreed upon.
19:52:02 <Arkady_Kanevsky> do we need to classify use cases in https://drive.google.com/folderview?id=0BxtM4AiszlEyfllFelZYR2RqNDFfWVRvWWtlb09laGxwR2ljc3UxVEl5VEpfMEhicnlxUFk&usp=sharing into themes?
19:52:55 <Shamail> Side note: The foundation is working to define themes too as they move to themes based releases.
19:53:10 <Shamail> They will want to work with us to make sure our themes and theirs are aligned.
19:53:24 <Shamail> Arkady_Kanevsky: Yes, but we need to define the themes first
19:53:27 <barrett1> Arkday_Kanevsky: Yes
19:53:34 <Shamail> So after themes is the part that has a ? for me
19:53:38 <Arkady_Kanevsky> theme will spend multiple releases.
19:53:42 <Shamail> We need to group user stories into epics...
19:53:57 <Arkady_Kanevsky> And with new tag process I am not usre what release is in this connotation.
19:53:58 <Shamail> Themes will probably be very long-lived... epics will span releases.
19:54:04 <Shamail> Arkady_Kanevsky: +1
19:54:13 <Shamail> So as far as epics are concerned, we can go two ways
19:54:37 <Shamail> 1) We can take an approach (as mentioned by johnthetubaguy) and build epics based on service user types
19:54:47 <Shamail> e.g.: 1 epic for cloud native
19:54:51 <Shamail> 1 epic for legacy
19:55:00 <Shamail> since the theme of "HA" would mean different things
19:55:07 <Shamail> OR
19:55:24 <Shamail> We can use epics to define attributes of themes (e.g. controller HA, data plane HA, etc.)
19:55:29 <barrett1> 5 min warning...
19:55:32 <Shamail> and then map user stories to attributes
19:55:34 <Shamail> thx barrett1
19:55:40 <Shamail> Which way makes more sense?
19:56:06 <barrett1> I like the Theme of HA with different epics beneath it...
19:56:13 <Rockyg> I suspect we'll pick one, then modify as we learn more....
19:56:14 <Arkady_Kanevsky> both rae having issues.
19:56:23 <Rockyg> Arkady_Kanevsky: ++
19:56:25 <Arkady_Kanevsky> rae -> are
19:56:27 <cloudrancher> Second makes more sense to me
19:56:27 <Shamail> the user stories are simple -> they map to our files in the repo based on the templates...  Tasks in our sense would be blueprints (each task/blueprint will be in one project but a user story can have multiple tasks/blueprints spanning projects)
19:56:57 <geoffarnold> +1 shamail
19:56:59 <Shamail> Thanks, so we'll proceed with documenting the second one first
19:57:20 <geoffarnold> .... while remaining agile
19:57:24 <Shamail> finally, there is a notion of an acceptance test... which is broader than tempest but in our case its the best we can do.
19:57:35 <Rockyg> high level interrupt:  Just want to put out there that we get much more done on the phone than on IRC.  Just sayin'
19:57:40 <Arkady_Kanevsky> it may sound crazy but maybe tagging for epic is a better way...
19:57:42 <Shamail> We want to ensure there are tests that span the user story to reduce gaps in coverage from the beginning.
19:58:04 <barrett1> #action Shamail to document Theme/Epic/ User Story approach as starting point for M design summit pilot
19:58:05 <Arkady_Kanevsky> where do we put tests? Rally?
19:58:08 <Shamail> Arkady_Kanevsky: that might be the implementation.  We would still have to define what those tags mean... that is what I was intending to capture.
19:58:13 <barrett1> RockyG: +1
19:58:23 <Shamail> Rockyg: +1
19:58:28 <Arkady_Kanevsky> it does not fit into Tempest CI since it span multiple projects
19:58:28 <Rockyg> Shamail: It might be worth having a session with QA in the design summit about user oriented tests
19:58:34 <Shamail> After I finish this document, we can schedule a call.
19:58:41 <Shamail> Rockyg: +1
19:58:41 <geoffarnold> +1
19:58:45 <Rockyg> Arkady_Kanevsky: scenario tests
19:58:46 <barrett1> Do we want to add a voice line for next week's meeting?
19:58:51 <Shamail> barrett1: +1
19:58:57 <Arkady_Kanevsky> +1 on voice
19:58:59 <Rockyg> please, please, please!
19:59:01 <Shamail> Can we extend the time too?
19:59:12 <Shamail> Next week, we will be at crunch time for multiple items
19:59:17 <Rockyg> The foundation has some sort of voice solution, too.
19:59:17 <barrett1> 90 mins? or 2 hrs?
19:59:26 <Shamail> starting to review user stories, taxonomy, user template, sessions, etc.
19:59:32 <Shamail> all will be at crit
19:59:39 <MeganR> I have a voice bridge we can use if needed
19:59:40 <Rockyg> ++
20:00:06 <Shamail> What is the teams vote?   I can do up to 2 hours.
20:00:07 <barrett1> OK - Let's go with 2 hrs, and if some folks have to drop they will. I'll update the wiki with phone info too
20:00:13 <Shamail> Thanks barrett1
20:00:15 <Rockyg> +1
20:00:15 <barrett1> We're out of time....
20:00:20 <Arkady_Kanevsky> 2 hours is fine
20:00:28 <Shamail> Please give feedback on the document I just shared too :)
20:00:34 <barrett1> We'll use the ML to get ourselves set for a long working session for next week.
20:00:38 <barrett1> Thanks everyone!
20:00:39 <Shamail> Sorry for going over.
20:00:39 <geoffarnold> And before we go.... Mid-cycle: please update https://wiki.openstack.org/wiki/Sprints/Product_WGLibertySprint if you're participating
20:01:03 <barrett1> Thanks Geoffarnold
20:01:05 <barrett1> #endmeeting