19:02:03 <barrett1> #startmeeting Product Working Group
19:02:04 <openstack> Meeting started Mon Aug 24 19:02:03 2015 UTC and is due to finish in 60 minutes.  The chair is barrett1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:07 <openstack> The meeting name has been set to 'product_working_group'
19:02:12 <kencjohnston> o/
19:02:19 <johnthetubaguy> o/
19:02:26 <geoffarnold> o\
19:02:29 <barrett1> Roll Call
19:02:55 <barrett1> Hi All
19:03:15 <barrett1> Agenda for today is available: https://wiki.openstack.org/wiki/Meetings/product-team
19:03:23 <Shamail> Hi everyone
19:03:39 <kencjohnston> johnthetubaguy can you join the bridge?
19:04:03 <jcook> o/
19:04:26 <barrett1> #topic Nova Specs & CPL Plans
19:04:40 <johnthetubaguy> kencjohnston: in now :)
19:04:57 <barrett1> Shamail will you lead this?
19:05:28 <barrett1> This is a follow-up from the pre-mid-cycle email thread on how PWG collaborates with Nova
19:08:11 <barrett1> Product WG is looking to both create new user stories, defining new requirements, as well as collaborate on existing requirements and help close resource gaps
19:10:55 <barrett1> We looked through the exisiting Nova priorities in our mid-cycle
19:11:36 <johnthetubaguy> #link https://review.openstack.org/#/c/216167/
19:16:22 <barrett1> Thanks for adding add'l detail - to the project priorities and unresourced priorities
19:16:57 <barrett1> CPL for Nova is Hugh Blemming
19:18:31 <kencjohnston> hughhalf if you are looking for him on irc
19:24:11 <barrett1> Nova is open for new specs now
19:24:27 <barrett1> Would like to have all of the specs submitted well before the Design Summit, not after
19:25:02 <Shamail> Hi barrett1, can you document any outcomes?  Unfortunately, I'm mobile today so talking and typing concurrently won't work. :(
19:26:40 <barrett1> Trying to Shamail...
19:27:40 <barrett1> Testable metrics - this was discussed as an element of a user story - both to communicate performance/scalability/reliability/etc requirements and tests to validate too
19:29:01 <barrett1> Current bar is does the gate stay green
19:29:40 <barrett1> A number people can shoot for, would be v helpful
19:29:49 <Shamail> #action Please review https://review.openstack.org/#/c/216167 to find additional details on the additional items on the nova priorities list.  We should discuss on the ML whether any teams are willing to help with them. - ALL
19:35:57 <barrett1> #action User Story owners: Include a definition of performance target in each story
19:37:48 <barrett1> #action Jesse Cook and Rocky Grober: Get in touch with Tailgaters to discuss performance targets and how we can collaborate with them
19:38:32 <johnthetubaguy> thanks all
19:39:41 <barrett1> #action Follow-up on Testing Non-Functional requirements at our working session in Tokyo
19:40:53 <geoffarnold> Non-functional: performance (latency, request rate), scale (per project, per cloud), availability, upgrade outage
19:41:24 <barrett1> Plan is to use the requirements section in the User Story template to capture the non-functional testing requirements
19:41:48 <barrett1> #topic Mid-cycle Summary & Follow-up
19:42:18 <barrett1> Mid-cycle etherpad:   https://etherpad.openstack.org/p/productwg-liberty-midcycle-meetup
19:42:42 <barrett1> Mid-cycle Action Tracker:   https://docs.google.com/spreadsheets/d/1N7UzJo80F0btlipaPsA5QDVhJJewMBCXmCsJRF1LcWs/edit?usp=sharing
19:43:09 <barrett1> User Story Repository: https://drive.google.com/folderviewid=0BxtM4AiszlEyfm9UTW5LMEQ5cUhHbmFsSkd5WFNfdTMwVFIwRUM1TVFXSHhhWHl6VHlpRzg&usp=sharing
19:43:27 <barrett1> User Story Tracker:  https://docs.google.com/spreadsheets/d/1d1ZKuZ6gsiG6CXXrfONBwAGGHA8SYINbYC9BSPBKllI/edit#gid=1956934401
19:43:40 <barrett1> GitHub Repo: https://github.com/openstack/openstack-user-stories/blob/master/HACKING.rst
19:44:21 <barrett1> Let's walk through the action tracker - this is a consolidation of action items from the 2 days
19:44:51 <Shamail> I missed the link :( (got disconnected)
19:45:36 <barrett1> Shamail: Which do you need?
19:47:46 <barrett1> Updated Operator Tools Repo Action Item
19:48:28 <geoffarnold> Off-topic: on the subject of public clouds: http://www.speakingofclouds.com/?p=381
19:49:30 <Shamail> The action tracker
19:49:47 <barrett1> #action Kenny Johnston Propose an Ops Tools Repo walk thru session to Tom Fifeld for Design Summit in Tokyo
19:50:19 <Shamail> geoffarnold: +1 on the need for a WG
19:50:21 <kencjohnston> Operator Tools Repo - https://github.com/osops
19:50:40 <barrett1> #Action Carol - Break line 32 in the Action Tracker into the 4 User Stories
19:50:41 <Shamail> #link Operator Tools Repo - https://github.com/osops
19:52:11 <barrett1> The 4 User Stories and Owners are:
19:52:33 <barrett1> Capacity/Quota: Geoff Arnold, Steve Gordon, Jesse Cook
19:52:40 <barrett1> This is a compilation of several related user stories – see tracker for details
19:52:47 <barrett1> Lifecycle Management: Arkady Kanesky, Sean Cohen
19:52:53 <barrett1> On-boarding: Jay Kruemcke, Deric Horn
19:52:59 <barrett1> Upgrades: Kenny Johnston , Keith Basil
19:53:04 <geoffarnold> Not sure why all those user stories have a due date of 10/23, since during our conversation last week we were talking of "by Tuesday". I'm finishing mine tonight.
19:53:36 <geoffarnold> (I'm listening to audio, but muted bc of ambient noise)
19:54:22 <jcook> What's the link for the doc that is being actively gone through?
19:54:36 <jcook> this: https://etherpad.openstack.org/p/productwg-liberty-midcycle-meetup ?
19:54:46 <barrett1> jcook: https://docs.google.com/spreadsheets/d/1N7UzJo80F0btlipaPsA5QDVhJJewMBCXmCsJRF1LcWs/edit#gid=1444917275
19:54:49 <jcook> thanks!
19:54:53 <geoffarnold> Right - I was confused about the uniform Tokyo date
19:54:57 <geoffarnold> yes
19:55:03 <Shamail> #link Generated HTML pages - http://specs.openstack.org/openstack/openstack-user-stories/
19:55:34 <barrett1> #Action Carol add 4 top priority user story creation added to tracker
19:57:32 <barrett1> Work flow for User Stories: Initial version goes into Draft; Comments, enhancements, etc are worked via Draft
19:58:30 <barrett1> When someone indicates a resource commitment to a User Story in Draft, it transitions to Proposed
20:02:42 <barrett1> Reminder: User Stories should be in the Draft repo ahead 8/31 team meeting
20:02:44 <barrett1> #endmeeting