21:02:34 <barrett> #startmeeting Product Working Group
21:02:35 <openstack> Meeting started Mon Nov 30 21:02:34 2015 UTC and is due to finish in 60 minutes.  The chair is barrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:39 <openstack> The meeting name has been set to 'product_working_group'
21:02:49 <hughhalf> o/
21:02:55 <kencjohnston> o/
21:03:00 <barrett> #topic roll call
21:03:02 <kencjohnston> I'm IRC only today
21:03:18 <thingee> o/
21:03:21 <hughhalf> o/
21:03:24 <barrett> #chair sarob
21:03:25 <openstack> Current chairs: barrett sarob
21:03:27 <sarob_> o/
21:03:37 <sarob_> sarob_
21:03:40 <sarob_> This time
21:04:21 <barrett> #chair sarob_
21:04:21 <openstack> Current chairs: barrett sarob sarob_
21:04:28 <leong> o/
21:05:18 <sarob_> Searching
21:05:29 <barrett> #agenda: https://etherpad.openstack.org/p/PWG_11_30_15
21:06:26 <barrett> #topic: rolling upgrades user story update - Leong & Kenny
21:07:02 <barrett> Kenny/Leong - Can you give an update and let us know where help is needed or issues?
21:07:31 <barrett> Kenny - You still here?
21:07:33 <kencjohnston> We continue to need additional reviews of the user story
21:07:56 <kencjohnston> And I have the action to update the user story with references to the blueprints underdevelopment in the Mitaka cycle
21:08:20 <kencjohnston> Once those are updated I'll send around a link and ask for product help in pushing those blueprints to completion
21:08:29 <barrett> I wonder if we want to use a team meeting to review the user story?
21:08:43 <sarob_> What's a team meeting?
21:09:09 <kencjohnston> It is a task that is very accommodating to being done asynchronously
21:09:19 <sarob_> Ah
21:09:23 <barrett> I meant this weekly team meeting - add an agenda item and dedicate a significant amount of time to it
21:09:29 <sarob_> Right on
21:09:47 <kencjohnston> I'd be happy to, but it seems like we could use our time for better purposes
21:09:56 <kencjohnston> and I'd want the review to happen as much in gerrit as possible
21:10:00 <leong> the link for rolling user story is here: http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/rollingupgrades.html
21:10:15 <sarob_> Gerrit is the place to collaborate
21:10:29 <leong> agree.. should try to use gerrit for review
21:10:36 <barrett> good point kencjohnston - was thinking we could take advantage of having people at the meeting
21:10:47 <sarob_> Here is the place for sprint update, like a need more reviews
21:10:59 <kencjohnston> sarob_ +1
21:11:02 <barrett> Is there anything preventing people from reviewing the user story today?
21:11:05 <barrett> or is it just time?
21:11:16 <sgordon> is there actually a gerrit review open for this?
21:11:25 <sgordon> (the above link is to a committed item?)
21:11:52 <kencjohnston> I'll make this offer, if you are intimidated by the change/commit process you can send me offline comments/suggestions and I'll add them
21:12:21 <kencjohnston> sgordon I guess I should say git not gerrit, our process was to accept items to draft folder, and then ask for changes to them
21:12:30 <sgordon> right
21:12:38 <sgordon> this is one of my concerns i guess about that process
21:12:45 <thingee> +1
21:12:46 <sarob_> What is the outstanding tasks for rolling upgrades user story?
21:12:49 <sarob_> Are
21:12:50 <sgordon> in that once it's merged there is no way to do inline comments
21:12:50 <sarob_> That is
21:12:56 <barrett> sgordon - can you say a few more words on your concern?
21:13:15 <thingee> barrett: typically an item is considered draft when it's in review.
21:13:16 <sgordon> simply that, we merge stuff to draft very quickly
21:13:26 <sgordon> but then there is no way to do inline commenting - because it's merged
21:13:29 <thingee> is there some gain by this process?
21:13:32 <kencjohnston> sgordon Agreed we thought it was more important to get it to a place where more people could view it via HTML
21:13:40 <sgordon> kencjohnston, you can do that anyway
21:13:46 <sgordon> kencjohnston, one of the jenkins jobs creates html
21:14:08 <sgordon> although that may not be set up for this repo
21:14:10 <sarob_> New patch for this
21:14:11 <sgordon> it is for e.g. nova-specs
21:14:17 <leong> there are three status of User Story: Draft, Proposed and Tracked
21:14:19 <sgordon> (and docs for that matter)
21:14:25 <kencjohnston> sgordon ahh - I didn't know that. Honestly shamail might have had some additional logic for why we accepted to draft
21:14:55 <leong> All user stories today are in Draft folder
21:15:01 <kencjohnston> There is one in proposed
21:15:03 <kencjohnston> :)
21:15:06 <leong> The only user story in Proposed folder is "Rolling Upgrade"
21:15:27 <kencjohnston> This might need to be added to another agenda item for next week
21:15:28 <sgordon> kencjohnston, so for example if i go to https://review.openstack.org/#/c/251442/ which you submitted and click "toggle ci" the jenkins comment includes the link to html
21:15:28 <barrett> Is there any reason not to use patches to a user story as the mechanism for making comments/changes?
21:15:32 <sgordon> even though it isn't merged yet
21:16:43 <kencjohnston> There are pros and cons for both approaches, we don't have a lot of reviewers on this project for gerrit review.
21:16:52 <kencjohnston> That might be a problem of our own creation though.
21:17:24 <kencjohnston> Again, my suggestion, let's add it as a topic for a later meeting. We should revisit the process and conform to community standards.
21:17:25 <leong> The workflow is here: https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
21:17:57 <barrett> Leong - Thanks.
21:18:13 <barrett> Do we need to be more specific on the "comments can be made.."?
21:18:57 <barrett> #action: Carol add work flow discussion to next team meeting agenda
21:19:07 <sarob_> Good plan
21:19:25 <thingee> so far the only advantage I have read is so we can see it as HTML. How often are the documents really hard to parse in raw rst format?
21:19:47 <thingee> I mention this just because this is the only group I have seen take this approach for this advantage.
21:20:39 <thingee> this document for rolling upgrades for example is not really complex. it's some bullet points.
21:20:48 <barrett> thingee - We took this approach because not everyone in the team is familiar with rst, gerrit or git and we wanted to lower the barriers to participation
21:21:29 <barrett> I'll add that to the agenda item for the next meeting too
21:22:08 <barrett> Kencjohnston: anything else? Do you think you are on track for Mitaka deliverables? And N-design summit?
21:22:18 <thingee> barrett: so this is difficult to read raw? https://raw.githubusercontent.com/openstack/openstack-user-stories/master/user-stories/proposed/rollingupgrades.rst
21:23:03 <barrett> thingee: I think it's readable
21:23:08 <sarob_> Me too
21:23:11 <kencjohnston> barrett Nope, nothing else. We haven't defined Mitaka deliverables in the user story, but I will be next week.
21:23:32 <barrett> kencjohnston: thanks, will look for an update again next week.
21:23:48 <hughhalf> I must admit I'd not thought of it until thingee pointed it out - but yes the RST is hardly tricky to parse by a human.  Maybe we are doing ourselves a disservice here ?
21:24:11 <barrett> Next up is Onboarding Legacy apps.
21:24:20 <barrett> Gerd - Are you here?
21:24:21 <sarob_> Link to the rst would save time and stale data
21:24:25 <leong> as part of the "workflow", we need to dedicate/allocate resources to work on the User Story/Blueprint for Rolling Upgrade
21:24:43 <barrett> Do we want to have the work flow conversation now?
21:25:37 <kencjohnston> I vote for keeping the current agenda
21:26:30 <sarob_> #top#topic onboarding legacy applications
21:26:41 <sarob_> Arg
21:26:45 <barrett> Ok - we'll stay with the current agenda. Maybe we should air the work flow discussion on the ML ahead of next week's meeting. Any volunteers to start that?
21:26:47 <hughhalf> I think workflow is important, but lets discuss that on list and/or put on agenda for next meeting
21:26:52 * hughhalf nods at barrett
21:27:03 <leong> agree! :)
21:27:28 <barrett> #action Sarob Start ML discussion on Work Flow, with goal to close any changes in our team meeting next week
21:27:35 <Arkady_Kanevsky> hello everybody
21:27:36 <sarob_> #topic onboarding legacy applications
21:27:40 <barrett> Gerd - Are you here?
21:28:03 <barrett> Moving along....Onboarding Hosts and VM into Openstack for management
21:28:08 <sarob_> #topic onboarding hosts and VMs
21:28:13 <barrett> Jay or Deric - are you here?
21:28:48 <barrett> ok .....
21:28:51 <sarob_> #topic complex instance placement
21:29:04 <barrett> #topic Complex Instance Placement - Steve
21:29:11 <barrett> sgordon - any update?
21:29:15 <sgordon> #link https://review.openstack.org/#/c/251442/
21:29:33 <sgordon> integrates calum's feedback from the original proposal
21:30:09 <sgordon> so currently awaiting further feedback on that
21:30:14 <sgordon> it was the only incomplete section
21:30:15 <kencjohnston> Yeah, that was me this morning. barrett can you review?
21:30:44 <leong> (sorry was distracted :-) for "onboarding hosts", IBM shared a presentation about PowerVC onboarding process in the previous meeting.
21:30:45 <leong> https://drive.google.com/open?id=0B0gXxpcL9MhGUHAtS2p5R3EwbHc
21:30:47 <barrett> kencjohnston - yes, will review after the meeting
21:31:00 * kencjohnston barrett Thanks!
21:31:05 <leong> sorry i'm slow..:-)
21:31:31 <barrett> Leong - hang on a sec, we'll come back to that one
21:31:36 <leong> anyone can check out the link above if you are interested..
21:31:40 <leong> i'm done with that.. :-)
21:31:44 <leong> pls continue.. :-)
21:32:03 <barrett> sgordon - anything else?
21:32:22 <sgordon> nope not at this time
21:32:29 <barrett> sgordon - thanks.
21:32:44 <barrett> #topic onboarding hosts and VMs
21:33:04 <barrett> #link:  https://drive.google.com/open?id=0B0gXxpcL9MhGUHAtS2p5R3EwbHc
21:33:27 <barrett> Leong: is the presentation an approach to implementing the user story or ?
21:33:47 <leong> that's the approach that IBM PowerVM is working on
21:34:06 <leong> haven't decided on the approach on get that "upstream"
21:34:20 <barrett> OK
21:34:36 <leong> Platform9 also share a presentation previously on their approach
21:34:51 <barrett> Do you have a link to that?
21:35:05 <sarob_> Page 8, 11
21:35:23 <sarob_> Can be retooled into a user story
21:35:28 <sarob_> Format I think
21:35:33 <leong> platform9: https://drive.google.com/drive/u/0/folders/0B0gXxpcL9MhGMy1tOU5ZbEFjRVU
21:35:56 <barrett> sarob: ?
21:36:18 <barrett> #link platform9:  https://drive.google.com/drive/u/0/folders/0B0gXxpcL9MhGMy1tOU5ZbEFjRVU
21:36:47 <leong> #link platform 9 presentation: https://drive.google.com/file/d/0B0gXxpcL9MhGYl9FUlk0eVlmenc/view
21:38:18 <barrett> Any other User Stories for updates?
21:38:30 <hughhalf> none from me at this point
21:39:01 <barrett> (for arkady): There is the database hygiene - Leong are you going to submit this or should Arkday?
21:39:03 <Arkady_Kanevsky> DB hygiene. Leong do you want me to resubmit it or do you want me do it?
21:39:09 <leong> sorry i haven't got time to review the DB-hygiene.
21:39:12 <sarob_> #topic db hygiene
21:39:41 <leong> Arkday: can you resubmit that?
21:39:46 <Arkady_Kanevsky> sure
21:40:12 <leong> https://review.openstack.org/#/c/237178/
21:40:20 <barrett> #action Arkady resubmit DB-Hygiene
21:40:37 <barrett> Good - Any other User Stories we want to cover?
21:40:43 <sarob_> Any other user stories?
21:40:46 <sarob_> Oops
21:41:06 <sarob_> #topic midcycle planning
21:41:34 <barrett> #link https://etherpad.openstack.org/p/PWG_Mitaka_Midcycle
21:41:38 <sarob_> Thanks
21:41:51 <barrett> I think we're still waiting on the final plans for the Ops Mid-cycle
21:42:20 <barrett> Are there any additions or comments on the agenda?
21:42:40 <sarob_> Looks right to me
21:43:10 <leong> Looks good on agenda
21:43:52 <kencjohnston> I think this was discussed last week, but Rackspace is willing to host a UK event at our London office if we end up deciding to hold the meeting there.
21:43:55 <kencjohnston> I'll add a note to the Etherpad.
21:44:00 <sarob_> Cool
21:44:09 <barrett> kencjohnston - Thanks
21:44:23 <sarob_> Maybe the operator midcycle as well?
21:44:41 <sarob_> At rax London?
21:44:47 <kencjohnston> I think that is already scheduled in Manchester
21:45:05 <sarob_> Oh duh, right
21:45:07 <kencjohnston> But if it isn't I can look into it.
21:45:32 <sgordon> it is
21:45:32 <barrett> kencjohnston - you might want to reach out to Tom
21:45:34 <Arkady_Kanevsky> Mr. grodron I commented on complex use case for groups
21:45:43 <barrett> nevermind....
21:45:56 <barrett> Let's revisit the timing and location of our Midcycle next week and if we have a final decision on Ops Midcycle, let's try to finalize our location and date
21:46:16 <Arkady_Kanevsky> does operator/user WG plan second midcycle in USA?
21:46:25 <barrett> #action Carol add Midcycle planning to agenda for next week and bring current status on Ops Midcycle
21:46:35 <kencjohnston> Arkady_Kanevsky That is the outstanding question.
21:46:51 <sarob_> Do we want to discuss a f2f in Portland in addition to UK no matter what
21:47:08 <sgordon> barrett, tbh i dont believe there was going to be a second mid-cycle
21:47:24 <sgordon> barrett, there was discussion of having more regional ops *events*
21:47:29 <sgordon> barrett, but one mid-cycle
21:47:40 <barrett> sgordon - Thanks for the clarification
21:47:56 <sarob_> That's started happening a bit already
21:47:57 <sgordon> there was certainly a fair bit of back and forth on this but there is still only one mid-cycle planned
21:48:07 <sgordon> right exactly
21:48:18 <sarob_> Plus the larger operators
21:48:31 <barrett> sgordon - do you know if the location/date are set and not going to move?
21:49:35 * hughhalf nods noting that tallies in with his reading of ML traffic on the topic
21:50:26 <barrett> Let's finalize this next week - what our plans are for covering (at a minimum) the Ops Mid-Cycle and where/when we want to have ours.
21:50:39 <barrett> #topic Opens
21:50:54 <barrett> Anyone have opens to share?
21:51:33 <hughhalf> None for me
21:51:37 <leong> nope
21:51:40 <kencjohnston> None for me
21:51:49 <sarob_> I posted to the ML on how to hold these meetings
21:52:00 <barrett> FYI - There's a board meeting on Thursday. You can find more info here: https://wiki.openstack.org/wiki/Governance/Foundation/3Dec2015BoardMeeting
21:52:00 <sarob_> My opinion!
21:52:14 <barrett> Thanks Sarob_
21:52:39 <barrett> If there's nothing else, let's all get back 8 mins....
21:52:48 <sarob_> anyone can attend the bod meeting btw
21:53:09 <Arkady_Kanevsky> how does one update wiki - http://specs.openstack.org/openstack/openstack-user-stories/?
21:53:40 <barrett> arkady: it's updated automatically, once merged
21:54:13 <leong> that's still under review.. so is not "merged" in the Draft folder yet
21:54:24 <barrett> anything else
21:54:26 <barrett> ?
21:54:28 <sarob_> It's it for me
21:54:31 <Arkady_Kanevsky> got it. still expected it to be listed in the wiki
21:54:39 <barrett> #endmeeting