21:00:39 <barrett> #startmeeting Product Working Group
21:00:40 <openstack> Meeting started Mon Dec  7 21:00:39 2015 UTC and is due to finish in 60 minutes.  The chair is barrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:44 <openstack> The meeting name has been set to 'product_working_group'
21:00:58 <barrett> Hi Folks - Who is here for the Product WG team meeting?
21:01:07 <pchadwick> I'm hre
21:01:08 <pchadwick> here
21:01:12 <pchadwick> Hi Carol
21:01:19 <leong> o/
21:01:19 <kencjohnston> o/
21:01:20 <barrett> HI Pete
21:01:43 <scohen1> o/
21:01:54 <cloudrancher> o/
21:02:06 <dpk_> o/
21:02:35 <sgordon> o/
21:02:54 <MeganR> o/
21:03:09 <barrett> great
21:03:13 <barrett> #topic Agenda
21:03:25 <barrett> #link:  https://wiki.openstack.org/wiki/Meetings/product-team#December_7.2C_2015_Product_Team_Meeting_Agenda
21:03:34 <barrett> You can find the agenda for today at the link
21:03:43 <barrett> #topic User Story Updates
21:04:00 <barrett> Leong & Kenny - Can you lead off with an update on Rolling Upgrades?
21:04:04 <kencjohnston> Sure
21:04:11 <barrett> Thanks
21:04:32 <kencjohnston> Frankly not much movement since last week. I've been compiling updates to the User Story in the form of a gaps analysis
21:04:37 <kencjohnston> which has been happening offline
21:04:48 <kencjohnston> I need to contribute those ammendments
21:05:08 <barrett> Do you have a target date for the completion of the gaps analysis?
21:05:20 <kencjohnston> but work is being planned, across versioned object support, schema migration, and live migrate
21:05:33 <kencjohnston> I'd like to make the ammendments to teh user story on Wednesday.
21:05:35 <leong> based on the current product wg workflow, i wondering if we should move this rolling upgrade user stories to "tracked"
21:05:45 <leong> #link: https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
21:05:45 <rockyg_> o/
21:05:59 <kencjohnston> leong I would think we need the gaps analysis first to target what we are tracking
21:05:59 <barrett> Hi Rockyg
21:06:15 <kencjohnston> But I agree that we should be able to do that this week
21:06:21 <barrett> Leong - Great point.
21:06:23 <leong> Gap Analysis is in phase "track"
21:06:27 <kencjohnston> I've broken down what is in flight for the Mitaka release
21:06:31 <Arkady_Kanevsky> no phone bridge today?
21:06:33 <kencjohnston> oh, sorry, I didn't read the link :)
21:06:38 <kencjohnston> then yes we should promote it to tracked
21:06:47 <kencjohnston> leong I can do that when I commit the gaps analysis changes
21:06:57 <barrett> arkady_kanevsky: nope, we're going IRC only for our team meetings starting today
21:07:07 <Arkady_Kanevsky> ok
21:07:10 <barrett> kencjohnston: +1
21:07:12 <kencjohnston> or we can do it today. It is definitely resourced.
21:07:15 <Shamail> (hi all, sorry for being late)
21:07:17 <leong> for Proposed stage, the next criteria to move into "tracked" is commit resource
21:07:22 <barrett> Hi Shamail
21:07:29 <leong> hi shamail
21:07:41 <kencjohnston> barrett OK, if there isn't any other thoughts I'll plan on doing that.
21:07:45 <leong> we are proposing moving "rolling upgrade" into "tracked"
21:07:49 <kencjohnston> Can I register an action for myself?
21:07:57 <Arkady_Kanevsky> so need to be done to move it to tracked? just move from one diretcory to another?
21:08:05 <sgordon> i believe a chair needs to record actions (or chair someone to do it)
21:08:06 <barrett> kencjohnston: No, but I will do it for you :)
21:08:08 <kencjohnston> Arkady_Kanevsky correct
21:08:26 <barrett> #action Kencjohnston move Rolling Upgrades to Tracked folder
21:08:38 <kencjohnston> actually, for review purposes I'll split them up.
21:08:50 <kencjohnston> I'll first move it to tracked, since the gaps anayslsis isn't required and we can all review that commit
21:09:04 <Shamail> kencjohnston: +1
21:09:04 <kencjohnston> then I'll add the gaps analysis so we can comment on that one separately
21:09:09 <kencjohnston> I'll do the tracked thing tonight.
21:09:36 <Shamail> I'll go ahead and create a fracker template in the repo too... That way we can at least populate the necessary information even if the final place is tbd
21:09:36 <barrett> kencjohnston: Sounds good. Will the gaps analysis be in a Google doc or are you going to create something that can be posted to repo?
21:09:45 <Shamail> Tracker*
21:09:52 <barrett> shamail: +1
21:10:08 <kencjohnston> Shamail oh, great, I was going to do it via text in the user story
21:10:20 <Shamail> Can you please assign that action to barrett?
21:10:29 <kencjohnston> Shamail process wise? DO I upload a version of the template into the tracked folder?
21:10:32 <leong> can the gap analysis be created in repo?
21:10:48 <barrett> #action Shamail to create a Tracker template and post to repo
21:10:57 <Shamail> It's actually supposed to live outside since the user story can change and others could fall under the same tracker eventually
21:11:10 <Shamail> Yes Leong, makes sense
21:11:28 <Shamail> My first reply was to tracker, not gap analysis
21:11:46 <barrett> Shamail - I'm confused. Are you going to post a tracker template to the Repo?
21:12:52 <Shamail> Yes barrett... It will have fields like blueprints, specs, market segments, team, etc
21:13:00 <barrett> Great.
21:13:05 <barrett> Anything else on Rolling Upgrades?
21:13:16 <kencjohnston> barrett Shamail I'll get with shamail on the process offline
21:13:23 <kencjohnston> nothing else for me
21:13:30 <Arkady_Kanevsky> do we have a user story for update not upgrade?
21:13:47 <Arkady_Kanevsky> that is minor version not major version change?
21:14:03 <annilai> good question
21:14:13 <pchadwick> what is the definition of a minor version?
21:14:17 <kencjohnston> Arkady_Kanevsky I think they have all been rolled in together
21:14:22 <leong> u mean like "patches"?
21:14:23 <barrett> Arkady_kanevsky: What is the difference?
21:14:43 <Arkady_Kanevsky> think of liberty.0 vs. liberty.1
21:15:00 <kencjohnston> The user story includes "Immediate Upgrade" to capture CVEs and other security patches
21:15:15 <Arkady_Kanevsky> some bug fixes do fix schema or ohter things that impact updgrade
21:15:32 <Arkady_Kanevsky> but the only version tested for upgrade is GA release
21:15:36 <barrett> sounds like the intention is to cover them.
21:15:51 <Arkady_Kanevsky> agree on intension.
21:15:59 <barrett> Arkady_Kanevsky: Can you review the user story and add comments where you think there are gaps?
21:16:16 <rockyg_> ++
21:16:19 <sgordon> mmm, bug fixes from where?
21:16:21 <Arkady_Kanevsky> give me that AI.
21:16:38 <rockyg_> stable branch
21:16:41 <Arkady_Kanevsky> I was justing if that is udner upgrade story or we want seperate story for update scenarios.
21:16:41 <sgordon> anything that requires a schema upgrade is more likely part of the "major version" upgrade
21:16:41 <leong> that might be cover under Usage Scenario section
21:16:47 <sgordon> yeah but stable branch doesnt allow that
21:16:50 <sgordon> kind of my point
21:17:06 <barrett> #action Arkday Kanevsky: Review the Rolling Upgrade User story and add comments describing any gaps for updates
21:17:13 <leong> #link: http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/rollingupgrades.html
21:17:17 <Shamail> sgordon: +1 and barrett: +1 to comments on user story
21:17:18 <Arkady_Kanevsky> thank you
21:17:28 <barrett> Let's move on....
21:17:54 <barrett> Jay/Deric can you give an update on Onboarding Hosts?
21:18:02 <cloudrancher> sure
21:18:06 <barrett> Thanks
21:18:14 <cloudrancher> We added new members from Platform9 as outcome from Tokyo
21:18:22 <cloudrancher> So we have been taking turns explaining each teams approach to onboarding: Platform9 and IBM PowerVC team
21:18:36 <cloudrancher> Each team approaches has gaps and advantages
21:18:48 <cloudrancher> Presentations in Onboarding Google Drive https://drive.google.com/drive/u/0/folders/0B0gXxpcL9MhGMy1tOU5ZbEFjRVU
21:19:29 <cloudrancher> we decided to split the blueprint drafts into three parts. Cinder changes, Neutron changes and a new project that will interact with Nova
21:19:55 <cloudrancher> that was just done last week. Unfortunately we have been slow due to RealJob(TM) workloads
21:20:09 <barrett> :)
21:20:11 <cloudrancher> so we have the new drafts in the google drive
21:20:42 <cloudrancher> and will be discussing this Friday. We are still using voice bridge for now, but will be adding IRC
21:20:52 <kencjohnston> cloudrancher - what is driving separating the overall story?
21:21:09 <cloudrancher> if anybody could sent a scheduling IRC meetings dummies guide that would be good
21:21:31 <leong> is the "onboarding resource" user stories ready to move into "proposed"?
21:21:35 <Arkady_Kanevsky> for new platforms is there a requirement for Ironic?
21:21:40 <cloudrancher> so, overall, taking lots of time and the new project is going to be a real challenge
21:21:42 <Shamail> I thought blueprints were being split, not user story?
21:21:47 <cloudrancher> no Ironic at this time
21:22:02 <kencjohnston> Shamail Ahh, I see, sorry I can't read. Makes sense
21:22:16 <cloudrancher> keeping it simple but Nova was pretty clear we need to be in a new project
21:22:29 <cloudrancher> and nobody on the team has done that yet
21:22:44 <cloudrancher> but overall we are makign progress
21:23:18 <barrett> cloudrancher: what's your timeframe for moving from Draft to Proposed?
21:23:19 <cloudrancher> thats about it. We will probaly have last meeting this week due to holidays, then restart in Jan.
21:23:39 <cloudrancher> I think we need to spend more time on the blueprints first
21:23:51 <cloudrancher> so Jan it probably the best
21:24:20 <cloudrancher> in reality it is unlikly we will get anything into Mitaka other than PTL awareness
21:24:27 <barrett> Blueprints aren't required for this per our work flow
21:24:38 <leong> sorry... pls correct me if i'm wrong.. based on the "workflow", the "blueprint" is address in "Tracked
21:24:46 <cloudrancher> yes, but I think we need to get a better idea of what we are trying to do
21:25:03 <cloudrancher> the Platform9 team had a much broader scope with VMWare
21:25:15 <cloudrancher> and the IBM team had more SAN and Neutron than Platform9
21:25:28 <cloudrancher> so - things are moving around a bit
21:25:30 <Shamail> leong: correct... I agree with Barrett about possibly considering a move to proposed... You can still refine items...
21:25:30 <barrett> Moving from Draft to proposed requires a good user story write-up that describes the requirements, etc.
21:25:34 <barrett> Not the solution
21:25:53 <Shamail> Barrett: +1
21:25:55 <leong> i think at this stage ("draft"), the team should focus on the "stories" or "problem statements" but not so much on "blueprint".
21:25:55 <barrett> See the work flow here:
21:25:58 <barrett> #link: https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
21:25:58 <cloudrancher> right. I'd like to give it a few more weeks because the requirements may change
21:26:37 <cloudrancher> The intial user story was a one way trip to OpenStack from KVM/other but the Platform9 approach was two way
21:26:56 <cloudrancher> so, there was lots of value in that and it's not reflected in the User Story right now
21:26:59 <leong> if the team thinks that the existing "stories/problem statements" is sufficient, then it can be considered moving into "proposed"  or even "tracked"
21:27:02 <pchadwick> Isn't that "outboarding"?
21:27:31 <pchadwick> If we want to do it bi-directionally, then it should be called migration or something.
21:27:48 <pchadwick> FWIW, most of the customers I talk to view it as one-way.
21:27:49 <cloudrancher> it's interesting because the two way capabiloity allows for leveraging both management interfacs
21:27:55 <Shamail> pchadwick: +1
21:27:57 <cloudrancher> we may end up there
21:28:05 <Shamail> I wouldn't want that part delaying the rest of it...
21:28:13 <pchadwick> shamail: +1
21:28:14 <barrett> pchadwick: this is about onboarding infrastructure for the purpose of tracking...not onboarding legacy apps
21:28:37 <pchadwick> right - and once the infrastructure is there, why would anyone move it back?
21:28:40 <cloudrancher> I won't think it will, but adding abotu 30% more team is taking some time to integrate views
21:28:50 <barrett> cloudrancher: pls look over the work flow. If you really need more time to capture the requirements fine. I'd like to see us follow the work flow as much as we can, as we execute through it theses first couple of times to test it out and be ready to refine it at our midcyle in Feb
21:29:00 <leong> the current "onboarding infrastructure resources" are leaning towards a "two-way" capabilities rather than just "one-way" migration.
21:29:03 <cloudrancher> ok. I'll work on
21:29:07 <cloudrancher> it a bit
21:29:27 <cloudrancher> I'm just saying we need a bit more time to digest
21:29:40 <barrett> OK - Any other comments/questions on this one?
21:29:51 <cloudrancher> nope. thats it for now
21:29:56 <barrett> Thanks
21:30:09 <barrett> Next up is Onboarding Legacy Apps - Gerd are you here?
21:30:59 <barrett> I think that team is still in the forming stage. I will connect with Gerd offline and ask him to send an update on the ML.
21:31:01 <leong> Gerd has drafted a Google Doc here to kick start the process.
21:31:05 <leong> #link: https://drive.google.com/open?id=122EzpeD2d-ZzpGyoruoOANCNvQv-ms70og6neQCMpsk
21:31:14 <barrett> Thanks LEong
21:31:30 <barrett> Next up is Complex Instance Placement - Steve can you give an update?
21:31:47 <Shamail> Ping ago rdon
21:32:01 <Shamail> Ping sgordon
21:32:06 <sgordon> mmmyes
21:32:09 <barrett> Thanks
21:32:25 <sgordon> although i briefly lost my link, second
21:33:06 <sgordon> so the open review for updates is
21:33:08 <sgordon> #link https://review.openstack.org/#/c/251442/
21:33:24 <sgordon> i haven't had a chance to integrate the feedback as yet
21:33:51 <kencjohn_> ok, I think barrett is ready to approve once you and Callum get to a consensus point
21:34:26 <barrett> kencjohn: +1 It seemed like there was some discussion going on with Arkday
21:35:12 <Arkady_Kanevsky> I +1 it already and I am original owner
21:35:29 <Arkady_Kanevsky> but I do not have +2 priviliges
21:35:48 <kencjohn_> Arkady_Kanevsky Actually you -1'd
21:35:52 <barrett> Are all of the questions resolved sgordon?
21:35:54 <sgordon> ???
21:35:59 <sgordon> yeah and you arent the original owner
21:36:00 <sgordon> lol
21:36:08 <Shamail> Arkady_Kanevsky: I believe you are referring to lifecycle management, not CIm
21:36:11 <sgordon> it's all from calum
21:36:17 <Shamail> CIM*
21:36:17 <sgordon> with minor edits
21:37:04 <Shamail> Please let us know once you and Calum close the loop.
21:37:11 <sgordon> will do
21:37:13 <barrett> shamail +1
21:37:28 <barrett> OK - Any other User Stories to be discussed?
21:37:39 <kencjohn_> one quick note on the ROlling upgrades
21:37:48 <kencjohn_> #link ttps://review.openstack.org/254389
21:37:53 <kencjohn_> is a review to promote to Tracked
21:38:03 <leong> one more user story: db_hygience
21:38:14 <leong> i think db_hygience is ready to merged into "draft", now pending "core reviewer" approval.
21:38:23 <barrett> kencyjohn: +1
21:38:23 <kencjohn_> ack bad link
21:38:23 <leong> #link: https://review.openstack.org/#/c/237178/
21:38:33 <Shamail> Thanks kencjohn_ and me ong
21:38:47 <Shamail> leong*
21:38:54 <kencjohn_> #link https://review.openstack.org/#/c/254389/
21:39:00 <Shamail> My mobile IRC client is bad.
21:39:24 <barrett> Thanks Leong - will check the user story and make comments.
21:39:30 <barrett> Anything else?
21:40:10 <barrett> #topic Mid Cycle Planning
21:40:49 <barrett> As far as I can tell Ops is set on 2/15 & 16 in Manchester
21:41:12 <barrett> Rackspace has offered to host our Midcycle at their London offices right after that
21:41:13 <leong> are we going to meet in Manchester or London? or both?
21:41:19 <Shamail> I had an action to confirm whether Manchester is the "official" ops summit.  I sent an email on the ops list but did not hear back... I think based on what I've seen... Manchester is the main one this time
21:41:31 <Shamail> Although others might happen in North America, Asia still
21:41:51 <kencjohn_> leong I thinkt he idea is yes, Ops meetup in Manchester, three hour train to London and then PWG Mid-Cycle
21:41:57 <Shamail> leong: we would need to do both if we are co-locating
21:42:05 <barrett> Shamail: I think Manchester is the offical one and satelite ops meetups might happen
21:42:28 <leong> i see...need to add that into travel plan for approval.. :-)
21:42:33 <barrett> kencjohn: That is the proposal
21:42:33 <Shamail> Yep. That's the likely scenario
21:42:53 <barrett> Who would not be able to make a meet-up in London in Feb?
21:43:12 <rockyg_> Do we have better dates on that?
21:43:22 <kencjohn_> 2/17-18
21:43:31 <rockyg_> Cool.  I can make that.
21:43:34 <barrett> kencjohn_ +1
21:43:42 <cloudrancher> I'm doubtful I could go at this point
21:43:54 <pchadwick> should be ok for me
21:43:59 <MeganR> I need to put in for approval, so I am tentative at this point
21:44:03 <Shamail> Thanks kencjohn_
21:44:13 <leong> mine also pending approval
21:44:17 <Arkady_Kanevsky> I will not be able to make it to Manchester.
21:44:23 <barrett> cloudrancher: Can you check it with your management?
21:44:26 <Shamail> I can confirm after January but no conflicts
21:44:32 <Arkady_Kanevsky> should be able to make it in USA.
21:44:38 <barrett> Megan: Can you check with your management?
21:44:40 <cloudrancher> I'll have to check after Jan
21:45:05 <barrett> I was hoping to nail down date and time by end of next week.
21:45:13 <MeganR> @barrett: I probably won't know until after the holiday - that's the main focus right now
21:45:22 <barrett> MeganR: Understand
21:45:24 <Shamail> ill try to confirm before then...
21:45:44 <Shamail> MeganR: welcome to retail :)
21:45:53 <kencjohn_> barrett Should we ask the reverse, who can confirm today?
21:45:58 <barrett> Megan, Cloudrancher: Getting confirmation in Jan would apply to a UK based midcycle or US base midcycle, right?
21:46:01 <leong> or do we want to plan for a USA meet-up, seems like more people can do in USA
21:46:01 <MeganR> :)
21:46:14 <annilai> i most likely can make it to Manchester
21:46:25 <Shamail> I think co-location withs ops summit is important...
21:46:26 <annilai> US is better
21:46:32 <rockyg_> Maybe we send emissaries to England and meet in US?
21:46:39 <MeganR> @barrett: I am aiming for Manchester - have already mentioned it to mgmt.
21:47:02 <barrett> We could do 2 things: Have a subset of our team attend Ops in Manchester and then have a US based midcycle immediately afterwards
21:47:05 <Shamail> rockyg: that might make approval for some harder... The "2-in-1" value prop wouldnt exist
21:47:08 <pchadwick> Just to be clear, we would attend the Ops Summit and then have the Product meeting?
21:47:14 <kencjohn_> I'm happy to be the emissary but I likely won't make a US meetup if I travel for the Ops mid-cycle
21:47:17 <sgordon> i believe we had at least two folks who cand make it
21:47:20 <sgordon> *can
21:47:23 <barrett> pchadwich: +1
21:47:43 <leong> what about this: everyone pls check with manegement approval and feedback early Jan (give a date).
21:48:02 <leong> if majority people cannot got, then plan for a local USA meetup?
21:48:02 <annilai> I can
21:48:06 <kencjohn_> Shamail rockyg_ I'd be affected by the lack of 2-in-1
21:48:21 <rockyg_> OK.  Good to know.
21:48:49 <Shamail> I could foresee the same... I can easily justify our mid-cycle but would have a hard time making tbe ops summit without it
21:49:00 <MeganR> +1
21:49:20 <barrett> We can put this on the agenda for 1/11 meeting. Everyone pls work on understanding what they can do ahead of that meeting.
21:49:21 <leong> time track.. we have less than 10 minutes
21:49:25 <pchadwick> This team meeting would be more important for me as well.
21:49:28 <barrett> Leong: Thanks
21:49:46 <barrett> #topic Stable Branch Project
21:49:55 <Shamail> barrett: lets revisit next week?  While all of us try to figure out commit for UK?
21:49:55 <barrett> RockyG - Can you take this one?
21:50:22 <barrett> Shamail: +1
21:50:29 <rockyg_> Yah.  So a very quick write up here:https://etherpad.openstack.org/p/Stable_Release_Maintenance_-_Prod_WG
21:50:44 <barrett> #link: https://etherpad.openstack.org/p/Stable_Release_Maintenance_-_Prod_WG
21:51:19 <rockyg_> There are converging interests on getting releases supported beyond the 1 year point
21:51:34 <Arkady_Kanevsky> review.openstack.org is not responding. so cannot comment on reviews
21:51:48 <kencjohn_> rockyg_ In reading the document, why was it deemed that PWG would be a good contributor above say, the Ops or other User Committees?
21:51:53 <rockyg_> Minimum for upgrade, but also to reduce work across companies who provide support
21:51:55 <pchadwick> Is there any converging interest on picking one release per year to be long term supported?
21:52:15 <pchadwick> that is the only real way to reduce the multi-company workload.
21:52:19 <rockyg_> Mainly because it's a corporate thing.  Companies provide the long support
21:52:31 <rockyg_> So, it is pretty much a "product"
21:52:49 <rockyg_> with the same planning and support needs
21:53:02 <rockyg_> Users and ops are consumers
21:53:14 <annilai> also, we need business case for it
21:53:27 <kencjohn_> Hmm, ok, I guess I have some concern with the general approach especially as it relates to Rolling Upgrades.
21:53:41 <annilai> that's why product WG is a good forum for it.
21:53:44 <rockyg_> There is talk of that, but first, we need to figure out how to just extending a release could work
21:53:50 <Shamail> kencjohn_: probably because the main limiting factor will be development resources, therefore asking the majority of contributing companies to get involved is the logical next step.
21:53:51 <barrett> I think that many view the Product WG as the planning arm for OpenStack - and this is a product planning issue
21:54:02 <kencjohn_> I realize this stable branch project is moving forward, but I'd rather see this group focus on things that remove the barriers to upgrades instead of adding additional stickiness to any given release
21:54:35 <rockyg_> The first focus is how to keep the upgrade tests working.
21:54:36 <Shamail> barrett: +1
21:54:40 <cloudrancher> Even with rolling upgrades companies like to test and validate new releases
21:54:42 <kencjohn_> That way new features are in the hands of users more quickly, instead of a multiyear feedback sycle
21:54:45 <barrett> kencjohn_: I think that finding that balance point will be part of the exercise for defining criteria and process
21:55:01 <rockyg_> barrett: ++
21:55:24 <barrett> For today, I'd like to get a show of hands of who would be interested in joining a subteam to work on this?
21:55:25 <pchadwick> We need to define what "support" means:
21:55:31 <pchadwick> accepting bug fix?
21:55:31 <rockyg_> Also, if only one company has to backport any patch, the amount of work in each company participating lessens
21:55:40 <barrett> Target time frame for 1st proposal is end of Jan
21:55:51 <rockyg_> o/
21:55:56 <kencjohn_> barrett o/
21:55:59 <barrett> Thanks Rockyg
21:56:02 <sgordon> w.r.t. development resources i would think these showing up to help maintain stable
21:56:08 <barrett> Thanks Kencjohn_
21:56:16 <sgordon> would be a precursor to extending the lifecycle
21:56:20 <rockyg_> sgordon: ++
21:56:31 <pchadwick> yes - but most of us already do it.
21:56:32 <rockyg_> Likely some framework effort, too.
21:56:42 <sgordon> pchadwick, well that's kinda what im getting at
21:56:52 <sgordon> we do in fact have multiple working on upstream stable
21:57:01 <pchadwick> Anecdotally, the problem is that the core teams are sometimes slow to accept backports.
21:57:01 <sgordon> this conversation is posited on the fact that others dont
21:57:03 <sgordon> so why is that?
21:57:23 <rockyg_> sgordon:  exactly.  if we each contribute directly, not only does the workload go down for each, but we get credit for it in the community
21:57:27 <sgordon> im skeptical that it's just because the branch closes
21:57:34 <sgordon> because they aren't there before that either
21:57:44 <Shamail> rockyg_: +1
21:57:46 <barrett> Folks - Don't mean to cut-off discussion, but we've got 3 mins left. Let's get a team formed where there can be more discussion to create a proposal. Then they can bring it back into this group for review/feedback. OK?
21:57:47 <rockyg_> The stable team will be doing the accepting of the backports
21:58:01 <leong> barrett: +1
21:58:03 <Shamail> barrett: +1
21:58:07 <annilai> +1
21:58:13 <pchadwick> +1
21:58:14 <MeganR> barrett +1
21:58:18 <pchadwick> I can work on the team.
21:58:23 <rockyg_> sgordon: lots more.  Rolling python package cahnges makes old code break
21:58:28 <barrett> Thanks pchadwick
21:58:32 <Shamail> barrett: I'd like to defer the CPL topic to next week but I'll send an email to the ML this week on it.
21:58:40 <cloudrancher> rope me in too
21:58:48 <rockyg_> Kewl.
21:58:53 <barrett> Rockyg: Will you take the action to pull together the interested folks for an initial meeting?
21:58:59 <kencjohn_> cloudrancher "rope" nice :)
21:59:01 <rockyg_> Sure.
21:59:09 <Shamail> kencjohn_: lol
21:59:12 <cloudrancher> <unintentional pun>
21:59:39 <rockyg_> This will likely dovetail into some of the other rolling upgrades/updates
21:59:46 <barrett> #action RockyG setup kick off meeting for Stable Branch team with Kenny, Jay, Pete, Carol.
21:59:49 <kencjohn_> cloudrancher I could hear the Texas drawl through my screen
22:00:00 <barrett> Great
22:00:00 <pchadwick> One interesting question for the mid-cycle ops is how many ops will really do regular upgrades
22:00:02 <cloudrancher> sorry - I really do talk that way sometimes
22:00:09 <sgordon> i would also like to be involved in framing the plan for stable
22:00:15 <pchadwick> vs most of my customers wanting to wait 12 months minimum
22:00:20 <sgordon> as a rep of a distributor who already has people contributing to stable...
22:00:28 <barrett> #action Rocky  Include Steve in the kickoff meeting too
22:00:32 <sgordon> which is where a lot of my questions are coming from
22:00:36 <barrett> Thanks folks - we
22:00:39 <rockyg_> I think the 12 months minimum is pretty standard at customer sites
22:00:41 <barrett> We're out of time for today.
22:00:46 <Shamail> barrett: i have to leave but did my plan on CPL sound good?
22:01:00 <pchadwick> shamail: +1
22:01:09 <leong> shamail: +1
22:01:15 <annilai> +1
22:01:15 <barrett> Shamail: Is the plan to address at midcycle?
22:01:34 <Shamail> No, ill send to ML and would like to have it on agenda next week
22:01:42 <rockyg_> Good.
22:01:45 <barrett> Shamail - OK.
22:01:53 <barrett> #endmeeting