21:01:55 <barrett> #startmeeting Product Working Group
21:01:56 <openstack> Meeting started Mon Dec 14 21:01:55 2015 UTC and is due to finish in 60 minutes.  The chair is barrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:00 <openstack> The meeting name has been set to 'product_working_group'
21:02:06 <thingee> o/
21:02:13 <hughhalf> o/
21:02:15 <Shamail> Hi all
21:02:22 <barrett> Hi - Who's here for the Product WG meeting?
21:02:30 <MeganR> o/
21:02:52 <hughhalf> o/
21:03:16 <sgordon> o/
21:03:18 <scohen1> o/
21:03:37 <kencjohnston> o/
21:03:57 <barrett> #link agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:04:09 <barrett> Link to the agenda
21:04:20 <barrett> #topic Mid cycle planning
21:04:27 <rockyg> o/
21:04:41 <pchadwick> o/
21:04:50 <barrett> #link: mid cycle planning etherpad https://etherpad.openstack.org/p/PWG_Mitaka_Midcycle
21:05:36 <barrett> In last week's meeting we talked about the UK option and asked folks to touch base with their management on whether it would be possible for folks to travel
21:06:26 <Shamail_> The etherpad shows preference for UK
21:06:33 <barrett> were people able to talk to their mgrs?
21:06:34 <barrett> I've added a section into the planning etherpad for folks to enter their names if they know they can attend
21:07:06 <Arkady_Kanevsky> hello
21:08:29 <barrett> It I also added a section for people to add their names if they know they cannot attend
21:08:30 * hughhalf regrets he will be unable to travel to the midcycle due to non-work commitments
21:08:37 <Shamail> I'll make it.
21:08:53 <barrett> too bad Hughhalf
21:09:10 <rockyg> Hey, Arkady_Kanevsky
21:09:20 <hughhalf> Aye, just a couple of (admittedly otherwise pleasant) things on that time of year
21:09:22 <Arkady_Kanevsky> here mam
21:09:39 <barrett> Ideally we can determine if we will haev a quorum if we hold this in the UK before the holiday break
21:09:48 <Arkady_Kanevsky> Rocky how can I help?
21:09:49 <barrett> hi Arkady
21:09:57 <Arkady_Kanevsky> I am reviewing rollingupgrade now
21:10:06 <pchadwick> How big is a quorum?
21:10:51 <barrett> pchadwick - good question - enough folks to review/prioritize user stories, revise work flow, volunteer to take leadership on user stories
21:11:24 <barrett> What do folks think is the minimum attendance that would make the midcycle viable?
21:12:02 <rockyg> Just being neighborly, Arkady_Kanevsky
21:12:16 <kencjohnston> barrett Good question, I'm not sure what our actual team size is. If we used the number of folks involved in the roadmap + contributors to the repo I think we'd be in the 10-12 range.
21:13:05 <scohen1> what about possible date poll?
21:13:06 <Arkady_Kanevsky> thank you Rocky.
21:13:10 <Shamail> kencjohnston: that number sounds about right, 12-15 active.
21:13:16 <kencjohnston> But we'd also discussed reaching out to get new members from European companies.
21:13:17 <barrett> kennycjohnston - That's a good starting place.
21:13:27 <barrett> kencjohnston: +1
21:13:42 <rockyg> Arkady_Kanevsky, Mikal Still is trying to collect/triage live upgrade bugs issues; you might connect with him on the user stories.
21:13:47 <pchadwick> Do I count as a European company ;)?
21:13:53 <barrett> scohen1: We could do that
21:14:06 <kencjohnston> So if we had 7 current members plus five new members I'd consider it a success
21:14:15 <Arkady_Kanevsky> sure Rocky. Do you have his email?
21:14:47 <barrett> kencjohnston - agree
21:15:00 <Shamail> kencjohnston: +1
21:15:12 <Leong_> +1
21:15:29 <kencjohnston> Arkady_Kanevsky his handle is mikal he's in #openstack right now
21:15:47 <Arkady_Kanevsky> +1 on number for midcycle
21:16:24 <kencjohnston> So we are at 7 current right now
21:17:32 <barrett> We could send out a doodle and see if the response aligns with the goal. Because some people get their emails bundled, we would need to leave the doodle open for a week. I'm concerned that we'd need to do this in Jan, which is getting a bit close to the event for making plans
21:17:37 <Arkady_Kanevsky> For upgrade iser story that have been merge how do you want me comment on it? Updating Wwbapge is too entrusive. email on product reflector?
21:17:38 * hughhalf notes mikal normally has a school run around this time, but will be back in about 60 minutes if you don't catch him now
21:18:05 <Arkady_Kanevsky> thanks hughhalf
21:18:23 <Arkady_Kanevsky> doodle wpork last time for midcycle planning.
21:18:25 <Shamail> barrett: I agree with this approach... It will still let us finalize location before the holidays if we send it out this week.
21:18:58 <barrett> Shamail - I'll be a pumpkin next week, can you take the action item to do this?
21:19:05 <Shamail> Sure thing
21:19:18 <barrett> Thanks
21:19:27 <Arkady_Kanevsky> so what is the proposal for the place fore mid cycle in NA?
21:19:42 <kencjohnston> Arkady_Kanevsky NA?
21:19:53 <Shamail> To clarify.... I will use doodle to vote for locations... The timing will probably align with ops summit in any case, right?
21:19:59 <Leong_> North America?
21:19:59 <Arkady_Kanevsky> North America
21:20:03 <Shamail> Or will we change timing if we don't do UK?
21:20:12 <barrett> #action Shamail to send out Doodle to close on whether or not we can get sufficent attendance at a mid-cycle held in London 2/17 & 18
21:20:37 <barrett> We have more options on timing if we don't meet in UK
21:20:46 <kencjohnston> barrett Shamail is it a doodle or a poll?
21:20:51 <Arkady_Kanevsky> I thought we want to try to have two. One in UK and one in North America.
21:20:52 <Leong_> Also take into considerarion in case EWG was in Uk but Pwg in Us?
21:20:55 <Shamail> Perfect.. (It will be a poll)
21:21:08 <barrett> Leong: +1
21:21:24 <MeganR> Leong: +1
21:21:27 <Shamail> Arkady_Kanevsky: not the plan yet, we can revisit if we get more active members.
21:21:36 <Shamail> leong: +1
21:21:38 <Arkady_Kanevsky> OK
21:21:49 <barrett> arkady_kanevsky: Ideally we'd have 1. Travel budgets aren't likely able to support 2.
21:21:59 * hughhalf nods at barrett
21:22:00 <Arkady_Kanevsky> +1 on doodle
21:22:14 <scohen1> +2 on doodle
21:22:24 <barrett> Ok - I think we have defined the path to closure. Shamail will let us know the results of the poll and we'll go from there.
21:22:36 <Leong_> Ok
21:22:36 <Shamail> +1
21:22:40 <barrett> Anything else on this one?
21:23:08 <barrett> OK
21:23:14 <barrett> #topic Revisiting CPL Assignments
21:23:26 <barrett> Shamail - Can you lead this one?
21:23:38 <Shamail> I have a couple of topics related to CPLs that will be a part of this discussion.  I'll start with the reassignment topic first.
21:23:44 <Shamail> barrett: sure thing
21:23:56 <Shamail> Based on recent changes in responsibilities, we have three vacancies for CPLs (Neutron, Magnum, and Keystone).  We need to find new volunteers to act as CPL (cross-project liaison) for these projects?
21:24:40 <kencjohnston> Shamail can I suggest that we de-prioritize Magnum, since it is not a core service?
21:24:49 <Shamail> I'd also like to thank Mike Cohen and Sheena Gregson for helping out with these projects.  They will still be involved with PWG but can not keep the CPL roles.
21:24:57 <Shamail> kencjohnston: +1, agreed
21:25:00 <sgordon> i would actually be willing to look into taking magnum
21:25:04 <Shamail> Others?
21:25:10 <kencjohnston> I'm happy to serve as a spot CPL for Magnum if need be
21:25:19 <sgordon> aligns with other work i have on my plate
21:25:34 <Shamail> Thanks sgordon and kencjohnston ... Any preference between you two?
21:25:43 <kencjohnston> sure thing sgordon, I work closely with Adrian Otto and can do an intro if need be
21:25:52 <sgordon> sure
21:26:25 <Shamail> Perfect.  Thanks kencjohnston and sgordon
21:26:40 <Shamail> #info sgordon is new CPL for magnum
21:27:05 <Shamail> Any one willing to help with keystone or neutron?  Those are rather important so I don't think we should leave them vacant for long...
21:27:41 <Arkady_Kanevsky> I am CPL for Tempest and Rally. Where should I document the roadmap for these to track?
21:28:08 <Shamail> Furthermore, there are a lot of other projects that currently do not have a CPL from PWG.  I'll post the open projects on our mailing list to continue this conversation.  We'll list core services as priority in the ML thread
21:28:18 <barrett> Just wondering - Is the issue for people to volunteer time or knowledge of the project?
21:28:40 <Arkady_Kanevsky> Shamail, do we have wiki or webpage where we track CPLs?
21:28:41 <Shamail> Arkady_Kanevsky: I'll reach out to you on this topic... More important to also start joining the weekly meetings for those projects
21:28:52 <kencjohnston> barrett My reluctance is for time
21:28:52 <Shamail> Yes (looking up the link)
21:29:00 <barrett> #link: https://wiki.openstack.org/wiki/CrossProjectLiaisons
21:29:00 <Arkady_Kanevsky> agree
21:29:06 <kencjohnston> I think I would struggle to attend appropriate meetings and stay up to speed
21:29:20 <Shamail> Thanks barrett
21:29:31 <pchadwick> My concern is time as well.
21:29:46 <kencjohnston> Maybe we should let the CPL priorities be determined by needs from the tracked User Stories?
21:30:22 <Shamail> kencjohnston: good idea, I was going to continue the topic on ML and I'll try to list of user story mapping in that thread.
21:30:23 <hughhalf> Good call kencjohnston - taht would help us naturally prioritise
21:30:26 <kencjohnston> Althought then you lose the general feedback loop from the Roadmap creation process because you wouldn't have CPLs established for all projects at all times
21:30:32 <barrett> kencjohnston: +1
21:30:39 <kencjohnston> Shamail cool, thanks
21:30:55 <Shamail> There are a lot of other projects that currently do not have a CPL from PWG.  I'll post the open projects on our mailing list to continue this conversation.  Naturally, the core services and ones with user story implications would be listed as priority.
21:31:12 <Shamail> Can you please assign the action item barrett?
21:31:22 <barrett> Shamail: +1. we're unlikely to be able to cover all of the projects
21:31:38 <Shamail> Lastly, can people who are CPLs currently give an update on whether they have been able to start attending the weekly time meeting for their project(s)?  I have been attending cinder meetings, but have missed the last 2-3.
21:31:56 <Shamail> I'd like to also propose that we make this a regular agenda item, like user story updates, except less frequently (maybe once a month to start)... So that we can bring up relevant topics from the projects and update the team.
21:31:57 <pchadwick> Shamail - same here for Manila
21:32:01 <barrett> #action Shamail send out an email to the ML call for CPLs, with a list of the projects currently identified as involved in a prioritized user story
21:32:18 <kencjohnston> Shamail +1 on updates
21:32:18 <barrett> Shamail - Will do on the agenda
21:32:24 <Shamail> Thanks pchadwick
21:32:39 <rockyg> Everybody, if you miss the meetings, it's often worthwhile to review the logs for it.  Helps a lot.
21:32:54 <Shamail> rockyg: +1
21:32:56 <Arkady_Kanevsky> +1 on shamail proposal
21:33:04 <MeganR> Do we still need someone on the OpenStack Client meetings? I have been attending those, but don't see it listed on the Wiki/
21:33:06 <pchadwick> rockyg - where are the logs?
21:33:49 <Shamail> #link http://eavesdrop.openstack.org/irclogs/
21:33:53 <pchadwick> never mind - I just googled it.
21:33:58 <rockyg> http://eavesdrop.openstack.org/meetings
21:34:22 <barrett> MeganR: It's there..called OSClient
21:34:37 <rockyg> when this meeting ends, look at the links that get auto-posted.
21:34:54 <barrett> #link:  PWG list of CPLs https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group
21:34:58 <rockyg> then go up-tree a bit.  You can work your way back down.
21:35:27 <Shamail> That's all I had on this topic... We got magnum covered and hopefully we get coverage for neutron and keystone via ML
21:35:42 <MeganR> barrett: thank you, I was looking at the wrong section
21:35:47 <Shamail> I look forward to project updates, that will be really beneficial
21:36:08 <Shamail> Any comments, questions before we move on?
21:36:35 <barrett> nope
21:36:41 <Shamail> Floor is yours barrett :)
21:36:54 <barrett> Thanks
21:37:03 <barrett> #topic User Story Updates
21:37:19 <barrett> Do any of the User Story owners have updates to share?
21:37:40 <kencjohnston> barrett I posted a revision to Rolling Upgrades which contains Gaps Analysis text
21:37:51 <kencjohnston> #link https://review.openstack.org/#/c/255633/
21:37:56 <Arkady_Kanevsky> DB hygiene have been merged. DItto for complex user scenarios
21:38:21 <barrett> Ok - let's start with Rolling Upgrades
21:38:28 <thingee> What is the goal of editing the rolling upgrades user stories. These kind of things are already being developered by various projects.
21:39:11 <kencjohnston> thingee I agree most of the items are already inflight, the intent was to capture the entire "outcome" in one place
21:39:14 <sgordon> i tend to agree with thingee here in as much as what is in the doc does not look so much like a use case
21:39:21 <sgordon> as a list of items that are already being worked on
21:39:36 <thingee> kencjohnston: got it
21:40:12 <barrett> The tracker should ideally contain what's underway as well as the gas
21:40:14 <barrett> gaps
21:40:15 <rockyg> Might be worth putting links to bps, bugs, reviews in where things are in-flight
21:40:16 <kencjohnston> I will say that I still struggle to find the status of all the various items that are inflight
21:40:26 <Shamail> kencjohnston: +1 and also helps keep additional details (like context, justification, etc.) to help share why it was tracked through PWG
21:40:36 <kencjohnston> rockyg I think that is the job of the tracker document
21:40:49 <Shamail> That will be the tracker
21:40:50 <thingee> kencjohnston: yeah it's not easy, because some projects have bits and pieces that work towards the goal.
21:40:57 <rockyg> What Shamail said.  +1
21:41:03 <kencjohnston> In my mind 1) Gaps contains written form of gaps in context of high level use case
21:41:16 <kencjohnston> 2) Tracker contains specific work items happening across projects and releases
21:41:18 <thingee> kencjohnston: it would help if CPL's communicate with projects on putting things under one topic branch in gerrit
21:41:20 <Shamail> I was trying to get a template created by today but hopefully will submit patch tomorrow.
21:41:25 <thingee> kencjohnston: so it's easy to spot the work happening
21:41:36 <Arkady_Kanevsky> https://review.openstack.org/#/c/237178/ - closed (DB hygiene)
21:41:39 <Shamail> thingee: that's a great idea
21:41:40 <kencjohnston> thingee Talk more about that...
21:42:02 <kencjohnston> All projects would put work in the same named topic branch?
21:42:04 <rockyg> kencjohnston, +1.  thingee, talk...
21:42:25 <thingee> so a lot of the times where we're doing cross project development, we put things under one topic branch. that way you can search by gerrit that topic branch and find things across different projects for the same initiative
21:42:38 * thingee finds an example
21:42:40 <rockyg> does the branch span repos or we just name it the same in each?
21:42:54 <Shamail> Name it the same.
21:43:06 <rockyg> Answered *my* question...Thanks!
21:43:32 <kencjohnston> thingee OK, I think I get it. I'll get a communication to the CPLs with that ask for rolling upgrades
21:43:42 <kencjohnston> Can someone take that action for me?
21:44:10 <thingee> so recently in OpenStack we rolled a new way for capturing release notes. The topic is called "add-reno" ... reno being the tool to capture release notes
21:44:11 <thingee> https://review.openstack.org/#/q/topic:+add-reno,n,z
21:44:24 <thingee> so you can see all the projects integrating reno^
21:44:25 <Arkady_Kanevsky> Are we covering rolling upgrade in each project or one person responsible for it for all projects?
21:44:31 <Shamail> thingee: this is a good addition to the workflow... Good thing is that everything is done via patch so the topic could show everything except blueprints.
21:44:49 <kencjohnston> Arkady_Kanevsky All projects
21:44:52 <Shamail> Code + specs would all show up.
21:46:03 <Shamail> barrett: can you please assign an action item to kencjohnston: "ask CPLs to share common branch topic with projects for rolling upgrades "
21:46:03 <barrett> Arkady_Kanevsky: CPLs cover all User Stories
21:46:34 <barrett> #action kencjohnston ask CPLs to share common branch topic with projects for rolling upgrades
21:46:49 <thingee> barrett: can I get an action item to update the workflow doc for the topic branch addition?
21:46:52 <Arkady_Kanevsky> sorry for confusion. We have an owner of user story. That may span multiple projects.
21:47:21 <Arkady_Kanevsky> And we have CPL that tracks roadmap for individual project.
21:47:33 <barrett> #Action Thingee Update workflow doc to include Topic Branch additions
21:47:53 <thingee> thank you
21:48:02 <Arkady_Kanevsky> So who owns tracking a user story "blueprint" in specific project? CPL? story owner? or both?
21:48:42 <thingee> Arkady_Kanevsky: wait, there's a separate blueprint for the user story?
21:48:58 <Shamail> CPL, but aggregated status is tracked by user story owner.
21:49:07 <barrett> does anyone knowif the #commands are case sensitive?
21:49:07 <barrett> Anything else on rolling upgrades?
21:49:18 <kencjohnston> barrett none from me
21:49:24 <Arkady_Kanevsky> The work in each individual project is driven by blueprints and specs.
21:49:33 <Shamail> not sure barrett
21:49:34 <thingee> There should just be a user story, which can include the user stories if there is not spec. If there is a spec in a project, CPLs should be providing the user stories in a spec update.
21:49:52 <thingee> there should just be one blueprnt*
21:50:11 <Arkady_Kanevsky> Once the user story is merged we either add blueprints and spec if they exsists in various projects to track it. Or create ones for each project
21:50:34 <Shamail> barrett: time check... 10 min
21:50:52 <thingee> Arkady_Kanevsky: yeah I think we're on the same page
21:51:05 <Arkady_Kanevsky> single blueprint can not handle multiple projects
21:51:24 <thingee> Arkady_Kanevsky: right, but a spec can
21:51:54 <thingee> Arkady_Kanevsky: http://specs.openstack.org/openstack/openstack-user-stories/workflow/workflow.html#cross-project-specifications
21:52:10 <thingee> each blueprint should be listed in the cross-project spec
21:52:16 <Arkady_Kanevsky> agree
21:52:20 <thingee> :)
21:53:57 <Shamail> Any other user story owners online?
21:53:59 <Arkady_Kanevsky> easier to track completion of all project dependent work for a user story if it in project specific blueprint or spec.
21:54:27 <Shamail> cloudrancher: ping
21:55:03 <Shamail> I don't think Deric and Jay are here
21:55:08 <Shamail> sgordon: ping
21:55:11 <Arkady_Kanevsky> looks like we are done early. No more calls till New year?
21:55:19 <sgordon> yo
21:55:19 <barrett> Weird, the channel went away for a while for me...back now
21:55:30 <Shamail> Any updates on Complex Instance?
21:55:33 <sgordon> we merged a thing, so that was nice
21:55:39 <barrett> Last meeting of this year. Next one is 1/11.
21:55:40 <rockyg> ++
21:55:41 <Shamail> :)
21:55:43 <Arkady_Kanevsky> +2
21:56:00 <sgordon> now i have to find the link again of course
21:56:05 <Arkady_Kanevsky> Happy Holidays to ALL
21:56:08 <kencjohnston> and barrett is on sabatical right?
21:56:10 <thingee> would like to informally add an agenda item... going back a couple of meetings on whether we should have drafts or not?
21:56:17 <Shamail> Are you now focusing on building out "add capacity" or gap analysis for Complex Instances?
21:56:27 <sgordon> #link https://review.openstack.org/#/c/251442/
21:56:30 <sgordon> yes
21:56:40 <Leong_> Carol on sabbatical, I will cover her
21:56:42 <Shamail> Yes kencjohnston, that is accurate... She will be on sabbatical
21:56:50 <kencjohnston> cross talk thingee +1
21:57:13 <Shamail> Yes = both sgordon ?
21:57:23 <rockyg> thingee, +1  Maybe add to next agenda?
21:57:28 <sgordon> both
21:57:31 <rockyg> If we don't get to it.
21:57:32 <kencjohnston> although that might be a better discussion for our midcycle
21:57:34 <thingee> rockyg: ok
21:57:37 <Shamail> Hi thingee... We'll add it
21:57:46 <Shamail> We have 3 min.. Defer to next meeting?
21:57:55 <rockyg> sgordon, any ready for review yet?
21:57:59 <Shamail> Thanks sgordon
21:58:00 <barrett> Yes -  I think so
21:58:04 <kencjohnston> Shamail I think we have to
21:58:12 <thingee> I would also like to remind that I think it would benefit us to start thinking of stuff we want for N release, and start putting that in the heads of project maintainers now
21:58:15 <Arkady_Kanevsky> agree. Post any new user story to review
21:58:26 <sgordon> rockyg, we have been merging them as they come, the link is above...
21:58:26 <kencjohnston> thingee +1
21:58:27 <thingee> and what resources we can bring forward from our respected companies on certain initiatives.
21:58:28 <barrett> thingee: +1
21:58:35 <Shamail> Agreed.  We'll add it to 1/2016
21:58:39 <barrett> thingee: +1
21:58:40 <Shamail> Did we decide to skip 1/4?
21:58:47 <Shamail> thingee: ++
21:58:50 <barrett> shamail: Yes we did
21:58:53 <sgordon> i believe we did
21:58:56 <Shamail> Okay
21:59:07 <Shamail> Thaknks
21:59:12 <sgordon> people anticipating some really good new years parties i guess
21:59:12 <Shamail> Thanks*
21:59:13 <sgordon> ;p
21:59:18 * kencjohnston jumps to another call thanks all, Happy Holidays!
21:59:20 <Shamail> Lol sgordon
21:59:28 <barrett> Happy Holiday folks - see ya next year!
21:59:30 <Arkady_Kanevsky> bye
21:59:34 <Shamail> Happy holidays everyone!! Talk to you on the mailing list.
21:59:34 <barrett> #endmeeting