21:00:35 <barrett1> #startmeeting Product Working Group
21:00:35 <openstack> Meeting started Mon Feb  1 21:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is barrett1. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:38 <openstack> The meeting name has been set to 'product_working_group'
21:00:45 <shamail> hi all
21:00:48 <leong> hi
21:00:54 <barrett1> Hi Folks - Let's start with role call
21:01:00 <sgordon`> o/
21:01:03 <barrett1> Hi Shamail
21:01:04 <pchadwick> o/
21:01:05 <barrett1> Hi Leong
21:01:11 <barrett1> Hi Pete
21:01:13 <shamail> Present
21:01:14 <barrett1> Hi Steve
21:01:14 <kencjohnston> o/
21:01:15 <pchadwick> Hi all
21:01:25 <kencjohnston> welcome back barrett1 !
21:01:30 <shamail> ++
21:01:48 <barrett1> Thanks Kenny - Good to type with everyone again ;-)
21:01:56 <kencjohnston> :)
21:02:04 <kencjohnston> It's a miracle shamail survived
21:02:08 <barrett1> The agenda can be found here: https://wiki.openstack.org/wiki/Meetings/product-team
21:02:19 <shamail> haha
21:02:27 <barrett1> kencjohnston: LOL
21:02:38 <leong_> LOL
21:02:42 <barrett1> more suprising is that you missed me at all!
21:02:50 <thingee> o/
21:03:05 <barrett1> Hi MIke
21:03:13 <barrett1> Ok Let's get going
21:03:26 <barrett1> #topic Review actions items from last meeting
21:03:35 <barrett1> #link http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-01-25-21.00.html
21:04:06 <shamail> I can start with mine
21:04:13 <barrett1> Thanks Shamail
21:04:24 <Arkady_Kanevsky> hello
21:04:31 <shamail> I sent an email out to the mailing list to ask for more volunteers as CPL (mainly Keystone) but no replies
21:04:34 <shamail> hi Arkady_Kanevsky
21:04:55 <kencjohnston> barrett1 I can report we did merge the pending "Upgrades Gaps Analysis" CR
21:05:01 <Arkady_Kanevsky> saw that.
21:05:05 <shamail> I also sent out the reminder for the CFP submission deadline (which was extended today to tomorrow)
21:05:22 <barrett1> kencjohnston:: we'll get to yours in a min
21:05:37 <shamail> I still have to update the wiki go incorporate the CSPL role in the workflow
21:05:46 <shamail> ill do that this week
21:05:51 <shamail> thats all from me :]
21:06:09 <MarkBaker> 0/
21:06:11 <leong> i haven't update the FAQ yet
21:06:21 <leong> i can't seem to find the email from Kenny
21:06:30 <kencjohnston> leong I'll forward it to you now
21:06:38 <leong> kencjohnston: do you still have that email>?
21:06:45 <leong> ok. thanks!
21:06:50 <barrett1> Shamail: What follow-on actions should we take since there was no response to your email?
21:07:05 <leong> i have included the meeting-time to midcycle meetup agenda
21:07:13 <shamail> Let's take it up at the mid-cycle since there is a bigger topic there
21:07:33 <barrett1> Shamail: OK
21:07:33 <rockyg> o/
21:07:40 <shamail> The next major item we need the CPL for is the roadmap refresh so holding off until mid-cycle won't slow anything down
21:08:36 <barrett1> Leong: When will you complete the FAQ update by?
21:08:58 <leong> today.. once i got the email :-)
21:09:10 <barrett1> #action Leong Complete update of FAQ adding in FAQ by 2/2/16
21:09:12 <leong> and just got the email :-)
21:09:12 <Arkady_Kanevsky> OK. I will update QA one after mid cycle
21:09:43 <barrett1> kencjohnston: Update on your action item?
21:09:58 <kencjohnston> barrett1 As mentioned CR was merged on Thursday
21:10:13 * shamail cheers
21:10:20 <kencjohnston> barrett1 For the other item, opening the user story for review and  sending around the gerrit link to Openstack-Dev, I need some advice
21:10:30 <kencjohnston> is there a best practice for creating a CR for review that doesn't have any changes?
21:10:40 <barrett1> kencjohnston: Great! (Sorry, still spinning back up on IRC flow)
21:10:42 <kencjohnston> I would imagine thingee sgordon` or rockyg woudl know.
21:11:03 <sgordon`> what did i break
21:11:08 <shamail> lol
21:11:11 <kencjohnston> sgordon` ha
21:11:13 <rocky_g> I would think you could just change the commit message to something like gettingg dev input to.....
21:11:17 <thingee> what is a cr?
21:11:18 <sgordon`> so kencjohnston when you propose it
21:11:25 <kencjohnston> thingee change request
21:11:27 <sgordon`> i think you need to do it against a new folder
21:11:31 <sgordon`> proposed instead of draft
21:11:33 <rocky_g> change request
21:11:36 <sgordon`> thus it is in fact a new change
21:11:37 <shamail> thingee: patch in gerrit
21:11:52 <thingee> you want to submit a change request that doesn't have changes?
21:12:07 <rocky_g> otherwise known as how to start a new review on existing files that aren't changing?
21:12:14 <kencjohnston> thingee correect, so we have something open to accept comments on
21:12:46 <pchadwick> Why can't we just comment on the base?
21:12:54 <thingee> Ok hang on
21:13:06 <thingee> I think we talked about this in the past.
21:13:14 <rocky_g> yup
21:13:29 <kencjohnston> pchadwick I don't know how to do that, say more.
21:13:33 <thingee> So I think last time we discussed, we said people merge stuff right away, because of readable reasons
21:13:38 <shamail> #link https://review.openstack.org/#/c/255633/
21:13:43 <thingee> I said, what's so hard to read the format of these documents
21:13:45 <sgordon`> pchadwick, it
21:13:50 <shamail> thingee, added the link to the review in question for your ref.
21:13:51 <sgordon`> pchadwick, it's already merged
21:13:55 <thingee> and people agreed that it wasn't hard to read
21:13:57 <sgordon`> pchadwick, so there is no review to comment on
21:13:58 <pchadwick> Ah - ok
21:14:03 <Arkady_Kanevsky> what is the point to comment on what is merged already?
21:14:19 <sgordon`> Arkady_Kanevsky, dev review time
21:14:26 <kencjohnston> Arkady_Kanevsky We wanted to ask a broader group for their feedback on the user story
21:14:26 <thingee> So here's the thing, if people prefer to have something rendered in order to do reviews, we can have a job set to render documents
21:14:36 <thingee> but I think merging things right away is not a good idea
21:14:44 <sgordon`> +1
21:14:48 <shamail> This user story went through an internal review (only PWG members have looked at it) and we would now like to send it out to openstack-dev for greater community feedback
21:14:49 <Arkady_Kanevsky> +2
21:14:52 <thingee> you should merge things when it's approved, and keep it iterating and commenting until you can merge it
21:15:08 <thingee> the reason why gerrit doesn't allow what you're asking for is because it wasn't meant to be used this way
21:15:27 <Arkady_Kanevsky> Do we want wider audience to comment on whole user story?
21:15:29 <kencjohnston> thingee agreed. Honestly I think I'll just make some nit changes to the doc and submit them for review and leave it open.
21:15:32 <shamail> all, maybe we should only accept things into "proposed" that have gone through PWG review and reserve "tracked" for community review... thoughts?
21:15:33 <sgordon`> we actually already have a job that renders the stuff afaict
21:15:34 <sgordon`> e.g. http://docs-draft.openstack.org/33/255633/7/gate/gate-openstack-user-stories-docs/8b21a31//doc/build/html/
21:15:37 <kencjohnston> any objections to that?
21:15:42 <thingee> So I recommend we revert the merge of the file and then post again.
21:15:50 <leong> shamail +1
21:15:53 <shamail> thingee: +1
21:15:55 <thingee> sgordon`: excellent
21:16:22 <sgordon`> folks may not necessarily realize that you can click through to that from the review though
21:16:23 <Arkady_Kanevsky> do not like revert.
21:16:31 <barrett1> shamail: +1
21:16:37 <thingee> Arkady_Kanevsky: well you can't comment then
21:16:42 <shamail> Does my suggestion sound okay (for workflow amendment?)... it doesn't work in this case but we can prevent this scenario in the future
21:16:44 <thingee> that's just not gerrit reviews work
21:16:53 <Arkady_Kanevsky> It is better to resubmit the full proposal for other folks to comment on it.
21:16:55 <sgordon`> what about if they do a move?
21:16:55 <leong> sgordon, looks like that job need to change to cater for the recently changes in folder structure
21:17:05 <Arkady_Kanevsky> Intiial merge shows that our group accepted it
21:17:18 <sgordon`> e.g. currently it's draft/mything.rst and they propose moving it to proposed/mything.rst
21:17:21 <thingee> Arkady_Kanevsky: if they accepted it, why do you need comments
21:17:23 <sgordon`> (just riffing off the original flow)
21:17:28 <thingee> you can't have it both ways
21:17:30 <shamail> barrett1, can you assign the action item to me?
21:17:52 <shamail> draft: review for syntax and language, proposed: internal PWG review, tracked: community review before merge
21:18:04 <sgordon`> as a reminder this was the draft workflow: https://wiki.openstack.org/wiki/ProductTeam/User_Stories
21:18:04 <kencjohnston> shamail I'm happy to repost I just didn't know if there was a best practice
21:18:07 <Arkady_Kanevsky> Like the idea that we submit a pulll request to Copy or move user story from draft to accepted folder
21:18:10 <sgordon`> i think folks are talking past each other
21:18:13 <barrett1> #action Shamail draft: review for syntax and language, proposed: internal PWG review, tracked: community review before merge
21:18:19 <kencjohnston> sgordon` +!
21:18:27 <kencjohnston> +1 :)
21:18:36 <shamail> sgordon`: +1
21:18:36 <thingee> Arkady_Kanevsky: but then people can't comment on the draft
21:18:38 <barrett1> The action is assigned, but we need to decide what to do with the current situation
21:18:43 <sgordon`> so what we have atm from that diagram is a heap of stuff in the first column
21:18:45 <thingee> Arkady_Kanevsky: it just doesn't work that way
21:18:46 <shamail> barrett1: +1
21:18:54 <sgordon`> which has been merged in draft/
21:19:01 <shamail> I agree with thingee, maybe unmerge for this particular case
21:19:04 <barrett1> kencjohnston: What direction do you want to go?
21:19:20 <kencjohnston> I'm happy to unmerge, rebuild the changes that happened during review and resubmit
21:19:30 <kencjohnston> I'm also happy to submit a nit change on the doc
21:19:39 <barrett1> Does anyone have heartburn with that approach?
21:19:40 <shamail> ooo
21:19:41 <Arkady_Kanevsky> we can add the state.
21:19:46 <shamail> I prefer the nit change :)
21:19:54 <shamail> would serve the same purpose of opening up reviews again.
21:20:04 <barrett1> Are we good with the Nit Change?
21:20:07 <Arkady_Kanevsky> Then we submit pull rquest toi change state to "VOTED" and let people to comment on full proposal.
21:20:16 <rocky_g> No, I like Arkady's, plan.  We can add a comment to the userstory so that it is changed.  Then the reviews will happen again.
21:20:22 <shamail> agreed sgordon`
21:20:30 <sgordon`> i am still thinking just moving it to proposed/
21:20:37 <sgordon`> will make the whole thing come up as a new review
21:20:40 <rocky_g> We can add "Approved by PWG {date}
21:20:41 <barrett1> rocky_g: Isn't that the Nit approach?
21:20:47 <Arkady_Kanevsky> Wee have 2 levers. One is state. and one is folder.
21:21:02 <Arkady_Kanevsky> Change for each is new pull request
21:21:47 <rocky_g> Either way works for me.  But having the record in the doc I think is a good thing
21:21:54 <barrett1> OK so we have 2 proposals on the table: Change the State to Proposed (from Tracked) or make a Nit Change to cause new review cycle
21:22:02 <thingee> What is the point of this idea though? Gerrit reviews are for approving. Why create yet another thing for approving?
21:22:13 <shamail> it should be passed proposed now (since we have all reviewed it) and it is getting resource assignments/gap
21:22:17 <thingee> or rather indicating something is approved
21:22:24 <shamail> barrett1: I vote for nit change
21:22:25 <rocky_g> Different group is approving the second time round
21:22:27 <barrett1> thingee: it's to gather comments
21:22:48 <shamail> thingee: the first approval was from the PWG... we want to now open it up for community review now that we agree with it
21:22:50 <thingee> But your process is the reason why you're creating this other thing
21:22:53 <thingee> let me explain again
21:22:54 <Arkady_Kanevsky> different audience. And because of that different merge criteria.
21:23:17 <thingee> The initial review is the time to gather comments. Don't merge the thing until comments are satisified. The things that aren't ready are the open reviews.
21:23:29 <thingee> I just can't understand why we're making things more complicated
21:23:38 <pchadwick> But this is more like just adding another gate
21:23:43 <thingee> why?
21:23:49 <thingee> what do you gain?
21:23:51 <Arkady_Kanevsky> see https://wiki.openstack.org/wiki/File:Userstoryflow.png
21:23:55 <pchadwick> we have reviewed, now we get wider input
21:24:16 <thingee> cc people you want wider input from. that's the point of gerrit reviews
21:24:20 <rocky_g> So, the first merge is PWG is ready to expose the story for comments/approval.  It's a multistage comment/approval process.
21:24:23 <Arkady_Kanevsky> <pchadwick> - right
21:24:24 <sgordon`> i am +1 to what thingee is saying here because we have some recent items that i think would get early negative feedback from the community and it's better to realize that sooner than later
21:24:25 <pchadwick> Last time we said we wanted the developers to look at it.
21:24:28 <thingee> we do it on cross-project specs all the time
21:24:29 <sgordon`> so that you can work that feedback in
21:24:53 <thingee> pchadwick: great, why can't they comment on the initial review before merging?
21:24:58 <sgordon`> as it stands it's "approved" but that doesn't really mean a lot in the grand scheme of things
21:25:04 <pchadwick> Ok, so then PWG shouldn't merge until we get the reviews.
21:25:11 <thingee> right
21:25:28 <kencjohnston> An alternative would be to send an email to the dev list and say "CRs welcome"?
21:25:33 <Arkady_Kanevsky> The first stage is to get enough content for developers to review it. If we are missing impact on some project, say nova, then nova dev folks will just ignore it.
21:25:41 <barrett1> Folks - I think we've got 2 discussions going in parallel. How to handle the current situation and how to update our work flow for future use
21:25:42 <shamail> thingee and sgordon`: Are you suggesting that the first review (product-wg review) should happen at the draft state and then it should be open thereafter?
21:25:49 <barrett1> Can we solve these one at a time?
21:25:52 <thingee> I guess who are the developers that you want to talk to?
21:25:58 <shamail> barrett1: +1
21:26:12 <kencjohnston> barrett1 +1, one at a time.
21:26:33 <shamail> Let's park the "workflow for future use" until the mid-cycle and focus on the current rolling upgrades story for now...
21:26:43 <barrett1> Shamail: +1
21:26:45 <leong> shamail +!
21:26:46 <pchadwick> +1
21:26:49 <Arkady_Kanevsky> +1
21:26:56 <rocky_g> +1
21:27:21 <barrett1> #action Carol Add work flow changes to mid-cycle agenda
21:27:21 <kencjohnston> shamail +1
21:27:23 <thingee> barrett1: if you remember, this came up because you can't figure out how to get comments on something you already merged. This is going to keep happening until you resolve the workflow problem
21:27:29 * shamail had to put out a small kitchen fire while having this conversation... good times.
21:27:43 <barrett1> thingee: the midcycle is in 2 weeks, think we'll be OK til then
21:27:49 <Arkady_Kanevsky> pointer to rolling upgrade user story?
21:27:54 <thingee> so don't merge anything until then
21:28:01 <pchadwick> https://review.openstack.org/#/c/254389/
21:28:11 * rocky_g would have like to roast some marshmallows befor shamail put out his fire
21:28:20 <barrett1> thingee: It's already been merged and we want to get developer feedback - this is the situation we're trying to figure out
21:28:37 <thingee> ok so you can't. I just told you that.
21:28:52 <kencjohnston> How about I'll just send my note with a reference to the User Story and ask for changes.
21:28:52 <thingee> you have to unmerge it and post it for review again
21:28:56 <Arkady_Kanevsky> it has 2 +2 already. Do you still want input for it?
21:29:01 <shamail> Let's make a small change so it re-opens it...
21:29:01 <kencjohnston> Does that work for everyone?
21:29:16 <thingee> kencjohnston: that's going to be annoyign to have a bunch of reviews for one thing to get feedback
21:29:27 <thingee> it's also just not the normal workflow in the openstack project
21:29:27 <barrett1> Shamail +1;
21:29:36 <barrett1> kencjohnston: +1
21:29:53 <kencjohnston> thingee ok so the next alternative in my mind is the nit change.
21:29:55 <shamail> thingee: so the best way would be to remove it and then re-submit?
21:30:04 <thingee> shamail: that also is a problem. Some of the review will be collapsed unless people expand the parts that are not similar to the previous revision
21:30:07 <Arkady_Kanevsky> do yuou want the feedback for just that change or for the whole proposal? If full proposal - please, resubmit
21:30:17 <thingee> shamail: people assume the review is the stuff highlighted
21:30:19 <shamail> thingee: makes sense.
21:30:34 <Arkady_Kanevsky> core folks - you can vote +1 and wait for more review before you votre +2
21:30:40 <rocky_g> Thingee, we're not a "project" persee, so our process may be different.
21:30:41 <shamail> Cleanest way seems to be to submit a patch to remove the story, then kencjohnston resubmit it.
21:30:52 <rocky_g> We are adapting a dev tool to work for our purposes.
21:30:55 <kencjohnston> shamail ok sounds good. I can do that.
21:31:03 <shamail> sorry for the re-work kencjohnston
21:31:08 <barrett1> Thingee: Are you OK with that approach?
21:31:09 <kencjohnston> not really rework...
21:31:24 <shamail> I'll keep an eye out and approve as soon as you submit (the removal)
21:31:26 <thingee> rocky_g: ok, well if you're going to interact with the openstack community, they're not going to pick up on this process unless you explain it to them. and good luck with developers following all the instructions
21:31:31 <thingee> or humans in general :)
21:31:34 <rocky_g> Another thing we could do is add links to reviews that address this issue.  There are projects already working on it.
21:31:38 <Arkady_Kanevsky> you can revert...
21:32:06 <thingee> barrett1: yes
21:32:07 <barrett1> #action kencjohnston  submit a patch to remove the story, then resubmit it.
21:32:07 <Arkady_Kanevsky> then resubmit
21:32:14 <shamail> awesome.
21:32:18 <barrett1> Folks - Can we close this one?
21:32:23 <kencjohnston> barrett1 +1
21:32:25 <thingee> and who are the developers that you want to target?
21:32:28 <shamail> barrett1, +1
21:32:34 <rocky_g> Also, by adding the review links, we can get devs to comment on adding/removing others and it starts to build toward the gap analysis
21:32:39 <pchadwick> barrett1 +1
21:33:16 <thingee> barrett1: ^
21:33:22 <barrett1> thingee: do we need to be explicit?
21:33:59 <thingee> well I think it's not entirely useful to say the openstack developers. Trust me, I've been a ptl for a project for a couple of releases and leading the cross-project initiatives.
21:34:03 <Arkady_Kanevsky> we can add PTL for each project impacted for review.
21:34:19 <thingee> saying everyone is just throwing ideas at noise. Having focused people is more useful
21:34:32 <Arkady_Kanevsky> Or we can add Perez for it.
21:34:40 <barrett1> kencjohnston: Do you know how to target the review to the PTLs for the key Projects we're targeing?
21:34:58 <kencjohnston> barrett1 Yes, I will do CPLs and PTLs
21:35:12 <thingee> and that's why I ask this. I think PTLs are really unreliable unless they're onboard with helping
21:35:13 <kencjohnston> barrett1 plus some other ugprade folks I know in various projects.
21:35:24 <thingee> because you're one of many working groups wanting their attention
21:35:32 <shamail> kencjohnston: +1, should TC be copied too?
21:35:49 <kencjohnston> shamail I'm not sure, I'm open to adding them as an FYI
21:36:01 <barrett1> #action kencjohnston Target the User Story review to required PTLs and Devs working on Upgrades
21:36:06 <barrett1> Let's move on
21:36:10 <egafford> kencjohnston: +1 to add both CPLs and PTLs; increases chance that it'll receive attention from each project without diluting the call to action too much.
21:36:11 <shamail> kencjohnston, fyi is good
21:36:24 <rocky_g> Don't include TCs  They've got enough on their plates and many are PTLs anyway.
21:36:24 <thingee> shamail, kencjohnston it's pretty easy. In gerrit you click the add button and start typing in their name. It'll auto-complete
21:36:35 <shamail> thingee: +1
21:36:40 <kencjohnston> thingee thanks!
21:36:53 <barrett1> Next actions are about reviewing User stories - did folks complete those?
21:37:37 <barrett1> #link https://review.openstack.org/253228
21:37:49 <barrett1> #link https://review.openstack.org/#/c/269874
21:38:11 <barrett1> I will review this week; others ?
21:38:21 <shamail> barrett1: same here, sorry for the delay everyone.
21:38:33 <pchadwick> +1
21:38:38 <barrett1> OK - will carry this action over
21:38:55 <barrett1> # Action all Please review https://review.openstack.org/253228
21:39:09 <barrett1> #Action all Please review https://review.openstack.org/253228
21:39:29 <barrett1> #Action all Please review https://review.openstack.org/#/c/269874
21:39:46 <barrett1> Next one is Shamail'sbout proposals
21:40:27 <barrett1> #topic OpenStack Austin Talk Proposals
21:40:41 <barrett1> #link https://etherpad.openstack.org/p/austin_summit_product_wg
21:40:59 <barrett1> Piet: Are you here?
21:41:17 <Arkady_Kanevsky> review https://review.openstack.org/#/c/269874 - its already merged. are oyu going to reopenit for comments?
21:41:21 <piet> Running an interview w an operator
21:41:45 <barrett1> Piet: OK, was wondering where you are on the UX BoF on Personas
21:41:50 <barrett1> Rocky_g: What's that status on yours?
21:42:09 <piet> BoF?
21:42:27 <barrett1> BoF = Bird of Feather
21:42:44 <barrett1> pchadwick: What's the status on yours?
21:42:54 <Arkady_Kanevsky> BOF sounds good. But it need to be done jointly with operator and user groups.
21:42:59 <piet> We didn't submit as BoF
21:43:01 <piet> Gotta go
21:43:01 <rocky_g> I'm gonna put it together today.  I'm thinking we could do both the newbie session and a BOF.
21:43:03 <pchadwick> I have the abstract, but no feedback on ether pad
21:43:27 <pchadwick> (for the Epic discussion)
21:43:34 <barrett1> rocky_g: Sound good
21:43:40 <barrett1> pchadwick: can you post the link?
21:43:41 <pchadwick> On the enterprise panel we only have one committed participant
21:43:58 <barrett1> pchadwick: who is it?
21:43:59 <Arkady_Kanevsky> BOF on big tent and multiple releases - droping it. No time to prepare submission
21:44:11 <barrett1> Arkady_Kanevsky: OK
21:44:12 <pchadwick> https://etherpad.openstack.org/p/austin_summit_product_wg (last one on the list)
21:44:43 <barrett1> pchadwick: any word back from Doug Hellman?
21:44:48 <pchadwick> Not yet
21:45:07 <barrett1> dhellmann: Are you around?
21:45:20 <shamail> pchadwick, I like the abstract but do you want to call out that epics == themes?
21:45:37 <pchadwick> shamail +1
21:45:40 <thingee> Arkady_Kanevsky: for what it's worth, Thierry and Doug covered that subject quite well https://www.openstack.org/summit/tokyo-2015/videos/presentation/herding-cats-into-boxes-how-openstack-release-management-changes-with-the-big-tent ... curious what you see we would get from a bof?
21:45:42 <shamail> We have been referring to them as "themes" in our roadmap presentation and mitaka PTL interviews
21:45:55 <barrett1> shamail: +1
21:46:05 <piet> Sorry to jump in, but could really use a room at the Ops Summit for interviews/usability
21:46:09 <leong> shamail +1
21:46:18 <barrett1> Team - pls review and provide add'l feedback to pchadwick
21:46:30 <barrett1> Piet: Talk to Tom Fifield
21:46:49 <Arkady_Kanevsky> <thingee> - agree. expect update once we start multiple release options per Mitake or Newton release.
21:47:01 <barrett1> I have submitted the Community Roadmap proposal - thanks for the feedback. Nate, Hugh and I are the speakers
21:47:02 <shamail> piet, email Tom Fifeld or Matt Jarvis
21:47:22 <rocky_g> piet, the ops summit hasn't started compiling its sessions yet
21:47:24 <barrett1> What about Confronting Complexity?
21:47:41 <kencjohnston> barrett1 I'm ready to submit it this evening
21:47:48 <barrett1> I think Piet is referring to the Ops Midcycle in Manchester
21:48:00 <barrett1> kencjohnston: Excellent!
21:48:08 <leong> kencjohnston: i assume you also include Kei?
21:48:17 <kencjohnston> leong yep!
21:48:23 <leong> +1
21:48:30 <barrett1> kencjohnston: what about the OpenStack SWOT or Business Strategy proposal?
21:48:30 <kencjohnston> MarkBaker you still interested?
21:48:41 <kencjohnston> barrett1 I'm planning on submitting that one as well
21:48:57 <kencjohnston> right now it is barrett1 and me, anyone else interested in joining?
21:49:04 <barrett1> kencjohnston: You are on it! Thanks!
21:49:05 <piet> Need both.  Would love to have rooms at both.  In fact, there is a ton of value to the community if we could run studies at both summits.
21:49:07 <thingee> Arkady_Kanevsky: multiple release options... you like intermediate, indepdent, milestone release types? https://governance.openstack.org/reference/tags/index.html#release-management-tags
21:49:14 <kencjohnston> #link https://etherpad.openstack.org/p/AUS-Summit-BOF-Business-Strategy-Proposal-Draft
21:49:19 <thingee> Arkady_Kanevsky: because those happened before mitaka.
21:49:51 <rocky_g> I think the stabilization theme should be added to themes talk.
21:49:58 <barrett1> Next one is Rolling Upgrades session. I know the Kolla team has proposed a session around this
21:50:02 <rocky_g> If you want, I can cover that one in the session.
21:50:02 <MarkBaker> kencjohnston, sure
21:50:14 <kencjohnston> MarkBaker Great I'll add you to the submission.
21:50:17 <Arkady_Kanevsky> I am talking releases for Enterprise, NFV, HPC and others not general bi-annual "release" of openstack
21:50:57 <Arkady_Kanevsky> Pete Chadwick - I will be happy to co-present with oyu
21:51:03 <barrett1> Folks - It's hard to follow the discussion when we have multiple conversations going on the channel
21:51:20 <barrett1> Arkady_Kanevsky: Can you and Pete close on that?
21:51:39 <Arkady_Kanevsky> working on it in etherpad
21:51:45 <barrett1> Thank you
21:52:08 <barrett1> Next one is the Stabilization efforts - Rockyg
21:52:13 <pchadwick> Arkady_Kanevsy: thanks. I assume you haven't hit your limit yet ;)
21:52:29 <MarkBaker> kencjohnston, I'd like to see if I can work an economics angle in there too
21:52:36 <rocky_g> I think that should be added as a new theme to the themes one.
21:52:53 <kencjohnston> MarkBaker Great, let's chat offline
21:53:27 <barrett1> Rocky_g: So this isn't intending to introduce the new project and guidelines around it?
21:54:58 <barrett1> Rocky_g: I think a BoF on the Stabalization project, at a minimum, would be good
21:55:22 <thingee> barrett1: what are the ideas with that exactly?
21:55:42 <rocky_g> barrett1, so it's not a project, so much as a cross project effort gaining awareness and importance in the dev community
21:56:05 <barrett1> rocky_g: That makes BoF sound like a better fit
21:56:18 <barrett1> Folks - We have 4 mins left. Have people looked at the Ops Midycle agenda?
21:56:30 <thingee> rocky_g: i'd recommend working with the stabilization folks. Matt Riedemann heads that team
21:56:47 <barrett1> Are there any topics that we want to propose? Or any volunteers to moderate already proposed sessions?
21:56:51 <rocky_g> Yup.  So, I can put together a BoF proposal on that.
21:57:03 <barrett1> rocky_g: Thanks!
21:57:03 <kencjohnston> barrett1 I've expressed my willingness to volunteer to Matt and Tom
21:57:22 <barrett1> Great kencjohnston!
21:57:24 <thingee> rocky_g: however as we've discussed in the past, it's hard to get support from the community. Linux distributions would rather keep making their money then contribute efforts there
21:57:34 <barrett1> I replied that I would lead the user story session if they want
21:57:43 <shamail> barrett1: 3 min left
21:57:51 <rocky_g> And I'll do the newbie "How you can make OpenStack better but you're not a developer" session
21:58:02 <thingee> rocky_g: +1
21:58:06 <thingee> that sounds awesome
21:58:11 <thingee> and we need more of that
21:58:21 <barrett1> rocky_g: +1
21:58:30 <shamail> Do we want to move over to #openstack-productwg to continue the conversation after our time is up or defer the remaining agenda items until next week?
21:58:53 <barrett1> I can go for another 30 mins
21:59:04 <shamail> same
21:59:06 <leong> same
21:59:07 <kencjohnston> shamail sounds like last remaining item was a discussion around meeting times
21:59:15 <kencjohnston> I cannot stay on
21:59:25 <shamail> https://wiki.openstack.org/wiki/Meetings/product-team
21:59:27 <shamail> it got updated
21:59:39 <barrett1> kencjohnston: agenda for our midcycle also needs discussion
21:59:40 <shamail> remaining items are: stabilization user story, mid-cycle planning
22:00:03 <shamail> mid-cycle planning being priority
22:00:10 <leong> let's jump to another channel..
22:00:17 <shamail> #openstack-productwg
22:00:21 <barrett1> OK
22:00:27 <barrett1> #endmeeting