21:00:49 <carolbarrett> #startmeeting Product Working Group
21:00:50 <openstack> Meeting started Mon Feb 29 21:00:49 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:54 <openstack> The meeting name has been set to 'product_working_group'
21:01:27 <carolbarrett> Hi Folks - Time for the Product Work Group team meeting
21:01:36 <KrishR> o/
21:01:45 <leong> o/
21:01:45 <MarkBaker> 0/
21:01:58 <shamail> Hello
21:02:05 <carolbarrett> Agenda can be found at the link
21:02:12 <MeganR> o/
21:02:14 <carolbarrett> let's start with roll call
21:02:16 <ian_ott> hello - this is Ian, sitting in for the first time, listening and learning
21:02:29 <kencjohnston> o/
21:02:35 <shamail> Welcome ian_ott!
21:02:36 <kencjohnston> ian_ott Welcome!
21:02:41 <sgordon> o/
21:02:50 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:02:51 <carolbarrett> Hi Iam
21:03:02 <carolbarrett> Ian (oops)
21:03:16 <pchadwick> hello all
21:03:20 <ian_ott> thanks for the welcome all
21:03:22 <leongs> o/
21:03:26 <breton> o/
21:03:31 <KrishR> o/
21:03:40 <rockyg> o/
21:03:44 <pchadwick> o/
21:03:51 <carolbarrett> Let's get going.
21:03:55 <carolbarrett> #topic Action Item Revie
21:03:56 <kei_> Hi everyone.  I'm Kei.  This is my first time to join.
21:04:06 <kencjohnston> welcome kei_ !
21:04:08 <carolbarrett> I seem to have typo-itis today...
21:04:15 <shamail> Welcome to you as well kei_!
21:04:24 <carolbarrett> #link http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-02-22-21.01.txt
21:04:27 <pchadwick> Welcome Kei
21:04:41 <carolbarrett> #link https://etherpad.openstack.org/p/PWG-LON16-MidCycle_Summary
21:04:45 <carolbarrett> Hi Kei
21:04:46 <leongs> welcome kei! good to have you in the meeting!
21:05:00 <rockyg> Welcome!
21:05:08 <kencjohnston> carolbarrett I had the first AR
21:05:19 <rockyg> Also:  fyi Anni is on leave so won't join us today.
21:05:19 <kencjohnston> * kencjohnston talk to talk to the infra team about adding more detail
21:05:19 <kencjohnston> on Windows setup to docs
21:05:20 <carolbarrett> Go ahead kenny
21:05:46 <kencjohnston> I started a thread on the dev list, and heard from teh Docs PTL that we should create our own guide so we could control the content more easily. Create one that references the infra guide
21:06:09 <kencjohnston> and then I heard from an infra core that they woudl welcome contributions to make their guide more usable by non-developers/windows folks
21:06:14 <kei_> Thank you, everyone.  I'm finally able to join here today, Leong.
21:06:17 <kencjohnston> So... my vote would be to add to the infra guide.
21:06:45 <shamail> kencjohnston: I saw that... Wanted your opinion on whether we need a guide or just add a wiki page since ours won't be updating that often?
21:06:45 <kencjohnston> Let me add links to the two examples
21:07:11 <kencjohnston> shamail I think it would be better to continue to point all new contributors to one place, the infra guide
21:07:21 <kencjohnston> just expand the definition of contributor
21:07:22 <carolbarrett> kencjohnston +1
21:07:23 <rockyg> we want it in the infra guide.  A doc as opposed to the wiki
21:07:43 <shamail> kencjohnston: +1
21:07:48 <leongs> +1
21:07:50 <rockyg> Especially since the wiki is currently under spam attack :-/
21:07:59 <KrishR> +1
21:08:00 <kencjohnston> #link http://docs.openstack.org/contributor-guide/index.html
21:08:14 <rockyg> kencjohnston, +1
21:08:23 <kencjohnston> #link http://docs.openstack.org/infra/manual/developers.html#getting-started
21:08:28 <kencjohnston> So we want to update the second link
21:08:40 <kencjohnston> rockyg Spam attack? Oh no.
21:08:52 <pchadwick> under additional Git workflow?
21:08:55 <carolbarrett> rockyg: that would explain the new challenge question when you post an update to a wiki page
21:09:54 <rockyg> back on topic, I think this section needs a diagram.  Some folks don't get things by reading words.
21:10:32 <kencjohnston> rockyg +1 and links to leongs videos
21:10:45 <rockyg> Yon spamming, they are locking down various parts of the site, then will look for patterns once they get things controlled.
21:11:02 <rockyg> kencjohnston, +1 to video links
21:11:16 <kencjohnston> one more link, this one to the email thread.
21:11:18 <kencjohnston> #link http://lists.openstack.org/pipermail/openstack-dev/2016-February/087286.html
21:12:40 <carolbarrett> It seems that the action items should be:
21:12:59 <carolbarrett> 1) Link Leong's videos to the getting started doc
21:13:05 <carolbarrett> Leong: Can you take that AR?
21:13:20 <leongs> +1
21:13:25 <carolbarrett> Thanks
21:13:35 <carolbarrett> #action Leong Leong's videos to the getting started doc
21:14:00 <carolbarrett> 2) Is there some enhancements to the existing diagram that need to be made or new ones created?
21:14:08 <kencjohnston> can I add to that action, leongs can you send us the gerrit link once committed?
21:14:48 <carolbarrett> #action leong send to the PWG ML the gerrit link once committed
21:14:57 <leongs> ok kencjohnston
21:15:01 <carolbarrett> kencjohnston: got it
21:15:15 <carolbarrett> What about diagrams, changes? Someone willing to own this?
21:15:26 <rockyg> I think we need a diagram for signing up and getting accounts squared away.
21:15:54 <carolbarrett> rockyg: Will you take ownership for this?
21:16:33 <carolbarrett> anyone else?
21:16:53 <rockyg> Interesting question.  Mostly drowning right now, but I may be able to do something.... but not immediately.  DefCore midcycle next week.
21:17:05 <shamail> Packed schedule until 3/11... I can help after that.
21:17:08 <kei_> leongs: Where can I find your video?
21:17:27 <carolbarrett> OK, we'll put it on the back burnder for now
21:17:29 <carolbarrett> OK, moving to next Action Item: Shamail - Do you want to reportout on the Roadmap meeting doodle?
21:17:36 <shamail> Sure
21:18:02 <MarkBaker> /me has not responded to roadmap meeting doodle
21:18:05 <shamail> I sent out a doodle for the roadmap sub-team weekly meeting
21:18:11 <shamail> The results are in!
21:18:24 <shamail> We will be meeting on Tuesdays at 2P ET/11A PST
21:19:02 <pchadwick> I didn't respond, but that time works for me.
21:19:03 <shamail> Hopefully that works MarkBaker
21:19:05 <cloudrancher> Great
21:19:22 <pchadwick> Starting tomorrow?
21:19:24 <leongs> kei_ : https://www.youtube.com/watch?v=uAVPDyK8flc
21:19:25 <shamail> Awesome pchadwick
21:19:25 <MarkBaker> shamail, that works, although not this week
21:19:27 <carolbarrett> Good
21:19:28 <shamail> Yes
21:19:35 <shamail> Starting tomorrow
21:19:38 <KrishR> works, but not this week
21:19:39 <kei_> leongs: Thanks.
21:19:45 <pchadwick> shamail: cool
21:19:48 <shamail> Tomorrow will just be a status update
21:19:54 <rockyg> what happens with Daylight savings time?
21:19:55 <carolbarrett> Anything else Shamail?
21:20:08 <shamail> That is all
21:20:28 <pchadwick> shamail: Where is the meeting info?
21:20:32 <carolbarrett> rockyg: when is that?
21:20:45 <rockyg> I think it's this coming sunday
21:21:07 <shamail> Pchadwick: I haven't sent the details out yet... Expect them tonight
21:21:15 <rockyg> Nope. Next sunday, 3/13
21:21:18 <pchadwick> OK - thanks.
21:21:45 <carolbarrett> OK - Let's figure out what to do with Daylight savings next week - will put on the agenda.
21:21:46 <carolbarrett> Let's move on
21:21:50 <carolbarrett> For my ARs, we're going to talk about the doodle results for training in a bit; On contacting Foundation folks for a room, I sent a note and they will get back to me as they sort out the overall conference rooms
21:22:16 <carolbarrett> Let's go to the Action Items from the Mid-cycle
21:22:30 <carolbarrett> That is the 2nd link I posted at the start of this topic
21:23:11 <carolbarrett> Has everyone looked over the Action Item Summary? The 1st section applies to all of us
21:23:51 <kencjohnston> carolbarrett I have
21:24:00 <kencjohnston> And I'm particularly fond of this one - AR: Add "openstack/openstack-user-stories" toyour watched Projects on Gerrit - https://review.openstack.org/#/settings/projects
21:24:00 <shamail> Same
21:24:01 <carolbarrett> +1
21:24:28 <cloudrancher> Confessing that I have not
21:24:37 <kencjohnston> carolbarrett do you want to review all items 1X1 here, or should we add status to the etherpad?
21:24:43 <carolbarrett> kencjohnston: nice to have a favorite!
21:24:47 <shamail> kencjohnston: +1 good idea
21:25:15 <carolbarrett> kencjohnston & Leong: How are the Rolling upgrade User Story  Action Items coming along? Can you put an update into the etherpad too?
21:25:39 <kencjohnston> Sure, most of them are completed as per
21:25:42 <kencjohnston> #link https://review.openstack.org/#/c/286103/
21:25:53 <kencjohnston> Which confirms to the new template and proposes for cross project spec creation
21:26:00 <kencjohnston> s/confirms/conforms
21:26:48 <shamail> The skeleton tracker file looks good too kencjohnston
21:27:06 <carolbarrett> +1
21:27:06 <kencjohnston> thanks shamail
21:27:59 <shamail> .
21:28:09 <carolbarrett> I've put updates in the etherpad for the items I own - more work required..
21:28:23 <shamail> Same here
21:28:23 <carolbarrett> Shamail: Thanks for th eupdate on o
21:28:34 <carolbarrett> oop: hit enter too soon
21:28:39 <carolbarrett> Shamail: Thanks for your updates
21:28:56 <shamail> You're welcome carolbarrett
21:29:02 <carolbarrett> Rocky: What's the status on your AR?
21:30:03 <carolbarrett> Mike Perez: Are you here?
21:30:04 <carolbarrett> I'll take that to mean it's still pending.
21:30:07 <carolbarrett> Thingee?
21:30:29 <carolbarrett> Piet are you here?
21:30:30 <shamail> Don't see him...
21:30:46 <shamail> Nor him
21:30:55 <carolbarrett> Thanks shamail
21:31:06 <rockyg> Swamped.  Just now catching up.  Can't find etherpad....
21:31:06 <carolbarrett> we'll move to Leong - Ready to share results on Doodle?
21:31:14 <rockyg> at least not at my fingertips.
21:31:27 <carolbarrett> #link: https://etherpad.openstack.org/p/PWG-LON16-MidCycle_Summary
21:31:55 <rockyg> Thanks.  Just found it up top
21:32:17 <leongs> I have received only 7 response for the PWG change time...
21:32:40 <rockyg> Ah.  On stable branch meeting in -4 now.  will update this week or next.
21:32:42 <shamail> Do you want to set a deadline leongs?
21:32:54 <carolbarrett> Does everyone have the doodle link to the meeting poll?
21:32:59 <carolbarrett> Leong: Can you post it here?
21:33:03 <shamail> +1
21:33:14 <leongs> https://www.surveymonkey.com/r/9WRDDTG
21:33:25 <carolbarrett> Thanks Leong
21:33:38 <leongs> #link PWG Meeting Time Survey: https://www.surveymonkey.com/r/9WRDDTG
21:33:50 <carolbarrett> When do you want to cut-off the survey?
21:34:07 <leongs> Appreciate if everyone could make you preferences by end of this week.
21:34:15 <shamail> I can do that
21:34:29 <MarkBaker> leongs, doing it now
21:34:42 <carolbarrett> #action All enter your prefences for meeting times into the doodle by end of this week https://www.surveymonkey.com/r/9WRDDTG
21:34:43 <leongs> i would propose we make the changes after US Daylight saving
21:34:49 <carolbarrett> OK - I think that takes care of action item review
21:34:51 <carolbarrett> phew!
21:34:59 <carolbarrett> #topic Work flow update
21:35:08 <carolbarrett> Shamail - Can you take us through this?
21:35:09 <shamail> Absolutely!
21:35:10 <pchadwick> leongs: +1
21:35:26 <shamail> I have updated the user story page on the wiki to reflect the new workflow...
21:35:31 <shamail> #link https://wiki.openstack.org/wiki/ProductTeam/User_Stories
21:35:45 <shamail> Summary of key changes:
21:35:52 <shamail> We will be getting rid of the draft folder
21:36:26 <shamail> The gap analysis phase has been moved into the community as a part of the cross project spec review process
21:36:35 <leongs> should we "archive" the draft folder?
21:36:51 <shamail> We will essentially be using Gerrit to review and update the user story concepts going forward
21:36:55 <leongs> there are quite a few user story drafted there...
21:37:01 <shamail> Mike will help us automate template validation
21:37:18 <shamail> Leong, we will move them to proposed as they are fit into the new template created by Kencjohnston
21:37:38 <shamail> The ones that don't get updated, I will eventually move to proposed and they will stay as open reviews
21:37:55 <leongs> ok
21:37:57 <leongs> got that
21:38:04 <kencjohnston> shamail I can help split up the work of reformatting and moving
21:38:23 <kencjohnston> but I agree we should do one commit for each one so we can review them individually.
21:38:30 <leongs> should the existing "user owner" do the move?
21:38:31 <shamail> Beyond that the changes mentioned above, we will basically be moving what used to be in tracked to cross project specs
21:38:40 <kencjohnston> leongs +1
21:38:48 <shamail> Thanks Kencjohnston, I'll keep you posted on the workload once the dust settles
21:39:05 <shamail> I will also be adding one more update to the wiki which will summarize these key changes
21:39:14 <shamail> Any questions so far on the new workflow?
21:39:44 <kencjohnston> shamail just a comment that a big component of the new process
21:39:53 <shamail> The tracker dashboard is going to be critical in the new workflow for visibility into user story status.... A few of us are starting to devise a plan of action on that.
21:40:00 <kencjohnston> is that we all review the submissions and discuss any contention as the content is added
21:40:10 <shamail> +1 Kencjohnston
21:40:17 <kencjohnston> so watching the repo is critical so you can provide feedback
21:40:21 <cloudrancher> can someone send me a email offline on what I need to do to convert the onboarding for management?
21:40:44 <shamail> Absolutely, we can't wait for IRC discussions or emails... All data/discussion should live in one place (that place will be Gerrit)
21:40:45 <kencjohnston> cloudrancher it is pretty straightforward check out the new template format
21:41:17 <cloudrancher> i'll take a look.
21:41:33 <kencjohnston> shamail I think another component is that the cores need to provide more time for other reviewers to review
21:41:58 <shamail> Agreed Kencjohnston
21:42:01 <kencjohnston> to facilitate a discussion
21:42:18 <shamail> Cores should go ahead and +2 but the second +2 shouldn't happen until there are a few +1s and discussion
21:43:00 <shamail> We also need to start attending cross project meetings
21:43:17 <shamail> Since they integrate in our workflow, the user story owners at the very minimum
21:43:28 <shamail> But ideally, both owners and CPLs should make it
21:43:35 <carolbarrett> shamail: we'll need to get more specific on that one
21:43:36 <shamail> And watch the cross project spec repo as well
21:44:10 <shamail> carolbarrett: Specifics as in dates/times or reasoning?
21:44:55 <carolbarrett> Who will attend, when they need to discuss a topic with this group, when they need someone else to join them in the meetings, etc
21:45:21 <shamail> Sounds good carolbarrett
21:45:33 <shamail> Should I add that to the wiki as well or socialize via email or IRC first?
21:45:54 <carolbarrett> Do we want the attendees to update this group on key discussions? Even if it's just coming into this meeting, raising the topic and posting a link to the discussion thread
21:46:06 <carolbarrett> shamail: that's a good idea. THanks
21:46:29 <shamail> carolbarrett: +1, I also want CPLs to provide regular updates on projects too... We can determine cadence.
21:46:43 <shamail> I'll edit the wiki with this information and send an email for feedback
21:47:06 <carolbarrett> #action Shamail Add info on Cross-Project Team liaison roles and requirements and send email  too
21:47:23 <carolbarrett> What else do we want to cover on work flow?
21:47:25 <shamail> Thanks carolbarrett, that's all I had unless there are questions.
21:47:57 <carolbarrett> #topic User Story Update Plan
21:47:59 <carolbarrett> OK, moving along
21:48:04 <carolbarrett> Kenny - Can you take this one?
21:48:11 <kencjohnston> carolbarrett sure
21:48:34 <kencjohnston> So, as mentioend previously, all current user story owners need to update their stories to conform to teh new template
21:48:47 <kencjohnston> you can see an example here - https://review.openstack.org/#/c/286103/
21:49:05 <kencjohnston> this same commit should also include moving the file to the "Proposed" folder from the "Draft" folder
21:49:28 <kencjohnston> I'm going to assume "owner" is the person who made the original commit
21:49:39 <shamail> Kencjohnston: +1
21:49:51 <kencjohnston> we'd like these reviews submitted by EOW
21:50:01 <shamail> We can handle orphans after the authors/owners move the ones they own.
21:50:01 <kencjohnston> so we can get the changes merged by a week from Friday
21:50:11 <kencjohnston> shamail +1
21:50:17 <kencjohnston> so an action for all and an action for Shamail and I
21:50:24 <kencjohnston> we'll pickup the orphans after Friday
21:50:40 <kencjohnston> and give mean looks to anyone who knowingly leaves a story orphaned for us to pickup :)
21:50:52 <leongs> +1
21:51:00 <carolbarrett> #action All-User-Story-Owners Update your user story to the new format by 3/11
21:51:03 <shamail> Haha Kencjohnston
21:51:23 <kencjohnston> carolbarrett I'd ask that they submit the change by 3/4
21:51:25 <leongs> that's a busy march...
21:51:32 <carolbarrett> #action Shamail/Kenny Update the user story orphans after 3/11
21:51:51 <kencjohnston> The template changes are very minor, jsut some heading restructuring
21:52:56 <carolbarrett> Any questions? Does everyone know where do find the info to make the changes?
21:53:22 <kencjohnston> #link Updated User Story Template https://github.com/openstack/openstack-user-stories/blob/master/user-story-template.rst
21:53:33 <carolbarrett> Thanks Kencjohnston
21:53:34 * kencjohnston learned from leongs that you can name links
21:53:35 <carolbarrett> Moving along
21:53:48 <carolbarrett> #topic Gerrit Team Training - Doodle Results
21:54:06 <carolbarrett> Thanks to all who responded to the doodle
21:54:30 <carolbarrett> The best time for people is 3/10 at 1PM Pacific
21:54:56 <carolbarrett> This session will focus on using the web interface of the newly released gerrit update
21:55:16 <carolbarrett> kencjohnston and shamial will be the trainers for the session
21:55:30 <pchadwick> That is right after the ebook review?
21:55:31 <kencjohnston> carolbarrett yep
21:55:39 <carolbarrett> Do we need a webex or video conferencing or is audio conference OK?
21:56:12 <pchadwick> carolbarrett: I would think that letting people see the WebUI would be useful
21:56:15 <kencjohnston> carolbarrett webex or somethign similiar woudl be great
21:56:30 <carolbarrett> pchadwick - I don't see a book review right before this
21:57:02 <pchadwick> argh - I was looking at 3/9 instead of 3/10
21:57:21 <carolbarrett> OK - will someone with a webex account take the action item to schedule this? (I don't have one)
21:57:35 <pchadwick> How many people are we talking about?
21:57:53 <pchadwick> I have a go to meeting
21:58:15 <MarkBaker> pchadwick, is gotomeeting more linux friendly?
21:58:30 <pchadwick> Yes, as in it actually works. ;)
21:58:30 <MeganR> I can schedule Webex if that is easier
21:58:40 <carolbarrett> There were 10 responses to the doodle, so I'd plan on ~15
21:58:57 <pchadwick> MarkBaker: you can even control GTM from Chrome on Linux
21:59:30 <carolbarrett> pchadwick - I'd appreciate if you'd send out a meeting invite to the PWG ML with the meeting info for 3/10 at 1:00 Pacific
21:59:44 <pchadwick> assign me the action
21:59:49 <carolbarrett> #action: Pete Chadwick Send out a meeting invite to the PWG ML with the meeting info for 3/10 at 1:00 Pacific
21:59:51 <carolbarrett> Thanks
22:00:34 <carolbarrett> We're out of time, so will push Persona to next meeting. Can always take this to the ML if that's too far out.
22:00:35 <carolbarrett> Thanks
22:00:43 <kencjohnston> carolbarrett thanks!
22:00:45 <kencjohnston> thanks all!
22:00:49 <carolbarrett> #endmeeting