21:01:10 <carolbarrett> #startmeeting Product Working Group
21:01:14 <openstack> Meeting started Mon Mar  7 21:01:10 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:17 <openstack> The meeting name has been set to 'product_working_group'
21:01:26 <shamail> Hi everyone.
21:01:31 <piet> Howdy
21:01:31 <carolbarrett> Hi Shamail
21:01:33 <pchadwick> Hi Shamail
21:01:35 <carolbarrett> #topic roll call
21:01:35 <philipw> Hey
21:01:38 <kei_> Hi.
21:01:42 <ian_ott> hello
21:01:42 <carolbarrett> who's here?
21:01:45 <hughhalf> o/
21:01:48 <pchadwick> 0/
21:01:49 <piet> o/
21:01:50 <philipw> o/
21:01:52 <kei_> o/
21:01:54 <pchadwick> o/
21:02:01 <carolbarrett> hi hugh- glad you could make it!
21:02:13 <MarkBaker> o/
21:02:31 <carolbarrett> You can find the agenda here
21:02:38 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:02:39 <hughhalf> thanks carolbarrett has been a frantic week or two so getting caught up
21:02:47 <leong> o/
21:03:05 <carolbarrett> Great to see everyone, let's get started
21:03:11 <carolbarrett> #topic Action Item Review
21:03:35 <carolbarrett> let's start with last week's meeting
21:03:39 <carolbarrett> #link http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-02-29-21.00.txt
21:03:55 <kencjohnston> hi team sorry I'm late o/
21:04:11 <shamail> Hi kencjohnston
21:04:17 <carolbarrett> Hi kencjohnston, we're just getting going
21:04:26 <carolbarrett> Leong - you have the 1st couple of ARs
21:04:35 <Arkady_Kanevsky> hello
21:04:58 <carolbarrett> Leong - can you provide updates?
21:05:01 <shamail> Hi Arkady_Kanevsky
21:05:06 <leong> have submitted the patch to include video link
21:05:31 <carolbarrett> Hi Arkady_Kanevsky
21:05:41 <KrishR> o/
21:05:41 <carolbarrett> Thanks Leong
21:05:43 <Arkady_Kanevsky> hi carol
21:05:51 <carolbarrett> Do you have doodle results too?
21:06:40 <carolbarrett> Leong - That's the for the alternative meeting time
21:06:48 <leong> haven't summarized the result yet
21:07:23 <leong> received 11 response so far
21:07:41 <carolbarrett> that's pretty good. Can you send the results to the ML when you close the doodle?
21:07:58 <leong> ok.
21:08:01 <carolbarrett> #action Leong send alternate meeting plan to the ML
21:08:03 <carolbarrett> Shamail - the next one is yours, about adding Cross-project Liasons to our work flow and wiki
21:09:04 <shamail> I haven't added the role of CSPLs in the workflow wiki yet, I plan to do that this week.  I'll send an email with summary of changes at that time too.  Sorry for the delay.
21:09:47 <shamail> It's captured in the diagram but still needs an explanation in the wiki... At the same time, I will add our role in cross project meetings too.
21:09:48 <carolbarrett> #action shamail Add info on Cross-Project Team liaison roles and     requirements and send email  too
21:09:53 <shamail> Thanks.
21:09:59 <carolbarrett> Sounds good
21:10:06 <carolbarrett> the next one is for all user story owners
21:10:21 <carolbarrett> Update stories to meet the new template and move the the proposed repo
21:10:27 <carolbarrett> How are we doing on this one?
21:10:37 <Arkady_Kanevsky> http://www.openstack.org/software/roadmap/ - falls short of expectaion on visiobility of roadmap. Where/how do we want to document longer term roadmap?
21:10:37 <kencjohnston> carolbarrett I think I've completed mine
21:10:52 <carolbarrett> Thanks kencjohnston
21:11:04 <shamail> We've seen updates to rolling upgrades, HA VM, and stable releasesz
21:11:19 <shamail> And one additional one (security groups)
21:11:53 <shamail> Arkady_Kanevsky: we can discuss this during open items near the end of the meeting.
21:12:27 <shamail> kencjohnston and I will start moving the remainder this week.
21:12:37 <carolbarrett> Thanks Shamail
21:12:41 <kencjohnston> shamail - I already got a head start :)
21:12:42 <carolbarrett> and Kencjohnston
21:12:46 <Arkady_Kanevsky> kenny, I am maybe missing somnthing HA VM is dependent on HA extension of ha proxy that is outside the scope of Openstack code base.
21:12:55 <shamail> The goal will be to merge them into the proposed folder and then do a simple update to keep the review open.
21:13:06 <shamail> I saw that Kencjohnston  :)
21:13:06 <Arkady_Kanevsky> Will be happy to review any pull requests.
21:13:10 <carolbarrett> # action shamail kencjohnston move the remaining user stories to proposed repo with appropriate content updates
21:13:57 <carolbarrett> arkady_kanevsky: Hold off on providing review comments until the moves are complete.
21:14:16 <carolbarrett> Next set of action items come from our midcycle.
21:14:19 <carolbarrett> #link https://etherpad.openstack.org/p/PWG-LON16-MidCycle_Summary
21:14:25 <Arkady_Kanevsky> ok
21:14:36 <pchadwick> You skipped mine ;)
21:14:47 <pchadwick> Did everybody get the invite for the Gerritt training?
21:14:53 <carolbarrett> Sorry pchadwick!
21:15:01 <kencjohnston> pchadwick Yep, on my calendar.
21:15:26 <carolbarrett> Thanks - yes, I saw it. Good reminder. The Gerrit training is 3/10 at 1:00 Pacific
21:15:27 <KrishR> yes, got the training invite
21:15:27 <pchadwick> Thanks - just checking.
21:15:50 <carolbarrett> Back the mid-cycle actions
21:16:05 <carolbarrett> Rolling upgrades team ARs look closed
21:16:25 <KrishR> pchadwick: can you send me the invitation again? it seems to ahve dropped off
21:16:29 <kencjohnston> carolbarrett I will take the action to submit it as a Cross Project spec this week
21:16:48 <carolbarrett> Ok kencjohnston
21:16:51 <pchadwick> krishR: what is your email?
21:17:04 <KrishR> krishnan.raghuram@intel.com
21:17:06 <carolbarrett> #action kencjohnston submit rolling upgrades user story to cross spec repo
21:17:11 <carolbarrett> Most of mine are done
21:17:13 <pchadwick> krishr: thanks.
21:17:57 <carolbarrett> Shamail - Your ARs look to be in good shape
21:18:03 <shamail> Most of mine are done/started... Workflow has been updated on wiki and will do minor updates for cross project.
21:18:05 <MeganR> pchadwick: can you send me the invitation again, I am not seeing it - rossetti.megan18@gmail.com
21:18:06 <shamail> Roadmap is started
21:18:16 <shamail> Yep carolbarrett, moving them along
21:18:53 <carolbarrett> RockyG are you here?
21:19:02 <pchadwick> Megan and Krish - sent, let me know if you don't see it.
21:19:19 <shamail> pchadwick: can you send it to me again as well?  Didn't show up as an invite
21:19:22 <carolbarrett> How about Mike Perez/Thingee??
21:19:43 <MeganR> pchadwick: got it, thank you!
21:20:02 <carolbarrett> Kencjohnston - Yours look to be in good shape too
21:20:24 <carolbarrett> Piet = are you here?
21:20:29 <piet> Yep
21:20:33 <KrishR> pchadwick: thank you
21:20:52 <carolbarrett> Piet - you have a couple of ARs from the Midcycle, can you give updates?
21:21:08 <carolbarrett> The first one is: Join the cross-project discussion and work to agreeon a common set of Role names and definitions that the Community can use - fromsetting policy, to describing requirements/needs
21:21:43 <piet> (knew I shouldn't have committed) I reached out to  Jamie, but haven't heard back.  Having Linette schedule a meeting since they're part of the same company.
21:22:17 <carolbarrett> OK, we'll revisit next week and see how things are progressing
21:22:20 <piet> We need to decide whether roles and personas are part of the same x-project spec or different ones
21:22:26 <carolbarrett> The next one is: Contact Heidi Bretz (heidi@openstack.org) for data on theOperators Certification program and the underlying data
21:22:56 <piet> I don have commitment from Linette and Gudrun to work on the personas spec
21:23:19 <piet> Sent an email, but no response.  Sent a second email this morning.
21:23:56 <carolbarrett> is the at precursor to contacting Heidi or joining the cross project team discussions?
21:24:45 <piet> carolbarrett You lost me a bit..
21:25:01 <carolbarrett> Piet: let's follow-up in email...
21:25:08 <piet> Kk
21:25:17 <piet> Just ping me in Lync
21:25:27 <carolbarrett> OK
21:25:28 <carolbarrett> OK that's all for action item review
21:25:50 <carolbarrett> #topic User Story Tracker Development Plan
21:26:03 <carolbarrett> #link  https://docs.google.com/document/d/14TC1DvQqx3Z60IhM49TerRIi2iQXbr3QJ7GgTUZ7hXQ/edit?usp=sharing
21:26:21 <carolbarrett> Thanks Shamail for creating the spec and sending it out. I posted to the google folder above
21:26:28 <shamail> You're welcome
21:26:34 <carolbarrett> Can everyone access it?
21:26:54 <vhdiaz> yes
21:26:58 <carolbarrett> Shamail: Do you want to walk through it or ?
21:27:16 <shamail> Sure, I won't walk through it in detail but can provide context and plan
21:28:05 <shamail> This document was created after the mid-cycle since it became apparent that the tracker is a high priority item for us but might also have value for the development community (especially related to cross project proposals)
21:28:30 <shamail> The document has a mock-up which is meant to show important attributes for the dashboard
21:28:48 <shamail> It also covers which data sources need to be accessed to build the view
21:29:23 <shamail> Intel has assigned developers to help with the prototype and we are also working with the OpenStack Foundation (Carol included the list of core members in the agenda)
21:29:56 <shamail> The team will meet later this week to walk through the design goals and consider alternatives (there might be room to use a custom version of ChiliProject)
21:30:12 <carolbarrett> Thanks Shamail
21:30:19 <shamail> The team will also revisit the sizing estimates to make them more realistic
21:30:33 <pchadwick> shamail: looks good
21:30:45 <carolbarrett> We have a doodle going to setup the kick off team meeting - if you're interested in contributing, pls indicate what times work for you.
21:30:55 <carolbarrett> #link http://doodle.com/poll/9r4dvmgt8kyxx5b2
21:31:03 <shamail> I have an additional action item (which I plan to start this week), which is to determine where this needs to live after we determine whether a custom dev effort is needed
21:31:41 <carolbarrett> #action Shamail determine where the repo will be for the tracker tool upstream
21:31:43 <shamail> That's all I have for now, any questions?  Thanks for the doodle link carolbarrett
21:31:44 <carolbarrett> got it
21:31:45 <vhdiaz> thanks for the walkthrough
21:32:27 <carolbarrett> hey all - vhdiaz leads the Intel team which will provide some of the development support.
21:32:33 <shamail> Extracting data is not going to be fun because of different sources and granulairty of the returns.
21:32:45 <carolbarrett> If others want to contribute resources, pls do!
21:32:54 <carolbarrett> shamail: +1
21:33:01 <Arkady_Kanevsky> carol, tomorrow and wed is refstack/refcore midcycle meeting in Austin. so none of doodle times will work for folks who want to attend it
21:33:11 <shamail> Nice to meet you vhdiaz!  Look forward to working with you.  Please add anything else that i might have missed in the update
21:33:27 <carolbarrett> If you have comments on the spec,pls put them into the google doc.
21:33:32 <vhdiaz> thanks carolbarrett, hello folks looking fw to contribute and meet you all
21:33:36 <Arkady_Kanevsky> ok
21:33:48 <carolbarrett> Arkady_Kanevsky: That's a good point, not sure if that impacts us though...
21:34:05 <carolbarrett> Let's keep going
21:34:16 <carolbarrett> #topic What to do about Daylight Savings
21:34:22 <shamail> Arkady_Kanevsky: I wojld sugget that people who are developers or data source SMEs participate in these meetings.  We will keep the group updated via our regular Monday meetings
21:34:39 <carolbarrett> this is always a fun time for all of us!
21:34:45 <shamail> Even if there is a conflict for this meeting, you can join a future meeting
21:34:46 <Arkady_Kanevsky> thanks Carol and Shamail.
21:35:19 <carolbarrett> Some of the US changes time on the 13th, some of Europe on the 27th and lots of the world has no idea why anyone would do this
21:35:20 <shamail> carolbarrett: I suggest we start doing the same thing as most OpenStack teams... Keep the time the same and adjust to DST.
21:35:42 <shamail> Thus would avoid confusion but could cause schedule conflicts.
21:35:44 <carolbarrett> It seems that staying with UTC time is the most commonly accepted OpenStack way of handling this
21:35:46 <Arkady_Kanevsky> 1 PST does work for us now.
21:35:47 <shamail> This*
21:36:05 <pchadwick> I think it is the only way to handle it.
21:36:07 <sgordon> is the meeting not already fixed to UTC?
21:36:12 <shamail> This would mean the meeting would be 2P PST
21:36:15 <shamail> It is
21:36:19 <pchadwick> Those of us who are in the affected time zones need to adjust
21:36:21 <hughhalf> Yes, agreed that tying to UTC makes most sense
21:36:28 <shamail> I am suggesting that we keep the same UTC time
21:36:35 <pchadwick> shamail: +1
21:36:36 <sgordon> +1 to UTC time
21:36:36 * hughhalf nods at shamail
21:36:41 <carolbarrett> +1 shamail
21:36:50 <shamail> Does this create schedule conflcits for anyone?
21:37:01 <Arkady_Kanevsky> yes. will see what I can do.
21:37:05 <shamail> I dont have a conflict.
21:37:18 <hughhalf> no, still works for me, just an hour earlier, possibly two
21:37:30 <carolbarrett> I have a conflict but will resolve it.
21:37:32 <shamail> Wonky DST is wonky.
21:37:33 <carolbarrett> Seems like we're got agreement on sticking with 2100 utc
21:37:40 <carolbarrett> anyone disagree with this?
21:37:42 <Arkady_Kanevsky> carol, will you resend invite after time change?
21:37:43 <shamail> Thanks carolbarrett!
21:37:47 <pchadwick> None for my - my morning meetings with Europe are an entirely different problem
21:38:16 <shamail> The invite will stay the same.  I think I sent it for UTC but will double check.
21:38:17 <carolbarrett> pchadwick - I can only imagine!
21:38:18 <carolbarrett> #decision team meeting will stay at 2100 UTC.
21:38:44 <carolbarrett> Arkady_Kanevsky: I think the meeting invite should self-adjust, but I'll check it and resend if necessary
21:38:48 <kei_> +1 to UTC time
21:38:57 <carolbarrett> #action carol resend team meeting invite after time change
21:39:14 <carolbarrett> Ok next topic
21:39:17 <shamail> Checked, will update invite.  Can you assign action Carolbarrett?
21:39:25 <carolbarrett> #topic Persona Work Shop
21:39:29 <Arkady_Kanevsky> It will not self adjust in outlook or google calendar.
21:39:29 <shamail> Never mind.
21:39:30 <carolbarrett> shamail: I did
21:39:36 <shamail> Saw that.
21:39:38 <carolbarrett> Piet - Can you take this one?
21:39:51 <piet> Yep
21:40:13 <piet> Wondering whether we should move the persona working session to SA
21:40:18 <Arkady_Kanevsky> what is persona(s) goals?
21:40:33 <carolbarrett> What are the dates?
21:40:43 <piet> Goals for the meeting or the personas in general?
21:41:29 <Arkady_Kanevsky> personas in general for openstack
21:41:42 <piet> week(s) of March 21st or 28th?
21:41:50 <Arkady_Kanevsky> beyond admin, user, and tenant admin
21:42:27 <piet> A couple of goals.  First, they're intended to help the Product WG focus their stories
21:42:45 <piet> Second, the community needs a common vernacular for it's users
21:42:47 <carolbarrett> #link https://docs.google.com/presentation/d/1krb3D6420_M-gwAT54DOcYcBEO4vT3yhQjKPj3wdsoo/edit#slide=id.gd9f9dd530_0_0
21:43:04 <carolbarrett> arkady_kanevsky see the link I posted for more info
21:43:14 <piet> The term "end user" is so completely generic that it doesn't mean anything
21:43:22 <Arkady_Kanevsky> thanks carol. opemning the doc
21:43:27 <piet> Personas =/ roles
21:44:04 <Arkady_Kanevsky> piet - agree
21:44:10 <piet> Roles are software specific and do not provide an overview of pain points, opportunities, etc
21:44:18 <piet> ;^)
21:45:10 <piet> So, the focus of the session would be to work on three new roles: cloud consumer (end user), project owner and tenant admin
21:45:46 <piet> And we need to add more content to the existing personas. For example, how do they vary by company size and industry?
21:46:00 <pchadwick> What is the difference between tenant admin and project owner?
21:46:39 <piet> Sorry, Domain Admin and Project Owner
21:46:40 <carolbarrett> Piet - You have 4 more mins...what do you want to get out of this discussion?
21:46:40 <carolbarrett> Are you looking for a show of hands as to who would be able to attend the session if you move it to San Antonio? And which week is better for them?
21:46:50 <carolbarrett> Or?
21:46:56 <Arkady_Kanevsky> I will have ot miss it.
21:47:11 <Arkady_Kanevsky> is the question on which week is better?
21:47:26 <piet> I may move to SA if attendance will be better.   Need a commitment to attend from at least two PMs, two operators and two end users.
21:47:39 <piet> The operators and end users can attend a single day
21:47:49 <shamail> I'll still have a hard time attending
21:47:55 <piet> SO, the chocie is driven by when people can attend and where
21:48:14 <piet> Sorry for the caps. "So, the choice....
21:48:22 <Arkady_Kanevsky> the week of 21-25 - I can not
21:48:35 <piet> Anyone else?
21:48:47 <carolbarrett> It'll be v hard for me to make room for a ~3 day event/travel between now and the Summit
21:48:55 <Arkady_Kanevsky> The week after will work.
21:49:10 <pchadwick> I am not able to attend.
21:49:14 <carolbarrett> Piet: Have you thought about trying to have a work session in Austin?
21:49:28 <MeganR> I won't be able to attend, have three trips scheduled before the summit
21:49:35 <Arkady_Kanevsky> I am for Austin - 1000%
21:49:44 <Arkady_Kanevsky> Are oyu suggesting summit time?
21:50:08 <piet> We're trying to have something in preparation for the summit and these work sessions generally take about three days.
21:50:37 <piet> I may pivot back to Seattle since we have a facility and a commitment from two ops and a PM
21:50:39 <carolbarrett> Piet: Not sure you're going to get critical mass. Do you want to use a doodle to finalize this?
21:50:50 <carolbarrett> need to move along
21:51:07 <piet> So, the decision is to pivot back to Seattle
21:51:25 <carolbarrett> OK
21:51:29 <carolbarrett> #topic OpenStack Days
21:51:57 <carolbarrett> I became aware of a couple of upcoming OpenStack DAys, though I'm sure there are many more
21:52:10 <carolbarrett> On June 10th, there will be one in Dublin Ireland.
21:52:35 <carolbarrett> We have been invited to give a sesion on requirements/user stories and roadmpa
21:52:41 <carolbarrett> I meant roadmap
21:52:58 <carolbarrett> I told the organizers I would make it and would talk with you all about getting 1 or 2 others to join
21:53:03 <kencjohnston> carolbarrett Link? What is OpenStack Days?
21:53:15 <carolbarrett> We could even host a hands on session to write user stories
21:53:28 <carolbarrett> #link  http://openstackdayireland.com/
21:53:31 <leong> kencjonston https://www.openstack.org/community/events/#openstack_days
21:53:58 <carolbarrett> I was wondering if Mark Baker could swing over for this one?
21:54:01 <carolbarrett> Any one else?
21:54:12 <sgordon> kencjohnston, basically a meetup, but for a day
21:54:18 <sgordon> (or days in some cases ;)
21:54:21 <sgordon> they are regional events
21:54:22 <shamail> I'd like to volunteer as well for ones close to me
21:54:22 <kencjohnston> carolbarrett Count me as interested.
21:54:41 <carolbarrett> sgordon: I think there will be a strong telco focus if you're interested in joining
21:54:50 <carolbarrett> shamail: Thanks!
21:55:00 <carolbarrett> kencjohston: Thanks
21:55:03 <sgordon> im in dublin earlier that week but might be a challenge to extend the trip
21:55:12 <Arkady_Kanevsky> We can also schedule one in Austin
21:55:23 <carolbarrett> sgordon: OK, let us know if you can extend.
21:55:27 <carolbarrett> There's also one coming up in Australia.
21:55:31 <MarkBaker> carolbarrett, Intel have already asked us about participating in OpenStack Ireland day - very strong possibility I will go
21:55:32 <kencjohnston> carolbarrett Same here in terms of volunteering for local events.
21:55:37 <leong> Some is more than just meetup... is like a one-day summit
21:55:39 <Arkady_Kanevsky> there is monthly meetups we can present at
21:55:41 <carolbarrett> #link
21:55:42 <hughhalf> carolbarrett We expect to have a couple of folk there
21:55:47 <carolbarrett> #link  http://australiaday.openstack.org.au
21:56:07 <leong> I will be at APAC in July.. any interest for the OpenStack Day Taiwan?
21:56:09 <MarkBaker> carolbarrett, Prague, Germany, Budapest too
21:56:11 <sgordon> leong, that is basically what i said
21:56:12 <carolbarrett> markbaker: Great! Between you, me, shamail we shoudl be covered
21:56:14 <leong> http://openstack.ithome.com.tw/
21:56:19 <carolbarrett> Sounds like a great tour!
21:56:19 <shamail> +1
21:56:40 <shamail> Let's coordinate on the content as we get closer
21:56:51 <carolbarrett> Leong: Is there a users group there? If so, would be a good starting point to explore that
21:57:15 <leong> I think Tom F. is coordinatiing the taiwan day if i'm not wrong?
21:57:26 <carolbarrett> hughhalf: Any chance you can get in touch with the Australia day organizers and see if you can give a user story and roadmap update?
21:57:30 <shamail> There is one possibly in NY soon too, details still emerging
21:57:57 <Arkady_Kanevsky> cool. Boston?
21:58:03 <hughhalf> carolbarrett Will do - i get the impression that the local one is a little less technical than most, but will make enquiries
21:58:16 <carolbarrett> thanks hughhalf
21:58:16 <shamail> NY would cover Northeast
21:58:27 <carolbarrett> Moving along, only 2 mins left...
21:58:30 <carolbarrett> #topic Opens
21:58:31 <kei_> FYI, there's one in tokyo in July as well.  http://openstackdays.com/index_e.html
21:58:39 <carolbarrett> We covered the training earlier
21:58:54 <carolbarrett> Also want to make sure everyone is aware of the upcoming PTL and TC elections
21:58:55 <leong> kei_ you can represent us there in Tokyo
21:59:08 <Arkady_Kanevsky> any suggestions for devcore midcycle meeting?
21:59:32 <shamail> Arkady_Kanevsky: to answer your question about roadmap visibility... We do need to raise awareness.  Heidi Joy might have some ideas at the next refresh cycle (community ML, etc.)
21:59:38 <carolbarrett> #action carolbarrett add OpenStack Days follow-up discussion to the next team meeting agenda
21:59:46 <leong> +1
21:59:48 <kei_> leong: yes, that's a good idea.
21:59:56 <leong> kei_ +1
21:59:59 <Arkady_Kanevsky> thanks shamail. Let's bring it up with her.
22:00:12 <carolbarrett> Any other opens
22:00:42 <shamail> Carol, did you want to discuss anything specific about elections?
22:00:49 <Arkady_Kanevsky> by everybody. thanks
22:01:02 <shamail> We can add as an item for a future meeting?
22:01:22 <carolbarrett> shamail: Let everyone know they are coming up and see who has plans.
22:01:37 <carolbarrett> #action carolbarrett add TC Election topic to next meeting agenda
22:01:41 <carolbarrett> Bye everyone!
22:01:43 <shamail> carolbarrett: +1
22:01:44 <carolbarrett> #endmeeting