21:00:43 <carolbarrett> #startmeeting Product Working Group
21:00:44 <openstack> Meeting started Mon Mar 14 21:00:43 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:48 <openstack> The meeting name has been set to 'product_working_group'
21:01:04 <carolbarrett> Hi All - Who's here for the Product WG meeting?
21:01:09 <ian_ott> o/
21:01:10 <leong> o/
21:01:10 <vmtyler> Here
21:01:11 <kei_> o/
21:01:16 <shamail> hi all
21:01:16 <vmtyler> o/
21:01:23 <cloudon> hi
21:01:28 <HeidiJoy> Howdy!
21:01:52 <Arkady_Kanevsky> hello Product team
21:02:01 <carolbarrett> Great to see everyone managed through the time change!
21:02:10 <carolbarrett> Here's a link to our agenda
21:02:15 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:02:25 <carolbarrett> Let's get started
21:02:32 <carolbarrett> #topic Action Item Review
21:02:43 <carolbarrett> First let's look at the ARs from last week's meeting
21:02:43 <pchadwick> o/
21:02:53 <carolbarrett> #link http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-03-07-21.01.txt
21:03:19 <carolbarrett> Leong: You have the 1st one....
21:03:33 <carolbarrett> It is: Leong send alternate meeting plan to the ML
21:03:33 <leong> the meeting time?
21:03:44 <leong> i have sent out the ML , suggesting the following:
21:03:48 <leong> 1. Continue to meet at existing time at Monday 1300 (pacific), adjusted to 1400 (pacific) after March 13 daylight saving.
21:03:49 <leong> 2. Set up a biweekly meeting at Tue 1000 (China)/Tue 1100 (Tokyo). (China & Tokyo do not observe DST, so that will be Monday 1900 Pacific)
21:04:04 <carolbarrett> Did you get feedback?
21:04:17 <Arkady_Kanevsky> Current invite has wrong IRC. Missing -alt
21:04:41 <leong> only feedback from Carol :-)
21:04:59 <carolbarrett> LOL
21:05:01 <Arkady_Kanevsky> Do not recall seeing doodle on proposed times.
21:05:14 <leong> based on the survey response..  8 prefer to meet at existing time
21:05:29 <Arkady_Kanevsky> I recall Europe has time chnage in 2 weeks.
21:05:37 <Arkady_Kanevsky> Are we going to hcnage it again???
21:05:51 <leong> EU will change at the end of the month
21:05:54 <leong> last sunday of march
21:06:00 <carolbarrett> arkady_kanevsky: we are staying with 2100 UTC
21:06:12 <Arkady_Kanevsky> I am OK with that.
21:06:35 <Arkady_Kanevsky> That means in 2 week we will move back on USA time
21:06:42 <leong> the main target audience for the alternate meeting time is those in APAC region
21:06:55 <carolbarrett> Leong: Do we need to do an alternate time too? Or just stay with current meeting time?
21:07:10 <leong> Arkady_Kanevsky... two weeks later we are still UTC 2100... which is 2pm pacific
21:07:31 <leong> kei_ are u here?
21:07:42 <kei_> leong: I am.
21:08:07 <leong> what would u think? do you think having an alternative time would be better for your region?
21:09:10 <carolbarrett> Kei_: Do you have a preference?
21:09:39 <carolbarrett> If not, we'll stay with exisiting time til we get a request to change.
21:09:46 <kei_> leong: Personally, I'm OK with 2100 UTC, which is 6am in my time zone (JST).
21:10:03 <leong> or maybe we can run for three months and see how it goes?
21:10:32 <carolbarrett> Leong: I think that sounds good
21:10:38 <leong> and send email to ML to invite folks to join the biweekly meeting
21:10:39 <Arkady_Kanevsky> Let's run it the way it is till Austin summit and put it on agenda there for the team
21:11:00 <leong> till Austin summit is too short to get engagement...
21:11:07 <leong> i would propose to run for 3 months..
21:11:11 <Arkady_Kanevsky> OK
21:11:17 <leong> starting 28th?
21:11:29 <Arkady_Kanevsky> Austin summit just the time whne most folks will be together
21:11:30 <leong> maybe Kei and I can lead the meeting first...
21:11:45 <carolbarrett> Leong: Sounds good.
21:12:00 <leong> Kei_ are you fine to co-lead that meeting with me?
21:12:01 <kei_> leong: +1
21:12:04 <leong> +1
21:12:21 <carolbarrett> #agreed Start bi-weekly alternate time meeting on 3/28 and continue for 3 months then re-evaluate need/effectiveness
21:12:27 <leong> i will send out to ML and schedule the meeting invitation.
21:12:41 <carolbarrett> #action carol add revisit of alternate meeting time to agenda in 3 months
21:12:47 <carolbarrett> OK, let's move to the next one
21:12:56 <carolbarrett> Shamail: Add info on Cross-Project Team liaison roles and     requirements and send email  too
21:12:59 <Arkady_Kanevsky> http://www.openstack.org/assets/tokyo-summit/OpenStack-Roadmap-Mitaka-Update.pptx & http://www.openstack.org/software/roadmap/ do have roadmap. But only a few projects put their views for mitaka and beyond. Not consistent
21:13:07 <shamail> fI still need to update the wiki with cross-project, the other item is waiting for our initial meeting on user story tracker so that I can figure out scope before making recommendations on repo.
21:13:25 <carolbarrett> Gotcha
21:13:32 <shamail> I can take care of that soon, it is on my lower priority list (roadmap was priority atm)
21:13:39 <shamail> the repo we can decide on afterwards
21:13:48 <carolbarrett> OK - we'll carry that action over to the next meeting
21:13:52 <shamail> thx
21:13:59 <carolbarrett> #action shamail Add info on Cross-Project Team liaison roles and     requirements and send email  too
21:14:08 <Arkady_Kanevsky> Thanks Shamail. Pete and I need to update roadmap for Austin summit presentation
21:14:24 <shamail> Arkady_Kanevsky: please hold off on that
21:14:33 <shamail> that session was originally for themes update
21:14:41 <carolbarrett> kencjohnston has the next one, he sent an email to our ML that he has submitted to the repo and it is scheduled for review in tomorrow's Cross-Project team meeting
21:14:44 <shamail> there was a separate roadmap session but we will see the outcome
21:14:53 <Arkady_Kanevsky> OK
21:14:59 <shamail> thanks
21:15:06 <carolbarrett> arkady_kanevsky: Can you pls hold these things til opens?
21:15:08 <pchadwick> Arkady_Kanevsky both sessions make sense.
21:15:34 <carolbarrett> #action Shamail determine where the repo will be for the tracker     tool upstream
21:15:53 <carolbarrett> I think that takes care of last week's actions items.
21:16:01 <carolbarrett> Let's review the ones from the midcycle
21:16:10 <carolbarrett> #link https://etherpad.openstack.org/p/PWG-LON16-MidCycle_Summary
21:16:44 <carolbarrett> Shamail: Where are we on getting the User Stories updated for format and moved to proposed?
21:16:56 <shamail> We have moved the remaining user stories
21:17:01 <shamail> brb, posting link to open reviews
21:17:06 <shamail> Some need +2 and workflow
21:17:13 <shamail> others have -1 workflow to stay open for review
21:17:32 <shamail> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-user-stories
21:17:36 <carolbarrett> Sounds good. I'll take the action to review for +2.
21:17:41 <Arkady_Kanevsky> I can review and add +|-1 but not 2.
21:17:51 <shamail> Thanks carolbarrett and Arkady_Kanevsky
21:17:55 <carolbarrett> #action carol review User Stories for +2/+1 needs
21:18:01 <leong> me too...
21:18:05 <carolbarrett> Thanks Arkday_kanevsky
21:18:05 <shamail> once these are removed from draft, I will submit a patch to remove the draft folder altogether
21:18:14 <carolbarrett> shamail +1
21:18:18 <shamail> thanks to you as well leong !
21:18:55 <shamail> side-note: I will update the workflow wiki to include that proposed stories should stay with -1 workflow until review period is over
21:19:07 <shamail> since that prevents accidental merges.
21:19:08 <carolbarrett> shamail +1
21:19:17 <carolbarrett> RockyG: Is the Stable Branch User Story updated and in Proposed too?
21:19:25 <carolbarrett> thingee: are you here?
21:19:28 <rockyg> Not yet.
21:19:37 <leong> shamail +1
21:19:42 <rockyg> Jeez.  My clock is all messed up today
21:19:45 <rockyg> Sorry.
21:19:46 <leong> stable branch is in proposed
21:19:52 <shamail> The current draft of stable release is actually against proposed: https://review.openstack.org/#/c/276933/
21:20:05 <carolbarrett> RockyG: Do you think you can complete that by next week?
21:20:08 <rockyg> Thanks, leong !
21:20:19 <carolbarrett> Never mind...:)
21:20:26 <shamail> It does have comments from sgordon that need to be addressed though rockyg
21:20:50 <carolbarrett> Mike Perez has a couple of ARs, but it doesn't look like he's here
21:21:01 <rockyg> It has lots of comments that need to be addressed.  Including mine.  I get to test editing in gerritt.
21:21:01 <carolbarrett> Will follow-up again via email
21:21:25 <carolbarrett> Let's move along
21:21:32 <carolbarrett> #topic Helping PTLs set Priorities
21:21:51 <carolbarrett> This is a follow-up from last week's meeting, and the comments Krish made regarding Ceilometer
21:22:13 <carolbarrett> Krish couldn't make the meeting today, but he and I discussed a possible approach to this...
21:23:07 <carolbarrett> We  could map our top Use Stories priorities to the roadmap covered projects and ask for a session at the cross-project team sessions at the design summit to discuss
21:23:34 <Arkady_Kanevsky> sounds good.
21:23:59 <shamail> FYI: At this point.. Nova, Glance, Horizon, Murano, Fuel, QA, and Telemetry will all have new PTLs so the topic is also much broader given upcoming changes
21:24:06 <leong> that's a good idea.. however, we don't have a "top user stories priorities" now apart from rolling-upgrade.. the rest of user-stories are still in review stage
21:24:22 <Arkady_Kanevsky> Thne should we create user stories taht we currently do not have by indivudial projects do, for completeness?
21:24:23 <rockyg> And Stable will, also.
21:24:32 <carolbarrett> Leong: Agree. If we want to pursue that direction, we will need to do some work ahead of time
21:24:35 <pchadwick> Do we need to point the PTLs to the user stories first?
21:24:37 <rockyg> I suspect Rally will, too.
21:24:46 <leong> pchadwick +1
21:24:56 <shamail> carolbarrett: I envisioned the request to offer assistance as being broader then just our user stories… we could help discuss their priorities that are already documented in the project to help determine customer/market needs.
21:24:58 <carolbarrett> pchadwick +1
21:25:21 <pchadwick> @shamail - I think that would be harder
21:25:30 <pchadwick> (at least without specific data)
21:25:44 <rockyg> pchadwick, shamail ++
21:25:45 <shamail> agreed, but that is where the Telemetry request came from
21:25:56 <shamail> it wasnt about our stories, it was about helping them priortize their own specs
21:25:56 <leong> not sure if we can push for the user-stories (ha_vm, stable, baremetal) prior to Austin Summit
21:26:09 <Arkady_Kanevsky> But also need to map user stories to projects and create blueprints/spec from them
21:26:17 <carolbarrett> shamail: That's another way we could offer assistance - but I wouldn't want to do that independent of the User Story priorities
21:26:21 <pchadwick> Shamail +1
21:26:27 <rockyg> Facilitate drawing up the priorities in their sessions at the summit
21:26:36 <shamail> agreed carolbarrett, I was just pointing out that there is another potential thread in this topic
21:26:44 <pchadwick> I have had a similar discussion with Manila, but in the absence of talking to a specific customer request, it gets hard.
21:26:46 <carolbarrett> shamail +1
21:26:50 <Arkady_Kanevsky> Rockyg +1
21:26:51 <shamail> agreed pchadwick
21:27:07 <leong> that's why we need drivers from user-stories, right?
21:27:15 <carolbarrett> leong +1
21:27:17 <shamail> where they algn
21:27:19 <shamail> but not all will
21:27:20 <leong> user-stories represent the "customer request"
21:27:26 <vmtyler> some things are tactical and don't have a user story
21:27:32 <shamail> ^
21:27:43 <vmtyler> and you don't want to see really basic user stories of "i want to be able to flip this bit"
21:27:55 <leong> agree vmtyler
21:28:05 <shamail> I think its both… We need to facilitate discussions on user stories since they are “big rocks” but also discuss their existing “rocks” separately
21:28:14 <carolbarrett> shamail +1
21:28:17 <vmtyler> and align them where we can
21:28:24 <shamail> vmtyler: +1
21:28:36 <carolbarrett> I think identifying the top 3 User Story priorities would be a step on that path
21:28:40 <vmtyler> and maybe help them de-prioritize some of them
21:28:49 <carolbarrett> vmtyler +1
21:28:58 <Arkady_Kanevsky> Does PTLs want to review thier roadmap and prioritize them based on our user stories, where we have them? It will also also us to pick up user storiees that maybe missing
21:29:08 <carolbarrett> one we have our priorities we can decide how to bring them to the community and projects
21:29:30 <vmtyler> yes, i think as we learn about their priorities it could drive new user stories based on previously uncaptured ones
21:29:36 <Arkady_Kanevsky> we did prioritized 3 user story for Mitaka.
21:30:08 <carolbarrett> arkady_kanevsky: I think we need to revisit priorities - lots of new stories and changes
21:30:26 <Arkady_Kanevsky> agree. We are prioritixing for Newton now
21:30:38 <carolbarrett> arkday_kanevsky +1
21:31:11 <Arkady_Kanevsky> Should review PTL list to see if we need to add some usre stories before prioritixzation?
21:31:19 <carolbarrett> Are folks interested/willing to spend time prioritizing User Stories as the 1st action on this topic?
21:31:29 <pchadwick> +1
21:31:32 <Arkady_Kanevsky> +1
21:31:48 <shamail> I thought we had removed priortization as a part of the workflow in the midcycle
21:31:53 <Arkady_Kanevsky> we did good job last time.
21:31:56 <carolbarrett> arkday_Kanevsky: There is always an opportunity for new user stories to flow into the repo. I don't think we need to wait.
21:32:18 <carolbarrett> shamail: We did for the purpose of gating what goes into the cross-project repo.
21:32:36 <shamail> got it
21:32:46 <carolbarrett> I don't know if that meant we would have no concept of priorities in our discussions with PTLs...?
21:33:21 <carolbarrett> any other thoughts on how we could approach this?
21:33:22 <shamail> no, we can do that but it’s not a formal thing
21:33:39 <shamail> I think we need to do some homework ourselves of what projecst have as exits8ing priority
21:33:47 <shamail> and then try to align or make a case
21:33:47 <Arkady_Kanevsky> what is wrong with the process we did last time?
21:35:32 <carolbarrett> shamail: I'm concerned that will be a lot of homework, followed by creating new user stories, which won't wrap-up before the Design summit - which seems like our opportunity to influence priorities
21:35:50 <Arkady_Kanevsky> shamail, do we waint for your rep list and then each of them get AI to get priority list per their project?
21:35:52 <shamail> carolbarrett: +1
21:36:14 <shamail> lets do what we can for now (which is move the ones we already know are important)
21:36:40 <carolbarrett> Instead, can we identify our top 3, then have CPLs review against project priorities and create a discussion for the Cross-Project team meeting in Austin?
21:36:49 <shamail> carolbarrett: +1
21:36:50 <carolbarrett> shamail +1
21:36:57 <Arkady_Kanevsky> +1
21:37:07 <shamail> Should we do this at our next meeting?
21:37:20 <shamail> since we are on a timeline
21:37:24 <carolbarrett> Do you think we can do this via IRC or will voice be needed?
21:37:34 <shamail> +1 to voice for this topic
21:37:36 <Arkady_Kanevsky> can we doodle current user stories?
21:37:57 <Arkady_Kanevsky> vote ofr top 3.
21:38:04 <carolbarrett> #action carol add user story prioritization to the next team meeting and add a voice line for the discussion
21:38:19 <shamail> Arkady_Kanevsky: A discussion might be good so we can understand the reasoning behind our choices
21:38:40 <carolbarrett> arkady_Kanevsky: I think that's a good idea. We'll need some pre-work. Will you send out the doodle?
21:38:40 <Arkady_Kanevsky> ok with it. Just want formal record of team vote
21:39:04 <carolbarrett> We can use the meeting to finalize the results.
21:39:33 <Arkady_Kanevsky> will create one aftre next meetings so people can make their votes after discussion. Give me AR
21:39:52 <carolbarrett> Arkday_kanevsky: OK
21:40:20 <carolbarrett> #action arkady send out doodle of user stories to prioritize after 3/21 team meeting discussion
21:40:29 <carolbarrett> OK let's move on.
21:40:40 <carolbarrett> #topic Rolling Upgrades User Story
21:41:10 <carolbarrett> Kencjohnston isn't able to join this time, now that daylight savings has kicked in...may be an issue for us
21:41:32 <carolbarrett> His update was that this User Story is on the cross-project team agenda for tomorrow.
21:41:40 <carolbarrett> Will other be able to attend?
21:42:01 <shamail> I’ll try to join
21:42:14 <carolbarrett> It is at 2100 UTC
21:42:22 <carolbarrett> Thanks Shamail
21:42:37 <Arkady_Kanevsky> I can only join for second halp 21:30
21:42:39 <rockyg> Ill be there
21:43:05 <carolbarrett> Thanks Arkady_Kanevsky and RockyG
21:43:11 <carolbarrett> I will try to be there too.
21:43:19 <carolbarrett> Anything else on rolling upgrades? Leong?
21:44:07 <carolbarrett> OK, moving along
21:44:11 <carolbarrett> #topic Planning for Austin
21:44:23 <carolbarrett> #link https://etherpad.openstack.org/p/Product_WG_Austin_Planning
21:44:38 <carolbarrett> we've started an etherpad for planning for Austin
21:45:18 <carolbarrett> Can people go flip to that and add in thoughts on topics and verify time for our working session?
21:45:23 <carolbarrett> BoF timing is TBD
21:45:30 <shamail> No time on the BoF yet carolbarrett ?
21:45:37 <carolbarrett> shamail: not yet
21:45:44 <carolbarrett> hopefully this week
21:45:47 <shamail> Alright, the Friday time works for me
21:46:04 <carolbarrett> Great - Can you +1 it in the etherpad?
21:46:17 <carolbarrett> Others pls do the same...if it doesn't work, pls -1 it
21:46:30 <shamail> sure thing
21:46:36 <carolbarrett> Thank shamail
21:47:07 <carolbarrett> Also, pls add your thoughts on topics for any of the 3 items (BoD update, BoF, Working Session)
21:48:13 <carolbarrett> let's take another 3 mins to add info to the planning etherpad
21:50:12 <carolbarrett> OK - Let's move on
21:50:18 <carolbarrett> I propose we skip discussion on OpenStack Days for this meeting and go to Opens.
21:50:24 <carolbarrett> because time is ticking...
21:50:24 <shamail> +1
21:50:31 <carolbarrett> #topic Opens
21:50:59 <carolbarrett> Can we get feedback on the Gerrit training and what, if any add'l training needed?
21:51:56 <shamail> I’m going to discuss with Kenny and see if we can record a video to post to our wiki
21:52:01 <Arkady_Kanevsky> Can we add Group presentations for Austin summit for next meeting agenda
21:52:18 <pchadwick> Arkady_Kanevsky +1
21:52:20 <carolbarrett> shamail +1
21:53:03 <carolbarrett> arkady_kanevsky: Can you pls add that topic to the etherpad? We'll look at all the proposals in ~2 weeks and decide how we want to spend our time
21:53:27 <carolbarrett> Ok - Shamail - You had an open on CPLs - do you want to cover that?
21:53:32 <kei_> shamail: that'd be really helpful.
21:53:33 <shamail> Sure
21:53:43 <shamail> just a reminder, we ahd discussed CPLs doing updates to the team
21:53:58 <shamail> Should we start those updates?
21:54:08 <shamail> Any volunteers to go first at one of our upcoming meetings?
21:54:15 <Arkady_Kanevsky> Carol, gladly. Do we have Macrh 21 wiki page?
21:54:48 <shamail> carolbarrett: ill reach out to some people and see if we can get the updates going
21:54:52 <shamail> that’s all on the topic
21:54:55 <carolbarrett> arkady_kanevsky: we have an austin planning etherpad: https://etherpad.openstack.org/p/Product_WG_Austin_Planning. Did I misunderstand your proposal?
21:55:06 <carolbarrett> shamail +1
21:55:27 <carolbarrett> #action shamail to ping CPLs for volunteers to start providing updates in Product WG team meeting
21:55:33 <Arkady_Kanevsky> +1 on that. I was looking for adding it to agenda. I will add to Austin page
21:55:41 <carolbarrett> Any other opens?
21:56:16 <carolbarrett> Is anyone planning to run for TC?
21:56:46 <shamail> I might run this time
21:56:53 <carolbarrett> I'm considering it too
21:57:14 <rockyg> not likely this time.  I still haven't fixed my 'puter for doing the submission
21:57:17 <shamail> good luck :)
21:57:32 <carolbarrett> ha-ha
21:58:08 <carolbarrett> OK - I think that's it for today.
21:58:14 <shamail> awesome
21:58:18 <Arkady_Kanevsky> have a good day!
21:58:19 <shamail> have a great day/evening!
21:58:22 <carolbarrett> Thanks everyone!
21:58:25 <carolbarrett> you too
21:58:30 <carolbarrett> #endmeeting