21:00:33 <carolbarrett> #startmeeting Product Working Group
21:00:35 <openstack> Meeting started Mon Mar 21 21:00:33 2016 UTC and is due to finish in 60 minutes. The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:39 <openstack> The meeting name has been set to 'product_working_group'
21:01:11 <shamail> hi everyone/
21:01:12 <carolbarrett> Hi - Who's hear for the product working group meeting?
21:01:16 <carolbarrett> hi Shamail
21:01:22 * shamail waves
21:01:26 <cloudrancher> Hi
21:01:26 <MarkBaker> Hi carolbarrett & shamail
21:01:28 <sgordon> \o
21:01:32 <pchadwick> \o
21:01:33 <carolbarrett> hi MarkBaker
21:01:40 <pchadwick> Hello all
21:01:41 <MarkBaker> o/
21:01:55 <carolbarrett> Hi pchadwick
21:01:57 <HeidiJoy> Here!
21:01:59 <rockyg> o/
21:02:07 <MeganR> o/
21:02:10 <Arkady_Kanevsky> hello
21:02:14 <carolbarrett> great to see everyone!
21:02:16 <annilai> Hi
21:02:24 <HeidiJoy> o/ = left-handed hand raise.
21:02:31 <carolbarrett> LOL
21:02:44 <carolbarrett> Let's get going!
21:02:54 <carolbarrett> #link: https://wiki.openstack.org/wiki/Meetings/product-team#March_21.2C_2016_Product_Team_Meeting_Agenda
21:02:58 <carolbarrett> here's our agenda
21:03:01 <pchadwick> I never knew what the symbol meant - thanks for the explanation!
21:03:03 <carolbarrett> Let's start with AR follow-up
21:03:04 <kencjohnston> o/
21:03:10 <carolbarrett> #topic Action Item Review
21:03:20 <carolbarrett> #link: http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-03-14-21.00.txt
21:03:31 <carolbarrett> let's start with last week's meeting
21:04:14 <carolbarrett> Leong is out this week, spring break here in Oregon. Not sure where we are on starting the alternating meetings. Does anyone have an update to share?
21:04:52 <shamail> I have not seen any updates on that topic (ML or otherwise), the poll was concluded… I think he was seeking someone to lead that meeting but none confirmed so far
21:05:20 <carolbarrett> I'll give him an action item to provide an update next week.
21:05:21 <carolbarrett> #action Leong Update the team on alternating meeting plan
21:06:08 <carolbarrett> Next one looks like it's Shamail's - Cross Project Liasons
21:06:37 <shamail> Please defer this one another week, sorry. I focused on the tracker, roadmap this past week,
21:06:49 <carolbarrett> Gotcha
21:07:02 <carolbarrett> #action Shamail Add info on Cross-Project Team liaison roles and requirements and send email too
21:07:09 <shamail> It’s an easy one to do, that’s why it keeps slipping. :) I’ll put it on my calendar this week.
21:07:26 <carolbarrett> Understand, think you're priorities are the right ones
21:07:34 <carolbarrett> That brings us to the Tracker repo - Shamial
21:07:39 <carolbarrett> Shamail (sorry)
21:07:45 <shamail> np!
21:07:52 <carolbarrett> determine where the repo will be for the tracker tool upstream
21:08:03 <shamail> We had the kick-off meeting for the tracker/dashboard project and we have identified the location (for now)
21:08:29 <shamail> we will build and deploy the first prototype using the OpenStack github repo that hosts the OpenStack Project Navigator
21:09:01 <shamail> We might want to have a longer term discussion after the initial prototype (if there is interest in the community) but for now it will be hosted in the same place as most of openstack.org content
21:09:10 <shamail> which means outside of OpenStack governance
21:09:34 <shamail> That is all for now. Any questions/comments?
21:09:34 <carolbarrett> Good starting point for now, I think
21:09:38 <shamail> Agreed
21:10:00 <carolbarrett> Thanks
21:10:00 <pchadwick> +1 consistency is good.
21:10:07 <carolbarrett> Next one is mine - review User Stories for +2/+1 needs
21:10:16 <shamail> for the record, Jimmy (OpenStack Foundation) has been awesome… as have Victor and Marcela (Intel)
21:10:48 <carolbarrett> I did this, but need to continue to do this regularly - lots of action in the repo these days.
21:11:11 <carolbarrett> The next one is also mine - add user story prioritization to the next team meeting and add a voice line for the discussion
21:11:24 <shamail> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-user-stories
21:11:35 <shamail> This link is very handy as it shows the current open items…
21:12:12 <carolbarrett> Thanks
21:12:25 <carolbarrett> I didn't do this, because it was dependent on the next action item which Arkady owns
21:12:45 <Arkady_Kanevsky> which one is that?
21:12:58 <carolbarrett> Send out doodle of user stories to prioritize after 3/21 team meeting discussion
21:13:08 <Arkady_Kanevsky> I reviewed most oif user stories.
21:13:23 <carolbarrett> I got confused and thought we wanted to do the Doodle first, but remembered our discussion too late.
21:13:25 <Arkady_Kanevsky> It is not doodle but google forms.
21:13:54 <Arkady_Kanevsky> Need one more round of update before ready for prioritization.
21:13:55 <carolbarrett> So I'll take the AR to setup a voice line for the 3/28 meeting and the only agenda item will be user story walk through
21:14:08 <shamail> carolbarrett: +1
21:14:14 <carolbarrett> arkday: google form is OK too.
21:14:48 <Arkady_Kanevsky> Unfortunately survey monkey and google forms does not allow more than 10 answers. With more than 10 stories to prioritize we can not have full linear order.
21:14:52 <carolbarrett> #action carol setup voice line for 3/28 meeting with agenda of User Story walk through
21:15:11 <carolbarrett> So let's look at the Action items remaining from our midcycle.
21:15:20 <carolbarrett> #link: https://etherpad.openstack.org/p/PWG-LON16-MidCycle_Summary
21:15:24 <Arkady_Kanevsky> Instead I had give priorities 0-3. 3,2,1 are your 3 top choices. Rest are 0.
21:15:32 <pchadwick> arkady_kanevsky - did you already send out the Google link?
21:15:46 <Arkady_Kanevsky> not yet. Need to add 2 more stories
21:15:55 <shamail> Arkady_Kanevsky: please send out to PWG via mailing list
21:15:59 <Arkady_Kanevsky> expect it later today
21:16:03 <shamail> along w/ instructions
21:16:03 <pchadwick> Thanks.
21:16:08 <Arkady_Kanevsky> yes.
21:17:14 <carolbarrett> I still have a few of my ARs to close out - but nothing that is time sensitive.
21:17:34 * shamail looking at etherpad
21:17:50 <shamail> mine are completed
21:17:50 <carolbarrett> Shamail: Are we ready to "tracked"?
21:18:03 <shamail> yes
21:18:06 <shamail> I can submit that patch today
21:18:09 <shamail> that folder is now empty
21:18:16 <shamail> draft should be empty soon too
21:18:37 <carolbarrett> Let's get rid of them as soon as they are empty.
21:18:38 <carolbarrett> Thanks
21:18:42 <shamail> carolbarrett: +1
21:18:55 <carolbarrett> Next up is Mike Perez - Are you here?
21:19:05 <shamail> I dont see thingee
21:19:35 <HeidiJoy> I'll look for him on Slack
21:19:44 <shamail> thanks HeidiJoy
21:20:03 <carolbarrett> OK - I've sent him a couple of emails looking for updates, I'm sure he's swamped with the Summit prep.
21:20:12 <carolbarrett> Will reach out again
21:20:19 <carolbarrett> Piet - Are you here?
21:20:21 <HeidiJoy> He's online but might be busy, so I pinged him and he might join.
21:20:32 <carolbarrett> HeidiJoy - Thanks
21:20:47 <HeidiJoy> NP
21:20:50 <carolbarrett> Don't see Piet either
21:21:01 <carolbarrett> That closes out the AR follow-up.
21:21:10 <HeidiJoy> I've been in touch with him today - drop him an email, I suggest.
21:21:17 <HeidiJoy> (Piet) ^^
21:21:19 <carolbarrett> Will do
21:21:41 <carolbarrett> #topic Rolling Upgrades User Story update - Post Cross-Project Team meeting
21:21:45 <rockyg> Quickie for my ARs. Following through with roadmap. Almost have Catherine and Refstack. Also, now on rally IRC
21:22:15 <carolbarrett> Rockyg: Thanks!
21:22:20 <shamail> thanks rockyg
21:22:24 <carolbarrett> Kencjohnston - can you take this next topic?
21:22:39 <kencjohnston> Sure
21:22:41 <shamail> kencjohnston: I’m glad you could make it (with the time adjustment)
21:22:42 <HeidiJoy> Follow up - @thingee has a conflicting meeting now. Feel free to send him an email. Also I'm dropping this meeting for another. TTYL.
21:22:51 <shamail> bye HeidiJoy
21:22:54 <kencjohnston> There was a cross project team meeting last Tuesday evening
21:23:04 <kencjohnston> where we discussed the Rolling Upgrades Cross Project Spec
21:23:09 * kencjohnston finds review link
21:23:32 <kencjohnston> #link Cross Project Spec - Rolling Upgrades Review https://review.openstack.org/#/c/290977/
21:23:47 <kencjohnston> The discussion devolved into one about what the definition and purpose of a cross project spec was
21:24:02 <kencjohnston> which slightly puts into question our proposed workflow which utilizes the Cross Proejct Spec repo
21:24:06 <rockyg> yeah. Not very pretty, I'm afraid.
21:24:14 <shamail> rockyg: +1
21:24:26 <kencjohnston> The discussion ended with an action item to furthe rdefine Cross Project Specs in the Project Team Guide
21:24:29 * kencjohnston again looks for link
21:24:37 <rockyg> thingee is attempting to enlighten the devs on this issue.
21:24:39 <shamail> kencjohnston: Will this discussion continue tomorrow?
21:25:03 <kencjohnston> #link Cross Project Spec Definition in Project Team Guide http://docs.openstack.org/project-team-guide/cross-project.html#cross-project-specifications
21:25:11 <kencjohnston> shamail form what I can tell it is not on the agenda
21:25:14 <rockyg> The xproj spec alteration is supposed to be ready for discussion
21:25:15 <kencjohnston> s/form/from
21:25:25 <shamail> kencjohnston: should we propose it or let it naturally happen?
21:25:28 <kencjohnston> rockyg I haven't seen it, can you send me the review/link?
21:25:40 <kencjohnston> shamail I was waiting for the alteration...
21:25:42 * rockyg looking
21:25:53 <shamail> kencjohnston: +1
21:25:57 <kencjohnston> if it is available I'll send a note to thingee to have it added to the agenda
21:26:10 <carolbarrett> I like the way it reads now...
21:26:14 <kencjohnston> I was hoping to comment on any review of the alteration
21:26:15 <Arkady_Kanevsky> I have a draft of user story prioritirization questionare ready - https://docs.google.com/forms/d/19zxTup3GrYWEmdus_jLUIpDigN3ubCyP6PsgKM9S1DE/viewform
21:26:33 <Arkady_Kanevsky> Will give people time to comment before sending for votes
21:26:37 <kencjohnston> carolbarrett Has it changed since last week?
21:26:45 <thingee> o/
21:26:50 <kencjohnston> ohai thingee
21:26:55 <thingee> hey everyone had another meeting to attend
21:27:00 <kencjohnston> no worries
21:27:05 <carolbarrett> thanks for joining
21:27:14 <kencjohnston> We were discussing the status of the xproject spec definition change in the Project Team Guide
21:27:15 <shamail> hi thingee
21:27:18 <carolbarrett> your timing is perfect
21:27:37 <thingee> yeah, we'll need to discuss it in tomorrow's cross-project meeting.
21:27:40 <rockyg> kencjohnston, not there yet. Doug Hellmann is doing it and he's been kinda busy with release last and this week
21:27:56 <kencjohnston> rockyg ok understood.
21:28:38 <kencjohnston> Another AR I have as a result is to adjust the User Story to be scoped exclusively to what work is already underway/completed in projects claiming "Rolling Ugprades"
21:29:08 <kencjohnston> Our original definition is more expansive than what is contained withing hte "supports-rolling-upgrades" meta-data tag
21:29:33 <Arkady_Kanevsky> Where is that defined?
21:29:36 <carolbarrett> kencjohnson: was there discussion about changing the tag?
21:29:46 <kencjohnston> carolbarrett there was not
21:29:56 <kencjohnston> Arkady_Kanevsky let me find the link
21:30:00 <rockyg> some stng discussion on "no rollbacks"
21:30:06 <shamail> kencjohnston and thingee: we can start from what
21:30:08 <rockyg> s/stng/strong
21:30:09 <Arkady_Kanevsky> thanjs.,
21:30:21 <Arkady_Kanevsky> What is the delta between user story and tag def?
21:30:21 <carolbarrett> thingee: is the working on the cross-spec page for the purpose of a Cross-Project spec , new proposed wording?
21:30:24 <shamail> what’s there and then add other things later right?
21:30:33 <kencjohnston> #link Rolling Upgrades Tag Definition https://governance.openstack.org/reference/tags/assert_supports-rolling-upgrade.html
21:30:49 <shamail> I mean reduce it to align with WIP and then add more things later
21:31:19 <kencjohnston> shamail yes that is my understanding
21:31:26 <shamail> glad to hear that
21:32:02 <Arkady_Kanevsky> +1 on the plan. We still need to define delta and track it for roadmap
21:32:14 <kencjohnston> Arkady_Kanevsky +1
21:32:44 <carolbarrett> Thingee: What is your goal for the discussion in the meeting tomorrow?
21:33:02 <Arkady_Kanevsky> should we review tags going forward?
21:33:41 <Arkady_Kanevsky> I htink thingee left for another meeting
21:33:50 <carolbarrett> OK
21:34:15 <shamail> I think those of us that can make the meeting tomorrow, should.
21:34:18 <carolbarrett> Who can attend the cross-project meeting tomorrow to help with the discussion?
21:34:22 <shamail> jinx
21:34:22 <thingee> carolbarrett: to discuss how we want to handle these sort of documents that people don't consider a specification.
21:34:24 <carolbarrett> shamail: +1
21:34:34 <rockyg> o/
21:34:35 <shamail> I’ll try to be there.
21:34:54 <kencjohnston> I'll be there.
21:34:57 <carolbarrett> thingee: are you bringing a proposal to the discussion?
21:35:12 <thingee> I think the rolling upgrade came across to some people as a wish list. Also the people that weren't happy with this were the people that would ideally help fill out the technical details.
21:35:13 <rockyg> But in this group, we need to do a postmordem to modify how we do this going forward.
21:35:35 <Arkady_Kanevsky> rockyg +1
21:35:36 <kencjohnston> rockyg +1
21:35:37 <shamail> thingee: this leads back to where does “gaps analysis” need to happen
21:35:38 <annilai> +1
21:36:07 <rockyg> One thing would be to separate out the update part of the story so it is independent. It's not somethind dev is even thinking about at the moment. It happens at the packager from most of their perspectives.
21:36:28 <thingee> so I think tomorrow I'm going to propose a change to the project team guide from the cross-project section on what our goals for the specifications should be.
21:36:31 <carolbarrett> I wonder at what point we take a discussion to the TC....
21:36:50 <shamail> If we could agree that cross-project specs can be used as a source for other cross-project specs then the rolling upgrades spec could be considered a concept/topic and the actual implementation guidelines (that would be cross project specs) could reference it.
21:36:56 <thingee> carolbarrett: keep in mind people like sdague are on the TC
21:36:56 <rockyg> carolbarrett, not there yet ;-)
21:36:59 <kencjohnston> carolbarrett Isn't the xproject team largely the TC?
21:37:08 <rockyg> Let's let thingee do some magic first
21:37:13 <shamail> rockyg: ++
21:37:29 <carolbarrett> kencjohnston: I didn't think so.
21:37:36 <Arkady_Kanevsky> reading reqs it is dependendent on Grenade testing. So they should be the one tagging...
21:37:40 <shamail> TCs + PTLs + CSPLs
21:37:42 <carolbarrett> rockyg: +1
21:37:47 <thingee> carolbarrett: who was not interested in the current format
21:38:13 <thingee> I think it just came across wrong and needs to be cleared up
21:38:17 <shamail> thingee: +1
21:38:20 <carolbarrett> thingee: not following your comment...?
21:38:33 <carolbarrett> That I understand
21:38:41 <shamail> carolbarrett: the person who didn’t agre with the format was a person who is also a TC
21:38:44 <shamail> agree*
21:38:54 <thingee> carolbarrett: you said, when do we bring this up to the TC... people from the TC already started commenting on it not understanding why this was proposed to cross-project specs to begin with
21:38:57 <rockyg> carolbarrett, our new process. It took us half a day to work it out. And we plopped it down in devs' laps with nary a word
21:39:18 <carolbarrett> thingee, rockgy: Gotcha.
21:39:24 <Arkady_Kanevsky> thingee, Is Grenade folks signed up for project PTL tag designation for rolling_upgrade?
21:39:40 <carolbarrett> OK - we'll have folks join the discussion tomorrow and see where it goes and regroup on next steps next week
21:39:52 <rockyg> Arkady_Kanevsky, sean dague is big in grenade
21:39:55 <shamail> I agree with rockyg, let’s see how the discussion that thingee leads goes… I think he has been successful in relaying the change to individuals but it probably just needs to happen with the cross-project team as a whole
21:39:56 <carolbarrett> Anything else on this one before we move on?
21:40:08 <carolbarrett> shamail: +1
21:40:16 <kencjohnston> carolbarrett none from me
21:40:32 <carolbarrett> thingee ?
21:40:41 <thingee> none
21:40:48 <carolbarrett> Next topic is Quota User Story
21:40:54 <carolbarrett> #topic Quota User Story
21:40:59 <carolbarrett> Shamail - can you take this one?
21:41:01 <shamail> sure
21:41:34 <rockyg> carolbarrett, actually funny that's the next topic. That's what is under discussion in the cross project meeting channel right now
21:41:35 <shamail> Nikhil K. recently sent out an email to the dev ML about a cross-project spec for quotas
21:41:49 <shamail> I don’t have the link to the message handy
21:41:52 * nikhil lurks
21:41:55 <shamail> but the cross project spec can be found here
21:42:00 <shamail> hi nikhil :)
21:42:02 <shamail> #link https://review.openstack.org/#/c/284454/
21:42:05 <nikhil> :)
21:42:10 <nikhil> shamail: here's the thread
21:42:13 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/thread.html#89453
21:42:18 <shamail> Thanks!
21:42:30 <shamail> We have had capacity management as a high pri. user story for a while now
21:42:32 <shamail> #link https://specs.openstack.org/openstack/openstack-user-stories/user-stories/draft/capacity_management.html
21:42:49 <shamail> and this might be a good time to intersect the quota cross-project spec and the user story
21:43:10 <kencjohnston> shamail My view is that Capacity Management is much more expansive then centralized quota enforcement
21:43:17 <rockyg> Certainly would be. It's great to have nikhil here!
21:43:19 <kencjohnston> Or the story as written is
21:43:21 <shamail> The cross-project quota team is deciding whether quotas should be a separate library or service in OpenStack so that we can have uniform features across the various services
21:43:25 <Arkady_Kanevsky> should we have this user story in our prioritirization list?
21:43:26 <shamail> kencjohnston: it certainly is!
21:43:44 <rockyg> And with that, gotta go. Sorry. I'll catch up later in the log
21:43:45 <nikhil> rockyg: :)
21:43:55 <shamail> The initial gameplan is to start the new cross project spec for quotas at a basic level and tackle things like nested quota support first
21:43:55 <kencjohnston> thanks rockyg
21:44:05 <kencjohnston> shamail I think that is the right approach
21:44:13 <kencjohnston> it would be good to have a centralized quota usage story
21:44:26 <kencjohnston> so we could outline the benefits and pain points experienced today in one central place
21:44:30 <shamail> but my thought was that we could also provide our user story so that those needs are captured and discussed before cross-project quota functionality continues to expand
21:44:38 <kencjohnston> but they way we have the story writtne now I'm not sure it's valuable to the effort at the moment.
21:44:41 <carolbarrett> bye rockyg
21:44:43 <shamail> better to be ahead of the curve versus behind it (like we ended up with rolling upgrades)
21:45:00 <kencjohnston> shamail +1, but I think we need a new story to do that
21:45:11 <carolbarrett> +1 shamail
21:45:14 <Arkady_Kanevsky> +1 on the story.
21:45:19 <shamail> kencjohnston: I agree, it’s just data points for now… we need to modified version as a starting point
21:45:44 <kencjohnston> shamail Say more about that? Not sure I follow.
21:45:53 <shamail> The topic I wanted to raise was trying to have an owner here so that we can progress this story
21:46:04 <kencjohnston> shamail ah, ok, agreed
21:46:32 <shamail> kencjohnston: I propose we have a new (minimal) user story that aligns with the current needs… assign an owner… and then ensure that we also share the advanced items from the original story as the opportunity surfaces
21:46:50 <carolbarrett> shamail: +1
21:46:55 <Arkady_Kanevsky> agree
21:46:57 <kencjohnston> shamail +1, although I'm keeping my hand down :)
21:47:04 <shamail> awww lol
21:47:17 <shamail> Any volunteers?
21:47:25 <shamail> I would be up for taking it if no one else is.
21:47:49 * shamail looks around the room
21:48:01 <Arkady_Kanevsky> every alreasy stepped back
21:48:05 <shamail> I’ll volunteer as owner :)
21:48:24 <carolbarrett> Shamail - I can team up with you, but don't think I have the details to own it
21:48:38 <shamail> I’ll work with nikhil and the cross project team to align user story with current status and keep our team updated
21:48:42 <kencjohnston> carolbarrett Piet got some good feedback from Operators on this subject at the Ops MidCycle
21:48:44 <nikhil> ++
21:48:46 <Arkady_Kanevsky> I will review. I need to create another user story for refcore reporting improvement. One story at a timne for me.
21:48:54 <shamail> thanks carolbarrett!
21:49:08 <Arkady_Kanevsky> thanks Shamail
21:49:11 <shamail> The other major ask for this topic is…
21:49:26 <carolbarrett> #action Shamail, Carol Create new Quota Management User Story
21:49:27 <shamail> The cross-project quota team is already investigating plans for Newton (and maybe Ocata)
21:49:55 <shamail> If any companies have an interest in this topic then let’s let our development teams know so that we can help out where/when possible
21:49:57 <carolbarrett> shamail: Let's set time this week to work on this.
21:50:04 <shamail> carolbarrett: +1
21:50:19 <shamail> That is all for now
21:50:27 <carolbarrett> Thanks shamail
21:50:49 <shamail> carolbarrett: I propose we defer the roadmap topic and use the remaining time for OSIC
21:50:57 <carolbarrett> The next topic is an OSIC roadmap Goals and Prioroties
21:51:06 <carolbarrett> Kencjohnston - we've only got 10 mins, do you want to do this now?
21:51:11 <kencjohnston> Thanks carolbarrett
21:51:14 <kencjohnston> sure I'll get as far as I can
21:51:24 <carolbarrett> OK
21:51:34 <carolbarrett> #topic OSIC Roadmap Goals and Priorities -
21:51:37 <kencjohnston> So, for those unfamiliar OSIC (OpenStack Innovation Center) is a joint effort between Intel and Rackspace
21:51:51 <kencjohnston> Think of it as two 1000 node clusters available for the community to use for testing
21:52:09 <kencjohnston> #link Cluster Signup http://www.osic.org/
21:52:31 <kencjohnston> AND I'd argue more importantly, because it is my job, 100+ and growing developers working directly upstream
21:52:41 <kencjohnston> with no agenda other than to improve enterprise adoption of OpenStack
21:52:43 <Arkady_Kanevsky> what about physical network? Is storage SDS on nodes onoy?
21:53:00 <kencjohnston> Arkady_Kanevsky I'm happy to get you to specifics about the cluster, ping me offline
21:53:10 <kencjohnston> So those developers are working against a roadmap
21:53:13 <Arkady_Kanevsky> sure.
21:53:24 <kencjohnston> we have a certain set of items/work that we consider a priority, which are really OSIC driven
21:53:45 <kencjohnston> but the majority of our time upstream is spent on community priorities that follow our mission, driving enterprise adoption
21:53:57 <kencjohnston> and themes: simplicity, upgradeability, reliability and scalability
21:54:03 <kencjohnston> all pretty motherhood and apple pie :)
21:54:22 <kencjohnston> Those OSIC driven priorities, some of which are internal baselining and CI setup are documented here:
21:54:28 <carolbarrett> always a favorite!
21:54:31 <nikhil> ++ (many ignored today)
21:54:44 <kencjohnston> #link OSIC Driven Priorities - https://etherpad.openstack.org/p/OSIC-Roadmap-Measurable-Goals
21:55:15 <kencjohnston> We'll be constantly reviewing community priorities and producing our first revision of what we plan to work on which includes community priorities and osic driven ones by the end of hte month
21:55:25 <Arkady_Kanevsky> yes. Enterprise requires many things. One of them is resiliency and improved pet handling. There are physical environment dependent...
21:55:35 <kencjohnston> We're hoping to conform to the projects internal prioritization process where they have them
21:55:46 <shamail> kencjohnston: What are the “OSIC projects”?
21:55:50 <kencjohnston> So I'd love feedback on the etherpad and our major goals
21:55:54 <kencjohnston> shamail there is a list at the bottom
21:55:56 <kencjohnston> of the etherpad
21:55:56 <shamail> Thanks
21:56:11 <shamail> good list
21:56:23 <kencjohnston> and be on the lookout for a published roadmap, agian which will have room to flex as priorities are defined and outlined at the Austin Design Summit
21:56:42 <kencjohnston> KrishR and I are your point people, feel free to reach out to either of us at anytiem
21:56:47 <Arkady_Kanevsky> is there a session at Austin summit on it?
21:57:01 <shamail> kencjohnston: Are OSIC roadmap items only able to come from developers using the resources and OSIC itself. Is there a set % of resources allocated to community (e.g. PWG user stories)?
21:57:04 <kencjohnston> Arkady_Kanevsky sadly the roadmap review session was not approved, so no
21:57:15 <Arkady_Kanevsky> what about BOF?
21:57:43 <kencjohnston> shamail OSIC roadmap items will likely include many items not originally derived by OSIC itself.
21:57:58 <shamail> kencjohnston: I guess the broader question I am getting at is how are items selected beyond topics raised by OSIC or the companies involved?
21:58:04 <carolbarrett> kencjohnston: +1
21:58:05 <KrishR> shamail: as kencjohnston explained, a lot of OSIC resources are kept for comunity priorities; so PWG-driven ones can be accommodated
21:58:20 <kencjohnston> KrishR +1
21:58:31 <shamail> kencjohnston: Thanks, that’s what I was asking and what do we need to provide from PWG to formally raise a topic for roadmap discussion
21:58:33 <kencjohnston> So PWG priorities are reviewed prior to roadmap finalization
21:58:41 <kencjohnston> that is how Rolling Upgrades got on as a theme
21:58:46 <Arkady_Kanevsky> what is OSA?
21:58:51 <shamail> OpenStack Ansible
21:58:52 <kencjohnston> Arkady_Kanevsky OpenStack Ansible
21:58:58 <Arkady_Kanevsky> thanks
21:59:09 <kencjohnston> So we are about out of time
21:59:19 <kencjohnston> but again follow up and thanks Carol for letting me have a few minutes to discuss.
21:59:26 <carolbarrett> So as we go through our next round of prioritization, we will provide input to the OSIC roadmap planning
21:59:36 <carolbarrett> kencjohston and krish: Thanks
21:59:39 <kencjohnston> One last thing, as you can see in the ehterpad our initiatives will be creating User Stories. There are two I created last week.
21:59:50 <kencjohnston> carolbarrett thanks
21:59:52 <shamail> Thanks kencjohnston and KrishR… Can you please raise notice in the PWG when the next cycle of roadmap reviews is about to happen so that we can discuss user stories concepts as a team for additional data points into your efforts?
21:59:58 <Arkady_Kanevsky> thanks team
22:00:03 <carolbarrett> OK folks we're out of time for today; Pls find time to look over the User Stories ahead of next week's meeting
22:00:08 <carolbarrett> Have a good week
22:00:08 <KrishR> shamail: we'll do that
22:00:12 <MeganR> bye
22:00:16 <Arkady_Kanevsky> bye
22:00:16 <pchadwick> bye
22:00:17 <kencjohnston> bye all, thanks
22:00:19 <carolbarrett> #endmeeting