21:00:22 <carolbarrett> #startmeeting Product Working Group
21:00:22 <openstack> Meeting started Mon Apr 11 21:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:25 <openstack> The meeting name has been set to 'product_working_group'
21:00:40 <kencjohnston> o/ howdy
21:00:42 <carolbarrett> Hi - Who is here for the Product WG Team meeting?
21:00:46 <kei> o/
21:00:48 <pchadwick> o/
21:00:48 <KrishR> o/
21:00:59 <fredli> o/
21:01:16 <carolbarrett> Hi everyone!
21:01:29 <carolbarrett> You can find the agenda here
21:01:30 <pchadwick> Hi Carol and everyone else
21:01:32 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team#April_11.2C_2016_Product_Team_Meeting_Agenda
21:01:35 <MarkBaker> o/
21:01:35 <shamail> Hi everyone
21:01:44 <MeganR> Hi
21:02:02 <carolbarrett> Glad to see everyone, we've got some important things to discuss ahead of Austin
21:02:15 <carolbarrett> Let's get started.
21:02:21 <carolbarrett> #topic Action Item Review
21:02:35 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_4_4_2016
21:03:12 <carolbarrett> From last week's prioritization call, there were a couple of follow-on actions for each of the Top 5 User Story owners.
21:03:32 <kencjohnston> carolbarrett Just seeing that aciton, sorry I missed it. I'll send an email to the ML today.
21:03:38 <carolbarrett> The main focus of the actions is getting on track for the Newton design summit
21:03:44 <carolbarrett> Thanks kencjohnston
21:04:06 <pchadwick> So, I talked to my developer that is driving the HA work
21:04:24 <pchadwick> The cross-project team did not want to have this as a session.
21:04:31 <carolbarrett> #action kencjohnston send out email to PWG ML
21:04:41 <shamail> kencjohnston: I thought you did send an email? lemme go check
21:04:47 <Arkady_Kanevsky> are we using phone bridge today?
21:04:50 <carolbarrett> pchadwick - was there a reason for this?
21:04:57 <pchadwick> There are apparently some people that still think OpenStack is just for cattle ;-)
21:04:59 <carolbarrett> arkady_kanevsky: no bridge today
21:05:05 <kencjohnston> shamail That must have been another kencjohnston ...
21:05:09 <pchadwick> So, it did not get enough +1s
21:05:13 <shamail> Nevermind, you sent it for Fleet Management
21:05:19 <kencjohnston> an evil one...
21:05:21 <shamail> It was the same kencjohnston, different story
21:05:48 <carolbarrett> pchadwick: Does your team have thoughts on how to advance this in face of that response?
21:06:07 <pchadwick> They asked me if the PWG could help.
21:06:25 <pchadwick> There is still interest in meeting, just not sure if we can do anything formal or if it just has to be ad hoc.
21:06:34 <shamail> pchadwick: what is the current thought?  Is this something we need to work with nova on or is it a new project or something that lives outside of OpenStack and is just “documented” in OpenStack?
21:06:42 <sgordon> pchadwick, was there any feedback from the cross project folks other than that?
21:06:48 <pchadwick> None that I saw
21:07:01 <sgordon> my confusion around this use case is primarily what it covers that does not already exist
21:07:44 <pchadwick> sgordon - that was my question as well. There are gaps that still need to be addressed to handle VM failures.
21:07:48 <sgordon> e.g. i thought there was already a cross project spec along these lines
21:08:04 <sgordon> and folks in a HA subteam ( #openstack-ha ) bashing out agreement
21:08:08 <sgordon> from intel, rh, suse, others
21:08:27 <shamail> I thought they are working more on how to make OpenStack services HA versus instances?
21:08:33 <sgordon> both
21:08:37 <shamail> good to know
21:08:48 <sgordon> several vendors already have pacemaker-based HA VM approaches in their distros
21:08:49 <carolbarrett> sgordon: good info, thanks!
21:08:50 <KrishR> there is an automatic host-evacuation spec
21:08:56 <sgordon> and were collaborating on making them more openstack-y
21:09:08 <Arkady_Kanevsky> is the ask to convert deployment tools to day2 operation?
21:09:21 <pchadwick> Yes, and I asked my developer leading our HA VM efforts to look at the user story - hence my comment about gaps.
21:09:28 <shamail> That is why I asked the question about what our goal is (or where would this live)?  It seems like this might be a documentation thing versus an actual code change
21:09:34 <Arkady_Kanevsky> That would make sense since the same tools are used for updtae/upgrade.
21:09:44 <sgordon> of course now i cant find the link i am looking for ;)
21:09:45 <Arkady_Kanevsky> But it still canot satisfy the requirements of fleet
21:09:57 <Arkady_Kanevsky> https://review.openstack.org/#/c/299531/5/user-stories/proposed/fleet-management.rst
21:10:12 <carolbarrett> pchadwick: can you catchup on the cross project spec and the sub team working the issues?
21:10:21 <shamail> pchadwick, any thoughts on my question or too early to know?
21:10:29 <carolbarrett> arkday_kanevsky: we're talking about HA VM now, will get to that one
21:10:36 <KrishR> arkady_kanevsky: fleet mgmt addresses diff requirements than HA of VMs
21:10:44 <Arkady_Kanevsky> thanks Carol
21:10:45 <sgordon> https://review.openstack.org/#/c/257809/ might have been what i was thinking of
21:10:46 <shamail> That would help us decide the next steps on how PWG can help...
21:11:06 <pchadwick> shamail - it is a combination of documentation and some hooks that the <I can't remember the project name> is trying to address.
21:11:12 <pchadwick> NEC was driving that effort
21:11:17 <KrishR> sgordon: that's the one i was thinking of too
21:11:18 <shamail> Mistral probably
21:11:24 <shamail> that looks like the right spec sgordon
21:11:34 <KrishR> yes, it's pacemaker with Mistral workflows
21:11:59 <sgordon> right, and some of the other cases are being handled via e.g. systemd at the distro level
21:12:29 <carolbarrett> pchadwick - will you take the action item to investigate the cross-project spec and work being done by the sub team and come back with more info on gaps and docs required?
21:12:38 <shamail> This leads back to what the next steps for the user story would be… would we still move it forward and then align with the work described in that spec?
21:12:40 <leong> Some of the requirements of the HA user story seems to be covered in Masakari but not in Mistral approach
21:12:46 <shamail> sounds like a good action item carolbarrett
21:13:18 <pchadwick> Yes - since the developer that I was talking to is the reviewer on the the spec just posted we should be able to figure out if we still need to track.
21:13:36 <carolbarrett> #action pchadwick Investigate the cross-project spec and work being done by the sub team and come back with more info on gaps and docs required to form action plan for this team
21:13:37 <leong> I think the User Story still serve as a good place to validate the gap...
21:13:58 <shamail> IMHO, we should still track but let’s determine if work is needed or if gaps are remaining…
21:14:15 <leong> pchadwick, please also include those findings in the user story review
21:14:15 <carolbarrett> OK - can we move to the next user story? Bare Metal Service?
21:14:17 <pchadwick> leong - right, we have Mistral, Masakari and the stuff that the distros have done with pacemaker-remote or systemd and this needs to be rationalized.
21:14:26 <Arkady_Kanevsky> Masakari is KVM only. HA VM is wider.
21:14:28 <shamail> Thanks for the info pchadwick and sgordon
21:14:36 <shamail> carolbarrett: +1
21:14:45 <Arkady_Kanevsky> https://github.com/ntt-sic/masakari
21:15:02 <carolbarrett> Leong - Can you give an update on next steps for the Bare Metal Service user story
21:15:05 <carolbarrett> ?
21:15:27 <leong> we aim to merge the user story next week..
21:15:35 <leong> still reviewing the content with couple of folks
21:16:04 <kencjohnston> leong - after story merger is the plan to review it with the Ironic team at the summit?
21:16:32 <leong> yes.. it is the plan to review the user story with Ironic team at the summit
21:16:47 <leong> i have notice our ironic core from intel perspective
21:16:48 <carolbarrett> +1
21:16:52 <Arkady_Kanevsky> have we got it on their calendar?
21:16:55 <kencjohnston> ok cool, I know jroll and team have already started reviewing
21:17:09 <carolbarrett> excellent
21:17:11 <shamail> i’ll let deva know too
21:17:19 <kei> kencjohnston: Ironic PTL and some cores have already reviewed the user story and gave us their comments.
21:17:19 <carolbarrett> +1
21:17:24 <leong> maybe kencjohnston can help to send the link to Ironic PTL (i assume he works for rax)?
21:17:37 <shamail> Red Hat I believe?
21:17:39 <leong> good!
21:17:43 <kencjohnston> leong already done :)
21:17:54 <carolbarrett> OK - Let's move to the next User Story - Capacity Management - Shamail
21:18:13 <leong> thanks kencjohnston !
21:18:15 <shamail> No action taken on this one yet but this one doesn’t require a user story to be merged before the summit
21:18:33 <shamail> The plan we had formed on this one was to identify 2-3 people willing to help draft a whitepaper with various use cases for capacity management/quotas
21:18:59 <shamail> We will then share that information with the cross-project quota team and start refining the user story based on the contents of the whitepapeer
21:19:02 <shamail> whitepaper*
21:19:11 <carolbarrett> Do you have folks signed up for the whitepapers?
21:19:19 <shamail> I haven’t sent the email to request people to sign up yet
21:19:25 <kencjohnston> shamail why the white paper and not just straight to the user story?
21:20:18 <Arkady_Kanevsky> Role based access is #5 ahead of capacity management
21:20:19 <shamail> kencjohnston: We discussed that there might be different ways that people are using quotas so we might need to find a common denominator first and, secondly, we weren’t at a point where most people were willing to commit resources to move this work forward
21:20:38 <shamail> We decided that at least giving feedback to the cross project team working on it might be a good starting point
21:20:44 <kencjohnston> shamail ahh, ok. So use the time for more robust definitions?
21:20:52 <shamail> kencjohnston: +1
21:21:01 <carolbarrett> arkady_kanevsky: in last week's discussion we decided to advance capacity managemnet as there is work underway currently in the community and we want to provide input
21:21:06 <kencjohnston> by cross project team you mean the nested quotas sub-team?
21:21:11 <Arkady_Kanevsky> +1
21:21:12 <shamail> carolbarrett: I will send out the email to the ML this week, I think Rocky had shown interest.
21:21:18 <shamail> yes thats the team kencjohnston
21:21:26 <shamail> they are meeting right now
21:21:44 <kencjohnston> shamail ok, and sorry because I missed the last meetings
21:21:48 <carolbarrett> shamail: OK on the email. Do you need the next level of requirements for Austin?
21:21:55 <shamail> They are working on building the foundation for nested quotas and a standard way of quotas across projects
21:22:05 <kencjohnston> shamail but the current capacity management story is MUCH more expansive then what the nested quotas team is working on
21:22:19 <shamail> the stuff we have in the user story is too advanced for what they are focused on atm
21:22:27 <kencjohnston> shamail ok, got it, thanks.
21:22:32 <shamail> so we decided to refine our requirements so that we are ready when the time comes
21:23:04 <shamail> carolbarrett: Not for this one, this is not one we will be able to intercept in Newton and I have already told nikhil that we are drafting a story
21:23:14 <carolbarrett> OK.
21:23:15 <shamail> This one will probably intersect later
21:23:23 <nikhil> ++
21:23:41 <carolbarrett> Let's move to our last User Story for today - Fleet Management - Kenny & Krish - Update?
21:23:46 <shamail> thanks nikhil
21:24:14 * kencjohnston looks at Krish...
21:24:28 <KrishR> carolbarrett: will need some more work to address all the comments
21:24:49 <kencjohnston> KrishR +1 I htink we are in a "get more feedback" phase with this story.
21:25:13 <carolbarrett> Is it likely to be merged ahead of Austin?
21:25:23 <kencjohnston> So the ask is "Review the Story"
21:25:39 <KrishR> carolbarrett: unlikely to be merged before Austin i think
21:25:41 <shamail> Definitely look forward to hearing more about this one in our Austin meeting…
21:25:41 <kencjohnston> carolbarrett I'd say unlikely. Only on patchset six.
21:26:18 <carolbarrett> Is that going to cause any issues with other discussions planned for the Design Summit?
21:27:10 <KrishR> carolbarrett: i don't think so...we will be talking about this being on OSIC roadmap though
21:27:10 <kencjohnston> carolbarrett Not that I'm aware of. I would think we would want to discuss it at the Ops Summit on Monday but not much anywhere else.
21:27:29 <carolbarrett> Sounds good.
21:27:32 <carolbarrett> Thanks
21:27:53 <carolbarrett> Let's move to Austin Planning - we've got 30 mins left
21:28:01 <carolbarrett> #topic Planning for Austin
21:28:12 <shamail> carolbarrett: I updated the etherpad with my suggestions and also room information
21:28:29 <carolbarrett> Thanks Shamail
21:28:38 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_Austin_Working_Session_Planning
21:30:06 <carolbarrett> shamail: Whether it's part of the work flow discussion or a separate topic, We want to ask that requirements and user stories get integrated into the updated OpenStack Design and Development work flow that will result from separating the Design Summit from the Conference
21:30:22 <shamail> carolbarrett: +1
21:30:40 <carolbarrett> Are you thinking it's part of the Work Flow or separate?
21:30:50 <shamail> It will be a part of the workflow but def. needs to be called out
21:31:14 <shamail> Does it make sense to have two mockups of the workflow (the current vs. the one with separate summits)?
21:31:36 <kencjohnston> shamail help me understand how summit separation might change our workflow?
21:31:42 <pchadwick> Does the workflow change or just the timing
21:31:52 <pchadwick> kencjohnston +1
21:31:52 <kencjohnston> shamail our team would meet at the "Design" summit still correct?
21:32:06 <shamail> that needs to be discussed
21:32:14 <shamail> because it might depend on where the ops decide to meet
21:32:28 <kencjohnston> shamail ok. Gotcha.
21:32:37 <carolbarrett> kencjohnston: As the Design Summit separates from the Conference, that means the Operators (and their feedback) gets more removed from the project teams.
21:32:52 <pchadwick> carolbarrett: +1
21:32:54 <shamail> I think the change to the workflow depends on whether we have responsibility to carry over feedback from one event to the other
21:32:59 <pchadwick> I would hope the board thought of that.
21:33:12 <Arkady_Kanevsky> are we eqauting roadmap with themes?
21:33:19 <kencjohnston> carolbarrett unless the operators stay with teh design summit, which was an assumption I'd made, but probably isn't fair to assume.
21:33:23 <carolbarrett> Because the release will occur several months ahead of the Conference, the feedback from the Operators will be even more valuable to the teams.
21:33:26 <shamail> carolbarrett: We should ask Tom what his thoughts are on which summit the ops-meetups will take place in
21:33:31 <anteaya> I think a lot of people will be working to continue communication between the various groups
21:33:56 <pchadwick> anteaya +1
21:33:57 <carolbarrett> kencjohnston: That is not the plan that has been discussed at the Board or I've seen from the TC. They are focused on project design activities only
21:34:11 <pchadwick> And the PWG should be part of that communication.
21:34:32 <shamail> anteaya, agreed… we should factor that into the workflow so that its a practice that is encouraged
21:34:48 <anteaya> I don't think anyone is excluded from that communication
21:34:51 <carolbarrett> it's great to hear that people will help bridge that gap - it would be good to outline the process for it as part of the updated design/development work flow
21:34:58 <shamail> carolbarrett: +1
21:35:05 <anteaya> but if you want a workflow that says so, then great
21:35:59 <carolbarrett> anteaya: Yes, we'd like to have an approach that the Community buys into and understands so we can successfully channel the info into the development efforts
21:36:33 <anteaya> well the community buys into anyone doing work that needs done
21:36:50 <carolbarrett> We want to use the time with the Board/TC to start this discussion and gain support for including the PWG in the redefinition efforts.
21:37:10 <anteaya> if you want, great
21:37:11 <kencjohnston> who is taking the action to propose a different workflow?
21:37:33 <shamail> kencjohnston: If the operators stay with the design summit then it becomes a lesser issue but there is value in having user stories/requirements gathering in the workflow in either case
21:38:00 <shamail> kencjohnston: I am working on it but would be glad for additional help
21:38:07 <pchadwick> shamail: it sounds like we should discuss this at the Friday working session after we know more.
21:38:14 <kencjohnston> I'm a bit concerned that the PWG would be painting ourselves into becoming a bottleneck for communication, which is contrary to our mission, and my appetite for headaches :)
21:38:16 <shamail> pchadwick: +1
21:38:30 <pchadwick> kencjohnston: +1
21:38:55 <carolbarrett> I think there are 2 changes to the work flow: The separation of the summits; and the desire to collaborate with other Industry groups (ex. OPNFV)
21:38:57 <carolbarrett> pchadwick: +1
21:39:02 <shamail> kencjohnston: we don’t want to be the bottleneck but we do want people to know there is a place to document and also eliminate any misunderstandings about how to translate user stories into actionable things inside the community
21:39:02 <MarkBaker> carolbarrett, are you taking it as a done deal that the release is going to shift?
21:39:20 <pchadwick> I just added it to the agenda for Friday.
21:39:20 <carolbarrett> MarkBaker: yes
21:39:38 <carolbarrett> pchadwick: Thanks
21:39:48 <pchadwick> markbaker: that is what I heard as well.
21:39:55 <pchadwick> Do you have a different sense?
21:40:28 <MarkBaker> pchadwick, I believe that whilst it is being actively discussed I am not aware that a decision has been made
21:40:40 <pchadwick> markbaker: thanks.
21:40:44 <carolbarrett> The other issue I think we want to cover in the Board/TC discussion is the challenge around introducing cross-project specs for new capabilities where the implementation methods are not defined.
21:41:26 <carolbarrett> MarkBaker: I think the decision will be made in Austin based upon the discussion in the Tahoe meeting
21:41:28 <shamail> thingee pointed us to a relevant change (https://review.openstack.org/#/c/295940/2), please review it when you have time.
21:42:02 <carolbarrett> Thanks Shamail
21:42:12 <carolbarrett> #link: https://review.openstack.org/#/c/295940/2
21:42:20 <shamail> carolbarrett: I think both of these topics can be covered under the context of workflow… this second topic is just as crucial
21:42:28 <carolbarrett> +1
21:43:09 <carolbarrett> Let's plan to review the slides for the Board meeting in our next meeting - Shamail: does that timing work for you?
21:43:15 <shamail> That will work
21:43:16 <Arkady_Kanevsky> Is the feel that our user story and cross peoject specs are too anti agile model?
21:43:33 <shamail> Arkady_Kanevsky: I don’t think so, agile has user stories as well
21:43:45 <Arkady_Kanevsky> code take presedence over spec?
21:43:48 <MarkBaker> carolbarrett, agreed - I believe that a decision will be made in Austin.
21:43:58 <carolbarrett> #action shamail draft slides for Board/TC discussion for 4/18 team meeting
21:44:17 <Arkady_Kanevsky> carol can you forward board meeting invite
21:44:29 <shamail> Essentially, can we include user stories into design workflows so that community members can document their requirements (and this allows feedback from one summit to the other) and also how can we then bring those into the community for technical design conversations
21:44:39 <shamail> both of the topics play a role.
21:44:44 <kencjohnston> Arkady_Kanevsky +1, is this the Sunday meeting?
21:44:50 <carolbarrett> arkady_kanevsky: you can find the info on the wiki
21:45:09 <leong> +1 shamail
21:45:26 <carolbarrett> #link https://etherpad.openstack.org/p/UnofficialBoardNotes-Apr24-2016
21:45:27 <shamail> kencjohnston: Does this approach seem reasonable or does it still trigger a bottleneck alarm?  Thank you for raising that concern since that is definitely something we want to avoid (in reality and perception)
21:46:06 <kencjohnston> shamail I think it's fine to say we have A process. I just would worry about saying it is THE process.
21:46:24 <Arkady_Kanevsky> https://wiki.openstack.org/wiki/Governance/Foundation/24Apr2016BoardMeeting
21:46:24 <kencjohnston> shamail and I don't think we are suggesting that the PWG needs involvement in single project User Stories or requests
21:46:28 <shamail> kencjohnston: +1, it definitely is A process, not THE.
21:46:31 <carolbarrett> board meeting invite sent...
21:46:46 <shamail> agreed on that too kencjohnston, the criteria still holds
21:47:03 <carolbarrett> +1
21:47:14 <kencjohnston> I think our value is a collaborative forum to discuss intended work and define requirements for cross project thigns
21:47:25 <kencjohnston> and a place to track the status of that intended work for others interested in contributing to the effort
21:47:58 <shamail> +1
21:48:01 <carolbarrett> +1
21:48:06 <KrishR> kencjohnston: +1
21:48:27 <kencjohnston> I just don't want us saying, "We take the requirements from the operators and give htem to the developers."
21:48:42 <kencjohnston> mostly because I have a life goal to never seriously quote Office Space...
21:49:00 <cloudrancher> +1
21:49:02 <shamail> no, plus that is only one of the parties that we would be representing
21:49:08 <carolbarrett> We also have a session in the Cross-project track on Tuesday from 5:30 - 6:10
21:49:11 <shamail> Are you not a people person kencjohnston>
21:49:14 <shamail> :-)
21:49:20 <kencjohnston> shamail obviously not...
21:49:23 <kencjohnston> :)
21:49:50 * shamail makes note to start deck with an office space meme
21:49:56 <kencjohnston> ha
21:50:00 <carolbarrett> LOL
21:50:28 <carolbarrett> In the cross project session, I'm hoping we can have collaborative discussions on the Cross-project specs topic and the work flow.
21:50:54 <rockyg> o/  Late because the company spyware hosed the micrsoft exchange software so I didn't get the calendar alert (thought this went well with current topic
21:51:01 <carolbarrett> If you can attend the cross project spec session , can you pls add your name to the etherpad?
21:51:07 <kencjohnston> carolbarrett agreed I think that will be a good forum for discussion.
21:52:03 <sgordon> shamail, i guess my concern about the above is that we're kind of losing sight of the original ideas behind the group
21:52:27 <sgordon> shamail, which was we're all companies with devs working on openstack, let's work on co-ordinating that better
21:52:39 <kencjohnston> sgordon +1
21:52:45 <rockyg> +1
21:52:47 <sgordon> shamail, whereas it seems like the ops->productwg->cross project->??? pipeline is too disconnected
21:52:58 <sgordon> shamail, from who actually does the work
21:53:06 <sgordon> i mean for me, rolling upgrades are important
21:53:11 <sgordon> so i have folks working on rolling upgrades
21:53:18 <shamail> sgordon: that is still our charter… however having needs or, even validation, for user stories identified from other sources isn’t a bad thing
21:53:25 <sgordon> and im sure other folks are the same about other use cases
21:53:27 <shamail> ultimately, commitment still drives what moves forward
21:53:33 <sgordon> even though they havent come through the pipe as "approved"
21:53:48 <kencjohnston> sgordon Agreed. I was thinking about this the other day, "How does a group of non-programmers participate in a software do-acracy."
21:53:56 <rockyg> So maybe we need to find a way to put all the differenct companies' devs who are working on the same topic together?
21:54:00 <sgordon> and i am concerned we may push some stuff through all this process and find oh nobody actually cares enough to dedicate bodies to that after all
21:54:05 <Arkady_Kanevsky> we still need to collect all rolling upgrade stories in all projects under user story
21:54:07 <sgordon> we all just thought it was a nice idea
21:54:39 <sgordon> Arkady_Kanevsky, i dont disagree with that but you could arguably skip straight to cross-project spec for that
21:54:44 <shamail> we have three main items in our original charter: 1) gather feedback 2) help with implementation and tracking 3) build roadmap for information sharing
21:54:48 <carolbarrett> kencjohnston: I think that's a great way to frame it.
21:54:48 <pchadwick> sgordon: +1 which is why to some extent we should be driving things that we know are getting worked on
21:54:51 <sgordon> Arkady_Kanevsky, as rolling upgrades have existed in some projects since icehouse...
21:55:00 <Arkady_Kanevsky> <sgordon> we still be able to report on the progress in one place
21:55:07 <sgordon> and e.g. cinder rolling upgrades happened in mitaka
21:55:11 <shamail> If that happens sgordon then we would have to make sure we let the submitters know the end result
21:55:13 <sgordon> with no product wg use case
21:55:23 <KrishR> sgordon: so maybe we ahve a requirement that whoever submits a user story is ready to put dev resources behind it?
21:55:24 <Arkady_Kanevsky> true for all core projects
21:55:29 <shamail> however, some of the feedback could align with a user story and provides greater insight into applicability
21:55:42 <sgordon> Arkady_Kanevsky, im not seeing how we are assisting with that if we spend so much time arguing about user story that it's already being implemented
21:56:02 <sgordon> admittedly this is also a tooling issue
21:56:03 <Arkady_Kanevsky> steve - agree with you
21:56:06 <rockyg> kencjohnston, we make the connections.  My devs, meet sgordon 's devs.  Now go figure out the rolling upgrade stuff and present it to the prod wg so we can review
21:56:07 <sgordon> in that we dont have that piece yet
21:56:11 <shamail> very valid point sgordon
21:56:26 <sgordon> rockyg, right i think a little focus on putting a dev lead for interested company against it
21:56:32 <sgordon> rockyg, would help make those connections
21:56:56 <carolbarrett> sgordon: I like that
21:57:00 <sgordon> some of whom are likely already working with each other
21:57:09 <nateziemann> +1 kencjohnston
21:57:18 <carolbarrett> sgordon: definitely
21:57:30 <shamail> sgordon: +1
21:57:44 <rockyg> yup.  Frinstance, I just got the names of the HA VM dev lead and the rolling upgrade lead for Huawei
21:57:44 <pchadwick> sgordon: +1
21:57:45 <kencjohnston> For instance nateziemann and I connected on our two companies interest in cells v2 :)
21:57:49 <shamail> Let’s figure out the best balance in our working session
21:57:56 <kencjohnston> shamail agreed
21:58:05 <kencjohnston> We have had the convo before actually, but never documented it.
21:58:19 <sgordon> shamail, thanks - i think that is the right forum
21:58:26 * kencjohnston is counting the times we've had it in his head now....
21:58:27 <carolbarrett> Do we need to discuss some of this more before the cross-project session and board discussion?
21:58:42 <sgordon> i think it will probably come out in the cross-project one
21:58:44 <KrishR> carolbarrett: i think you started on the chart showing sho's interested in which user story...just add names of devs from each company
21:58:47 <sgordon> maybe not the board one though
21:58:54 <rockyg> I think the best thing we can do is to connect our devs and architects for a specific user story and stand back.  Make sure they keep talking and developing, though
21:59:18 <MeganR> rockyg +1, and sometimes the hardest task
21:59:18 <KrishR> who's*
21:59:29 <carolbarrett> rockyg: I think we need to also frame up the requrements for the solution they are specing and developing
21:59:47 <kencjohnston> carolbarrett +1 agreeing to the problem definition is usually the hardest part
22:00:16 <shamail> We are at time carolbarrett
22:00:17 <rockyg> carolbarrett, that's the user story.  But they create the cross-proj spec or other specs and we review
22:00:32 <carolbarrett> Rockyg +1
22:00:34 <shamail> We can continue in #openstack-product (I will be leaving in 5-10 min)
22:01:02 <carolbarrett> We're at the top of the hour....in the Austin etherpad there's a link to slides for the BoF, would appreciate if people would review
22:01:20 <shamail> Good meeting!
22:01:30 <KrishR> thks everyone, bye
22:01:30 <carolbarrett> #endmeeting